source: archive/add/kate.xml@ 88bb10f

10.0 10.1 11.0 7.10 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt lazarus nosym perl-modules qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 88bb10f was 88bb10f, checked in by Bruce Dubbs <bdubbs@…>, 6 years ago

Remove obsolete KDE entities in packages.ent.
Update to mlt-6.2.0.
Update to kf5-apps-16.04.0.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@17284 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 5.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY kate-download-http "&kde-download-http;&kde-old-version;/src/kate-&kde-old-version;.tar.xz">
8 <!ENTITY kate-download-ftp " ">
9 <!ENTITY kate-md5sum "bf7e13e6454de354ff6b4f1905179311">
10 <!ENTITY kate-size "1.4 MB">
11 <!ENTITY kate-buildsize "36 MB">
12 <!ENTITY kate-time "3.0 SBU">
13]>
14
15<sect1 id="kate" xreflabel="kate-&kde-old-version;">
16 <?dbhtml filename="kate.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>Kate-&kde-old-version;</title>
24
25 <indexterm zone="kate">
26 <primary sortas="a-kate">kate</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to Kate</title>
31
32 <para>This package provides two text editors: Kate and KWrite. Kate is a
33 powerful programmer's text editor with syntax highlighting for many
34 programming and scripting languages. KWrite is the lightweight cousin of
35 Kate.</para>
36
37 &lfs79_checked;
38
39 <bridgehead renderas="sect3">Package Information</bridgehead>
40 <itemizedlist spacing="compact">
41 <listitem>
42 <para>Download (HTTP): <ulink url="&kate-download-http;"/></para>
43 </listitem>
44 <listitem>
45 <para>Download (FTP): <ulink url="&kate-download-ftp;"/></para>
46 </listitem>
47 <listitem>
48 <para>Download MD5 sum: &kate-md5sum;</para>
49 </listitem>
50 <listitem>
51 <para>Download size: &kate-size;</para>
52 </listitem>
53 <listitem>
54 <para>Estimated disk space required: &kate-buildsize;</para>
55 </listitem>
56 <listitem>
57 <para>Estimated build time: &kate-time;</para>
58 </listitem>
59 </itemizedlist>
60
61<!--
62 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
63 <itemizedlist spacing='compact'>
64 <listitem>
65 <para>Required patch: <ulink
66 url="&patch-root;/kate-&kdeutils-version;-fixes-1.patch"/></para>
67 </listitem>
68 </itemizedlist>
69-->
70 <bridgehead renderas="sect3">Kate Dependencies</bridgehead>
71
72 <bridgehead renderas="sect4">Required</bridgehead>
73 <para role="required">
74 <xref linkend="kdelibs"/>
75 </para>
76
77 <bridgehead renderas="sect4">Recommended</bridgehead>
78 <para role="recommended">
79 <xref linkend="kactivities"/>
80 </para>
81
82 <bridgehead renderas="sect4">Optional</bridgehead>
83 <para role="optional">
84 <xref linkend="qjson"/> and
85 <ulink url="&kde-download-http;&kde-old-version;/src/">PyKDE4</ulink>
86 </para>
87
88 <para condition="html" role="usernotes">User Notes:
89 <ulink url="&blfs-wiki;/kate"/>
90 </para>
91
92 </sect2>
93
94 <sect2 role="installation">
95 <title>Installation of Kate</title>
96
97 <para>Install <application>Kate</application> by running
98 the following commands:</para>
99
100<screen><userinput>mkdir build &amp;&amp;
101cd build &amp;&amp;
102
103cmake -DCMAKE_INSTALL_PREFIX=&kde-dir; \
104 -DCMAKE_BUILD_TYPE=Release \
105 -DCMAKE_MINIMUM_REQUIRED_VERSION=3.0 \
106 -DINSTALL_PYTHON_FILES_IN_PYTHON_PREFIX=TRUE \
107 -Wno-dev .. &amp;&amp;
108make</userinput></screen>
109
110 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
111
112<screen role="root"><userinput>make install</userinput></screen>
113
114 </sect2>
115
116 <sect2 role="commands">
117 <title>Command Explanations</title>
118
119 <para><option>-DINSTALL_PYTHON_FILES_IN_PYTHON_PREFIX=TRUE</option>: This option is
120 set to install the KDE Python objects in the correct place.</para>
121
122 </sect2>
123
124 <sect2 role="content">
125 <title>Contents</title>
126
127 <segmentedlist>
128 <segtitle>Installed Programs</segtitle>
129 <segtitle>Installed Libraries</segtitle>
130 <segtitle>Installed Directories</segtitle>
131
132 <seglistitem>
133 <seg>kate and kwrite</seg>
134 <seg>libkateinterfaces.so, libkatepartinterfaces.so,
135 libkdeinit4_kate.so, libkdeinit4_kwrite.so and several in
136 &kde-dir;/lib/kde4</seg>
137 <seg>&kde-dir;/include/kate and several in &kde-dir;/share</seg>
138 </seglistitem>
139 </segmentedlist>
140
141 <variablelist>
142 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
143 <?dbfo list-presentation="list"?>
144 <?dbhtml list-presentation="table"?>
145
146 <varlistentry id="kate-prog">
147 <term><command>kate</command></term>
148 <listitem>
149 <para>is the KDE text editor.</para>
150 <indexterm zone="kate kate-prog">
151 <primary sortas="b-kate">kate</primary>
152 </indexterm>
153 </listitem>
154 </varlistentry>
155
156 <varlistentry id="kwrite">
157 <term><command>kwrite</command></term>
158 <listitem>
159 <para>
160 is a text editor for KDE, that is a light version of
161 <command>kate</command>.
162 </para>
163 <indexterm zone="kate kwrite">
164 <primary sortas="b-kwrite">kwrite</primary>
165 </indexterm>
166 </listitem>
167 </varlistentry>
168
169 </variablelist>
170
171 </sect2>
172
173</sect1>
Note: See TracBrowser for help on using the repository browser.