source: archive/deprecated/libgnomeui.xml@ 87068b5

10.0 10.1 11.0 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 87068b5 was 87068b5, checked in by Bruce Dubbs <bdubbs@…>, 8 years ago

Move deprecated gnome packages and gnucash to the archive.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@11556 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libgnomeui-download-http "&gnome-download-http;/libgnomeui/2.24/libgnomeui-&libgnomeui-version;.tar.bz2">
8 <!ENTITY libgnomeui-download-ftp "&gnome-download-ftp;/libgnomeui/2.24/libgnomeui-&libgnomeui-version;.tar.bz2">
9 <!ENTITY libgnomeui-md5sum "d4bb506b1916015323928faab5aa708b">
10 <!ENTITY libgnomeui-size "1.4 MB">
11 <!ENTITY libgnomeui-buildsize "53 MB">
12 <!ENTITY libgnomeui-time "0.7 SBU">
13]>
14
15<sect1 id="libgnomeui" xreflabel="libgnomeui-&libgnomeui-version;">
16 <?dbhtml filename="libgnomeui.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>libgnomeui-&libgnomeui-version;</title>
24
25 <indexterm zone="libgnomeui">
26 <primary sortas="a-Libgnomeui">Libgnomeui</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to libgnomeui</title>
31
32 <para>The <application>libgnomeui</application> package contains
33 <filename class="libraryfile">libgnomeui</filename> libraries.</para>
34
35 &lfs72_checked;
36
37 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
38 href="../../xincludes/gnome2.xml"/>
39
40 <bridgehead renderas="sect3">Package Information</bridgehead>
41 <itemizedlist spacing="compact">
42 <listitem>
43 <para>Download (HTTP): <ulink url="&libgnomeui-download-http;"/></para>
44 </listitem>
45 <listitem>
46 <para>Download (FTP): <ulink url="&libgnomeui-download-ftp;"/></para>
47 </listitem>
48 <listitem>
49 <para>Download MD5 sum: &libgnomeui-md5sum;</para>
50 </listitem>
51 <listitem>
52 <para>Download size: &libgnomeui-size;</para>
53 </listitem>
54 <listitem>
55 <para>Estimated disk space required: &libgnomeui-buildsize;</para>
56 </listitem>
57 <listitem>
58 <para>Estimated build time: &libgnomeui-time;</para>
59 </listitem>
60 </itemizedlist>
61
62 <bridgehead renderas="sect3">libgnomeui Dependencies</bridgehead>
63
64 <bridgehead renderas="sect4">Required</bridgehead>
65 <para role="required"><xref linkend="libbonoboui"/>,
66 <xref linkend="libgnome-keyring"/>, and
67 <xref linkend="xorg7-lib"/></para>
68
69 <bridgehead renderas="sect4">Optional</bridgehead>
70 <para role="optional"><!-- <xref linkend="libjpeg"/>,
71 <xref linkend="esound"/>, and -->
72 <xref linkend="gtk-doc"/></para>
73
74 <para condition="html" role="usernotes">User Notes:
75 <ulink url="&blfs-wiki;/libgnomeui"/></para>
76
77 </sect2>
78
79 <sect2 role="installation">
80 <title>Installation of libgnomeui</title>
81
82 <para>Install <application>libgnomeui</application> by running the following
83 commands:</para>
84
85<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
86 --libexecdir=$(pkg-config \
87 --variable=prefix ORBit-2.0)/lib/libgnomeui &amp;&amp;
88make</userinput></screen>
89
90 <para>This package's testsuite is only intended to be used by the
91 maintainer to check i18n files.</para>
92
93 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
94
95<screen role="root"><userinput>make install</userinput></screen>
96
97 </sect2>
98
99 <sect2 role="commands">
100 <title>Command Explanations</title>
101
102 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
103 href="../../xincludes/gnome-old-prefix.xml"/>
104
105 <para><parameter>--libexecdir=$(pkg-config --variable=prefix
106 ORBit-2.0)/lib/libgnomeui</parameter>: This parameter causes the libexec
107 files to be installed in the preferred location of
108 <filename class="directory">$GNOME_PREFIX/lib/libgnomeui</filename> instead
109 of <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
110
111 <para><option>--disable-static</option>: This switch prevents the static
112 libraries being installed.</para>
113
114 <!-- seems bogus, no kde dependencies. dashes changed to plus to keep it
115 as a valid comment
116 <para><option>++with-kde-datadir=&kde-dir;/share</option>: Use this
117 parameter if you have <application>KDE</application> installed in any prefix
118 other than <filename class='directory'>/usr</filename>.</para>-->
119
120 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
121 href="../../xincludes/gtk-doc-rebuild.xml"/>
122
123 </sect2>
124
125 <!-- not relevant to anything using the deprecated packages
126 <sect2 role="configuration">
127 <title>Configuring libgnomeui</title>
128
129 <sect3>
130 <title>Configuration Information</title>
131
132 <para>Some applications cannot properly discover the
133 <application>libglade</application> interface library installed by
134 <application>libgnomeui</application>. Get around this problem by
135 initializing an environment variable which identifies the location
136 of the library. Add the following line to the system-wide
137 <filename>/etc/profile</filename> file, or to individual user's
138 <filename>~/.profile</filename> or <filename>~/.bashrc</filename>
139 files:</para>
140
141<screen><literal>export LIBGLADE_MODULE_PATH=$GNOME_PREFIX/lib/libglade/2.0</literal></screen>
142
143 </sect3>
144
145 </sect2> -->
146
147 <sect2 role="content">
148 <title>Contents</title>
149
150 <segmentedlist>
151 <segtitle>Installed Programs</segtitle>
152 <segtitle>Installed Libraries</segtitle>
153 <segtitle>Installed Directories</segtitle>
154
155 <seglistitem>
156 <seg>None</seg>
157 <seg>libgnomeui-2.{so,a} and libgnome.{so,a} Glade library</seg>
158 <seg>/usr/include/libgnomeui-2.0/libgnomeui,
159 /usr/share/gtk-doc/html/libgnomeui</seg>
160 </seglistitem>
161 </segmentedlist>
162
163 <variablelist>
164 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
165 <?dbfo list-presentation="list"?>
166 <?dbhtml list-presentation="table"?>
167
168 <varlistentry id="libgnomeui-2">
169 <term><filename class='libraryfile'>libgnomeui-2.{so,a}</filename></term>
170 <listitem>
171 <para>are the GUI portion of the <application>GNOME</application>
172 libraries.</para>
173 <indexterm zone="libgnomeui libgnomeui-2">
174 <primary sortas="c-libgnomeui-2">libgnomeui-2.{so,a}</primary>
175 </indexterm>
176 </listitem>
177 </varlistentry>
178
179 </variablelist>
180
181 </sect2>
182
183</sect1>
Note: See TracBrowser for help on using the repository browser.