source: archive/imagemagick6.xml@ 918c149

10.0 10.1 11.0 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 918c149 was 918c149, checked in by Ken Moffat <ken@…>, 16 months ago

Archive ImageMagick-6.

In emacs add optional switch to emable ImageMagick-7.
In transcode optional deps point to legacy imagemagick site.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23535 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 17.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY imagemagick6-patch-version "93">
8
9 <!ENTITY imagemagick6-download-http "https://www.imagemagick.org/download/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
10 <!ENTITY imagemagick6-download-ftp "ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
11 <!ENTITY imagemagick6-md5sum "ddbb2bed4145e3f7b0ff6c105ddbf612">
12 <!ENTITY imagemagick6-size "8.7 MB">
13 <!ENTITY imagemagick6-buildsize "158 MB, with typical dependencies (add 40 MB for tests)">
14 <!ENTITY imagemagick6-time "0.9 SBU (Using parallelism=4; add 1.9 SBU for tests)">
15]>
16
17<!-- Editors: It is highly unlikely that the buildsize (disk space used) will
18 be less than the figure shown above. Unless you have installed *all* the
19 delegate dependencies, you will see a smaller buildsize, but what is
20 currently listed above is the space one would require if all the
21 dependencies available in the book are installed.
22
23 [bdubbs 2019-92-09] Reduced SBU and disk space for libraries only.
24
25 [bdubbs 2018-08-26] I upddated the above stats slightly for 8.3. All BLFS
26 dependencies were installed except gimp and texlive. Note that at this
27 writing the only packages in the book that use this are gimp and
28 inkscape.
29
30 [pierre 2017-02-14] For a build of 6.9.7-8 with dependencies available in
31 the book, but with the configure command as below, I got 179 MB (2.3 SBU)
32 (and 472 KB (0.8 SBU) for the validation suite).
33
34 For a non-full build of 6.9.3-8 I got an actual space of 173 MB and running
35 the validation suite does not increase the net space. I recommend running
36 that instead of check (after the install)!
37
38 Following comments preserved from when we did a full install of -6.
39
40 Marked as 'typical' because nobody builds ALL the optional extras [ken]
41
42 [bdubbs] I do; at least the internal ones. I still got only 200 MB.
43
44 Saved the "full" 450MB as a comment - feel free to update this iff you
45 do build all dependencies, it's probably a lot bigger now.
46
47 [bdubbs] Just removed it. I don't think it adds anything.
48
49 Also, please look over the output from the configure command for any
50 additional dependencies that need to be listed, as ImageMagick is
51 constantly adding additional features and dependencies.
52
53 For those of us who touch this infrequently:
54 DPS/dpsXclient is from apple so not relevant to linux builds
55 GVC is part of Graphviz and documented in the explanations
56 LQR is Liquid Rescale
57
58 -->
59
60<sect1 id="imagemagick6" xreflabel="ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version; libraries">
61 <?dbhtml filename="imagemagick6.html"?>
62
63 <sect1info>
64 <othername>$LastChangedBy$</othername>
65 <date>$Date$</date>
66 </sect1info>
67
68 <title>ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;</title>
69
70 <indexterm zone="imagemagick6">
71 <primary sortas="a-ImageMagick-6 libraries">ImageMagick-6 libraries</primary>
72 </indexterm>
73
74 <sect2 role="package">
75 <title>Introduction to ImageMagick-6 libraries</title>
76
77 <para>
78 <application>ImageMagick</application> underwent many changes in its
79 libraries between versions 6 and 7. Most packages in BLFS which use
80 <application>ImageMagick</application> can use version 7, but for the
81 others this page will install only the libraries, headers and general
82 documentation (not programs, manpages, perl modules), and it will
83 rename the unversioned pkgconfig files so that they do not overwrite the
84 same-named files from version 7.
85 </para>
86
87 &lfs91_checked;
88
89 <bridgehead renderas="sect3">Package Information</bridgehead>
90 <itemizedlist spacing="compact">
91 <listitem>
92 <para>
93 Download (HTTP): <ulink url="&imagemagick6-download-http;"/>
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download (FTP): <ulink url="&imagemagick6-download-ftp;"/>
99 </para>
100 </listitem>
101 <listitem>
102 <para>
103 Download MD5 sum: &imagemagick6-md5sum;
104 </para>
105 </listitem>
106 <listitem>
107 <para>
108 Download size: &imagemagick6-size;
109 </para>
110 </listitem>
111 <listitem>
112 <para>
113 Estimated disk space required: &imagemagick6-buildsize;
114 </para>
115 </listitem>
116 <listitem>
117 <para>
118 Estimated build time: &imagemagick6-time;
119 </para>
120 </listitem>
121 </itemizedlist>
122
123 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
124 <itemizedlist spacing="compact">
125 <listitem>
126 <para>
127 Required patch:
128 <ulink url="&patch-root;/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch"/>
129 </para>
130 </listitem>
131 </itemizedlist>
132
133 <note>
134 <para>
135 The <application>ImageMagick</application> source releases are updated
136 frequently and the version shown above may no longer be available from
137 the download locations. You can download a more recent version and use
138 the existing BLFS instructions to install it. Chances are that it will
139 work just fine, but this has not been tested by the BLFS team. If the
140 package version shown above is not available from the locations shown
141 above, or from the <filename class='directory'>legacy/</filename>
142 directory at <literal>ftp.ImageMagick.org/pub/ImageMagick</literal> you
143 can download it from the BLFS package server at Oregon State University:
144 <ulink url="ftp://ftp.osuosl.org/pub/blfs/conglomeration/ImageMagick/"/>.
145 </para>
146 </note>
147
148 <bridgehead renderas="sect3">ImageMagick-6 Dependencies</bridgehead>
149
150 <bridgehead renderas="sect4">Recommended</bridgehead>
151 <para role="recommended">
152 <xref linkend="xorg7-lib"/>
153 </para>
154
155 <para>
156 The optional dependencies listed below should be installed if you need
157 support for the specific format or the conversion tool the dependency
158 provides. Many of the dependencies' capabilities and uses are described in
159 the <quote>MAGICK DELEGATES</quote> section of the
160 <filename>README.txt</filename> file located in the source tree.
161 Additional information about the dependencies can be found in the
162 <filename>Install-unix.txt</filename> file located in the source tree as
163 well as issuing the <command>./configure --help</command> command. A
164 summary of this information, as well as some additional notes can be
165 viewed on-line at <ulink
166 url="http://www.imagemagick.org/script/advanced-unix-installation.php"/>.
167 </para>
168
169 <bridgehead renderas="sect4">Optional System Utilities</bridgehead>
170 <para role="optional">
171 <xref linkend="cups"/>,
172 <xref linkend="curl"/>,
173 <xref linkend="ffmpeg"/>,
174 <xref linkend="fftw"/>,
175 <xref linkend="p7zip"/> (LZMA),
176 <xref linkend="sane"/>,
177 <xref linkend="wget"/>,
178 <xref linkend="xdg-utils"/>,
179 <xref linkend="xterm2"/>,
180 <ulink url="http://dmalloc.com/">Dmalloc</ulink>,
181 <ulink url="http://linux.softpedia.com/get/Programming/Debuggers/Electric-Fence-3305.shtml/">Electric Fence</ulink>,
182 <ulink url="http://www.openpgp.org/about/">PGP</ulink> or
183 <xref linkend="gnupg2"/>
184 (you'll have to do some hacking to use <application>GnuPG</application>),
185 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates">Profiles</ulink>,
186 and
187 <ulink url="http://ufraw.sourceforge.net/">ufraw</ulink> (for raw formats
188 listed in
189 <ulink url="http://imagemagick.org/script/formats.php">
190 http://www.imagemagick.org/www/formats.html</ulink>)
191 </para>
192
193 <bridgehead renderas="sect4">Optional Graphics Libraries</bridgehead>
194 <para role="optional">
195 <xref linkend="jasper"/>,
196 <xref role="nodep" linkend="lcms"/> or
197 <xref linkend="lcms2"/>,
198 <xref linkend="libexif"/>,
199 <xref linkend="libgxps"/>,
200 <xref linkend="libjpeg"/>,
201 <xref linkend="libpng"/>,
202 <xref linkend="libraw"/> (RAW_R),
203 <xref linkend="librsvg"/>,
204 <xref linkend="libtiff"/>,
205 <xref linkend="libwebp"/>,
206 <xref linkend="openjpeg2"/>,
207 <xref linkend="pango"/>,
208 <ulink url="http://djvu.sourceforge.net/">DjVuLibre</ulink>,
209 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates/">
210 FlashPIX (libfpx)</ulink>,
211 <ulink url="https://github.com/FLIF-hub/FLIF/releases">FLIF</ulink>,
212 <ulink url="http://www.cl.cam.ac.uk/~mgk25/jbigkit/">JBIG-KIT</ulink>,
213 <!-- <ulink url="&gnome-download-http;/libgxps/">libgxps</ulink>, -->
214 <ulink url="https://github.com/HOST-Oman/libraqm/">libraqm</ulink>,
215 <ulink url="http://liblqr.wikidot.com/en:download-page">Liquid Rescale</ulink>,
216 <ulink url="http://www.openexr.com/">OpenEXR</ulink>, and
217 <ulink url="http://www.agocg.ac.uk/train/cgm/ralcgm.htm">RALCGM</ulink>
218 (or <ulink url="http://www.mcmurchy.com/ralcgm/ralcgm-3.51.tar.gz">ralcgm</ulink>)
219 </para>
220
221 <bridgehead renderas="sect4">Optional Graphics Utilities</bridgehead>
222 <para role="optional">
223 <xref linkend="dejavu-fonts"/>,
224 <xref linkend="gs"/>,
225 <xref linkend="gimp"/>,
226 <xref linkend="graphviz"/>,
227 <xref linkend="inkscape"/>,
228 <ulink url="http://www.blender.org/">Blender</ulink>,
229 <ulink url="http://corefonts.sourceforge.net/">corefonts</ulink>,
230 <ulink url="http://www.ghostscript.com/download/gpcldnld.html">GhostPCL</ulink>,
231 <ulink url="http://www.gnuplot.info/">Gnuplot</ulink>,
232 <ulink url="http://www.povray.org/">POV-Ray</ulink>, and
233 <ulink url="http://www.radiance-online.org/">Radiance</ulink>
234 </para>
235
236 <bridgehead renderas="sect4">Optional Conversion Tools</bridgehead>
237 <para role="optional">
238 <xref linkend="enscript"/>,
239 <xref linkend="texlive"/> (or <xref linkend="tl-installer"/>)
240 <ulink url="http://autotrace.sourceforge.net/">AutoTrace</ulink>,
241 <ulink url="http://www.lizardtech.com/downloads/category/">
242 GeoExpress Command Line Utilities, AKA MrSID Utilities (binary package)</ulink>,
243 <ulink url="http://www.gnu.org/software/hp2xx/">hp2xx</ulink>,
244 <ulink url="https://fossies.org/linux/www/old/html2ps-1.0b7.tar.gz/">html2ps</ulink>,
245 <ulink url="http://wvware.sourceforge.net/">libwmf</ulink>,
246 <ulink url="https://sk1project.net/uc2/">UniConvertor</ulink>, and
247 <ulink url="http://www.cs.utah.edu/gdc/projects/urt/">Utah Raster Toolkit</ulink>
248 (or <ulink url="http://www.mcmurchy.com/urt/urt-3.1b.tar.gz">URT-3.1b</ulink>)
249 </para>
250
251 <para condition="html" role="usernotes">User Notes:
252 <!-- share the main page -->
253 <ulink url="&blfs-wiki;/imagemagick"/></para>
254
255 </sect2>
256
257 <sect2 role="installation">
258 <title>Installation of ImageMagick-6 libraries</title>
259
260 <para>
261 Install <application>ImageMagick</application> by running the following
262 commands:
263 </para>
264
265<screen><userinput>patch -Np1 -i ../ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch &amp;&amp;
266autoreconf -fi &amp;&amp;
267./configure --prefix=/usr \
268 --sysconfdir=/etc \
269 --enable-hdri \
270 --with-modules \
271 --disable-static &amp;&amp;
272make</userinput></screen>
273
274 <para>
275 Now, as the <systemitem class="username">root</systemitem> user:
276 </para>
277
278<screen role="root"><userinput>make DOCUMENTATION_PATH=/usr/share/doc/imagemagick-&imagemagick6-version; install-libs-only</userinput></screen>
279
280 <para>
281 To test the installation, issue: <command>make check</command>.
282 <!-- in 6.9.9-9 make check runs tests-validate-* A more
283 comprehensive test is the <application>ImageMagick</application>
284 validation suite. If <command>make check</command> has not been executed,
285 run <command>make tests/validate</command> to compile it. Issue
286 <command>tests/validate 2>&amp;1 | tee validate.log</command> to run the
287 validation suite. The result summary may be obtained with <command>grep
288 "validation suite" validate.log</command>.--> Note that the EPS, PS, and PDF
289 tests require a working <application>Ghostscript</application>. One test
290 in 'make check' needs <quote>Helvetica</quote> from <quote>Ghostscript
291 Standard Fonts</quote>, which are optionally installed in
292 <xref linkend="gs"/> - that test, and one other, might fail, but all the
293 validation can still pass.
294 </para>
295
296 </sect2>
297
298 <sect2 role="commands">
299 <title>Command Explanations</title>
300
301 <para>
302 <command>patch -Np1 -i
303 ../ImageMagick-&imagemagick6-version;-imagemagick6_libs_only-1.patch</command>:
304 Move unversioned pkgconfig files to versioned names and provide an option to
305 only install libraries and associated files.
306 </para>
307
308 <para>
309 <parameter>--enable-hdri</parameter>: Enables building of a
310 high dynamic range version of ImageMagick.
311 </para>
312
313 <para>
314 <parameter>--with-modules</parameter>: Enables support for
315 dynamically loadable modules.
316 </para>
317
318 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
319 href="../../xincludes/static-libraries.xml"/>
320
321 <para>
322 <option>--with-gslib</option>: Enables support to use the
323 <application>Ghostscript</application> shared library.
324 </para>
325
326 <para>
327 <option>--with-rsvg</option>: Enables support to use the
328 <application>librsvg</application> library.
329 </para>
330
331 <para>
332 <option>--with-autotrace</option>: Enables support to use
333 the <application>Autotrace</application> library.
334 </para>
335
336 <para>
337 <option>--with-wmf</option>: Enables support to use the
338 <application>libwmf</application> library.
339 </para>
340
341 <para>
342 <option>--with-gvc</option>: Enables support to use
343 <application>GraphViz</application>.
344 </para>
345
346 <para>
347 <option>--with-windows-font-dir=
348 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
349 This option specifies the directory where the Windows CoreFonts are
350 installed.
351 </para>
352
353 <para>
354 <option>--with-dejavu-font-dir=
355 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
356 This option specifies the directory where the DejaVu fonts are
357 installed.
358 </para>
359
360 <para>
361 The options and parameters listed above are the only ones you should
362 have to pass to the <command>configure</command> script to activate all
363 the delegate dependencies. All other dependencies will be automatically
364 detected and utilized in the build if they are installed.
365 </para>
366
367 </sect2>
368
369 <sect2 role="content">
370 <title>Contents</title>
371
372 <segmentedlist>
373 <segtitle>Installed Programs</segtitle>
374 <segtitle>Installed Libraries</segtitle>
375 <segtitle>Installed Directories</segtitle>
376
377 <seglistitem>
378 <seg>
379 None
380 </seg>
381 <seg>
382 libMagickCore-6.Q16HDRI.so,
383 libMagickWand-6.Q16HDRI.so and
384 libMagick++-6.Q16HDRI.so
385 </seg>
386 <seg>
387 /etc/ImageMagick-6,
388 /usr/include/ImageMagick-6,
389 /usr/lib/ImageMagick-&imagemagick6-version;,
390 /usr/share/doc/ImageMagick-&imagemagick6-version;, and
391 /usr/share/ImageMagick-6
392 </seg>
393 </seglistitem>
394 </segmentedlist>
395
396 <variablelist>
397 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
398 <?dbfo list-presentation="list"?>
399 <?dbhtml list-presentation="table"?>
400
401 <varlistentry id="libMagickCore-6.Q16HDRI">
402 <term><filename class="libraryfile">libMagickCore-6.Q16HDRI.so</filename></term>
403 <listitem>
404 <para>
405 provides the C API for ImageMagick.
406 </para>
407 <indexterm zone="imagemagick6 libMagickCore-6.Q16HDRI">
408 <primary sortas="c-libMagickCore-6.Q16HDRI">libMagickCore-6.Q16HDRI.so</primary>
409 </indexterm>
410 </listitem>
411 </varlistentry>
412
413 <varlistentry id="libMagickWand-6.Q16HDRI">
414 <term><filename class="libraryfile">libMagickWand-6.Q16HDRI.so</filename></term>
415 <listitem>
416 <para>
417 is the recommended C API for ImageMagick. Unlike the MagickCore API it
418 uses only a few opaque types.
419 </para>
420 <indexterm zone="imagemagick6 libMagickWand-6.Q16HDRI">
421 <primary sortas="c-libMagickWand-6.Q16HDRI">libMagickWand-6.Q16HDRI.so</primary>
422 </indexterm>
423 </listitem>
424 </varlistentry>
425
426 <varlistentry id="libMagickpp-6.Q16HDRI">
427 <term><filename class="libraryfile">libMagick++-6.Q16HDRI.so</filename></term>
428 <listitem>
429 <para>
430 provides the C++ API for ImageMagick.
431 </para>
432 <indexterm zone="imagemagick6 libMagickpp-6.Q16HDRI">
433 <primary sortas="c-libMagick++-6.Q16HDRI">libMagick++-6.Q16HDRI.so</primary>
434 </indexterm>
435 </listitem>
436 </varlistentry>
437
438 </variablelist>
439
440 </sect2>
441
442</sect1>
Note: See TracBrowser for help on using the repository browser.