source: archive/js60.xml@ 8da5263

10.0 10.1 11.0 qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 8da5263 was 8da5263, checked in by Bruce Dubbs <bdubbs@…>, 16 months ago

Update to polkit-cf22af32. Allows use of js68.
Archive js60.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23262 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 7.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY js60-download-http "http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-&JS60-version;.tar.bz2">
8 <!ENTITY js60-download-ftp "ftp://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-&JS60-version;.tar.bz2">
9 <!ENTITY js60-md5sum "5eda38cc08a3594a3f2c3cc185d4f15b">
10 <!ENTITY js60-size "31 MB">
11 <!ENTITY js60-buildsize "640 MB"> <!-- The buildsize is over 4GB! Actually installed is much smaller. -->
12 <!ENTITY js60-time "6.6 SBU">
13]>
14
15<sect1 id="js60" xreflabel="js60-&JS60-version;">
16 <?dbhtml filename="js60.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>JS-&JS60-version;</title>
24
25 <indexterm zone="js60">
26 <primary sortas="a-js60">js60</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to JS</title>
31
32 <para>
33 <application>JS</application> is Mozilla's JavaScript engine
34 written in C.
35 </para>
36
37 &lfs91_checked;
38
39 <bridgehead renderas="sect3">Package Information</bridgehead>
40 <itemizedlist spacing="compact">
41 <listitem>
42 <para>
43 Download (HTTP): <ulink url="&js60-download-http;"/>
44 </para>
45 </listitem>
46 <listitem>
47 <para>
48 Download (FTP): <ulink url="&js60-download-ftp;"/>
49 </para>
50 </listitem>
51 <listitem>
52 <para>
53 Download MD5 sum: &js60-md5sum;
54 </para>
55 </listitem>
56 <listitem>
57 <para>
58 Download size: &js60-size;
59 </para>
60 </listitem>
61 <listitem>
62 <para>
63 Estimated disk space required: &js60-buildsize;
64 </para>
65 </listitem>
66 <listitem>
67 <para>
68 Estimated build time: &js60-time;
69 </para>
70 </listitem>
71 </itemizedlist>
72<!--
73 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
74 <itemizedlist spacing="compact">
75 <listitem>
76 <para>
77 Required patch:
78 <ulink url="&patch-root;/js60-&JS60-version;-security_fix-1.patch"/>
79 </para>
80 </listitem>
81 </itemizedlist>
82-->
83 <bridgehead renderas="sect3">JS60 Dependencies</bridgehead>
84
85 <bridgehead renderas="sect4">Required</bridgehead>
86 <para role="required">
87 <xref linkend="autoconf213"/>,
88 <xref linkend="icu"/>,
89 <xref linkend="python2"/>,
90 <xref linkend="which"/>,
91 <!--<xref linkend="yasm"/>,--> and
92 <xref linkend="zip"/>
93 </para>
94
95 <bridgehead renderas="sect4">Optional</bridgehead>
96 <para role="optional">
97 <xref linkend="doxygen"/>
98 </para>
99
100 <para condition="html" role="usernotes">
101 User Notes: <ulink url="&blfs-wiki;/js60"/>
102 </para>
103 </sect2>
104
105 <sect2 role="installation">
106 <title>Installation of JS</title>
107
108 <!--caution>
109 <para>
110 If you are upgrading JS60 from a previously installed old version,
111 save all work and exit your GNOME Session if you have one running.
112 Replacing the JS60 binary will cause the GNOME Shell to crash and return
113 you to your display manager or TTY. After installing the new version,
114 reinstall <xref linkend="gjs"/>. Polkit is unaffected.
115 </para>
116 </caution-->
117<!--
118 <para>
119 First, apply a security patch:
120 </para>
121
122<screen><userinput remap="pre">patch -Np1 -i ../js60-&JS60-version;-security_fix-1.patch</userinput></screen>
123-->
124 <para>
125 Install <application>JS</application> by running the following
126 commands:
127 </para>
128
129<!-- &shell-env;-->
130
131 <note>
132 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
133 href="../../xincludes/mozshm.xml"/>
134
135 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
136 href="../../xincludes/mozconfigure.xml"/>
137 </note>
138
139<screen><userinput>mkdir mozjs-build &amp;&amp;
140cd mozjs-build &amp;&amp;
141
142../js/src/configure --prefix=/usr \
143 --with-intl-api \
144 --with-system-zlib \
145 --with-system-icu \
146 --disable-jemalloc \
147 --enable-readline &amp;&amp;
148make</userinput></screen>
149
150 <para>
151 This package does not come with a working test suite.
152 </para>
153
154 <para>
155 Now, as the <systemitem class="username">root</systemitem> user:
156 </para>
157
158<screen role="root"><userinput>make install</userinput></screen>
159
160 </sect2>
161
162 <sect2 role="commands">
163 <title>Command Explanations</title>
164
165 <para>
166 <parameter>--with-*</parameter>: These parameters allow the build system
167 to use system versions of the above libriares. These are required for
168 stability.
169 </para>
170
171 <para>
172 <parameter>--enable-readline</parameter>: This switch enables Readline
173 support in the JS shell.
174 </para>
175
176 <para>
177 <parameter>--disable-jemalloc</parameter>: This switch disables the
178 internal memory allocator used in JS60. jemalloc causes a conflict with glibc.
179 </para>
180
181 </sect2>
182
183 <sect2 role="content">
184 <title>Contents</title>
185
186 <segmentedlist>
187 <segtitle>Installed Programs</segtitle>
188 <segtitle>Installed Libraries</segtitle>
189 <segtitle>Installed Directories</segtitle>
190
191 <seglistitem>
192 <seg>
193 js60 and js60-config
194 </seg>
195 <seg>
196 libmozjs-60.so and libjs_static.ajs <!-- The AJS file doesn't
197 conflict with the one from js52 like originally thought -->
198 </seg>
199 <seg>
200 /usr/include/mozjs-60
201 </seg>
202 </seglistitem>
203 </segmentedlist>
204
205 <variablelist>
206 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
207 <?dbfo list-presentation="list"?>
208 <?dbhtml list-presentation="table"?>
209
210 <varlistentry id="js6-js60">
211 <term><command>js60</command></term>
212 <listitem>
213 <para>
214 provides a command line interface to the
215 <application>JavaScript</application> engine.
216 </para>
217 <indexterm zone="js60 js60">
218 <primary sortas="b-js60">js60</primary>
219 </indexterm>
220 </listitem>
221 </varlistentry>
222
223 <varlistentry id="js60-config">
224 <term><command>js60-config</command></term>
225 <listitem>
226 <para>
227 is used to find the JS compiler and linker flags.
228 </para>
229 <indexterm zone="js60 js60-config">
230 <primary sortas="b-js60-config">js60-config</primary>
231 </indexterm>
232 </listitem>
233 </varlistentry>
234
235 <varlistentry id="libmozjs-60">
236 <term><filename class="libraryfile">libmozjs-60.so</filename></term>
237 <listitem>
238 <para>
239 contains the Mozilla JavaScript API functions.
240 </para>
241 <indexterm zone="js60 libmozjs-60">
242 <primary sortas="c-libmozjs60">libmozjs-60.so</primary>
243 </indexterm>
244 </listitem>
245 </varlistentry>
246 </variablelist>
247 </sect2>
248</sect1>
Note: See TracBrowser for help on using the repository browser.