source: archive/js60.xml@ fa91d2e

11.0 ken/refactor-virt lazarus qt5new trunk
Last change on this file since fa91d2e was 45ab6c7, checked in by Xi Ruoyao <xry111@…>, 5 months ago

more SVN prop clean up

Remove "$LastChanged$" everywhere, and also some unused $Date$

  • Property mode set to 100644
File size: 7.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY js60-download-http "http://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-&JS60-version;.tar.bz2">
8 <!ENTITY js60-download-ftp "ftp://ftp.gnome.org/pub/gnome/teams/releng/tarballs-needing-help/mozjs/mozjs-&JS60-version;.tar.bz2">
9 <!ENTITY js60-md5sum "5eda38cc08a3594a3f2c3cc185d4f15b">
10 <!ENTITY js60-size "31 MB">
11 <!ENTITY js60-buildsize "640 MB"> <!-- The buildsize is over 4GB! Actually installed is much smaller. -->
12 <!ENTITY js60-time "6.6 SBU">
13]>
14
15<sect1 id="js60" xreflabel="js60-&JS60-version;">
16 <?dbhtml filename="js60.html"?>
17
18 <sect1info>
19 <date>$Date$</date>
20 </sect1info>
21
22 <title>JS-&JS60-version;</title>
23
24 <indexterm zone="js60">
25 <primary sortas="a-js60">js60</primary>
26 </indexterm>
27
28 <sect2 role="package">
29 <title>Introduction to JS</title>
30
31 <para>
32 <application>JS</application> is Mozilla's JavaScript engine
33 written in C.
34 </para>
35
36 &lfs91_checked;
37
38 <bridgehead renderas="sect3">Package Information</bridgehead>
39 <itemizedlist spacing="compact">
40 <listitem>
41 <para>
42 Download (HTTP): <ulink url="&js60-download-http;"/>
43 </para>
44 </listitem>
45 <listitem>
46 <para>
47 Download (FTP): <ulink url="&js60-download-ftp;"/>
48 </para>
49 </listitem>
50 <listitem>
51 <para>
52 Download MD5 sum: &js60-md5sum;
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download size: &js60-size;
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Estimated disk space required: &js60-buildsize;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Estimated build time: &js60-time;
68 </para>
69 </listitem>
70 </itemizedlist>
71<!--
72 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
73 <itemizedlist spacing="compact">
74 <listitem>
75 <para>
76 Required patch:
77 <ulink url="&patch-root;/js60-&JS60-version;-security_fix-1.patch"/>
78 </para>
79 </listitem>
80 </itemizedlist>
81-->
82 <bridgehead renderas="sect3">JS60 Dependencies</bridgehead>
83
84 <bridgehead renderas="sect4">Required</bridgehead>
85 <para role="required">
86 <xref linkend="autoconf213"/>,
87 <xref linkend="icu"/>,
88 <xref linkend="python2"/>,
89 <xref linkend="which"/>,
90 <!--<xref linkend="yasm"/>,--> and
91 <xref linkend="zip"/>
92 </para>
93
94 <bridgehead renderas="sect4">Optional</bridgehead>
95 <para role="optional">
96 <xref linkend="doxygen"/>
97 </para>
98
99 <para condition="html" role="usernotes">
100 User Notes: <ulink url="&blfs-wiki;/js60"/>
101 </para>
102 </sect2>
103
104 <sect2 role="installation">
105 <title>Installation of JS</title>
106
107 <!--caution>
108 <para>
109 If you are upgrading JS60 from a previously installed old version,
110 save all work and exit your GNOME Session if you have one running.
111 Replacing the JS60 binary will cause the GNOME Shell to crash and return
112 you to your display manager or TTY. After installing the new version,
113 reinstall <xref linkend="gjs"/>. Polkit is unaffected.
114 </para>
115 </caution-->
116<!--
117 <para>
118 First, apply a security patch:
119 </para>
120
121<screen><userinput remap="pre">patch -Np1 -i ../js60-&JS60-version;-security_fix-1.patch</userinput></screen>
122-->
123 <para>
124 Install <application>JS</application> by running the following
125 commands:
126 </para>
127
128<!-- &shell-env;-->
129
130 <note>
131 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
132 href="../../xincludes/mozshm.xml"/>
133
134 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
135 href="../../xincludes/mozconfigure.xml"/>
136 </note>
137
138<screen><userinput>mkdir mozjs-build &amp;&amp;
139cd mozjs-build &amp;&amp;
140
141../js/src/configure --prefix=/usr \
142 --with-intl-api \
143 --with-system-zlib \
144 --with-system-icu \
145 --disable-jemalloc \
146 --enable-readline &amp;&amp;
147make</userinput></screen>
148
149 <para>
150 This package does not come with a working test suite.
151 </para>
152
153 <para>
154 Now, as the <systemitem class="username">root</systemitem> user:
155 </para>
156
157<screen role="root"><userinput>make install</userinput></screen>
158
159 </sect2>
160
161 <sect2 role="commands">
162 <title>Command Explanations</title>
163
164 <para>
165 <parameter>--with-*</parameter>: These parameters allow the build system
166 to use system versions of the above libriares. These are required for
167 stability.
168 </para>
169
170 <para>
171 <parameter>--enable-readline</parameter>: This switch enables Readline
172 support in the JS shell.
173 </para>
174
175 <para>
176 <parameter>--disable-jemalloc</parameter>: This switch disables the
177 internal memory allocator used in JS60. jemalloc causes a conflict with glibc.
178 </para>
179
180 </sect2>
181
182 <sect2 role="content">
183 <title>Contents</title>
184
185 <segmentedlist>
186 <segtitle>Installed Programs</segtitle>
187 <segtitle>Installed Libraries</segtitle>
188 <segtitle>Installed Directories</segtitle>
189
190 <seglistitem>
191 <seg>
192 js60 and js60-config
193 </seg>
194 <seg>
195 libmozjs-60.so and libjs_static.ajs <!-- The AJS file doesn't
196 conflict with the one from js52 like originally thought -->
197 </seg>
198 <seg>
199 /usr/include/mozjs-60
200 </seg>
201 </seglistitem>
202 </segmentedlist>
203
204 <variablelist>
205 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
206 <?dbfo list-presentation="list"?>
207 <?dbhtml list-presentation="table"?>
208
209 <varlistentry id="js6-js60">
210 <term><command>js60</command></term>
211 <listitem>
212 <para>
213 provides a command line interface to the
214 <application>JavaScript</application> engine.
215 </para>
216 <indexterm zone="js60 js60">
217 <primary sortas="b-js60">js60</primary>
218 </indexterm>
219 </listitem>
220 </varlistentry>
221
222 <varlistentry id="js60-config">
223 <term><command>js60-config</command></term>
224 <listitem>
225 <para>
226 is used to find the JS compiler and linker flags.
227 </para>
228 <indexterm zone="js60 js60-config">
229 <primary sortas="b-js60-config">js60-config</primary>
230 </indexterm>
231 </listitem>
232 </varlistentry>
233
234 <varlistentry id="libmozjs-60">
235 <term><filename class="libraryfile">libmozjs-60.so</filename></term>
236 <listitem>
237 <para>
238 contains the Mozilla JavaScript API functions.
239 </para>
240 <indexterm zone="js60 libmozjs-60">
241 <primary sortas="c-libmozjs60">libmozjs-60.so</primary>
242 </indexterm>
243 </listitem>
244 </varlistentry>
245 </variablelist>
246 </sect2>
247</sect1>
Note: See TracBrowser for help on using the repository browser.