source: archive/libusb-compat.xml

trunk
Last change on this file was 45ab6c7, checked in by Xi Ruoyao <xry111@…>, 3 months ago

more SVN prop clean up

Remove "$LastChanged$" everywhere, and also some unused $Date$

  • Property mode set to 100644
File size: 4.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libusb-compat-download-http "&sourceforge-dl;/libusb/libusb-compat-&libusb-compat-version;.tar.bz2">
8 <!ENTITY libusb-compat-download-ftp " ">
9 <!ENTITY libusb-compat-md5sum "2780b6a758a1e2c2943bdbf7faf740e4">
10 <!ENTITY libusb-compat-size "276 KB">
11 <!ENTITY libusb-compat-buildsize "2.4 MB">
12 <!ENTITY libusb-compat-time "less than 0.1 SBU">
13]>
14
15<sect1 id="libusb-compat" xreflabel="libusb-compat-&libusb-compat-version;">
16 <?dbhtml filename="libusb-compat.html"?>
17
18 <sect1info>
19 <date>$Date$</date>
20 </sect1info>
21
22 <title>libusb-compat-&libusb-compat-version;</title>
23
24 <indexterm zone="libusb-compat">
25 <primary sortas="a-libusb-compat">libusb-compat</primary>
26 </indexterm>
27
28 <sect2 role="package">
29 <title>Introduction to libusb-compat</title>
30
31 <para>
32 The <application>libusb-compat</application> package aims to look,
33 feel and behave exactly like <application>libusb-0.1</application>. It is a
34 compatibility layer needed by packages that have not been upgraded to the
35 <application>libusb-1.0</application> API.
36 </para>
37
38 &lfs83_checked;
39
40 <bridgehead renderas="sect3">Package Information</bridgehead>
41 <itemizedlist spacing="compact">
42 <listitem>
43 <para>
44 Download (HTTP): <ulink url="&libusb-compat-download-http;"/>
45 </para>
46 </listitem>
47 <listitem>
48 <para>
49 Download (FTP): <ulink url="&libusb-compat-download-ftp;"/>
50 </para>
51 </listitem>
52 <listitem>
53 <para>
54 Download MD5 sum: &libusb-compat-md5sum;
55 </para>
56 </listitem>
57 <listitem>
58 <para>
59 Download size: &libusb-compat-size;
60 </para>
61 </listitem>
62 <listitem>
63 <para>
64 Estimated disk space required: &libusb-compat-buildsize;
65 </para>
66 </listitem>
67 <listitem>
68 <para>
69 Estimated build time: &libusb-compat-time;
70 </para>
71 </listitem>
72 </itemizedlist>
73
74 <bridgehead renderas="sect3">libusb-compat Dependencies</bridgehead>
75
76 <bridgehead renderas="sect4">Required</bridgehead>
77 <para role="required">
78 <xref linkend="libusb"/>
79 </para>
80
81 <para condition="html" role="usernotes">User Notes:
82 <ulink url="&blfs-wiki;/libusb-compat"/>
83 </para>
84 </sect2>
85
86 <sect2 role="installation">
87 <title>Installation of libusb-compat</title>
88
89 <para>
90 Install <application>libusb-compat</application> by running the
91 following commands:
92 </para>
93
94<screen><userinput>./configure --prefix=/usr --disable-static &amp;&amp;
95make</userinput></screen>
96
97 <para>
98 This package does not come with a test suite.
99 </para>
100
101 <para>
102 Now, as the <systemitem class="username">root</systemitem> user:
103 </para>
104
105<screen role="root"><userinput>make install</userinput></screen>
106
107 </sect2>
108
109 <sect2 role="content">
110 <title>Contents</title>
111
112 <segmentedlist>
113 <segtitle>Installed Program</segtitle>
114 <segtitle>Installed Library</segtitle>
115 <segtitle>Installed Directories</segtitle>
116
117 <seglistitem>
118 <seg>libusb-config</seg>
119 <seg>libusb.so</seg>
120 <seg>None</seg>
121 </seglistitem>
122 </segmentedlist>
123
124 <variablelist>
125 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
126 <?dbfo list-presentation="list"?>
127 <?dbhtml list-presentation="table"?>
128
129 <varlistentry id="libusb-config">
130 <term><command>libusb-config</command></term>
131 <listitem>
132 <para>
133 determines the compile and linker flags that should be used to compile
134 and link programs that use <filename class='libraryfile'>libusb</filename>.
135 </para>
136 <indexterm zone="libusb-compat libusb-config">
137 <primary sortas="b-libusb-config">libusb-config</primary>
138 </indexterm>
139 </listitem>
140 </varlistentry>
141
142 <varlistentry id="libusb-compat-lib">
143 <term><filename class='libraryfile'>libusb.so</filename></term>
144 <listitem>
145 <para>
146 is a library that is compatible with
147 <application>libusb-0.1</application>, but uses
148 <application>libusb-1.0</application> to provide functionality.
149 </para>
150 <indexterm zone="libusb-compat libusb-compat-lib">
151 <primary sortas="c-libusb-compat">libusb.so</primary>
152 </indexterm>
153 </listitem>
154 </varlistentry>
155
156 </variablelist>
157
158 </sect2>
159
160</sect1>
Note: See TracBrowser for help on using the repository browser.