source: archive/webkitgtk2.xml-again@ 4af9931

10.0 10.1 11.0 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind lazarus perl-modules qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 4af9931 was 4af9931, checked in by Bruce Dubbs <bdubbs@…>, 5 years ago

Update to shadow-4.4.
Archive WebKitGTK+-2.4.11.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@18258 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 13.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY webkitgtk2-download-http "http://webkitgtk.org/releases/webkitgtk-&webkitgtk2-version;.tar.xz">
8 <!ENTITY webkitgtk2-download-ftp " ">
9 <!ENTITY webkitgtk2-md5sum "24a25ccc30a7914ae50922aedf24b7bc">
10 <!ENTITY webkitgtk2-size "9.5 MB">
11 <!ENTITY webkitgtk2-buildsize "1.5 GB (both built)">
12 <!ENTITY webkitgtk2-time "80 SBU (using parallelism=4, both built, webkitgtk-3.0 takes a little longer than webkitgtk-1.0)">
13]>
14
15<sect1 id="webkitgtk2" xreflabel="WebKitGTK+-&webkitgtk2-version;">
16 <?dbhtml filename="webkitgtk2.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>WebKitGTK+-&webkitgtk2-version;</title>
24
25 <indexterm zone="webkitgtk2">
26 <primary sortas="a-WebKitGTK+">WebKitGTK+</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to WebKitGTK+</title>
31
32 <para>
33 The <application>WebKitGTK+</application> is the port of the portable
34 web rendering engine <application>WebKit</application> to the
35 <application>GTK+ 3</application> and <application>GTK+ 2</application>
36 platforms.
37 </para>
38
39 &lfs7a_checked;
40
41 <bridgehead renderas="sect3">Package Information</bridgehead>
42 <itemizedlist spacing="compact">
43 <listitem>
44 <para>
45 Download (HTTP): <ulink url="&webkitgtk2-download-http;"/>
46 </para>
47 </listitem>
48 <listitem>
49 <para>
50 Download (FTP): <ulink url="&webkitgtk2-download-ftp;"/>
51 </para>
52 </listitem>
53 <listitem>
54 <para>
55 Download MD5 sum: &webkitgtk2-md5sum;
56 </para>
57 </listitem>
58 <listitem>
59 <para>
60 Download size: &webkitgtk2-size;
61 </para>
62 </listitem>
63 <listitem>
64 <para>
65 Estimated disk space required: &webkitgtk2-buildsize;
66 </para>
67 </listitem>
68 <listitem>
69 <para>
70 Estimated build time: &webkitgtk2-time;
71 </para>
72 </listitem>
73 </itemizedlist>
74
75 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
76 <itemizedlist spacing="compact">
77 <listitem>
78 <para>
79 Required patch if using gcc-6 or later
80 <ulink url="&patch-root;/webkitgtk-&webkitgtk2-version;-gcc6-1.patch"/>
81 </para>
82 </listitem>
83 </itemizedlist>
84
85 <bridgehead renderas="sect3">WebKitGTK+ Dependencies</bridgehead>
86
87 <bridgehead renderas="sect4">Required</bridgehead>
88 <para role="required">
89 <xref linkend="gst10-plugins-base"/>,
90 <xref linkend="gtk3"/> or
91 <xref linkend="gtk2"/> or both,
92 <xref linkend="icu"/>,
93 <xref linkend="libgudev"/>,
94 <xref linkend="libsecret"/>,
95 <xref linkend="libsoup"/>,
96 <xref linkend="libwebp"/>,
97 <xref linkend="mesa"/>,
98 <xref linkend="ruby"/>,
99 <xref linkend="sqlite"/> and
100 <xref linkend="which"/>
101 </para>
102
103 <note>
104 <para>
105 Note that WebKit2 links against <application>GTK+ 2</application>
106 (even if <application>GTK+ 3</application> is being used) in order
107 to be able to use NPAPI plugins such as Adobe Flash.
108 </para>
109 </note>
110
111 <bridgehead renderas="sect4">Recommended</bridgehead>
112 <para role="recommended">
113 <xref linkend="enchant"/>,
114 <xref linkend="geoclue2"/> or
115 <xref linkend="geoclue"/>,
116 <xref linkend="gobject-introspection"/> and
117 <xref linkend="hicolor-icon-theme"/>
118 </para>
119
120 <bridgehead renderas="sect4">Optional</bridgehead>
121 <para role="optional">
122 <xref linkend="gtk-doc"/>,
123 <xref linkend="llvm"/> and
124 <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>
125 </para>
126
127 <para condition="html" role="usernotes">
128 User Notes: <ulink url="&blfs-wiki;/webkitgtk"/>
129 </para>
130
131<!-- <caution>
132 <para>
133 The BLFS systemd development team is looking into archiving this
134 package due to ease of maintenance and incompatibility with GCC6.
135 </para>
136 </caution>-->
137
138 </sect2>
139
140 <sect2 role="installation">
141 <title>Installation of WebKitGTK+</title>
142
143 <para>
144 If you have not installed <xref linkend="gtk-doc"/>, fix a bug that will
145 cause <command>make install</command> to fail:
146 </para>
147
148<screen><userinput>sed -i '/generate-gtkdoc --rebase/s:^:# :' GNUmakefile.in</userinput></screen>
149
150 <para>
151 Fix a couple of compiler issues when built with GCC-6.1:
152 </para>
153
154<screen><userinput>patch -Np1 -i ../webkitgtk-&webkitgtk2-version;-gcc6-1.patch</userinput></screen>
155
156 <note>
157 <para>
158 Unless noted otherwise, the packages depending on this package
159 expect it to be built against <application>GTK+ 3</application>.
160 </para>
161 </note>
162
163 <para>
164 To build <application>WebKitGTK+</application> against
165 <application>GTK+ 3</application>, run the following
166 commands:
167 </para>
168
169<screen><userinput>mkdir build3 &amp;&amp;
170pushd build3 &amp;&amp;
171CFLAGS="-fno-delete-null-pointer-checks" \
172CXXFLAGS="-fno-delete-null-pointer-checks" \
173../configure --prefix=/usr --enable-introspection &amp;&amp;
174make &amp;&amp;
175popd</userinput></screen>
176
177 <para>
178 To build <application>WebKitGTK+</application> against
179 <application>GTK+ 2</application>, run the following
180 commands:
181 </para>
182
183<screen><userinput>mkdir build2 &amp;&amp;
184pushd build2 &amp;&amp;
185CFLAGS="-fno-delete-null-pointer-checks" \
186CXXFLAGS="-fno-delete-null-pointer-checks" \
187../configure --prefix=/usr --with-gtk=2.0 --disable-webkit2 &amp;&amp;
188make &amp;&amp;
189popd</userinput></screen>
190
191 <para>
192 This package does not have a working testsuite. However, there are two
193 useable basic graphical web browsers in the build directory,
194 <application>Programs/GtkLauncher</application> and
195 <application>Programs/MiniBrowser</application>. If launching any one
196 fails, there is a problem with the build.
197 </para>
198
199 <para>
200 If you have built the package against <application>GTK+ 3</application>,
201 install it by running the following commands as the <systemitem
202 class="username">root</systemitem> user:
203 </para>
204
205<screen role="root"><userinput>make -C build3 install &amp;&amp;
206rm -rf /usr/share/gtk-doc/html/webkit{,dom}gtk-3.0 &amp;&amp;
207if [ -e /usr/share/gtk-doc/html/webkitdomgtk ]; then
208 mv -v /usr/share/gtk-doc/html/webkitdomgtk{,-3.0}
209fi
210if [ -e /usr/share/gtk-doc/html/webkitgtk ]; then
211 mv -v /usr/share/gtk-doc/html/webkitgtk{,-3.0}
212fi</userinput></screen>
213
214 <para>
215 If you have built the package against <application>GTK+ 2</application>,
216 install it by running the following commands as the <systemitem
217 class="username">root</systemitem> user:
218 </para>
219
220<screen role="root"><userinput>make -C build2 install &amp;&amp;
221rm -rf /usr/share/gtk-doc/html/webkit{,dom}gtk-1.0 &amp;&amp;
222if [ -e /usr/share/gtk-doc/html/webkitdomgtk ]; then
223 mv -v /usr/share/gtk-doc/html/webkitdomgtk{,-1.0}
224fi
225if [ -e /usr/share/gtk-doc/html/webkitgtk ]; then
226 mv -v /usr/share/gtk-doc/html/webkitgtk{,-1.0}
227fi</userinput></screen>
228
229 </sect2>
230
231 <sect2 role="commands">
232 <title>Command Explanations</title>
233
234 <para>
235 <parameter>--enable-introspection</parameter>: This switch enables
236 <application>Gobject Introspection</application> bindings and is
237 required if building <application>GNOME</application> Desktop.
238 Remove if you don't have <application>Gobject
239 Introspection</application> installed or you don't want to install
240 <application>GNOME</application>. It is not needed if building
241 against <application>GTK+ 2</application>, although it can be used
242 if desired.
243 </para>
244
245 <para>
246 <parameter>--with-gtk=2.0 --disable-webkit2</parameter>: These switches
247 force <application>WebKitGTK+</application> to compile against
248 <application>GTK+ 2</application>, even if
249 <application>GTK+ 3</application> is also installed.
250 </para>
251
252 <para>
253 <option>--disable-geolocation</option>: Use this switch if you don't
254 want to install <xref linkend="geoclue"/> or
255 <xref linkend="geoclue2"/>.
256 </para>
257
258 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
259 href="../../xincludes/gtk-doc-rebuild.xml"/>
260
261 </sect2>
262
263 <sect2 role="content">
264 <title>Contents</title>
265
266 <segmentedlist>
267 <segtitle>Installed Programs</segtitle>
268 <segtitle>Installed Libraries</segtitle>
269 <segtitle>Installed Directories</segtitle>
270
271 <seglistitem>
272 <seg>
273 jsc-3 <emphasis>or</emphasis> jsc-1
274 </seg>
275 <seg>
276 libjavascriptcoregtk-3.0.so,
277 libwebkit2gtk-3.0.so and
278 libwebkitgtk-3.0.so <emphasis>or</emphasis>
279 libjavascriptcoregtk-1.0.so and
280 libwebkitgtk-1.0.so
281 </seg>
282 <seg>
283 /usr/include/webkitgtk-3.0,
284 /usr/lib/webkit2gtk-3.0,
285 /usr/share/gtk-doc/html/webkitgtk-3.0,
286 /usr/share/gtk-doc/html/webkitdomgtk-3.0,
287 /usr/share/gtk-doc/html/webkit2gtk and
288 /usr/share/webkitgtk-3.0 <emphasis>or</emphasis>
289 /usr/include/webkit-1.0,
290 /usr/share/gtk-doc/html/webkitgtk-1.0,
291 /usr/share/gtk-doc/html/webkitdomgtk-1.0 and
292 /usr/share/webkit-1.0
293 </seg>
294 </seglistitem>
295 </segmentedlist>
296
297 <variablelist>
298 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
299 <?dbfo list-presentation="list"?>
300 <?dbhtml list-presentation="table"?>
301
302 <varlistentry id="jsc-3">
303 <term><command>jsc-3</command></term>
304 <listitem>
305 <para>
306 is a command-line utility that allows you to run JavaScript programs
307 outside of the context of a web browser linked against
308 <filename class="libraryfile">libjavascriptcoregtk-3.0.so</filename>.
309 </para>
310 <indexterm zone="webkitgtk2 jsc-3">
311 <primary sortas="b-jsc-3">jsc-3</primary>
312 </indexterm>
313 </listitem>
314 </varlistentry>
315
316 <varlistentry id="jsc-1">
317 <term><command>jsc-1</command></term>
318 <listitem>
319 <para>
320 is a command-line utility that allows you to run JavaScript programs
321 outside of the context of a web browser linked against
322 <filename class="libraryfile">libjavascriptcoregtk-1.0.so</filename>.
323 </para>
324 <indexterm zone="webkitgtk2 jsc-1">
325 <primary sortas="b-jsc-1">jsc-1</primary>
326 </indexterm>
327 </listitem>
328 </varlistentry>
329
330 <varlistentry id="libjavascriptcoregtk-3.0">
331 <term><filename
332 class="libraryfile">libjavascriptcoregtk-3.0.so</filename></term>
333 <listitem>
334 <para>
335 contains core JavaScript API functions used by <command>jsc-3</command>
336 and <filename class="libraryfile">libwebkitgtk-3.0.so</filename>.
337 </para>
338 <indexterm zone="webkitgtk2 libjavascriptcoregtk-3.0">
339 <primary sortas="c-libjavascriptcoregtk-3.0">libjavascriptcoregtk-3.0.so</primary>
340 </indexterm>
341 </listitem>
342 </varlistentry>
343
344 <varlistentry id="libwebkitgtk-3.0">
345 <term><filename class="libraryfile">libwebkitgtk-3.0.so</filename></term>
346 <listitem>
347 <para>
348 contains the <application>WebKitGTK+</application> API functions for
349 <application>GTK+ 3</application>.
350 </para>
351 <indexterm zone="webkitgtk2 libwebkitgtk-3.0">
352 <primary sortas="c-libwebkitgtk-3.0">libwebkitgtk-3.0.so</primary>
353 </indexterm>
354 </listitem>
355 </varlistentry>
356
357 <varlistentry id="libwebkit2gtk-3.0">
358 <term><filename class="libraryfile">libwebkit2gtk-3.0.so</filename></term>
359 <listitem>
360 <para>
361 contains the <application>WebKit2</application> API functions.
362 </para>
363 <indexterm zone="webkitgtk2 libwebkit2gtk-3.0">
364 <primary sortas="c-libwebkit2gtk-3.0">libwebkit2gtk-3.0.so</primary>
365 </indexterm>
366 </listitem>
367 </varlistentry>
368
369 <varlistentry id="libjavascriptcoregtk-1.0">
370 <term><filename
371 class="libraryfile">libjavascriptcoregtk-1.0.so</filename></term>
372 <listitem>
373 <para>
374 contains core JavaScript API functions used by <command>jsc-1</command>
375 and <filename class="libraryfile">libwebkitgtk-1.0.so</filename>.
376 </para>
377 <indexterm zone="webkitgtk2 libjavascriptcoregtk-1.0">
378 <primary sortas="c-libjavascriptcoregtk-1.0">libjavascriptcoregtk-1.0.so</primary>
379 </indexterm>
380 </listitem>
381 </varlistentry>
382
383 <varlistentry id="libwebkitgtk-1.0">
384 <term><filename class="libraryfile">libwebkitgtk-1.0.so</filename></term>
385 <listitem>
386 <para>
387 contains the <application>WebKitGTK+</application> API functions for
388 <application>GTK+ 2</application>.
389 </para>
390 <indexterm zone="webkitgtk2 libwebkitgtk-1.0">
391 <primary sortas="c-libwebkitgtk-1.0">libwebkitgtk-1.0.so</primary>
392 </indexterm>
393 </listitem>
394 </varlistentry>
395
396 </variablelist>
397
398 </sect2>
399
400</sect1>
Note: See TracBrowser for help on using the repository browser.