source: general.ent@ 2e15af7

10.0 10.1 11.0 11.1 11.2 7.10 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind lazarus nosym perl-modules plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since 2e15af7 was 2e15af7, checked in by Ken Moffat <ken@…>, 6 years ago

Reinstate building firefox as a normal user, removed in error.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@17503 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.8 KB
Line 
1<!-- $LastChangedBy$ $Date$ -->
2
3<!ENTITY day "16"> <!-- Always 2 digits -->
4<!ENTITY month "06"> <!-- Always 2 digits -->
5<!ENTITY year "2016">
6<!ENTITY copyrightdate "2001-&year;">
7<!ENTITY copyholder "The BLFS Development Team">
8<!ENTITY version "&year;-&month;-&day;">
9<!ENTITY releasedate "June 16th &year;">
10<!ENTITY pubdate "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
11<!ENTITY blfs-version "svn"> <!-- svn|[release #] -->
12<!ENTITY lfs-version "development"> <!-- x.y|development -->
13<!ENTITY lfs-versiond "systemd"> <!-- x.y-systemd|systemd -->
14<!ENTITY last-commit "$Date$"> <!-- Automatic update -->
15<!ENTITY lfs-domainname "linuxfromscratch.org">
16
17<!ENTITY maintainer-fullname "The BLFS Team">
18<!ENTITY maintainer-firstname "BLFS">
19<!ENTITY maintainer-address "blfs-maintainer@&lfs-domainname;">
20
21
22<!ENTITY lfs-website "http://www.&lfs-domainname;">
23<!-- downloads_root must have an entity because it is needed for scripts
24 change svn to x.y for release. Note: s/_/-/ in comment to avoid grep error -->
25<!ENTITY downloads-root "http://www.linuxfromscratch.org/blfs/downloads/svn">
26<!ENTITY downloads-project "http://downloads.&lfs-domainname;">
27
28<!ENTITY sources-anduin-http "http://anduin.linuxfromscratch.org/BLFS">
29<!ENTITY sources-anduin-ftp "ftp://anduin.linuxfromscratch.org/BLFS">
30
31<!ENTITY hints-root "http://www.&lfs-domainname;/hints">
32<!ENTITY patch-downloads "http://www.linuxfromscratch.org/patches/downloads">
33<!ENTITY patch-root "http://www.&lfs-domainname;/patches/blfs/svn">
34<!ENTITY errata "http://www.&lfs-domainname;/blfs/errata/&blfs-version;/">
35<!ENTITY blfs-ticket-root "http://wiki.&lfs-domainname;/blfs/ticket/">
36
37<!ENTITY lfs-root "../../../../lfs/view/&lfs-version;">
38<!ENTITY lfs-rootd "../../../../lfs/view/&lfs-versiond;">
39<!ENTITY lfs-dev "../../../../lfs/view/development">
40<!ENTITY kernel "http://www.kernel.org/pub/">
41<!ENTITY gstreamer-dl "http://gstreamer.freedesktop.org/src">
42<!ENTITY gnu-alpha-ftp "ftp://alpha.gnu.org/gnu/">
43<!ENTITY gnu-alpha-http "http://alpha.gnu.org/gnu/">
44<!ENTITY sourceforge-repo "http://downloads.sourceforge.net">
45<!ENTITY sourceforge-repo2 "http://sourceforge.net">
46<!ENTITY gentoo-ftp-repo "ftp://mirror.ovh.net/gentoo-distfiles/distfiles">
47<!ENTITY fedora-http-repo "http://pkgs.fedoraproject.org/repo/pkgs">
48<!ENTITY jaist-ftp-repo "ftp://ftp.jaist.ac.jp/pub//sourceforge">
49<!ENTITY lxqt-http-repo "http://downloads.lxqt.org/lxqt">
50<!ENTITY publisher "Unknown">
51<!--<!ENTITY xorg-download-http "http://xorg.freedesktop.org/archive/individual">-->
52<!ENTITY xorg-download-http "http://ftp.x.org/pub/individual">
53<!ENTITY xorg-download-ftp "ftp://ftp.x.org/pub/individual">
54<!ENTITY mozilla-http "https://ftp.mozilla.org/pub/mozilla.org">
55<!ENTITY mozilla-ftp "ftp://ftp.mozilla.org/pub">
56
57<!-- These entities are used to identify versions of LFS
58 packages referenced throughout the BLFS book. -->
59<!ENTITY lfs-autoconf-version "2.69">
60<!ENTITY lfs-coreutils-version "8.23">
61<!ENTITY lfs-e2fsprogs-version "1.42.11">
62<!ENTITY lfs-flex-version "2.5.39">
63<!ENTITY lfs-gcc-version "4.9.1">
64<!ENTITY lfs-gdbm-version "1.11">
65<!ENTITY lfs-m4-version "1.4.17">
66<!-- this was originally the perl version used by the corresponding
67 version of lfs, in those days always for i686, but now BLFS is a rolling
68 release -->
69<!ENTITY lfs-perl-version "&lt;5.x.y&gt;/&lt;arch-linux&gt;">
70<!ENTITY lfs-shadow-version "4.2.1">
71<!ENTITY lfs-vim-version "7.4">
72<!-- End LFS versions -->
73
74<!ENTITY blfs-bootscripts-version "20160415">
75<!ENTITY systemd-units-version "20160602">
76
77
78<!ENTITY blfs-wiki "http://wiki.&lfs-domainname;/blfs/wiki">
79
80<!-- These entities are used to annotate the current status of a package as it
81 relates to the version of LFS it will build/work against -->
82<!ENTITY lfs79_checked "<para>This package is known to build and work
83 properly using an LFS-7.9 platform.</para>">
84<!ENTITY lfs79_built "<para>This package is known to build using an LFS
85 7.9 platform but has not been tested.</para>">
86
87<!-- usage: <para>&lfssvn_checked;ccyymmdd&lfssvn_checked2;</para> -->
88<!ENTITY lfssvn_checked "This package is known to build and work properly
89 using an LFS-SVN-">
90<!ENTITY lfssvn_checked2 " platform.">
91<!ENTITY lfssvn_built "This package is known to build using an LFS-SVN-">
92<!ENTITY lfssvn_built2 " platform but has not been tested.">
93<!-- End special entities about LFS compatibility -->
94
95<!ENTITY as_root "<note><para>When installing multiple packages in a script,
96 the installation needs to be done as the root user. There are three general
97 options that can be used to do this:</para>
98
99 <orderedlist>
100
101 <listitem><para>Run the entire script as the root user (not
102 recommended).</para></listitem>
103
104 <listitem><para>Use the <command>sudo</command> command from the <xref
105 linkend='sudo'/> package.</para></listitem>
106
107 <listitem><para>Use <command>su -c &quot;command arguments&quot;</command>
108 (quotes required) which will ask for the root password for every iteration
109 of the loop.</para></listitem>
110
111 </orderedlist>
112
113 <para>One way to handle this situation is to create a short
114 <command>bash</command> function that automatically selects the appropriate
115 method. Once the command is set in the environment, it does not need to be
116 set again.</para>
117
118 <screen><userinput>as_root()
119{
120 if [ $EUID = 0 ]; then $*
121 elif [ -x /usr/bin/sudo ]; then sudo $*
122 else su -c \\&quot;$*\\&quot;
123 fi
124}
125
126export -f as_root</userinput></screen>
127</note>">
128
129<!ENTITY not-katamari "<para>This package is not a part of the Xorg
130 katamari and is provided only as a dependency to
131 other packages or for testing the completed Xorg
132 installation.</para>">
133
134<!-- Problem with some packages introduced by a given dependency version -->
135<!ENTITY gcc-490 "gcc-4.9.0">
136
137<!ENTITY gcc6_checked "<para>This package is known to build
138 properly using the gcc-6 compiler.</para>">
139
140<!ENTITY % package-entities SYSTEM "packages.ent">
141%package-entities;
142
143<!ENTITY parallel_issues "<note><para>This package may occasionally fail when
144 building with multiple processors. See <xref
145 linkend='parallel-builds'/> for more information.</para></note>">
146
Note: See TracBrowser for help on using the repository browser.