source: general.ent@ bb7f58e

10.0 10.1 11.0 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since bb7f58e was bb7f58e, checked in by Krejzi <krejzi@…>, 9 years ago

Xorg packages and xml updates.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@10911 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 40.6 KB
Line 
1<!--
2$LastChangedBy$
3$Date$
4-->
5
6<!ENTITY day "30"> <!-- Always 2 digits -->
7<!ENTITY month "12"> <!-- Always 2 digits -->
8<!ENTITY year "2012">
9<!ENTITY copyrightdate "2001-&year;">
10<!ENTITY copyholder "The BLFS Development Team">
11<!ENTITY version "&year;-&month;-&day;">
12<!ENTITY releasedate "December 30th, &year;">
13<!ENTITY pubdate "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
14<!ENTITY blfs-version "svn"> <!-- svn|[release #] -->
15<!ENTITY lfs-version "development"> <!-- version|testing|unstable|development] -->
16<!ENTITY last-commit "$Date$"> <!-- Automatic update -->
17<!ENTITY lfs-domainname "linuxfromscratch.org">
18
19<!ENTITY maintainer-fullname "The BLFS Team">
20<!ENTITY maintainer-firstname "BLFS">
21<!ENTITY maintainer-address "blfs-maintainer@&lfs-domainname;">
22
23<!ENTITY downloads-root "http://www.linuxfromscratch.org/blfs/downloads/svn">
24<!ENTITY downloads-project "http://downloads.&lfs-domainname;">
25<!ENTITY sources-anduin-http "http://anduin.&lfs-domainname;/sources/BLFS/svn">
26<!ENTITY sources-anduin-ftp "ftp://anduin.&lfs-domainname;/BLFS/svn">
27<!ENTITY sources-anduin-other "ftp://anduin.&lfs-domainname;/other">
28<!ENTITY files-anduin "http://anduin.&lfs-domainname;/files/BLFS/svn">
29<!ENTITY hints-root "http://www.&lfs-domainname;/hints">
30<!ENTITY patch-downloads "http://www.linuxfromscratch.org/patches/downloads">
31<!ENTITY patch-root "http://www.&lfs-domainname;/patches/blfs/svn">
32<!ENTITY errata "http://www.&lfs-domainname;/blfs/errata/&blfs-version;/">
33<!ENTITY blfs-ticket-root "http://wiki.&lfs-domainname;/blfs/ticket/">
34<!-- <!ENTITY lfs-root "http://www.&lfs-domainname;/lfs/view/&lfs-version;"> -->
35<!ENTITY lfs-root "../../../../lfs/view/&lfs-version;">
36<!ENTITY lfs-dev "../../../../lfs/view/development">
37<!ENTITY kernel "http://www.kernel.org/pub/">
38<!ENTITY gstreamer-dl "http://gstreamer.freedesktop.org/src">
39<!ENTITY gnu-alpha-ftp "ftp://alpha.gnu.org/gnu/">
40<!ENTITY gnu-alpha-http "http://alpha.gnu.org/gnu/">
41<!ENTITY sourceforge-repo "http://downloads.sourceforge.net">
42<!ENTITY sourceforge-repo2 "http://sourceforge.net">
43<!ENTITY gentoo-ftp-repo "ftp://mirror.ovh.net/gentoo-distfiles/distfiles">
44<!ENTITY trinity-repo-ftp "ftp://anduin.&lfs-domainname;/trinity">
45<!ENTITY trinity-repo-http "http://anduin.&lfs-domainname;/sources/trinity">
46<!ENTITY publisher "Unknown">
47<!ENTITY xorg-download-http "http://xorg.freedesktop.org/releases/individual">
48<!ENTITY xorg-download-ftp "ftp://ftp.x.org/pub/individual">
49<!ENTITY mozilla-http "http://releases.mozilla.org/pub/mozilla.org">
50<!ENTITY mozilla-ftp "ftp://ftp.mozilla.org/pub/mozilla.org">
51
52<!-- These entities are used to identify versions of LFS
53 packages referenced throughout the BLFS book. -->
54<!ENTITY lfs-autoconf-version "2.67">
55<!ENTITY lfs-coreutils-version "8.5">
56<!ENTITY lfs-e2fsprogs-version "1.41.12">
57<!ENTITY lfs-flex-version "2.5.35">
58<!ENTITY lfs-gcc-version "4.7.2">
59<!ENTITY lfs-gdbm-version "1.8.3">
60<!ENTITY lfs-m4-version "1.4.14">
61<!-- this was originally the perl version used by the corresponding
62 version of lfs, in those days always for i686, but now BLFS is a rolling
63 release -->
64<!ENTITY lfs-perl-version "&lt;5.x.y&gt;/&lt;arch-linux&gt;">
65<!ENTITY lfs-shadow-version "4.1.5">
66<!ENTITY lfs-vim-version "7.3">
67<!-- End LFS versions -->
68
69<!ENTITY blfs-bootscripts-version "20120828">
70<!ENTITY blfs-bootscripts-download "&downloads-root;/blfs-bootscripts-&blfs-bootscripts-version;.tar.bz2">
71
72<!ENTITY blfs-wiki "http://wiki.&lfs-domainname;/blfs/wiki">
73
74<!-- These entities are used to annotate the current status of a package as it
75 relates to the version of LFS it will build/work against -->
76<!ENTITY lfs65_checked "<para>This package is known to build and work
77 properly using an LFS-6.5 platform.</para>">
78<!ENTITY lfs65_built "<para>This package is known to build using an LFS
79 6.5 platform but has not been tested.</para>">
80<!ENTITY lfs65_needs_update "<para>This package is known to build and work
81 properly using an LFS-6.5 platform if you use
82 current package sources. See <xref
83 linkend='package_updates'/> for more
84 information.</para>">
85<!ENTITY lfs66_checked "<para>This package is known to build and work
86 properly using an LFS-6.6 platform.</para>">
87<!ENTITY lfs66_built "<para>This package is known to build using an LFS
88 6.6 platform but has not been tested.</para>">
89<!ENTITY lfs67_checked "<para>This package is known to build and work
90 properly using an LFS-6.7 platform.</para>">
91<!ENTITY lfs67_built "<para>This package is known to build using an LFS
92 6.7 platform but has not been tested.</para>">
93<!ENTITY lfs68_checked "<para>This package is known to build and work
94 properly using an LFS-6.8 platform.</para>">
95<!ENTITY lfs68_built "<para>This package is known to build using an LFS
96 6.8 platform but has not been tested.</para>">
97<!ENTITY lfs70_checked "<para>This package is known to build and work
98 properly using an LFS-7.0 platform.</para>">
99<!ENTITY lfs70_built "<para>This package is known to build using an LFS
100 7.0 platform but has not been tested.</para>">
101<!ENTITY lfs71_checked "<para>This package is known to build and work
102 properly using an LFS-7.1 platform.</para>">
103<!ENTITY lfs71_built "<para>This package is known to build using an LFS
104 7.1 platform but has not been tested.</para>">
105<!ENTITY lfs72_checked "<para>This package is known to build and work
106 properly using an LFS-7.2 platform.</para>">
107<!ENTITY lfs72_built "<para>This package is known to build using an LFS
108 7.2 platform but has not been tested.</para>">
109
110<!-- usage: <para>&lfssvn_checked;ccyymmdd&lfssvn_checked2;</para> -->
111<!ENTITY lfssvn_checked "This package is known to build and work properly
112 using an LFS-SVN-">
113<!ENTITY lfssvn_checked2 " platform.">
114<!ENTITY lfssvn_built "This package is known to build using an LFS-SVN-">
115<!ENTITY lfssvn_built2 " platform but has not been tested.">
116<!-- End special entities about LFS compatibility -->
117
118<!ENTITY as_root "<note><para>When installing multiple packages in a script,
119 the installation needs to be done as the root user. There are three general
120 options that can be used to do this:</para>
121
122 <orderedlist>
123
124 <listitem><para>Run the entire script as the root user (not
125 recommended).</para></listitem>
126
127 <listitem><para>Use the <command>sudo</command> command from the <xref
128 linkend='sudo'/> package.</para></listitem>
129
130 <listitem><para>Use <command>su -c &quot;command arguments&quot;</command>
131 (quotes required) which will ask for the root password for every iteration
132 of the loop.</para></listitem>
133
134 </orderedlist>
135
136 <para>One way to handle this situation is to create a short
137 <command>bash</command> function that automatically selects the appropriate
138 method. Once the command is set in the environment, it does not need to be
139 set again.</para>
140
141 <screen><userinput>as_root()
142{
143 if [ $EUID = 0 ]; then $*
144 elif [ -x /usr/bin/sudo ]; then sudo $*
145 else su -c \\&quot;$*\\&quot;
146 fi
147}
148
149export -f as_root</userinput></screen>
150</note>">
151
152<!ENTITY not-katamari "<para>This package is not a part of the Xorg
153 katamari and is provided only as a dependency to
154 other packages or for testing the completed Xorg
155 installation.</para>">
156
157<!ENTITY gst-compat "<note><para><application>GStreamer</application> 1.0 series
158 is not API or ABI compatible with
159 <application>GStreamer</application> 0.10 series and both
160 can be installed on the same system.</para></note>">
161
162<!-- Part II -->
163<!-- Chapter 3 -->
164<!ENTITY initd-tools-version "0.1.3">
165<!ENTITY lsb-release-version "1.4">
166
167<!-- Chapter 4 -->
168
169<!ENTITY acl-version "2.2.51">
170<!ENTITY attr-version "2.4.46">
171<!ENTITY consolekit-version "0.4.6">
172<!ENTITY cracklib-version "2.8.19">
173<!ENTITY cyrus-sasl-version "2.1.25">
174<!ENTITY gnupg-version "1.4.12">
175<!ENTITY gnupg2-version "2.0.19">
176<!ENTITY gnutls-version "3.1.5">
177<!ENTITY gpgme-version "1.3.2">
178<!ENTITY iptables-version "1.4.16.2">
179<!ENTITY libcap2-version "2.22">
180<!ENTITY liboauth-version "1.0.0">
181<!ENTITY libpwquality-version "1.2.0">
182<!ENTITY linux-pam-version "1.1.6">
183<!ENTITY mitkrb-version "1.10.3">
184<!ENTITY nettle-version "2.5">
185<!ENTITY nss-major-version "14">
186<!ENTITY nss-minor-version "0">
187<!ENTITY nss-version "3.&nss-major-version;">
188<!ENTITY openssh-version "6.1p1">
189<!ENTITY openssl-version "1.0.1c">
190<!ENTITY p11-kit-version "0.14">
191<!ENTITY polkit-version "0.109">
192<!ENTITY shadow-version "4.1.5.1">
193<!ENTITY stunnel-version "4.54">
194<!ENTITY sudo-version "1.8.6p3">
195<!ENTITY tripwire-version "2.4.2.2">
196
197<!-- Chapter 5 -->
198<!ENTITY fuse-version "2.9.2">
199<!ENTITY jfsutils-version "1.1.15">
200<!ENTITY lvm2-version "2.02.98">
201<!ENTITY mdadm-version "3.2.6">
202<!ENTITY ntfs-3g-version "2012.1.15">
203<!ENTITY reiser-version "3.6.21">
204<!ENTITY sshfs-fuse-version "2.4">
205<!ENTITY xfsprogs-version "3.1.8">
206
207<!-- Chapter 6 -->
208<!ENTITY bluefish-version "2.2.3">
209<!ENTITY ed-version "1.6">
210<!ENTITY emacs-version "24.2">
211<!ENTITY joe-version "3.7">
212<!ENTITY nano-version "2.3.1">
213<!ENTITY vim-version "7.3">
214
215<!-- Chapter 7 -->
216<!ENTITY dash-version "0.5.7">
217<!ENTITY tcsh-version "6.18.01">
218<!ENTITY zsh-version "5.0.0">
219
220<!-- Chapter 8 Virtualization -->
221<!ENTITY qemu-kvm-version "1.2.0">
222
223<!-- Part III -->
224<!-- Chapter 9 -->
225<!ENTITY apr-version "1.4.6">
226<!ENTITY aspell-version "0.60.6.1">
227
228<!ENTITY boost-major "1">
229<!ENTITY boost-minor "52">
230<!ENTITY boost-patch "0">
231<!ENTITY boost-version "&boost-major;.&boost-minor;.&boost-patch;">
232<!ENTITY boost-dl-version "&boost-major;_&boost-minor;_&boost-patch;">
233
234<!ENTITY enchant-version "1.6.0">
235<!ENTITY exempi-version "2.2.0">
236<!ENTITY expat-version "2.1.0">
237<!ENTITY gamin-version "0.1.10">
238<!ENTITY glib2-version "2.34.3">
239<!ENTITY glibmm-version "2.34.1">
240<!ENTITY gmime-version "2.6.13">
241<!ENTITY gobject-introspection-version "1.34.2">
242<!ENTITY gsl-version "1.15">
243
244<!ENTITY icu-major "50">
245<!ENTITY icu-minor "1">
246<!ENTITY icu-patch "1">
247<!ENTITY icu-version "&icu-major;.&icu-minor;.&icu-patch;">
248<!ENTITY icu-dl-version "&icu-major;_&icu-minor;_&icu-patch;">
249
250<!ENTITY iso-codes-version "3.40">
251<!ENTITY json-c-version "0.9">
252<!ENTITY json-glib-version "0.15.2">
253<!ENTITY keyutils-version "1.5.5">
254<!ENTITY libassuan-version "2.0.3">
255<!ENTITY libatasmart-version "0.19">
256<!ENTITY libatomic_ops-version "7.2d">
257<!ENTITY libcroco-version "0.6.8">
258<!ENTITY libdaemon-version "0.14">
259<!ENTITY libdbusmenu-qt-version "0.9.2">
260<!ENTITY libdrm-version "2.4.40">
261<!ENTITY libesmtp-version "1.0.6">
262<!ENTITY libffi-version "3.0.11">
263<!ENTITY libgcrypt-version "1.5.0">
264<!ENTITY libglade-version "2.6.4">
265<!ENTITY libgpg-error-version "1.10">
266<!ENTITY libgsf-version "1.14.25">
267<!ENTITY libical-version "0.48">
268<!ENTITY libidl-version "0.8.14">
269<!ENTITY libidn-version "1.25">
270<!ENTITY libksba-version "1.3.0">
271<!ENTITY libsigc-version "2.2.11">
272<!ENTITY libtasn1-version "3.2">
273<!ENTITY libunique-version "3.0.2">
274<!ENTITY libunistring-version "0.9.3">
275<!ENTITY libusb-version "1.0.9">
276<!ENTITY libusb-compat-version "0.1.4">
277<!ENTITY libxml2-version "2.9.0">
278<!ENTITY libxslt-version "1.1.28">
279<!ENTITY LZO-version "2.06">
280<!ENTITY mtdev-version "1.1.3">
281<!ENTITY nspr-version "4.9.4">
282<!ENTITY openobex-version "1.6">
283<!ENTITY pcre-version "8.32">
284<!ENTITY popt-version "1.16">
285<!ENTITY pth-version "2.0.7">
286<!ENTITY ptlib-version "2.10.9">
287<!ENTITY qca-version "2.0.3">
288<!ENTITY slib-version "3b3">
289<!ENTITY talloc-version "2.0.7">
290<!ENTITY telepathy-farstream-version "0.6.0">
291<!ENTITY telepathy-glib-version "0.20.1">
292<!ENTITY telepathy-logger-version "0.6.0">
293<!ENTITY telepathy-mission-control-version "5.14.0">
294<!ENTITY wv-version "1.2.9">
295
296<!-- Chapter 10 -->
297<!ENTITY aalib-version "1.4rc5">
298<!ENTITY babl-version "0.1.10">
299<!ENTITY exiv2-version "0.23">
300<!ENTITY freetype2-version "2.4.11">
301<!ENTITY fontconfig-version "2.10.2">
302<!ENTITY fribidi-version "0.19.5">
303<!ENTITY gegl-version "0.2.0">
304<!ENTITY giflib-version "4.1.6">
305<!ENTITY harfbuzz-version "0.9.9">
306<!ENTITY ijs-version "0.35">
307<!ENTITY imlib2-version "1.4.5">
308<!ENTITY jasper-version "1.900.1">
309<!ENTITY lcms-version "1.19">
310<!ENTITY lcms2-version "2.4">
311<!ENTITY libart_lgpl-version "2.3.21">
312<!ENTITY libexif-version "0.6.21">
313<!ENTITY libjpeg-version "8d">
314<!ENTITY libmng-version "1.0.10">
315<!ENTITY libpng-version "1.5.13">
316<!ENTITY librsvg-version "2.36.4">
317<!ENTITY libtiff-version "4.0.3">
318<!ENTITY openjpeg-version "1.5.1">
319<!ENTITY pixman-version "0.28.2">
320<!ENTITY poppler-version "0.22.0">
321<!ENTITY qpdf-version "3.0.2">
322
323<!-- Chapter 11 -->
324<!ENTITY apr-util-version "1.5.1">
325<!ENTITY bc-version "1.06.95">
326<!ENTITY compface-version "1.5.2">
327<!ENTITY desktop-file-utils-version "0.21">
328<!ENTITY gperf-version "3.0.4">
329<!ENTITY graphviz-version "2.28.0">
330<!ENTITY gtk-doc-version "1.18">
331<!ENTITY hd2u-version "1.0.3">
332<!ENTITY icon-naming-utils-version "0.8.90">
333<!ENTITY imagemagick-version "6.7.9">
334<!ENTITY intltool-version "0.50.2">
335<!ENTITY libiodbc-version "3.52.8">
336<!ENTITY pinentry-version "0.8.2">
337<!ENTITY rarian-version "0.8.1">
338<!ENTITY recode-version "3.6">
339<!ENTITY rep-gtk-version "0.90.8.1">
340<!ENTITY rxvt-unicode-version "9.15">
341<!ENTITY screen-version "4.0.3">
342<!ENTITY sharutils-version "4.11.1">
343<!ENTITY spidermonkey-version "1.0.0">
344<!ENTITY tidy-version "cvs_20101110">
345<!ENTITY unixodbc-version "2.3.1">
346<!ENTITY xscreensaver-version "5.20">
347
348<!-- Chapter 12 -->
349<!ENTITY apache-ant-version "1.8.4">
350<!ENTITY at-version "3.1.13">
351<!ENTITY autofs-version "5.0.7">
352<!ENTITY bluez-version "4.101">
353<!ENTITY colord-version "0.1.26">
354<!ENTITY cpio-version "2.11">
355<!ENTITY dbus-version "1.6.8">
356<!ENTITY dbus-glib-version "0.100">
357<!ENTITY dbus-python-version "1.1.1">
358<!ENTITY eject-version "2.1.5">
359<!ENTITY fcron-version "3.0.6">
360<!ENTITY gpm-version "1.20.7">
361<!ENTITY hdparm-version "9.42">
362<!ENTITY ibus-version "1.4.99.20121109">
363<!ENTITY libarchive-version "3.0.4">
364<!ENTITY lm_sensors-version "3.3.2">
365<!ENTITY mc-version "4.8.6">
366<!ENTITY obex-data-server-version "0.4.6">
367<!ENTITY obexd-version "0.47">
368<!ENTITY parted-version "3.1">
369<!ENTITY pciutils-version "3.1.10">
370<!ENTITY raptor-version "2.0.8">
371<!ENTITY rasqal-version "0.9.29">
372<!ENTITY redland-version "1.0.15">
373<!ENTITY sg3_utils-version "1.34">
374<!ENTITY strigi-version "0.7.7">
375<!ENTITY sysstat-version "10.0.5">
376<!ENTITY udev-version "Installed LFS Version">
377<!ENTITY udisks-version "1.0.4">
378<!ENTITY udisks2-version "2.0.0">
379<!ENTITY unrar-version "4.2.4">
380<!ENTITY unzip-version "6.0">
381<!ENTITY upower-version "0.9.18">
382<!ENTITY usbutils-version "006">
383<!ENTITY which-version "2.20">
384<!ENTITY zip-version "3.0">
385
386<!-- Chapter 13 -->
387<!ENTITY bazaar-version "2.5.0">
388<!ENTITY check-version "0.9.9">
389<!ENTITY cmake-version "2.8.10">
390<!ENTITY cvs-version "1.11.23">
391<!ENTITY dejagnu-version "1.5">
392<!ENTITY doxygen-version "1.8.2">
393<!ENTITY expect-version "5.45">
394<!ENTITY gcc-version "4.7.2">
395<!ENTITY gc-version "7.2d">
396<!ENTITY gdb-version "7.5">
397<!ENTITY git-version "1.8.0">
398<!ENTITY guile-version "2.0.7">
399<!ENTITY icedtea-version "2.3.3">
400<!ENTITY openjdk-version "1.7.0.9">
401<!ENTITY junit-version "4.10">
402<!ENTITY librep-version "0.92.2.1">
403<!ENTITY llvm-version "3.2">
404<!ENTITY mercurial-version "2.3.2">
405<!ENTITY NASM-version "2.10.05">
406<!ENTITY php-version "5.4.8">
407<!ENTITY pkgconfig-version "0.27.1">
408<!ENTITY python2-version "2.7.3">
409<!ENTITY python3-version "3.3.0">
410<!ENTITY ruby-version "1.9.3-p286">
411<!ENTITY slang-version "2.2.4">
412<!ENTITY subversion-version "1.7.7">
413<!ENTITY tcl-version "8.5.12">
414<!ENTITY tk-version "8.5.12">
415<!ENTITY vala-version "0.18.1">
416<!ENTITY yasm-version "1.2.0">
417
418<!ENTITY cmake-major-version "2.8">
419<!ENTITY python2-majorver "2.7">
420<!ENTITY python3-majorver "3.3">
421
422<!-- Perl module versions used in the Perl Modules instructions -->
423<!ENTITY Archive-Zip-version "1.30">
424<!ENTITY Crypt-SSLeay-version "0.64">
425<!ENTITY Date-Manip-version "6.37">
426<!ENTITY ExtUtils-Depends-version "0.304">
427<!ENTITY ExtUtils-PkgConfig-version "1.13">
428<!ENTITY Finance-Quote-version "1.18">
429<!ENTITY Glib-perl-version "1.280">
430<!ENTITY HTML-Parser-version "3.69">
431<!ENTITY HTML-TableExtract-version "2.11">
432<!ENTITY LWP-version "6.04">
433<!ENTITY Net-DNS-version "0.70">
434<!ENTITY SGMLSpm-version "1.1">
435<!ENTITY URI-version "1.60">
436<!ENTITY XML-Parser-version "2.41">
437<!ENTITY XML-Simple-version "2.20">
438
439<!-- Python module versions used in the Python Modules instructions -->
440<!ENTITY notify-python-version "0.1.1">
441<!ENTITY pyxml-version "0.8.4">
442<!ENTITY py2cairo-version "1.10.0">
443<!ENTITY pygobject2-version "2.28.6">
444<!ENTITY pygobject3-version "3.4.2">
445<!ENTITY pygtk-version "2.24.0">
446<!ENTITY pygtksourceview-version "2.10.1">
447<!ENTITY pyatspi2-version "2.6.0">
448<!ENTITY pyrex-version "0.9.9">
449<!ENTITY pyxdg-version "0.23">
450
451<!-- Part IV -->
452<!-- Chapter 14 -->
453<!ENTITY ppp-version "2.4.5">
454<!ENTITY dhcpcd-version "5.6.2">
455<!ENTITY dhcp-version "4.2.4-P2">
456
457<!-- Chapter 15 -->
458<!ENTITY bridgeutils-version "1.5">
459<!ENTITY cifsutils-version "5.7">
460<!ENTITY ncftp-version "3.2.5">
461<!ENTITY net-tools-version "CVS_20101030">
462<!ENTITY nfs-utils-version "1.2.6">
463<!ENTITY ntp-version "4.2.6p5">
464<!ENTITY rpcbind-version "0.2.0">
465<!ENTITY rsync-version "3.0.9">
466<!ENTITY samba3-version "3.6.8">
467<!ENTITY wget-version "1.14">
468<!ENTITY wireless-tools-version "29">
469<!ENTITY wpa_supplicant-version "1.0">
470
471<!-- Chapter 16 -->
472<!ENTITY avahi-version "0.6.31">
473<!ENTITY bind-version "9.9.2">
474<!ENTITY mod_dnssd-version "0.6">
475<!ENTITY NetworkManager-version "0.9.6.4">
476<!ENTITY nmap-version "6.01">
477<!ENTITY traceroute-version "2.0.18">
478<!ENTITY whois-version "5.0.20">
479<!ENTITY wicd-version "1.7.2.4">
480<!ENTITY wireshark-version "1.8.3">
481
482<!ENTITY wicd-major-version "1.7">
483
484<!-- Chapter 17 -->
485<!ENTITY curl-version "7.28.1">
486<!ENTITY geoclue-version "0.12.0">
487<!ENTITY glib-networking-version "2.34.2">
488<!ENTITY libevent-version "2.0.21">
489<!ENTITY libnice-version "0.1.3">
490<!ENTITY libnl-version "3.2.16">
491<!ENTITY libpcap-version "1.3.0">
492<!ENTITY libproxy-version "0.4.7">
493<!ENTITY librest-version "0.7.90">
494<!ENTITY libsoup-version "2.40.2">
495<!ENTITY libtirpc-version "0.2.2">
496<!ENTITY neon-version "0.29.6">
497
498<!-- Chapter 18 -->
499<!ENTITY Links-version "2.7">
500<!ENTITY lynx-version "2.8.8dev.14">
501<!ENTITY w3m-version "0.5.3">
502
503<!-- Chapter 19 -->
504<!ENTITY mailx-version "12.4">
505<!ENTITY procmail-version "3.22">
506<!ENTITY fetchmail-version "6.3.21">
507<!ENTITY mutt-version "1.5.21">
508<!ENTITY re-alpine-version "2.02">
509<!ENTITY tin-version "1.8.3">
510
511<!-- Part V -->
512<!-- Chapter 20 -->
513<!ENTITY apache-version "2.4.3">
514<!ENTITY proftpd-version "1.3.4b">
515<!ENTITY vsftpd-version "3.0.2">
516
517<!-- Chapter 21 -->
518<!ENTITY exim-version "4.80.1">
519<!ENTITY postfix-version "2.9.4">
520<!ENTITY qpopper-version "4.1.0">
521<!ENTITY sendmail-version "8.14.5">
522
523<!-- Chapter 22 -->
524<!ENTITY db-version "5.3.21">
525<!ENTITY mysql-version "5.5.28">
526<!ENTITY postgresql-version "9.2.1">
527<!ENTITY sqlite-version "3.7.14.1">
528
529<!-- Chapter 23 -->
530<!ENTITY openldap-version "2.4.33">
531<!ENTITY virtuoso-version "6.1.6">
532<!ENTITY soprano-version "2.8.0">
533<!ENTITY xinetd-version "2.3.15">
534
535<!-- Part VI -->
536<!-- Chapter 24 -->
537<!ENTITY xorg-version "7.7">
538<!ENTITY util-macros-version "1.17">
539<!ENTITY makedepend-version "1.0.4">
540<!ENTITY libXau-version "1.0.7">
541<!ENTITY libXdmcp-version "1.1.1">
542<!ENTITY libpthread-stubs-version "0.3">
543<!ENTITY xcb-proto-version "1.8">
544<!ENTITY libxcb-version "1.9">
545<!ENTITY xbitmaps-version "1.1.1">
546<!ENTITY xcursor-themes-version "1.0.3">
547<!ENTITY xkeyboard-config-version "2.7">
548<!ENTITY mesalib-version "9.0.1">
549<!ENTITY glu-version "9.0.0">
550<!ENTITY xcb-util-version "0.3.9">
551<!ENTITY printproto-version "1.0.5">
552<!ENTITY libXp-version "1.0.1">
553<!ENTITY xorg-server-version "1.12.4">
554<!ENTITY twm-version "1.0.7">
555<!ENTITY xterm-version "279">
556<!ENTITY xclock-version "1.0.6">
557<!ENTITY xinit-version "1.3.2">
558
559<!-- Chapter 25 -->
560<!ENTITY agg-version "2.5">
561<!ENTITY atk-version "2.6.0">
562<!ENTITY atkmm-version "2.22.6">
563<!ENTITY at-spi2-core-version "2.6.3">
564<!ENTITY at-spi2-atk-version "2.6.2">
565<!ENTITY cairo-version "1.12.8">
566<!ENTITY cairomm-version "1.10.0">
567<!ENTITY cogl-version "1.12.0">
568<!ENTITY clutter-version "1.12.2">
569<!ENTITY clutter-gst2-version "1.9.92">
570<!ENTITY clutter-gtk-version "1.4.2">
571<!ENTITY colord-gtk-version "0.1.24">
572<!ENTITY freeglut-version "2.8.0">
573<!ENTITY gdk-pixbuf-version "2.26.5">
574<!ENTITY goffice-version "0.8.17">
575<!ENTITY gtk2-version "2.24.14">
576<!ENTITY gtk3-version "3.6.2">
577<!ENTITY gtk-engines-version "2.20.2">
578<!ENTITY gtkmm2-version "2.24.2">
579<!ENTITY gtkmm3-version "3.6.0">
580<!ENTITY gtk-vnc-version "0.5.1">
581<!ENTITY hicolor-icon-theme-version "0.12">
582<!ENTITY libnotify-version "0.7.5">
583<!ENTITY libxklavier-version "5.3">
584<!ENTITY notification-daemon-version "0.7.6">
585<!ENTITY pango-version "1.32.5">
586<!ENTITY pangox-version "0.0.2">
587<!ENTITY pangomm-version "2.28.4">
588<!ENTITY qt-version "4.8.4">
589<!ENTITY shared-mime-info-version "1.0">
590<!ENTITY startup-notification-version "0.12">
591<!ENTITY webkitgtk-version "1.10.2">
592<!ENTITY xulrunner-version "16.0.1">
593
594<!ENTITY gtk2-libdir "2.0/2.10.0">
595<!ENTITY qt-dir "$QTDIR">
596
597<!-- Removed
598<!ENTITY libsexy-version "0.1.11">
599<!ENTITY mx-version "1.4.6">
600-->
601
602<!-- Chapter 26 -->
603<!ENTITY fluxbox-version "1.3.2">
604<!ENTITY icewm-version "1.3.7">
605<!ENTITY openbox-version "3.5.0">
606<!ENTITY sawfish-version "1.9.1">
607
608<!-- Part VII -->
609<!-- Chapters 27-29 -->
610<!ENTITY kde-version "4.9.3">
611<!ENTITY kde-dldir "&kde-version;">
612<!ENTITY kde-download-http "http://mirrors.isc.org/pub/kde/stable/">
613<!ENTITY kde-download-ftp "ftp://ftp.kde.org/pub/kde/stable/">
614<!ENTITY kde-dir-var "KDE_PREFIX">
615<!ENTITY kde-dir "$&kde-dir-var;">
616<!ENTITY automoc4-version "0.9.88">
617<!ENTITY phonon-version "4.6.0">
618<!ENTITY phonon-backend-gstreamer-version "4.6.2">
619<!ENTITY phonon-backend-vlc-version "0.6.0">
620<!ENTITY attica-version "0.4.1">
621<!ENTITY akonadi-version "1.8.1">
622<!ENTITY qimageblitz-version "0.0.6">
623<!ENTITY shared-desktop-ontologies-version "0.10.0">
624<!ENTITY polkit-qt-version "0.103.0">
625<!ENTITY polkit-kde-agent-version "0.99.0">
626
627<!-- Part VIII -->
628
629<!ENTITY gnome-version "3.6">
630<!ENTITY gnome-minor-version ".2">
631<!-- this is used by old gnome-2, which will be going, and by deprecated gnome,
632 which will be staying for a little while -->
633<!ENTITY gnome-old-etc-dir "/etc/gnome/2.30.2">
634<!ENTITY gnome-download-http "http://ftp.gnome.org/pub/gnome/sources">
635<!ENTITY gnome-download-ftp "ftp://ftp.gnome.org/pub/gnome/sources">
636
637<!-- Chapter 30 -->
638
639<!-- Platform -->
640<!ENTITY accountsservice-version "0.6.26">
641<!ENTITY polkit-gnome-version "0.105">
642<!ENTITY gnome-doc-utils-version "0.20.10">
643<!ENTITY yelp-xsl-version "3.6.1">
644<!ENTITY libgnome-keyring-version "3.6.0">
645<!ENTITY libsecret-version "0.11">
646<!ENTITY gsettings-desktop-schemas-version "3.6.1">
647<!ENTITY dconf-version "0.14.1">
648<!ENTITY GConf-version "3.2.5">
649<!ENTITY gcr-version "3.6.2">
650<!ENTITY libgee-version "0.6.6.1">
651<!ENTITY libgweather-version "3.6.2">
652<!ENTITY libwnck-version "3.4.4">
653<!ENTITY libgnomekbd-version "3.6.0">
654<!ENTITY libgtop-version "2.28.4">
655<!ENTITY libwacom-version "0.6">
656<!ENTITY gnome-online-accounts-version "3.6.2">
657<!ENTITY libgdata-version "0.13.2">
658<!ENTITY evolution-data-server-version "3.6.2">
659<!ENTITY libzeitgeist-version "0.3.18">
660<!ENTITY folks-version "0.8.0">
661<!ENTITY gnome-js-common-version "0.1.2">
662<!ENTITY gjs-version "1.34.0">
663<!ENTITY seed-version "3.2.0">
664<!ENTITY libpeas-version "1.6.1">
665<!ENTITY gtksourceview-version "3.6.1">
666<!ENTITY gtkhtml-version "4.6.1">
667<!ENTITY totem-pl-parser-version "3.4.3">
668<!ENTITY vte-version "0.34.2">
669
670<!-- Desktop -->
671<!ENTITY gnome-backgrounds-version "3.6.1">
672<!ENTITY gnome-icon-theme-version "3.6.2">
673<!ENTITY gnome-icon-theme-extras-version "3.6.2">
674<!ENTITY gnome-icon-theme-symbolic-version "3.6.2">
675<!ENTITY gnome-themes-standard-version "3.6.2">
676<!ENTITY gnome-video-effects-version "0.4.0">
677<!ENTITY gnome-desktop-version "3.6.2">
678<!ENTITY gnome-keyring-version "3.6.2">
679<!ENTITY gnome-menus-version "3.6.1">
680<!ENTITY gnome-panel-version "3.6.2">
681<!ENTITY gvfs-version "1.14.2">
682<!ENTITY nautilus-version "3.6.2">
683<!ENTITY nautilus-sendto-version "3.6.0">
684<!ENTITY gnome-screensaver-version "3.6.1">
685<!ENTITY gnome-power-manager-version "3.6.0">
686<!ENTITY gnome-bluetooth-version "3.6.1">
687<!ENTITY gnome-user-share-version "3.0.4">
688<!ENTITY gnome-settings-daemon-version "3.6.3">
689<!ENTITY gnome-control-center-version "3.6.3">
690<!ENTITY gnome-terminal-version "3.6.1">
691<!ENTITY zenity-version "3.6.0">
692<!ENTITY metacity-version "2.34.13">
693<!ENTITY network-manager-applet-version "0.9.6.4">
694<!ENTITY caribou-version "0.4.4.2">
695<!ENTITY mutter-version "3.6.2">
696<!ENTITY gnome-shell-version "3.6.2">
697<!ENTITY gnome-session-version "3.6.2">
698<!ENTITY gnome-user-docs-version "3.6.2">
699<!ENTITY yelp-version "3.6.2">
700
701<!-- System Services -->
702<!ENTITY gdm-version "3.6.2">
703
704<!-- Chapter 31 -->
705<!-- Applications -->
706<!ENTITY aisleriot-version "3.6.2">
707<!ENTITY alacarte-version "3.6.1">
708<!ENTITY baobab-version "3.6.3">
709<!ENTITY brasero-version "3.6.1">
710<!ENTITY cheese-version "3.6.2">
711<!ENTITY empathy-version "3.6.2">
712<!ENTITY eog-version "3.6.2">
713<!ENTITY epiphany-version "3.6.1">
714<!ENTITY epiphany-extensions-version "3.6.0">
715<!ENTITY evince-version "3.6.1">
716<!ENTITY evolution-version "3.6.2">
717<!ENTITY file-roller-version "3.6.2">
718<!ENTITY gcalctool-version "6.6.2">
719<!ENTITY gedit-version "3.6.2">
720<!ENTITY gnome-color-manager-version "3.6.0">
721<!ENTITY gnome-contacts-version "3.6.1">
722<!ENTITY gnome-dictionary-version "3.6.0">
723<!ENTITY gnome-disk-utility-version "3.6.1">
724<!ENTITY gnome-games-version "3.6.1">
725<!ENTITY gnome-nettool-version "3.2.0">
726<!ENTITY gnome-screenshot-version "3.6.1">
727<!ENTITY gnome-search-tool-version "3.6.0">
728<!ENTITY gnome-system-log-version "3.6.1">
729<!ENTITY gnome-system-monitor-version "3.6.1">
730<!ENTITY gnome-tweak-tool-version "3.6.1">
731<!ENTITY gucharmap-version "3.6.1">
732<!ENTITY mousetweaks-version "3.6.0">
733<!ENTITY orca-version "3.6.2">
734<!ENTITY seahorse-version "3.6.3">
735<!ENTITY sound-juicer-version "3.4.0">
736<!ENTITY totem-version "3.6.3">
737<!ENTITY vinagre-version "3.6.2">
738<!ENTITY vino-version "3.6.2">
739
740<!-- Chapter 32 -->
741<!-- Deprecated -->
742<!ENTITY ORBit2-version "2.14.19">
743<!ENTITY libbonobo-version "2.32.1">
744<!ENTITY gnome-mime-data-version "2.18.0">
745<!ENTITY gnome-vfs-version "2.24.4">
746<!ENTITY libgnome-version "2.32.1">
747<!ENTITY libgnomecanvas-version "2.30.3">
748<!ENTITY libbonoboui-version "2.24.5">
749<!ENTITY libgnomeui-version "2.24.5">
750
751<!-- Xfce core -->
752<!ENTITY xfce4-version "4.10">
753<!ENTITY exo-version "0.8.0">
754<!ENTITY garcon-version "0.2.0">
755<!ENTITY gtk-xfce-engine-version "3.0.0">
756<!ENTITY libwnck2-version "2.30.7">
757<!ENTITY libxfce4ui-version "4.10.0">
758<!ENTITY libxfce4util-version "4.10.0">
759<!ENTITY libxfcegui4-version "4.10.0">
760<!ENTITY thunar-version "1.4.0">
761<!ENTITY thunar-volman-version "0.8.0">
762<!ENTITY tumbler-version "0.1.25">
763<!ENTITY xfce4-appfinder-version "4.10.0">
764<!ENTITY xfce4-panel-version "4.10.0">
765<!ENTITY xfce4-power-manager-version "1.2.0">
766<!ENTITY xfce4-session-version "4.10.0">
767<!ENTITY xfce4-settings-version "4.10.0">
768<!ENTITY xfconf-version "4.10.0">
769<!ENTITY xfdesktop-version "4.10.0">
770<!ENTITY xfwm4-version "4.10.0">
771
772<!-- Xfce apps -->
773<!ENTITY midori-version "0.4.5">
774<!ENTITY parole-version "0.2.0.6">
775<!ENTITY terminal-version "0.4.8">
776<!ENTITY vte2-version "0.28.2">
777<!ENTITY xfburn-version "0.4.3">
778<!ENTITY xfce4-notifyd-version "0.2.2">
779
780<!-- Part X -->
781<!-- Chapter 35 -->
782<!ENTITY AbiWord-version "2.9.3">
783<!ENTITY gnumeric-version "1.10.17">
784<!ENTITY gnucash-version "2.4.11">
785
786<!ENTITY libreoffice-version "3.6.4">
787<!ENTITY libreoffice-patch ".3">
788<!ENTITY libreoffice-dlversion "&libreoffice-version;&libreoffice-patch;">
789
790<!-- Chapter 36 -->
791<!ENTITY seamonkey-version "2.13.2">
792<!ENTITY firefox-version "&xulrunner-version;">
793
794<!-- Chapter 37 -->
795<!ENTITY balsa-version "2.4.12">
796<!ENTITY blueman-version "1.23">
797<!ENTITY ekiga-version "4.0.0">
798<!ENTITY gparted-version "0.14.0">
799<!ENTITY gnash-version "0.8.10">
800<!ENTITY gimp-version "2.8.2">
801<!ENTITY icedtea-web-version "1.3">
802<!ENTITY inkscape-version "0.48.4">
803<!ENTITY pan-version "0.133">
804<!ENTITY pidgin-version "2.10.6">
805<!ENTITY rox-filer-version "2.11">
806<!ENTITY thunderbird-version "16.0.1">
807<!ENTITY transmission-version "2.73">
808<!ENTITY xchat-version "2.8.8">
809<!ENTITY xdg-utils-version "1.1.0-rc1">
810
811<!-- Part XI -->
812<!-- Chapter 38 -->
813<!ENTITY alsa-download-http "http://gd.tuwien.ac.at/opsys/linux/alsa">
814<!ENTITY alsa-download-ftp "ftp://ftp.alsa-project.org/pub">
815<!ENTITY alsa-version "1.0.26">
816<!ENTITY alsa-lib-version "1.0.26">
817<!ENTITY alsa-plugins-version "1.0.26">
818<!ENTITY alsa-utils-version "1.0.26">
819<!ENTITY alsa-tools-version "1.0.25">
820<!ENTITY alsa-firmware-version "1.0.25">
821<!ENTITY alsa-oss-version "1.0.25">
822<!ENTITY audiofile-version "0.3.4">
823<!ENTITY esound-version "0.2.41">
824<!ENTITY faac-version "1.28">
825<!ENTITY faad2-version "2.7">
826<!ENTITY farstream-version "0.2.1">
827<!ENTITY flac-version "1.2.1">
828<!ENTITY gstreamer-version "0.10.36">
829<!ENTITY gst-plugins-base-version "0.10.36">
830<!ENTITY gst-plugins-good-version "0.10.31">
831<!ENTITY gst-plugins-bad-version "0.10.23">
832<!ENTITY gst-plugins-ugly-version "0.10.19">
833<!ENTITY gst-ffmpeg-version "0.10.13">
834<!ENTITY gstreamer10-version "1.0.4">
835<!ENTITY gst10-plugins-base-version "1.0.4">
836<!ENTITY gst10-plugins-good-version "1.0.4">
837<!ENTITY gst10-plugins-bad-version "1.0.4">
838<!ENTITY gst10-plugins-ugly-version "1.0.4">
839<!ENTITY gst10-libav-version "1.0.4">
840<!ENTITY liba52-version "0.7.4">
841<!ENTITY libao-version "1.1.0">
842<!ENTITY libcanberra-version "0.30">
843<!ENTITY libdiscid-version "0.2.2">
844<!ENTITY libdvdcss-version "1.2.12">
845<!ENTITY libdvdread-version "4.2.0">
846<!ENTITY libdvdnav-version "4.2.0">
847<!ENTITY libdv-version "1.0.0">
848<!ENTITY libmad-version "0.15.1b">
849<!ENTITY libmpeg2-version "0.5.1">
850<!ENTITY libmpeg3-version "1.8">
851<!ENTITY libmusicbrainz-version "2.1.5">
852<!ENTITY libmusicbrainz3-version "3.0.3">
853<!ENTITY libmusicbrainz5-version "5.0.1">
854<!ENTITY libogg-version "1.3.0">
855<!ENTITY libquicktime-version "1.2.4">
856<!ENTITY libsamplerate-version "0.1.8">
857<!ENTITY libsndfile-version "1.0.25">
858<!ENTITY libtheora-version "1.1.1">
859<!ENTITY libvorbis-version "1.3.3">
860<!ENTITY libvpx-version "1.1.0">
861<!ENTITY opal-version "3.10.9">
862<!ENTITY pulseaudio-version "2.1">
863<!ENTITY sdl-version "1.2.15">
864<!ENTITY soundtouch-version "1.7.0">
865<!ENTITY speex-version "1.2rc1">
866<!ENTITY taglib-version "1.7.2">
867<!ENTITY xine-lib-version "1.2.2">
868<!ENTITY xvid-version "1.3.2">
869
870<!-- Chapter 39 -->
871<!ENTITY mpg123-version "1.14.4">
872<!ENTITY vorbistools-version "1.4.0">
873<!ENTITY lame-version "3.99.5">
874<!ENTITY CDParanoia-version "III-10.2">
875<!ENTITY freetts-version "1.2.2">
876<!ENTITY audacious-version "3.3.2">
877<!ENTITY audacious-plugins-version "3.3.2">
878<!ENTITY amarok-version "2.6.0">
879<!ENTITY gvolwheel-version "1.0">
880
881<!-- Chapter 40 -->
882<!ENTITY dvb-apps-version "2012-06-10">
883<!ENTITY ffmpeg-version "1.0">
884<!ENTITY mplayer-version "1.1">
885<!ENTITY xine-ui-version "0.99.7">
886<!ENTITY transcode-version "1.1.7">
887<!ENTITY vlc-version "2.0.5">
888
889<!-- Chapter 41 -->
890<!ENTITY cdrdao-version "1.2.3">
891<!ENTITY dvd-rw-tools-version "7.1">
892<!ENTITY k3b-version "2.0.2">
893<!ENTITY libburn-version "1.2.4">
894<!ENTITY libisoburn-version "1.2.4">
895<!ENTITY libisofs-version "1.2.4">
896
897<!-- Part XII -->
898<!-- Chapter 42 -->
899<!ENTITY cups-version "1.6.1">
900<!ENTITY cups-filters-version "1.0.24">
901<!ENTITY LPRng-version "3.8.B">
902<!ENTITY gs-version "9.06">
903<!ENTITY gutenprint-version "5.2.9">
904
905<!-- Chapter 43 -->
906<!ENTITY sane-version "1.0.23">
907<!ENTITY sane-fe-version "1.0.14">
908<!ENTITY xsane-version "0.998">
909
910<!-- Chapter 44 -->
911<!ENTITY sgml-common-version "0.6.3">
912<!ENTITY sgml-dtd-3-version "3.1">
913<!ENTITY sgml-dtd-version "4.5">
914<!ENTITY opensp-version "1.5.2">
915<!ENTITY openjade-version "1.3.2">
916<!ENTITY docbook-dsssl-version "1.79">
917<!ENTITY docbook-utils-version "0.6.14">
918
919<!-- Chapter 45 -->
920<!ENTITY DocBook-version "4.5">
921<!ENTITY docbook-xsl-version "1.77.1">
922<!ENTITY itstool-version "1.2.0">
923<!ENTITY xmlto-version "0.0.25">
924
925<!-- Chapter 46 -->
926<!ENTITY a2ps-version "4.14">
927<!ENTITY enscript-version "1.6.4">
928<!ENTITY psutils-version "p17">
929<!ENTITY gsview-version "4.8">
930<!ENTITY xpdf-version "3.02">
931<!ENTITY epdfview-version "0.1.8">
932<!ENTITY fop-version "1.1">
933<!ENTITY paps-version "0.6.8">
934
935<!-- Removed
936<!ENTITY libgxps-version "0.2.2">
937-->
938
939<!-- Chapter 47 -->
940<!ENTITY texlive-version "20120701">
941<!ENTITY jadetex-version "3.13">
942
Note: See TracBrowser for help on using the repository browser.