source: general/genlib/libgpg-error.xml@ 952c2494

10.0 10.1 11.0 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt lazarus perl-modules qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 952c2494 was 952c2494, checked in by Bruce Dubbs <bdubbs@…>, 4 years ago

Update to git-2.16.2.
Update to gdb-8.1.
Tags

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@19791 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 5.4 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libgpg-error-download-http "&gnupg-http;/libgpg-error/libgpg-error-&libgpg-error-version;.tar.bz2">
8 <!-- Something is wrong with ftp server and it confuses curl when currency runs it -->
9 <!-- <!ENTITY libgpg-error-download-ftp "&gnupg-ftp;/libgpg-error/libgpg-error-&libgpg-error-version;.tar.bz2"> -->
10 <!ENTITY libgpg-error-download-ftp " ">
11 <!ENTITY libgpg-error-md5sum "5217ef3e76a7275a2a3b569a12ddc989">
12 <!ENTITY libgpg-error-size "796 KB">
13 <!ENTITY libgpg-error-buildsize "7.8 MB (with tests)">
14 <!ENTITY libgpg-error-time "less than 0.1 SBU (with tests)">
15]>
16
17<sect1 id="libgpg-error" xreflabel="libgpg-error-&libgpg-error-version;">
18 <?dbhtml filename="libgpg-error.html"?>
19
20 <sect1info>
21 <othername>$LastChangedBy$</othername>
22 <date>$Date$</date>
23 </sect1info>
24
25 <title>libgpg-error-&libgpg-error-version;</title>
26
27 <indexterm zone="libgpg-error">
28 <primary sortas="a-libgpg-error">libgpg-error</primary>
29 </indexterm>
30
31 <sect2 role="package">
32 <title>Introduction to libgpg-error</title>
33
34 <para>
35 The <application>libgpg-error</application> package contains a
36 library that defines common error values for all
37 <application>GnuPG</application> components.
38 </para>
39
40 &lfs82_checked;
41
42 <bridgehead renderas="sect3">Package Information</bridgehead>
43 <itemizedlist spacing="compact">
44 <listitem>
45 <para>
46 Download (HTTP): <ulink url="&libgpg-error-download-http;"/>
47 </para>
48 </listitem>
49 <listitem>
50 <para>
51 Download (FTP): <ulink url="&libgpg-error-download-ftp;"/>
52 </para>
53 </listitem>
54 <listitem>
55 <para>
56 Download MD5 sum: &libgpg-error-md5sum;
57 </para>
58 </listitem>
59 <listitem>
60 <para>
61 Download size: &libgpg-error-size;
62 </para>
63 </listitem>
64 <listitem>
65 <para>
66 Estimated disk space required: &libgpg-error-buildsize;
67 </para>
68 </listitem>
69 <listitem>
70 <para>
71 Estimated build time: &libgpg-error-time;
72 </para>
73 </listitem>
74 </itemizedlist>
75
76 <para condition="html" role="usernotes">User Notes:
77 <ulink url="&blfs-wiki;/libgpg-error"/>
78 </para>
79 </sect2>
80
81 <sect2 role="installation">
82 <title>Installation of libgpg-error</title>
83
84 <para>
85 Install <application>libgpg-error</application> by running the
86 following commands:
87 </para>
88
89<screen><userinput>./configure --prefix=/usr &amp;&amp;
90make</userinput></screen>
91
92 <para>
93 To test the results, issue: <command>make check</command>.
94 </para>
95
96 <para>
97 Now, as the <systemitem class="username">root</systemitem> user:
98 </para>
99
100<screen role="root"><userinput>make install &amp;&amp;
101install -v -m644 -D README /usr/share/doc/libgpg-error-&libgpg-error-version;/README</userinput></screen>
102
103 </sect2>
104
105 <sect2 role="content">
106 <title>Contents</title>
107
108 <segmentedlist>
109 <segtitle>Installed Programs</segtitle>
110 <segtitle>Installed Library</segtitle>
111 <segtitle>Installed Directories</segtitle>
112
113 <seglistitem>
114 <seg>
115 gpg-error and gpg-error-config
116 </seg>
117 <seg>
118 libgpg-error.so
119 </seg>
120 <seg>
121 /usr/share/common-lisp/source/gpg-error,
122 /usr/share/libgpg-error, and
123 /usr/share/doc/libgpg-error-&libgpg-error-version;
124 </seg>
125 </seglistitem>
126 </segmentedlist>
127
128 <variablelist>
129 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
130 <?dbfo list-presentation="list"?>
131 <?dbhtml list-presentation="table"?>
132
133 <varlistentry id="gpg-error">
134 <term><command>gpg-error</command></term>
135 <listitem>
136 <para>
137 is used to determine <application>libgpg-error</application>
138 error codes.
139 </para>
140 <indexterm zone="libgpg-error gpg-error">
141 <primary sortas="b-gpg-error">gpg-error</primary>
142 </indexterm>
143 </listitem>
144 </varlistentry>
145
146 <varlistentry id="gpg-error-config">
147 <term><command>gpg-error-config</command></term>
148 <listitem>
149 <para>
150 is a utility used to configure and build applications based on
151 the <application>libgpg-error</application> library. It can be used
152 to query the C compiler and linker flags which are required to
153 correctly compile and link the application against the
154 <application>libgpg-error</application> library.
155 </para>
156 <indexterm zone="libgpg-error gpg-error-config">
157 <primary sortas="b-gpg-error-config">gpg-error-config</primary>
158 </indexterm>
159 </listitem>
160 </varlistentry>
161
162 <varlistentry id="libgpg-error-lib">
163 <term><filename class="libraryfile">libgpg-error.so</filename></term>
164 <listitem>
165 <para>
166 contains the <application>libgpg-error</application> API
167 functions.
168 </para>
169 <indexterm zone="libgpg-error libgpg-error-lib">
170 <primary sortas="c-libgpg-error">libgpg-error.so</primary>
171 </indexterm>
172 </listitem>
173 </varlistentry>
174
175 </variablelist>
176
177 </sect2>
178
179</sect1>
Note: See TracBrowser for help on using the repository browser.