source: general/genlib/libgpg-error.xml@ a980725

10.0 10.1 11.0 7.10 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt lazarus nosym perl-modules qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since a980725 was a980725, checked in by Igor Živković <igor@…>, 6 years ago

Update to firefox-46.0.
Update to libgpg-error-1.22.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@17288 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 5.4 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libgpg-error-download-http " ">
8 <!ENTITY libgpg-error-download-ftp "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-&libgpg-error-version;.tar.bz2">
9 <!ENTITY libgpg-error-md5sum "83c686abe3fa223ec89f3b51da830770">
10 <!ENTITY libgpg-error-size "759 KB">
11 <!ENTITY libgpg-error-buildsize "9 MB (with tests)">
12 <!ENTITY libgpg-error-time "less than 0.1 SBU (with tests)">
13]>
14
15<sect1 id="libgpg-error" xreflabel="libgpg-error-&libgpg-error-version;">
16 <?dbhtml filename="libgpg-error.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>libgpg-error-&libgpg-error-version;</title>
24
25 <indexterm zone="libgpg-error">
26 <primary sortas="a-libgpg-error">libgpg-error</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to libgpg-error</title>
31
32 <para>
33 The <application>libgpg-error</application> package contains a
34 library that defines common error values for all
35 <application>GnuPG</application> components.
36 .</para>
37
38 &lfs79_checked;
39
40 <bridgehead renderas="sect3">Package Information</bridgehead>
41 <itemizedlist spacing="compact">
42 <listitem>
43 <para>
44 Download (HTTP): <ulink url="&libgpg-error-download-http;"/>
45 </para>
46 </listitem>
47 <listitem>
48 <para>
49 Download (FTP): <ulink url="&libgpg-error-download-ftp;"/>
50 </para>
51 </listitem>
52 <listitem>
53 <para>
54 Download MD5 sum: &libgpg-error-md5sum;
55 </para>
56 </listitem>
57 <listitem>
58 <para>
59 Download size: &libgpg-error-size;
60 </para>
61 </listitem>
62 <listitem>
63 <para>
64 Estimated disk space required: &libgpg-error-buildsize;
65 </para>
66 </listitem>
67 <listitem>
68 <para>
69 Estimated build time: &libgpg-error-time;
70 </para>
71 </listitem>
72 </itemizedlist>
73
74 <para condition="html" role="usernotes">User Notes:
75 <ulink url="&blfs-wiki;/libgpg-error"/>
76 </para>
77 </sect2>
78
79 <sect2 role="installation">
80 <title>Installation of libgpg-error</title>
81
82 <para>
83 Install <application>libgpg-error</application> by running the
84 following commands:
85 </para>
86
87<screen><userinput>./configure --prefix=/usr &amp;&amp;
88make</userinput></screen>
89
90 <para>
91 To test the results, issue: <command>make check</command>.
92 </para>
93
94 <para>
95 Now, as the <systemitem class="username">root</systemitem> user:
96 </para>
97
98<screen role="root"><userinput>make install &amp;&amp;
99install -v -m644 -D README /usr/share/doc/libgpg-error-&libgpg-error-version;/README</userinput></screen>
100
101 </sect2>
102<!-- No longer needed
103 <sect2 role="commands">
104 <title>Command Explanations</title>
105
106 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
107 href="../../xincludes/static-libraries.xml"/>
108
109 </sect2>
110-->
111 <sect2 role="content">
112 <title>Contents</title>
113
114 <segmentedlist>
115 <segtitle>Installed Programs</segtitle>
116 <segtitle>Installed Library</segtitle>
117 <segtitle>Installed Directories</segtitle>
118
119 <seglistitem>
120 <seg>
121 gpg-error and gpg-error-config
122 </seg>
123 <seg>
124 libgpg-error.so
125 </seg>
126 <seg>
127 /usr/share/common-lisp/source/gpg-error and
128 /usr/share/doc/libgpg-error-&libgpg-error-version;
129 </seg>
130 </seglistitem>
131 </segmentedlist>
132
133 <variablelist>
134 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
135 <?dbfo list-presentation="list"?>
136 <?dbhtml list-presentation="table"?>
137
138 <varlistentry id="gpg-error">
139 <term><command>gpg-error</command></term>
140 <listitem>
141 <para>
142 is used to determine <application>libgpg-error</application>
143 error codes.
144 </para>
145 <indexterm zone="libgpg-error gpg-error">
146 <primary sortas="b-gpg-error">gpg-error</primary>
147 </indexterm>
148 </listitem>
149 </varlistentry>
150
151 <varlistentry id="gpg-error-config">
152 <term><command>gpg-error-config</command></term>
153 <listitem>
154 <para>
155 is a utility used to configure and build applications based on
156 the <application>libgpg-error</application> library. It can be used
157 to query the C compiler and linker flags which are required to
158 correctly compile and link the application against the
159 <application>libgpg-error</application> library.
160 </para>
161 <indexterm zone="libgpg-error gpg-error-config">
162 <primary sortas="b-gpg-error-config">gpg-error-config</primary>
163 </indexterm>
164 </listitem>
165 </varlistentry>
166
167 <varlistentry id="libgpg-error-lib">
168 <term><filename class="libraryfile">libgpg-error.so</filename></term>
169 <listitem>
170 <para>
171 contains the <application>libgpg-error</application> API
172 functions.
173 </para>
174 <indexterm zone="libgpg-error libgpg-error-lib">
175 <primary sortas="c-libgpg-error">libgpg-error.so</primary>
176 </indexterm>
177 </listitem>
178 </varlistentry>
179
180 </variablelist>
181
182 </sect2>
183
184</sect1>
Note: See TracBrowser for help on using the repository browser.