source: general/genlib/libqmi.xml@ b7887423

11.0 11.1 11.2 lazarus plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since b7887423 was b7887423, checked in by Douglas R. Reno <renodr@…>, 16 months ago

libqmi: now requires libgudev per the release notes

  • Property mode set to 100644
File size: 6.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libqmi-download-http "https://www.freedesktop.org/software/libqmi/libqmi-&libqmi-version;.tar.xz">
8 <!ENTITY libqmi-download-ftp " ">
9 <!ENTITY libqmi-md5sum "1a30e5304d01e72845bd3e9c353c8ded">
10 <!ENTITY libqmi-size "1.2 MB">
11 <!ENTITY libqmi-buildsize "150 MB (with tests)">
12 <!ENTITY libqmi-time "0.3 SBU (Using parallelism=4; with tests)">
13]>
14
15<sect1 id="libqmi" xreflabel="libqmi-&libqmi-version;">
16 <?dbhtml filename="libqmi.html"?>
17
18 <sect1info>
19 <date>$Date$</date>
20 </sect1info>
21
22 <title>libqmi-&libqmi-version;</title>
23
24 <indexterm zone="libqmi">
25 <primary sortas="a-libqmi">libqmi</primary>
26 </indexterm>
27
28 <sect2 role="package">
29 <title>Introduction to libqmi</title>
30
31 <para>
32 The <application>libqmi</application> package contains a GLib-based library
33 for talking to WWAN modems and devices which speak the Qualcomm MSM Interface
34 (QMI) protocol.
35 </para>
36
37 &lfs101_checked;
38
39 <bridgehead renderas="sect3">Package Information</bridgehead>
40 <itemizedlist spacing="compact">
41 <listitem>
42 <para>
43 Download (HTTP): <ulink url="&libqmi-download-http;"/>
44 </para>
45 </listitem>
46 <listitem>
47 <para>
48 Download (FTP): <ulink url="&libqmi-download-ftp;"/>
49 </para>
50 </listitem>
51 <listitem>
52 <para>
53 Download MD5 sum: &libqmi-md5sum;
54 </para>
55 </listitem>
56 <listitem>
57 <para>
58 Download size: &libqmi-size;
59 </para>
60 </listitem>
61 <listitem>
62 <para>
63 Estimated disk space required: &libqmi-buildsize;
64 </para>
65 </listitem>
66 <listitem>
67 <para>
68 Estimated build time: &libqmi-time;
69 </para>
70 </listitem>
71 </itemizedlist>
72
73 <bridgehead renderas="sect3">libqmi Dependencies</bridgehead>
74
75 <bridgehead renderas="sect4">Required</bridgehead>
76 <para role="required">
77 <xref linkend="glib2"/> and
78 <xref linkend="libgudev"/>
79 </para>
80
81 <bridgehead renderas="sect4">Recommended</bridgehead>
82 <para role="recommended">
83 <xref linkend="gobject-introspection"/> and
84 <xref linkend="libmbim"/>
85 </para>
86
87 <bridgehead renderas="sect4">Optional</bridgehead>
88 <para role="optional">
89 <xref linkend="gtk-doc"/>,
90 <ulink url="https://ftpmirror.gnu.org/gnu/help2man/">help2man</ulink>, and
91 <ulink url="https://gitlab.freedesktop.org/mobile-broadband/libqrtr-glib">libqrtr-glib</ulink>
92 </para>
93
94 <para condition="html" role="usernotes">User Notes:
95 <ulink url="&blfs-wiki;/libqmi"/>
96 </para>
97 </sect2>
98
99 <sect2 role="installation">
100 <title>Installation of libqmi</title>
101
102 <para>
103 Install <application>libqmi</application> by running the following
104 commands:
105 </para>
106
107<screen><userinput>PYTHON=python3 ./configure --prefix=/usr --disable-static &amp;&amp;
108make</userinput></screen>
109
110 <para>
111 To test the results, issue: <command>make check</command>.
112 </para>
113
114 <para>
115 Now, as the <systemitem class="username">root</systemitem> user:
116 </para>
117
118<screen role="root"><userinput>make install</userinput></screen>
119
120 </sect2>
121
122 <sect2 role="commands">
123
124 <title>Command Explanations</title>
125
126 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
127 href="../../xincludes/static-libraries.xml"/>
128
129 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
130 href="../../xincludes/gtk-doc-rebuild.xml"/>
131
132 <para>
133 <option>--disable-mbim-qmux</option>: This switch disables support for
134 using a MBIM control device for QMI messages. Use this switch if you
135 did not install <application>libmbim</application>.
136 </para>
137
138 </sect2>
139
140 <sect2 role="content">
141 <title>Contents</title>
142
143 <segmentedlist>
144 <segtitle>Installed Programs</segtitle>
145 <segtitle>Installed Libraries</segtitle>
146 <segtitle>Installed Directories</segtitle>
147
148 <seglistitem>
149 <seg>
150 qmicli,
151 qmi-firmware-update,
152 and qmi-network
153 </seg>
154 <seg>
155 libqmi-glib.so
156 </seg>
157 <seg>
158 /usr/include/libqmi-glib and
159 /usr/share/gtk-doc/html/libqmi-glib
160 </seg>
161 </seglistitem>
162 </segmentedlist>
163
164 <variablelist>
165 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
166 <?dbfo list-presentation="list"?>
167 <?dbhtml list-presentation="table"?>
168
169 <varlistentry id="qmicli">
170 <term><command>qmicli</command></term>
171 <listitem>
172 <para>
173 is an utility used to control QMI devices
174 </para>
175 <indexterm zone="libqmi qmicli">
176 <primary sortas="b-qmicli">qmicli</primary>
177 </indexterm>
178 </listitem>
179 </varlistentry>
180
181 <varlistentry id="qmi-firmware-update">
182 <term><command>qmi-firmware-update</command></term>
183 <listitem>
184 <para>
185 is an utility used to perform firmware updates on QMI devices
186 </para>
187 <indexterm zone="libqmi qmi-firmware-update">
188 <primary sortas="b-qmi-firmware-update">qmi-firmware-update</primary>
189 </indexterm>
190 </listitem>
191 </varlistentry>
192
193 <varlistentry id="qmi-network">
194 <term><command>qmi-network</command></term>
195 <listitem>
196 <para>
197 is an utility used for simple network management
198 of QMI devices
199 </para>
200 <indexterm zone="libqmi qmi-network">
201 <primary sortas="b-qmi-network">qmi-network</primary>
202 </indexterm>
203 </listitem>
204 </varlistentry>
205
206 <varlistentry id="libqmi-glib">
207 <term><filename class="libraryfile">libqmi-glib.so</filename></term>
208 <listitem>
209 <para>
210 contains API functions for talking to WWAN modems and devices
211 which speak the Qualcomm MSM Interface (QMI) protocol
212 </para>
213 <indexterm zone="libqmi libqmi-glib">
214 <primary sortas="c-libqmi-glib">libqmi-glib.so</primary>
215 </indexterm>
216 </listitem>
217 </varlistentry>
218
219 </variablelist>
220
221 </sect2>
222
223</sect1>
Note: See TracBrowser for help on using the repository browser.