source: general/genutils/imagemagick6.xml@ a6a3fa6

10.0 10.1 11.0 11.1 11.2 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind lazarus perl-modules plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since a6a3fa6 was a6a3fa6, checked in by Ken Moffat <ken@…>, 5 years ago

ImageMagick: 7.0.7-23, and 6.9.9-35 for its libs.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@19816 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 16.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY imagemagick6-patch-version "35">
8
9 <!ENTITY imagemagick6-download-http "https://www.imagemagick.org/download/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
10 <!ENTITY imagemagick6-download-ftp "ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
11 <!ENTITY imagemagick6-md5sum "85d5a523e3fe27105242f87dc39ae2cd">
12 <!ENTITY imagemagick6-size "8.6 MB">
13 <!ENTITY imagemagick6-buildsize "182 MB, with typical dependencies (add 32 MB for the tests)">
14 <!ENTITY imagemagick6-time "2.1 SBU - typical build (add 1.6 SBU for the tests)">
15]>
16
17<!-- Editors: It is highly unlikely that the buildsize (disk space used) will
18 be less than the figure shown above. Unless you have installed *all* the
19 delegate dependencies, you will see a smaller buildsize, but what is
20 currently listed above is the space one would require if all the
21 dependencies available in the book are installed.
22
23 [pierre 2017-02-14]] For a build of 6.9.7-8 with dependencies available in
24 the book, but with the configure command as below, I got 179 MB (2.3 SBU)
25 (and 472 KB (0.8 SBU) for the validation suite).
26
27 For a non-full build of 6.9.3-8 I got an actual space of 173 MB and running
28 the validation suite does not increase the net space. I recommend running
29 that instead of check (after the install)!
30
31 Following comments preserved from when we did a full install of -6.
32
33 Marked as 'typical' because nobody builds ALL the optional extras [ken]
34
35 [bdubbs] I do; at least the internal ones. I still got only 200 MB.
36
37 Saved the "full" 450MB as a comment - feel free to update this iff you
38 do build all dependencies, it's probably a lot bigger now.
39
40 [bdubbs] Just removed it. I don't think it adds anything.
41
42 Also, please look over the output from the configure command for any
43 additional dependencies that need to be listed, as ImageMagick is
44 constantly adding additional features and dependencies.
45
46 For those of us who touch this infrequently:
47 DPS/dpsXclient is from apple so not relevant to linux builds
48 GVC is part of Graphviz and documented in the explanations
49 LQR is Liquid Rescale -->
50
51<sect1 id="imagemagick6" xreflabel="ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version; libraries">
52 <?dbhtml filename="imagemagick6.html"?>
53
54 <sect1info>
55 <othername>$LastChangedBy$</othername>
56 <date>$Date$</date>
57 </sect1info>
58
59 <title>ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;</title>
60
61 <indexterm zone="imagemagick6">
62 <primary sortas="a-ImageMagick-6 libraries">ImageMagick-6 libraries</primary>
63 </indexterm>
64
65 <sect2 role="package">
66 <title>Introduction to ImageMagick-6 libraries</title>
67
68 <para>
69 <application>ImageMagick</application> underwent many changes in its
70 libraries between versions 6 and 7. Most packages in BLFS which use
71 <application>ImageMagick</application> can use version 7, but for the
72 others this page will install only the libraries, headers and general
73 documentation (not programs, manpages, perl modules), and it will
74 rename the unversioned pkgconfig files so that they do not overwrite the
75 same-named files from version 7.
76 </para>
77
78 &lfs81_checked;
79
80 <bridgehead renderas="sect3">Package Information</bridgehead>
81 <itemizedlist spacing="compact">
82 <listitem>
83 <para>Download (HTTP): <ulink url="&imagemagick6-download-http;"/></para>
84 </listitem>
85 <listitem>
86 <para>Download (FTP): <ulink url="&imagemagick6-download-ftp;"/></para>
87 </listitem>
88 <listitem>
89 <para>Download MD5 sum: &imagemagick6-md5sum;</para>
90 </listitem>
91 <listitem>
92 <para>Download size: &imagemagick6-size;</para>
93 </listitem>
94 <listitem>
95 <para>Estimated disk space required: &imagemagick6-buildsize;</para>
96 </listitem>
97 <listitem>
98 <para>Estimated build time: &imagemagick6-time;</para>
99 </listitem>
100 </itemizedlist>
101
102 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
103 <itemizedlist spacing="compact">
104 <listitem>
105 <para>
106 Required patch:
107 <ulink url="&patch-root;/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch"/>
108 </para>
109 </listitem>
110 </itemizedlist>
111
112 <note>
113 <para>
114 The <application>ImageMagick</application> source releases are updated
115 frequently and the version shown above may no longer be available from
116 the download locations. You can download a more recent version and use
117 the existing BLFS instructions to install it. Chances are that it will
118 work just fine, but this has not been tested by the BLFS team. If the
119 package version shown above is not available from the locations shown
120 above, or from the <filename class='directory'>legacy/</filename>
121 directory at <literal>ftp.ImageMagick.org/pub/ImageMagick</literal> you
122 can download it from the BLFS package server at Oregon State University:
123 <ulink url="ftp://ftp.osuosl.org/pub/blfs/conglomeration/ImageMagick/"/>.
124 </para>
125 </note>
126
127 <bridgehead renderas="sect3">ImageMagick-6 Dependencies</bridgehead>
128
129 <bridgehead renderas="sect4">Recommended</bridgehead>
130 <para role="recommended">
131 <xref linkend="xorg7-lib"/>
132 </para>
133
134 <para>
135 The optional dependencies listed below should be installed if you need
136 support for the specific format or the conversion tool the dependency
137 provides. Many of the dependencies' capabilities and uses are described in
138 the <quote>MAGICK DELEGATES</quote> section of the
139 <filename>README.txt</filename> file located in the source tree.
140 Additional information about the dependencies can be found in the
141 <filename>Install-unix.txt</filename> file located in the source tree as
142 well as issuing the <command>./configure --help</command> command. A
143 summary of this information, as well as some additional notes can be
144 viewed on-line at <ulink
145 url="http://www.imagemagick.org/script/advanced-unix-installation.php"/>.
146 </para>
147
148 <bridgehead renderas="sect4">Optional System Utilities</bridgehead>
149 <para role="optional">
150 <xref linkend="cups"/>,
151 <xref linkend="curl"/>,
152 <xref linkend="ffmpeg"/>,
153 <xref linkend="fftw"/>,
154 <xref linkend="p7zip"/> (LZMA),
155 <xref linkend="sane"/>,
156 <xref linkend="wget"/>,
157 <xref linkend="xdg-utils"/>,
158 <xref linkend="xterm2"/>,
159 <ulink url="http://dmalloc.com/">Dmalloc</ulink>,
160 <ulink url="http://linux.softpedia.com/get/Programming/Debuggers/Electric-Fence-3305.shtml/">Electric Fence</ulink>,
161 <ulink url="http://www.openpgp.org/about/">PGP</ulink> or
162 <xref linkend="gnupg2"/>
163 (you'll have to do some hacking to use <application>GnuPG</application>),
164 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates">Profiles</ulink>,
165 and
166 <ulink url="http://ufraw.sourceforge.net/">ufraw</ulink> (for raw formats
167 listed in
168 <ulink url="http://imagemagick.org/script/formats.php">
169 http://www.imagemagick.org/www/formats.html</ulink>)
170 </para>
171
172 <bridgehead renderas="sect4">Optional Graphics Libraries</bridgehead>
173 <para role="optional">
174 <xref linkend="jasper"/>,
175 <xref linkend="lcms"/> or
176 <xref linkend="lcms2"/>,
177 <xref linkend="libexif"/>,
178 <xref linkend="libjpeg"/>,
179 <xref linkend="libpng"/>,
180 <xref linkend="libraw"/> (RAW_R),
181 <xref linkend="librsvg"/>,
182 <xref linkend="libtiff"/>,
183 <xref linkend="libwebp"/>,
184 <xref linkend="openjpeg2"/>,
185 <xref linkend="pango"/>,
186 <ulink url="http://djvu.sourceforge.net/">DjVuLibre</ulink>,
187 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates/">
188 FlashPIX (libfpx)</ulink>,
189 <ulink url="https://github.com/FLIF-hub/FLIF/releases">FLIF</ulink>,
190 <ulink url="http://www.cl.cam.ac.uk/~mgk25/jbigkit/">JBIG-KIT</ulink>,
191 <ulink url="&gnome-download-http;/libgxps/">libgxps</ulink>,
192 <ulink url="https://github.com/HOST-Oman/libraqm/">libraqm</ulink>,
193 <ulink url="http://liblqr.wikidot.com/en:download-page">Liquid Rescale</ulink>,
194 <ulink url="http://www.openexr.com/">OpenEXR</ulink>, and
195 <ulink url="http://www.agocg.ac.uk/train/cgm/ralcgm.htm">RALCGM</ulink>
196 (or <ulink url="http://www.mcmurchy.com/ralcgm/ralcgm-3.51.tar.gz">ralcgm</ulink>)
197 </para>
198
199 <bridgehead renderas="sect4">Optional Graphics Utilities</bridgehead>
200 <para role="optional">
201 <xref linkend="dejavu-fonts"/>,
202 <xref linkend="gs"/>,
203 <xref linkend="gimp"/>,
204 <xref linkend="graphviz"/>,
205 <xref linkend="inkscape"/>,
206 <ulink url="http://www.blender.org/">Blender</ulink>,
207 <ulink url="http://corefonts.sourceforge.net/">corefonts</ulink>,
208 <ulink url="http://www.ghostscript.com/download/gpcldnld.html">GhostPCL</ulink>,
209 <ulink url="http://www.gnuplot.info/">Gnuplot</ulink>,
210 <ulink url="http://www.povray.org/">POV-Ray</ulink>, and
211 <ulink url="http://www.radiance-online.org/">Radiance</ulink>
212 </para>
213
214 <bridgehead renderas="sect4">Optional Conversion Tools</bridgehead>
215 <para role="optional">
216 <xref linkend="enscript"/>,
217 <xref linkend="texlive"/> (or <xref linkend="tl-installer"/>)
218 <ulink url="http://autotrace.sourceforge.net/">AutoTrace</ulink>,
219 <ulink url="http://www.lizardtech.com/downloads/category/">
220 GeoExpress Command Line Utilities, AKA MrSID Utilities (binary package)</ulink>,
221 <ulink url="http://www.gnu.org/software/hp2xx/">hp2xx</ulink>,
222 <ulink url="http://user.it.uu.se/~jan/html2ps.html">html2ps</ulink>,
223 <ulink url="http://wvware.sourceforge.net/">libwmf</ulink>,
224 <ulink url="http://sk1project.org/modules.php?name=products&amp;product=uniconvertor">
225 UniConvertor</ulink>, and
226 <ulink url="http://www.cs.utah.edu/gdc/projects/urt/">Utah Raster Toolkit</ulink>
227 (or <ulink url="http://www.mcmurchy.com/urt/urt-3.1b.tar.gz">URT-3.1b</ulink>)
228 </para>
229
230 <para condition="html" role="usernotes">User Notes:
231 <!-- share the main page -->
232 <ulink url="&blfs-wiki;/imagemagick"/></para>
233
234 </sect2>
235
236 <sect2 role="installation">
237 <title>Installation of ImageMagick-6 libraries</title>
238
239 <para>
240 Install <application>ImageMagick</application> by running the following
241 commands:
242 </para>
243
244<screen><userinput>patch -Np1 -i ../ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch &amp;&amp;
245autoreconf -fi &amp;&amp;
246./configure --prefix=/usr \
247 --sysconfdir=/etc \
248 --enable-hdri \
249 --with-modules \
250 --disable-static &amp;&amp;
251make</userinput></screen>
252
253 <para>
254 Now, as the <systemitem class="username">root</systemitem> user:
255 </para>
256
257<screen role="root"><userinput>make DOCUMENTATION_PATH=/usr/share/doc/imagemagick-&imagemagick6-version; install-libs-only</userinput></screen>
258
259 <para>
260 To test the installation, issue: <command>make check</command>.
261 <!-- in 6.9.9-9 make check runs tests-validate-* A more
262 comprehensive test is the <application>ImageMagick</application>
263 validation suite. If <command>make check</command> has not been executed,
264 run <command>make tests/validate</command> to compile it. Issue
265 <command>tests/validate 2>&amp;1 | tee validate.log</command> to run the
266 validation suite. The result summary may be obtained with <command>grep
267 "validation suite" validate.log</command>.--> Note that the EPS, PS, and PDF
268 tests require a working <application>Ghostscript</application>. One test
269 in 'make check' needs <quote>Helvetica</quote> from <quote>Ghostscript
270 Standard Fonts</quote>, which are optionally installed in
271 <xref linkend="gs"/> - that test, and one other, might fail, but all the
272 validation can still pass.
273 </para>
274
275 </sect2>
276
277 <sect2 role="commands">
278 <title>Command Explanations</title>
279
280 <para>
281 <command>patch -Np1 -i
282 ../ImageMagick-&imagemagick6-version;-imagemagick6_libs_only-1.patch</command>:
283 Move unversioned pkgconfig files to versioned names and provide an option to
284 only install libraries and associated files.
285 </para>
286
287 <para>
288 <parameter>--enable-hdri</parameter>: Enables building of a
289 high dynamic range version of ImageMagick.
290 </para>
291
292 <para>
293 <parameter>--with-modules</parameter>: Enables support for
294 dynamically loadable modules.
295 </para>
296
297 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
298 href="../../xincludes/static-libraries.xml"/>
299
300 <para>
301 <option>--with-gslib</option>: Enables support to use the
302 <application>Ghostscript</application> shared library.
303 </para>
304
305 <para>
306 <option>--with-rsvg</option>: Enables support to use the
307 <application>librsvg</application> library.
308 </para>
309
310 <para>
311 <option>--with-autotrace</option>: Enables support to use
312 the <application>Autotrace</application> library.
313 </para>
314
315 <para>
316 <option>--with-wmf</option>: Enables support to use the
317 <application>libwmf</application> library.
318 </para>
319
320 <para>
321 <option>--with-gvc</option>: Enables support to use
322 <application>GraphViz</application>.
323 </para>
324
325 <para>
326 <option>--with-windows-font-dir=
327 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
328 This option specifies the directory where the Windows CoreFonts are
329 installed.
330 </para>
331
332 <para>
333 <option>--with-dejavu-font-dir=
334 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
335 This option specifies the directory where the DejaVu fonts are
336 installed.
337 </para>
338
339 <para>
340 The options and parameters listed above are the only ones you should
341 have to pass to the <command>configure</command> script to activate all
342 the delegate dependencies. All other dependencies will be automatically
343 detected and utilized in the build if they are installed.
344 </para>
345
346 </sect2>
347
348 <sect2 role="content">
349 <title>Contents</title>
350
351 <segmentedlist>
352 <segtitle>Installed Programs</segtitle>
353 <segtitle>Installed Libraries</segtitle>
354 <segtitle>Installed Directories</segtitle>
355
356 <seglistitem>
357 <seg>
358 None
359 </seg>
360 <seg>
361 libMagickCore-6.Q16HDRI.so,
362 libMagickWand-6.Q16HDRI.so and
363 libMagick++-6.Q16HDRI.so
364 </seg>
365 <seg>
366 /etc/ImageMagick-6,
367 /usr/include/ImageMagick-6,
368 /usr/lib/ImageMagick-&imagemagick6-version;,
369 /usr/share/doc/ImageMagick-&imagemagick6-version;, and
370 /usr/share/ImageMagick-6
371 </seg>
372 </seglistitem>
373 </segmentedlist>
374
375 <variablelist>
376 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
377 <?dbfo list-presentation="list"?>
378 <?dbhtml list-presentation="table"?>
379
380 <varlistentry id="libMagickCore-6.Q16HDRI">
381 <term><filename class="libraryfile">libMagickCore-6.Q16HDRI.so</filename></term>
382 <listitem>
383 <para>
384 provides the C API for ImageMagick.
385 </para>
386 <indexterm zone="imagemagick6 libMagickCore-6.Q16HDRI">
387 <primary sortas="c-libMagickCore-6.Q16HDRI">libMagickCore-6.Q16HDRI.so</primary>
388 </indexterm>
389 </listitem>
390 </varlistentry>
391
392 <varlistentry id="libMagickWand-6.Q16HDRI">
393 <term><filename class="libraryfile">libMagickWand-6.Q16HDRI.so</filename></term>
394 <listitem>
395 <para>
396 is the recommended C API for ImageMagick. Unlike the MagickCore API it
397 uses only a few opaque types.
398 </para>
399 <indexterm zone="imagemagick6 libMagickWand-6.Q16HDRI">
400 <primary sortas="c-libMagickWand-6.Q16HDRI">libMagickWand-6.Q16HDRI.so</primary>
401 </indexterm>
402 </listitem>
403 </varlistentry>
404
405 <varlistentry id="libMagickpp-6.Q16HDRI">
406 <term><filename class="libraryfile">libMagick++-6.Q16HDRI.so</filename></term>
407 <listitem>
408 <para>
409 provides the C++ API for ImageMagick.
410 </para>
411 <indexterm zone="imagemagick6 libMagickpp-6.Q16HDRI">
412 <primary sortas="c-libMagick++-6.Q16HDRI">libMagick++-6.Q16HDRI.so</primary>
413 </indexterm>
414 </listitem>
415 </varlistentry>
416
417 </variablelist>
418
419 </sect2>
420
421</sect1>
Note: See TracBrowser for help on using the repository browser.