source: general/genutils/imagemagick6.xml@ ce80f45

10.0 10.1 11.0 9.0 9.1 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since ce80f45 was ce80f45, checked in by Ken Moffat <ken@…>, 2 years ago

ImageMagick updates for 9.0.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21975 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 17.0 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY imagemagick6-patch-version "60">
8
9 <!ENTITY imagemagick6-download-http "https://www.imagemagick.org/download/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
10 <!ENTITY imagemagick6-download-ftp "ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;.tar.xz">
11 <!ENTITY imagemagick6-md5sum "f76ab105bf4dd23aaae7d4995b0fe9dc">
12 <!ENTITY imagemagick6-size "8.6 MB">
13 <!ENTITY imagemagick6-buildsize "200 MB, with typical dependencies (add 39 MB for tests)">
14 <!ENTITY imagemagick6-time "0.9 SBU (Using parallelism=4; add 1.5 SBU for tests)">
15]>
16
17<!-- Editors: It is highly unlikely that the buildsize (disk space used) will
18 be less than the figure shown above. Unless you have installed *all* the
19 delegate dependencies, you will see a smaller buildsize, but what is
20 currently listed above is the space one would require if all the
21 dependencies available in the book are installed.
22
23 [bdubbs 2019-92-09] Reduced SBU and disk space for libraries only.
24
25 [bdubbs 2918-08-26] I upddated the above stats slightly for 8.3. All BLFS
26 dependencies were installed except gimp and texlive. Note that at this
27 writing the only packagges in the book that use this are gimp and
28 inkscape.
29
30 [pierre 2017-02-14]] For a build of 6.9.7-8 with dependencies available in
31 the book, but with the configure command as below, I got 179 MB (2.3 SBU)
32 (and 472 KB (0.8 SBU) for the validation suite).
33
34 For a non-full build of 6.9.3-8 I got an actual space of 173 MB and running
35 the validation suite does not increase the net space. I recommend running
36 that instead of check (after the install)!
37
38 Following comments preserved from when we did a full install of -6.
39
40 Marked as 'typical' because nobody builds ALL the optional extras [ken]
41
42 [bdubbs] I do; at least the internal ones. I still got only 200 MB.
43
44 Saved the "full" 450MB as a comment - feel free to update this iff you
45 do build all dependencies, it's probably a lot bigger now.
46
47 [bdubbs] Just removed it. I don't think it adds anything.
48
49 Also, please look over the output from the configure command for any
50 additional dependencies that need to be listed, as ImageMagick is
51 constantly adding additional features and dependencies.
52
53 For those of us who touch this infrequently:
54 DPS/dpsXclient is from apple so not relevant to linux builds
55 GVC is part of Graphviz and documented in the explanations
56 LQR is Liquid Rescale
57
58 -->
59
60<sect1 id="imagemagick6" xreflabel="ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version; libraries">
61 <?dbhtml filename="imagemagick6.html"?>
62
63 <sect1info>
64 <othername>$LastChangedBy$</othername>
65 <date>$Date$</date>
66 </sect1info>
67
68 <title>ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;</title>
69
70 <indexterm zone="imagemagick6">
71 <primary sortas="a-ImageMagick-6 libraries">ImageMagick-6 libraries</primary>
72 </indexterm>
73
74 <sect2 role="package">
75 <title>Introduction to ImageMagick-6 libraries</title>
76
77 <para>
78 <application>ImageMagick</application> underwent many changes in its
79 libraries between versions 6 and 7. Most packages in BLFS which use
80 <application>ImageMagick</application> can use version 7, but for the
81 others this page will install only the libraries, headers and general
82 documentation (not programs, manpages, perl modules), and it will
83 rename the unversioned pkgconfig files so that they do not overwrite the
84 same-named files from version 7.
85 </para>
86
87 &lfs84_checked;
88
89 <bridgehead renderas="sect3">Package Information</bridgehead>
90 <itemizedlist spacing="compact">
91 <listitem>
92 <para>Download (HTTP): <ulink url="&imagemagick6-download-http;"/></para>
93 </listitem>
94 <listitem>
95 <para>Download (FTP): <ulink url="&imagemagick6-download-ftp;"/></para>
96 </listitem>
97 <listitem>
98 <para>Download MD5 sum: &imagemagick6-md5sum;</para>
99 </listitem>
100 <listitem>
101 <para>Download size: &imagemagick6-size;</para>
102 </listitem>
103 <listitem>
104 <para>Estimated disk space required: &imagemagick6-buildsize;</para>
105 </listitem>
106 <listitem>
107 <para>Estimated build time: &imagemagick6-time;</para>
108 </listitem>
109 </itemizedlist>
110
111 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
112 <itemizedlist spacing="compact">
113 <listitem>
114 <para>
115 Required patch:
116 <ulink url="&patch-root;/ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch"/>
117 </para>
118 </listitem>
119 </itemizedlist>
120
121 <note>
122 <para>
123 The <application>ImageMagick</application> source releases are updated
124 frequently and the version shown above may no longer be available from
125 the download locations. You can download a more recent version and use
126 the existing BLFS instructions to install it. Chances are that it will
127 work just fine, but this has not been tested by the BLFS team. If the
128 package version shown above is not available from the locations shown
129 above, or from the <filename class='directory'>legacy/</filename>
130 directory at <literal>ftp.ImageMagick.org/pub/ImageMagick</literal> you
131 can download it from the BLFS package server at Oregon State University:
132 <ulink url="ftp://ftp.osuosl.org/pub/blfs/conglomeration/ImageMagick/"/>.
133 </para>
134 </note>
135
136 <bridgehead renderas="sect3">ImageMagick-6 Dependencies</bridgehead>
137
138 <bridgehead renderas="sect4">Recommended</bridgehead>
139 <para role="recommended">
140 <xref linkend="xorg7-lib"/>
141 </para>
142
143 <para>
144 The optional dependencies listed below should be installed if you need
145 support for the specific format or the conversion tool the dependency
146 provides. Many of the dependencies' capabilities and uses are described in
147 the <quote>MAGICK DELEGATES</quote> section of the
148 <filename>README.txt</filename> file located in the source tree.
149 Additional information about the dependencies can be found in the
150 <filename>Install-unix.txt</filename> file located in the source tree as
151 well as issuing the <command>./configure --help</command> command. A
152 summary of this information, as well as some additional notes can be
153 viewed on-line at <ulink
154 url="http://www.imagemagick.org/script/advanced-unix-installation.php"/>.
155 </para>
156
157 <bridgehead renderas="sect4">Optional System Utilities</bridgehead>
158 <para role="optional">
159 <xref linkend="cups"/>,
160 <xref linkend="curl"/>,
161 <xref linkend="ffmpeg"/>,
162 <xref linkend="fftw"/>,
163 <xref linkend="p7zip"/> (LZMA),
164 <xref linkend="sane"/>,
165 <xref linkend="wget"/>,
166 <xref linkend="xdg-utils"/>,
167 <xref linkend="xterm2"/>,
168 <ulink url="http://dmalloc.com/">Dmalloc</ulink>,
169 <ulink url="http://linux.softpedia.com/get/Programming/Debuggers/Electric-Fence-3305.shtml/">Electric Fence</ulink>,
170 <ulink url="http://www.openpgp.org/about/">PGP</ulink> or
171 <xref linkend="gnupg2"/>
172 (you'll have to do some hacking to use <application>GnuPG</application>),
173 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates">Profiles</ulink>,
174 and
175 <ulink url="http://ufraw.sourceforge.net/">ufraw</ulink> (for raw formats
176 listed in
177 <ulink url="http://imagemagick.org/script/formats.php">
178 http://www.imagemagick.org/www/formats.html</ulink>)
179 </para>
180
181 <bridgehead renderas="sect4">Optional Graphics Libraries</bridgehead>
182 <para role="optional">
183 <xref linkend="jasper"/>,
184 <xref linkend="lcms"/> or
185 <xref linkend="lcms2"/>,
186 <xref linkend="libexif"/>,
187 <xref linkend="libgxps"/>,
188 <xref linkend="libjpeg"/>,
189 <xref linkend="libpng"/>,
190 <xref linkend="libraw"/> (RAW_R),
191 <xref linkend="librsvg"/>,
192 <xref linkend="libtiff"/>,
193 <xref linkend="libwebp"/>,
194 <xref linkend="openjpeg2"/>,
195 <xref linkend="pango"/>,
196 <ulink url="http://djvu.sourceforge.net/">DjVuLibre</ulink>,
197 <ulink url="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates/">
198 FlashPIX (libfpx)</ulink>,
199 <ulink url="https://github.com/FLIF-hub/FLIF/releases">FLIF</ulink>,
200 <ulink url="http://www.cl.cam.ac.uk/~mgk25/jbigkit/">JBIG-KIT</ulink>,
201 <!-- <ulink url="&gnome-download-http;/libgxps/">libgxps</ulink>, -->
202 <ulink url="https://github.com/HOST-Oman/libraqm/">libraqm</ulink>,
203 <ulink url="http://liblqr.wikidot.com/en:download-page">Liquid Rescale</ulink>,
204 <ulink url="http://www.openexr.com/">OpenEXR</ulink>, and
205 <ulink url="http://www.agocg.ac.uk/train/cgm/ralcgm.htm">RALCGM</ulink>
206 (or <ulink url="http://www.mcmurchy.com/ralcgm/ralcgm-3.51.tar.gz">ralcgm</ulink>)
207 </para>
208
209 <bridgehead renderas="sect4">Optional Graphics Utilities</bridgehead>
210 <para role="optional">
211 <xref linkend="dejavu-fonts"/>,
212 <xref linkend="gs"/>,
213 <xref linkend="gimp"/>,
214 <xref linkend="graphviz"/>,
215 <xref linkend="inkscape"/>,
216 <ulink url="http://www.blender.org/">Blender</ulink>,
217 <ulink url="http://corefonts.sourceforge.net/">corefonts</ulink>,
218 <ulink url="http://www.ghostscript.com/download/gpcldnld.html">GhostPCL</ulink>,
219 <ulink url="http://www.gnuplot.info/">Gnuplot</ulink>,
220 <ulink url="http://www.povray.org/">POV-Ray</ulink>, and
221 <ulink url="http://www.radiance-online.org/">Radiance</ulink>
222 </para>
223
224 <bridgehead renderas="sect4">Optional Conversion Tools</bridgehead>
225 <para role="optional">
226 <xref linkend="enscript"/>,
227 <xref linkend="texlive"/> (or <xref linkend="tl-installer"/>)
228 <ulink url="http://autotrace.sourceforge.net/">AutoTrace</ulink>,
229 <ulink url="http://www.lizardtech.com/downloads/category/">
230 GeoExpress Command Line Utilities, AKA MrSID Utilities (binary package)</ulink>,
231 <ulink url="http://www.gnu.org/software/hp2xx/">hp2xx</ulink>,
232 <ulink url="http://user.it.uu.se/~jan/html2ps.html">html2ps</ulink>,
233 <ulink url="http://wvware.sourceforge.net/">libwmf</ulink>,
234 <ulink url="http://sk1project.org/modules.php?name=products&amp;product=uniconvertor">
235 UniConvertor</ulink>, and
236 <ulink url="http://www.cs.utah.edu/gdc/projects/urt/">Utah Raster Toolkit</ulink>
237 (or <ulink url="http://www.mcmurchy.com/urt/urt-3.1b.tar.gz">URT-3.1b</ulink>)
238 </para>
239
240 <para condition="html" role="usernotes">User Notes:
241 <!-- share the main page -->
242 <ulink url="&blfs-wiki;/imagemagick"/></para>
243
244 </sect2>
245
246 <sect2 role="installation">
247 <title>Installation of ImageMagick-6 libraries</title>
248
249 <para>
250 Install <application>ImageMagick</application> by running the following
251 commands:
252 </para>
253
254<screen><userinput>patch -Np1 -i ../ImageMagick-&imagemagick6-version;-&imagemagick6-patch-version;-libs_only-1.patch &amp;&amp;
255autoreconf -fi &amp;&amp;
256./configure --prefix=/usr \
257 --sysconfdir=/etc \
258 --enable-hdri \
259 --with-modules \
260 --disable-static &amp;&amp;
261make</userinput></screen>
262
263 <para>
264 Now, as the <systemitem class="username">root</systemitem> user:
265 </para>
266
267<screen role="root"><userinput>make DOCUMENTATION_PATH=/usr/share/doc/imagemagick-&imagemagick6-version; install-libs-only</userinput></screen>
268
269 <para>
270 To test the installation, issue: <command>make check</command>.
271 <!-- in 6.9.9-9 make check runs tests-validate-* A more
272 comprehensive test is the <application>ImageMagick</application>
273 validation suite. If <command>make check</command> has not been executed,
274 run <command>make tests/validate</command> to compile it. Issue
275 <command>tests/validate 2>&amp;1 | tee validate.log</command> to run the
276 validation suite. The result summary may be obtained with <command>grep
277 "validation suite" validate.log</command>.--> Note that the EPS, PS, and PDF
278 tests require a working <application>Ghostscript</application>. One test
279 in 'make check' needs <quote>Helvetica</quote> from <quote>Ghostscript
280 Standard Fonts</quote>, which are optionally installed in
281 <xref linkend="gs"/> - that test, and one other, might fail, but all the
282 validation can still pass.
283 </para>
284
285 </sect2>
286
287 <sect2 role="commands">
288 <title>Command Explanations</title>
289
290 <para>
291 <command>patch -Np1 -i
292 ../ImageMagick-&imagemagick6-version;-imagemagick6_libs_only-1.patch</command>:
293 Move unversioned pkgconfig files to versioned names and provide an option to
294 only install libraries and associated files.
295 </para>
296
297 <para>
298 <parameter>--enable-hdri</parameter>: Enables building of a
299 high dynamic range version of ImageMagick.
300 </para>
301
302 <para>
303 <parameter>--with-modules</parameter>: Enables support for
304 dynamically loadable modules.
305 </para>
306
307 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
308 href="../../xincludes/static-libraries.xml"/>
309
310 <para>
311 <option>--with-gslib</option>: Enables support to use the
312 <application>Ghostscript</application> shared library.
313 </para>
314
315 <para>
316 <option>--with-rsvg</option>: Enables support to use the
317 <application>librsvg</application> library.
318 </para>
319
320 <para>
321 <option>--with-autotrace</option>: Enables support to use
322 the <application>Autotrace</application> library.
323 </para>
324
325 <para>
326 <option>--with-wmf</option>: Enables support to use the
327 <application>libwmf</application> library.
328 </para>
329
330 <para>
331 <option>--with-gvc</option>: Enables support to use
332 <application>GraphViz</application>.
333 </para>
334
335 <para>
336 <option>--with-windows-font-dir=
337 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
338 This option specifies the directory where the Windows CoreFonts are
339 installed.
340 </para>
341
342 <para>
343 <option>--with-dejavu-font-dir=
344 <replaceable>&lt;Some/Directory&gt;</replaceable></option>:
345 This option specifies the directory where the DejaVu fonts are
346 installed.
347 </para>
348
349 <para>
350 The options and parameters listed above are the only ones you should
351 have to pass to the <command>configure</command> script to activate all
352 the delegate dependencies. All other dependencies will be automatically
353 detected and utilized in the build if they are installed.
354 </para>
355
356 </sect2>
357
358 <sect2 role="content">
359 <title>Contents</title>
360
361 <segmentedlist>
362 <segtitle>Installed Programs</segtitle>
363 <segtitle>Installed Libraries</segtitle>
364 <segtitle>Installed Directories</segtitle>
365
366 <seglistitem>
367 <seg>
368 None
369 </seg>
370 <seg>
371 libMagickCore-6.Q16HDRI.so,
372 libMagickWand-6.Q16HDRI.so and
373 libMagick++-6.Q16HDRI.so
374 </seg>
375 <seg>
376 /etc/ImageMagick-6,
377 /usr/include/ImageMagick-6,
378 /usr/lib/ImageMagick-&imagemagick6-version;,
379 /usr/share/doc/ImageMagick-&imagemagick6-version;, and
380 /usr/share/ImageMagick-6
381 </seg>
382 </seglistitem>
383 </segmentedlist>
384
385 <variablelist>
386 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
387 <?dbfo list-presentation="list"?>
388 <?dbhtml list-presentation="table"?>
389
390 <varlistentry id="libMagickCore-6.Q16HDRI">
391 <term><filename class="libraryfile">libMagickCore-6.Q16HDRI.so</filename></term>
392 <listitem>
393 <para>
394 provides the C API for ImageMagick.
395 </para>
396 <indexterm zone="imagemagick6 libMagickCore-6.Q16HDRI">
397 <primary sortas="c-libMagickCore-6.Q16HDRI">libMagickCore-6.Q16HDRI.so</primary>
398 </indexterm>
399 </listitem>
400 </varlistentry>
401
402 <varlistentry id="libMagickWand-6.Q16HDRI">
403 <term><filename class="libraryfile">libMagickWand-6.Q16HDRI.so</filename></term>
404 <listitem>
405 <para>
406 is the recommended C API for ImageMagick. Unlike the MagickCore API it
407 uses only a few opaque types.
408 </para>
409 <indexterm zone="imagemagick6 libMagickWand-6.Q16HDRI">
410 <primary sortas="c-libMagickWand-6.Q16HDRI">libMagickWand-6.Q16HDRI.so</primary>
411 </indexterm>
412 </listitem>
413 </varlistentry>
414
415 <varlistentry id="libMagickpp-6.Q16HDRI">
416 <term><filename class="libraryfile">libMagick++-6.Q16HDRI.so</filename></term>
417 <listitem>
418 <para>
419 provides the C++ API for ImageMagick.
420 </para>
421 <indexterm zone="imagemagick6 libMagickpp-6.Q16HDRI">
422 <primary sortas="c-libMagick++-6.Q16HDRI">libMagick++-6.Q16HDRI.so</primary>
423 </indexterm>
424 </listitem>
425 </varlistentry>
426
427 </variablelist>
428
429 </sect2>
430
431</sect1>
Note: See TracBrowser for help on using the repository browser.