source: general/graphlib/poppler.xml@ 333dd3f

10.0 10.1 11.0 9.1 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 333dd3f was 333dd3f, checked in by Xi Ruoyao <xry111@…>, 2 years ago

poppler: add optional dependency boost

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@22193 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 16.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY poppler-download-http "https://poppler.freedesktop.org/poppler-&poppler-version;.tar.xz">
8 <!ENTITY poppler-download-ftp " ">
9 <!ENTITY poppler-md5sum "8ff9964d1fcc9c334a9c66f6f426ab9c">
10 <!ENTITY poppler-size "1.5 MB">
11 <!ENTITY poppler-buildsize "64 MB (with Qt5 library and tests)">
12 <!ENTITY poppler-time "0.8 SBU (with parallelism=4, Qt5 library, and tests)">
13
14 <!ENTITY poppler-data-version "0.4.9">
15
16 <!ENTITY poppler-data-download-http "https://poppler.freedesktop.org/poppler-data-&poppler-data-version;.tar.gz">
17 <!ENTITY poppler-data-md5sum "35cc7beba00aa174631466f06732be40">
18 <!ENTITY poppler-data-size "4.1 MB">
19 <!ENTITY poppler-data-buildsize "13 MB">
20 <!ENTITY poppler-data-time "less than 0.1 SBU">
21]>
22
23<sect1 id="poppler" xreflabel="Poppler-&poppler-version;">
24 <?dbhtml filename="poppler.html"?>
25
26 <sect1info>
27 <othername>$LastChangedBy$</othername>
28 <date>$Date$</date>
29 </sect1info>
30
31 <title>Poppler-&poppler-version;</title>
32
33 <indexterm zone="poppler">
34 <primary sortas="a-Poppler">Poppler</primary>
35 </indexterm>
36
37 <sect2 role="package">
38 <title>Introduction to Poppler</title>
39
40 <para>
41 The <application>Poppler</application> package contains a PDF rendering
42 library and command line tools used to manipulate PDF files. This is
43 useful for providing PDF rendering functionality as a shared library.
44 </para>
45
46 &lfs90_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&poppler-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&poppler-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &poppler-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &poppler-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &poppler-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &poppler-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83
84 <itemizedlist spacing="compact">
85 <title>Poppler Encoding Data</title>
86 <listitem>
87 <para>
88 Download (HTTP): <ulink url="&poppler-data-download-http;"/>
89 </para>
90 </listitem>
91 <listitem>
92 <para>
93 Download MD5 sum: &poppler-data-md5sum;
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download size: &poppler-data-size;
99 </para>
100 </listitem>
101 <listitem>
102 <para>
103 Estimated disk space required: &poppler-data-buildsize;
104 </para>
105 </listitem>
106 <listitem>
107 <para>
108 Estimated build time: &poppler-data-time;
109 </para>
110 </listitem>
111 </itemizedlist>
112
113 <para>
114 The additional package consists of encoding files for use with
115 <application>Poppler</application>. The encoding files are optional and
116 <application>Poppler</application> will automatically read them if they
117 are present. When installed, they enable
118 <application>Poppler</application> to render CJK and Cyrillic properly.
119 </para>
120
121 <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
122
123 <bridgehead renderas="sect4">Required</bridgehead>
124 <para role="required">
125 <xref linkend="cmake"/> and
126 <xref linkend="fontconfig"/>
127 </para>
128
129 <bridgehead renderas="sect4">Recommended</bridgehead>
130 <para role="recommended">
131 <xref linkend="cairo"/>,
132 <xref linkend="lcms2"/>,
133 <xref linkend="libjpeg"/>,
134 <xref linkend="libpng"/>,
135 <xref linkend="nss"/>, and
136 <xref linkend="openjpeg2"/>
137 </para>
138
139 <bridgehead renderas="sect4">Optional</bridgehead>
140 <para role="optional">
141 <xref linkend="boost"/>,
142 <xref linkend="curl"/>,
143 <xref linkend="gdk-pixbuf"/>,
144 <xref linkend="git"/> (for downloading test files),
145 <xref linkend="gobject-introspection"/>,
146 <xref linkend="gtk-doc"/>,
147 <xref linkend="gtk3"/>,
148 <xref linkend="libtiff"/>,
149 <xref linkend="python2"/>, and
150 <xref linkend="qt5"/>
151 (required for PDF support in <xref role="nodep" linkend="okular5"/>)
152 </para>
153
154 <para condition="html" role="usernotes">
155 User Notes: <ulink url="&blfs-wiki;/poppler"/>
156 </para>
157 </sect2>
158
159 <sect2 role="installation">
160 <title>Installation of Poppler</title>
161
162 <para>
163 Install <application>Poppler</application> by running the following
164 commands:
165 </para>
166
167<screen><userinput>mkdir build &amp;&amp;
168cd build &amp;&amp;
169
170cmake -DCMAKE_BUILD_TYPE=Release \
171 -DCMAKE_INSTALL_PREFIX=/usr \
172 -DTESTDATADIR=$PWD/testfiles \
173 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
174<!-- -DENABLE_GTK_DOC=ON \
175--> .. &amp;&amp;
176make</userinput></screen>
177
178 <para>
179 In order to run the test suite, some testcases are needed and can
180 be obtained only from a git repository. The command to download
181 them is:
182<command>git clone git://git.freedesktop.org/git/poppler/test testfiles</command>.
183 Then issue: <command>LC_ALL=en_US.UTF-8 make test</command>.
184 Only the Qt5 libraries are tested.
185 </para>
186
187 <para>
188 Now, as the <systemitem class="username">root</systemitem> user:
189 </para>
190
191<screen role="root"><userinput>make install</userinput></screen>
192<!-- Seems makeinstall does the job now:
193 <para>
194 If you have Qt installed, again as the
195 <systemitem class="username">root</systemitem> user:
196 </para>
197
198<screen role="root"><userinput>make -C qt5 install &amp;&amp;
199install -m644 poppler-qt5.pc /usr/lib/pkgconfig</userinput></screen>
200-->
201 <para>
202 To install the documentation, run the following commands as
203 <systemitem class="username">root</systemitem>:
204 </para>
205
206<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/poppler-&poppler-version; &amp;&amp;
207cp -vr ../glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput></screen>
208
209<!-- ==== Poppler Data ====== -->
210 <bridgehead renderas="sect3">Poppler Data</bridgehead>
211
212 <para>
213 If you downloaded the additional encoding data package, install it by
214 issuing the following commands:
215 </para>
216
217<screen><userinput>tar -xf ../../poppler-data-&poppler-data-version;.tar.gz &amp;&amp;
218cd poppler-data-&poppler-data-version;</userinput></screen>
219
220 <para>
221 Now, as the <systemitem class="username">root</systemitem> user:
222 </para>
223
224<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
225
226 </sect2>
227
228 <sect2 role="commands">
229 <title>Command Explanations</title>
230
231 <para>
232 <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
233 to apply a higher level of compiler optimizations.
234 </para>
235
236 <para>
237 <parameter>-DTESTDATADIR=$PWD/testfiles</parameter>: Tell the test
238 programs where the auxiliary files are located.
239 </para>
240
241 <para>
242 <parameter>-DENABLE_UNSTABLE_API_ABI_HEADERS=ON</parameter>: Install some old
243 <application>Xpdf</application> headers required by certain programs (e.g.
244 <application>Inkscape</application>).
245 </para>
246<!-- This was broken for me - Bruce
247 Still broken with 0.69.0 - Doug
248 Seems to work with 0.73.0 - Pierre -->
249 <para>
250 <option>-DENABLE_GTK_DOC=ON</option>: Use this parameter if
251 GTK-Doc is installed and you wish to rebuild and install
252 the API documentation. If Python 2 is not installed, one script
253 needs to be changed: run <command>sed -i '1s/python/&amp;3/'
254 make-glib-api-docs</command> first.
255 </para>
256
257 <para>
258 <command>LC_ALL=en_US.UTF-8 make test</command>: Run the test suite.
259 The environment variable LC_ALL=en_US.UTF-8 is only needed if the
260 default locale does not include UTF-8.
261 </para>
262
263 </sect2>
264
265 <sect2 role="content">
266 <title>Contents</title>
267
268 <segmentedlist>
269 <segtitle>Installed Programs</segtitle>
270 <segtitle>Installed Libraries</segtitle>
271 <segtitle>Installed Directories</segtitle>
272
273 <seglistitem>
274 <seg>
275 pdfattach, pdfdetach, pdffonts, pdfimages, pdfinfo, pdfseparate,
276 pdfsig, pdftocairo, pdftohtml, pdftoppm, pdftops, pdftotext, and
277 pdfunite
278 </seg>
279 <seg>
280 libpoppler.so,
281 libpoppler-cpp.so,
282 libpoppler-glib.so, and
283 libpoppler-qt5.so
284 </seg>
285 <seg>
286 /usr/include/poppler,
287 /usr/share/poppler, and
288 /usr/share/doc/poppler-&poppler-version;
289 </seg>
290 </seglistitem>
291 </segmentedlist>
292
293 <variablelist>
294 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
295 <?dbfo list-presentation="list"?>
296 <?dbhtml list-presentation="table"?>
297
298 <varlistentry id="pdfattach">
299 <term><command>pdfattach</command></term>
300 <listitem>
301 <para>
302 adds a new embedded file to an existing PDF file.
303 </para>
304 <indexterm zone="poppler pdfattach">
305 <primary sortas="b-pdfattach">pdfattach</primary>
306 </indexterm>
307 </listitem>
308 </varlistentry>
309
310 <varlistentry id="pdfdetach">
311 <term><command>pdfdetach</command></term>
312 <listitem>
313 <para>
314 lists or extracts embedded files from PDF files.
315 </para>
316 <indexterm zone="poppler pdfdetach">
317 <primary sortas="b-pdfdetach">pdfdetach</primary>
318 </indexterm>
319 </listitem>
320 </varlistentry>
321
322 <varlistentry id="pdffonts">
323 <term><command>pdffonts</command></term>
324 <listitem>
325 <para>
326 lists the fonts used in a PDF file along with various information
327 for each font.
328 </para>
329 <indexterm zone="poppler pdffonts">
330 <primary sortas="b-pdffonts">pdffonts</primary>
331 </indexterm>
332 </listitem>
333 </varlistentry>
334
335 <varlistentry id="pdfimages">
336 <term><command>pdfimages</command></term>
337 <listitem>
338 <para>
339 saves images from a PDF file as PPM, PBM, or JPEG files.
340 </para>
341 <indexterm zone="poppler pdfimages">
342 <primary sortas="b-pdfimages">pdfimages</primary>
343 </indexterm>
344 </listitem>
345 </varlistentry>
346
347 <varlistentry id="pdfinfo">
348 <term><command>pdfinfo</command></term>
349 <listitem>
350 <para>
351 prints the contents of the 'Info' dictionary (plus some other useful
352 information) from a PDF file.
353 </para>
354 <indexterm zone="poppler pdfinfo">
355 <primary sortas="b-pdfinfo">pdfinfo</primary>
356 </indexterm>
357 </listitem>
358 </varlistentry>
359
360 <varlistentry id="pdfseparate">
361 <term><command>pdfseparate</command></term>
362 <listitem>
363 <para>
364 extracts single pages from a PDF file.
365 </para>
366 <indexterm zone="poppler pdfseparate">
367 <primary sortas="b-pdseparate">pdfseparate</primary>
368 </indexterm>
369 </listitem>
370 </varlistentry>
371
372 <varlistentry id="pdfsig">
373 <term><command>pdfsig</command></term>
374 <listitem>
375 <para>
376 verifies the digital signatures in a PDF document.
377 </para>
378 <indexterm zone="poppler pdfsig">
379 <primary sortas="b-pdseparate">pdfsig</primary>
380 </indexterm>
381 </listitem>
382 </varlistentry>
383
384 <varlistentry id="pdftocairo">
385 <term><command>pdftocairo</command></term>
386 <listitem>
387 <para>
388 converts a PDF file to one of several formats (PNG, JPEG, PDF, PS,
389 EPS, SVG) using the cairo output device of the poppler library.
390 </para>
391 <indexterm zone="poppler pdftocairo">
392 <primary sortas="b-pdftocairo">pdftocairo</primary>
393 </indexterm>
394 </listitem>
395 </varlistentry>
396
397 <varlistentry id="pdftohtml">
398 <term><command>pdftohtml</command></term>
399 <listitem>
400 <para>
401 converts a PDF file to HTML.
402 </para>
403 <indexterm zone="poppler pdftohtml">
404 <primary sortas="b-pdftohtml">pdftohtml</primary>
405 </indexterm>
406 </listitem>
407 </varlistentry>
408
409 <varlistentry id="pdftoppm">
410 <term><command>pdftoppm</command></term>
411 <listitem>
412 <para>
413 converts PDF files to PBM, PGM and PPM formats.
414 </para>
415 <indexterm zone="poppler pdftoppm">
416 <primary sortas="b-pdftoppm">pdftoppm</primary>
417 </indexterm>
418 </listitem>
419 </varlistentry>
420
421 <varlistentry id="pdftops">
422 <term><command>pdftops</command></term>
423 <listitem>
424 <para>
425 converts PDF files to Postscript format.
426 </para>
427 <indexterm zone="poppler pdftops">
428 <primary sortas="b-pdftops">pdftops</primary>
429 </indexterm>
430 </listitem>
431 </varlistentry>
432
433 <varlistentry id="pdftotext">
434 <term><command>pdftotext</command></term>
435 <listitem>
436 <para>
437 converts PDF files to plain text.
438 </para>
439 <indexterm zone="poppler pdftotext">
440 <primary sortas="b-pdftotext">pdftotext</primary>
441 </indexterm>
442 </listitem>
443 </varlistentry>
444
445 <varlistentry id="pdfunite">
446 <term><command>pdfunite</command></term>
447 <listitem>
448 <para>
449 merges several PDF files, in the order of their occurrence on the
450 command line, to one PDF output file.
451 </para>
452 <indexterm zone="poppler pdfunite">
453 <primary sortas="b-pdfunite">pdfunite</primary>
454 </indexterm>
455 </listitem>
456 </varlistentry>
457
458 <varlistentry id="libpoppler">
459 <term><filename class="libraryfile">libpoppler.so</filename></term>
460 <listitem>
461 <para>
462 contains the API functions to render PDF files.
463 </para>
464 <indexterm zone="poppler libpoppler">
465 <primary sortas="c-libpoppler">libpoppler.so</primary>
466 </indexterm>
467 </listitem>
468 </varlistentry>
469
470 <varlistentry id="libpoppler-cpp">
471 <term><filename class="libraryfile">libpoppler-cpp.so</filename></term>
472 <listitem>
473 <para>
474 is a C++ backend for rendering PDF files.
475 </para>
476 <indexterm zone="poppler libpoppler-cpp">
477 <primary sortas="c-libpoppler-cpp">libpoppler-cpp.so</primary>
478 </indexterm>
479 </listitem>
480 </varlistentry>
481
482 <varlistentry id="libpoppler-glib">
483 <term><filename class="libraryfile">libpoppler-glib.so</filename></term>
484 <listitem>
485 <para>
486 is a wrapper library used to interface the PDF rendering functions
487 with <application>GTK+</application>.
488 </para>
489 <indexterm zone="poppler libpoppler-glib">
490 <primary sortas="c-libpoppler-glib">libpoppler-glib.so</primary>
491 </indexterm>
492 </listitem>
493 </varlistentry>
494
495 <varlistentry id="libpoppler-qt5">
496 <term><filename class="libraryfile">libpoppler-qt5.so</filename></term>
497 <listitem>
498 <para>
499 is a wrapper library used to interface the PDF rendering functions
500 with <application>Qt</application>5.
501 </para>
502 <indexterm zone="poppler libpoppler-qt5">
503 <primary sortas="c-libpoppler-qt5">libpoppler-qt5.so</primary>
504 </indexterm>
505 </listitem>
506 </varlistentry>
507
508 </variablelist>
509
510 </sect2>
511
512</sect1>
Note: See TracBrowser for help on using the repository browser.