source: general/graphlib/poppler.xml@ 420c072

10.0 10.1 11.0 7.10 7.6 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 420c072 was 420c072, checked in by Fernando de Oliveira <fernando@…>, 7 years ago

Update to libreoffice-4.3.0. Patch sent by Christopher G, from systemd branch, thank you very much. Some fixes from Armin K, from systemd branch, thanks.
Update to poppler-0.26.4.
Update to doxygen-1.8.8.
Update to lxpanel-0.7.0.
Update to xine-ui-0.99.9.
Update to php-5.5.16.
Update to libwebp-0.4.18.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@13990 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 15.9 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY poppler-download-http
8 "http://poppler.freedesktop.org/poppler-&poppler-version;.tar.xz">
9 <!ENTITY poppler-download-ftp " ">
10 <!ENTITY poppler-md5sum "e58cdddfc7dc01f00bf7394e0e4f21ce">
11 <!ENTITY poppler-size "1.6 MB">
12 <!ENTITY poppler-buildsize "145 MB (building Qt4 and Qt5 libraries, additional 46 MB for the test suite and 24 MB for poppler-data)">
13 <!ENTITY poppler-time "1.7 SBU (building Qt4 and Qt5 libraries, additional 0.2 SBU for the test suite for each Qt)">
14
15 <!ENTITY poppler-data-version "0.4.7">
16
17 <!ENTITY poppler-data-download-http
18 "http://poppler.freedesktop.org/poppler-data-&poppler-data-version;.tar.gz">
19 <!ENTITY poppler-data-md5sum "636a8f2b9f6df9e7ced8ec0946961eaf">
20 <!ENTITY poppler-data-size "4.0 MB">
21]>
22
23<sect1 id="poppler" xreflabel="Poppler-&poppler-version;">
24 <?dbhtml filename="poppler.html"?>
25
26 <sect1info>
27 <othername>$LastChangedBy$</othername>
28 <date>$Date$</date>
29 </sect1info>
30
31 <title>Poppler-&poppler-version;</title>
32
33 <indexterm zone="poppler">
34 <primary sortas="a-Poppler">Poppler</primary>
35 </indexterm>
36
37 <sect2 role="package">
38 <title>Introduction to Poppler</title>
39
40 <para>
41 The <application>Poppler</application> package contains a PDF rendering
42 library and command line tools used to manipulate PDF files. This is
43 useful for providing PDF rendering functionality as a shared library.
44 </para>
45
46 &lfs75_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&poppler-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&poppler-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &poppler-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &poppler-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &poppler-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &poppler-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83
84 <itemizedlist spacing="compact">
85 <title>Poppler Encoding Data</title>
86 <listitem>
87 <para>
88 Download (HTTP): <ulink url="&poppler-data-download-http;"/>
89 </para>
90 </listitem>
91 <listitem>
92 <para>
93 Download MD5 sum: &poppler-data-md5sum;
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download size: &poppler-data-size;
99 </para>
100 </listitem>
101 </itemizedlist>
102
103 <para>
104 The additional package consists of encoding files for use with
105 <application>Poppler</application>. The encoding files are optional and
106 <application>Poppler</application> will automatically read them if they
107 are present. When installed, they enable
108 <application>Poppler</application> to render CJK and Cyrillic properly.
109 </para>
110
111 <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
112
113 <bridgehead renderas="sect4">Required</bridgehead>
114 <para role="required">
115 <xref linkend="fontconfig"/>
116 </para>
117
118 <bridgehead renderas="sect4">Recommended</bridgehead>
119 <para role="recommended">
120 <xref linkend="cairo"/>,
121 <xref linkend="libjpeg"/>, and
122 <xref linkend="libpng"/>
123 </para>
124
125 <bridgehead renderas="sect4">Optional</bridgehead>
126 <para role="optional">
127 <xref linkend="curl"/>,
128 <xref linkend="gobject-introspection"/>,
129 <xref linkend="gtk2"/>,
130 <xref linkend="lcms"/> or <xref linkend="lcms2"/>,
131 <xref linkend="libtiff"/>,
132 <xref linkend="openjpeg"/>,
133 <xref linkend="qt4"/> (the <filename>libpoppler-qt4.so</filename> library
134 is needed for PDF support in <application>Okular</application>), and
135 <xref linkend="qt5"/>
136 </para>
137
138 <para condition="html" role="usernotes">
139 User Notes: <ulink url="&blfs-wiki;/poppler"/>
140 </para>
141 </sect2>
142
143 <sect2 role="installation">
144 <title>Installation of Poppler</title>
145
146 <para>
147 In order to optionally run the test suite, additional download of about
148 9 MB, using <xref linkend="git"/>, is necessary. Make sure that you do
149 not have the directory ../test.
150 </para>
151
152<screen><userinput>git clone git://git.freedesktop.org/git/poppler/test ../test</userinput></screen>
153
154 <para>
155 If you are not building both <application>Qt</application> libraries,
156 jump to the following paragraph. In order to build both
157 <application>Qt4</application> and <application>Qt5</application>
158 libraries, you need to run the install commands twice, because although
159 both are detected, only wrapper for the first
160 <application>Qt</application> version in PATH is built. Either can be
161 built first, but to facilitate the explanation, we choose first the
162 <application>Qt4</application> library. You can do this using
163 <command>source setqt4</command> (script from <xref linkend="qt4"/>).
164 </para>
165
166 <para>
167 Install <application>Poppler</application> by running the following
168 commands:
169 </para>
170
171<!-- Warning: Using zlib is not totally safe -->
172<screen><userinput>./configure --prefix=/usr \
173 --sysconfdir=/etc \
174 --disable-static \
175 --enable-xpdf-headers &amp;&amp;
176make</userinput></screen>
177
178 <para>
179 To test the results, issue: <command>make check</command>.
180 </para>
181
182 <para>
183 Now, as the <systemitem class="username">root</systemitem> user:
184 </para>
185
186<screen role="root"><userinput>make install</userinput></screen>
187
188 <para>
189 If you are not building both <application>Qt</application> libraries,
190 jump to the following paragraph. If you want to build both
191 <application>Qt</application> libraries, first switch back to
192 unpriviledged user, run <command>source setqt5</command>, from
193 <xref linkend="qt5"/>, and repeat the instructions from configuration
194 until install. After that, proceed to install the documents until the end.
195 </para>
196
197 <para>
198 The documents are installed using the following commands:
199 </para>
200
201<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/poppler-&poppler-version; &amp;&amp;
202install -v -m644 README* /usr/share/doc/poppler-&poppler-version;</userinput></screen>
203
204 <para>
205 If you downloaded the additional encoding data package, install it by
206 issuing the following commands as the
207 <systemitem class="username">root</systemitem> user:
208 </para>
209
210<screen><userinput>tar -xf ../poppler-data-&poppler-data-version;.tar.gz &amp;&amp;
211cd poppler-data-&poppler-data-version;</userinput></screen>
212
213 <para>
214 Now, as the <systemitem class="username">root</systemitem> user:
215 </para>
216
217<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
218
219 </sect2>
220
221 <sect2 role="commands">
222 <title>Command Explanations</title>
223
224 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
225 href="../../xincludes/static-libraries.xml"/>
226
227 <para>
228 <option>--enable-xpdf-headers</option>: Install some old
229 <application>Xpdf</application> headers required by certain programs (e.g.
230 <application>Okular</application>, <application>LibreOffice</application>
231 and <application>Inkscape</application>).
232 </para>
233
234 <para>
235 <option>--enable-libcurl</option>: Use libcurl for HTTP support.
236 </para>
237
238 </sect2>
239
240 <sect2 role="content">
241 <title>Contents</title>
242
243 <segmentedlist>
244 <segtitle>Installed Programs</segtitle>
245 <segtitle>Installed Libraries</segtitle>
246 <segtitle>Installed Directories</segtitle>
247
248 <seglistitem>
249 <seg>
250 pdfdetach, pdffonts, pdfimages, pdfinfo, pdfseparate,
251 pdftocairo, pdftohtml, pdftoppm, pdftops, pdftotext,
252 pdfunite, and poppler-glib-demo
253 </seg>
254 <seg>
255 libpoppler.so, libpoppler-cpp.so,
256 libpoppler-glib.so,
257 libpoppler-qt4.so, and
258 libpoppler-qt5.so
259 </seg>
260 <seg>
261 /usr/include/poppler,
262 /usr/share/doc/poppler-&poppler-version;,
263 /usr/share/gtk-doc/html/poppler, and
264 /usr/share/poppler
265 </seg>
266 </seglistitem>
267 </segmentedlist>
268
269 <variablelist>
270 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
271 <?dbfo list-presentation="list"?>
272 <?dbhtml list-presentation="table"?>
273
274 <varlistentry id="pdfdetach">
275 <term><command>pdfdetach</command></term>
276 <listitem>
277 <para>
278 lists or extracts embedded files from PDF files.
279 </para>
280 <indexterm zone="poppler pdfdetach">
281 <primary sortas="b-pdfdetach">pdfdetach</primary>
282 </indexterm>
283 </listitem>
284 </varlistentry>
285
286 <varlistentry id="pdffonts">
287 <term><command>pdffonts</command></term>
288 <listitem>
289 <para>
290 lists the fonts used in a PDF file along with various information
291 for each font.
292 </para>
293 <indexterm zone="poppler pdffonts">
294 <primary sortas="b-pdffonts">pdffonts</primary>
295 </indexterm>
296 </listitem>
297 </varlistentry>
298
299 <varlistentry id="pdfimages">
300 <term><command>pdfimages</command></term>
301 <listitem>
302 <para>
303 saves images from a PDF file as PPM, PBM, or JPEG files.
304 </para>
305 <indexterm zone="poppler pdfimages">
306 <primary sortas="b-pdfimages">pdfimages</primary>
307 </indexterm>
308 </listitem>
309 </varlistentry>
310
311 <varlistentry id="pdfinfo">
312 <term><command>pdfinfo</command></term>
313 <listitem>
314 <para>
315 prints the contents of the 'Info' dictionary (plus some other useful
316 information) from a PDF file.
317 </para>
318 <indexterm zone="poppler pdfinfo">
319 <primary sortas="b-pdfinfo">pdfinfo</primary>
320 </indexterm>
321 </listitem>
322 </varlistentry>
323
324 <varlistentry id="pdfseparate">
325 <term><command>pdfseparate</command></term>
326 <listitem>
327 <para>
328 extracts single pages from a PDF file.
329 </para>
330 <indexterm zone="poppler pdfseparate">
331 <primary sortas="b-pdseparate">pdfseparate</primary>
332 </indexterm>
333 </listitem>
334 </varlistentry>
335
336 <varlistentry id="pdftocairo">
337 <term><command>pdftocairo</command></term>
338 <listitem>
339 <para>
340 converts a PDF file to one of several formats (PNG, JPEG, PDF, PS,
341 EPS, SVG) using the cairo output device of the poppler library.
342 </para>
343 <indexterm zone="poppler pdftocairo">
344 <primary sortas="b-pdftocairo">pdftocairo</primary>
345 </indexterm>
346 </listitem>
347 </varlistentry>
348
349 <varlistentry id="pdftohtml">
350 <term><command>pdftohtml</command></term>
351 <listitem>
352 <para>
353 converts a PDF file to HTML.
354 </para>
355 <indexterm zone="poppler pdftohtml">
356 <primary sortas="b-pdftohtml">pdftohtml</primary>
357 </indexterm>
358 </listitem>
359 </varlistentry>
360
361 <varlistentry id="pdftoppm">
362 <term><command>pdftoppm</command></term>
363 <listitem>
364 <para>
365 converts PDF files to PBM, PGM and PPM formats.
366 </para>
367 <indexterm zone="poppler pdftoppm">
368 <primary sortas="b-pdftoppm">pdftoppm</primary>
369 </indexterm>
370 </listitem>
371 </varlistentry>
372
373 <varlistentry id="pdftops">
374 <term><command>pdftops</command></term>
375 <listitem>
376 <para>
377 converts PDF files to Postscript format.
378 </para>
379 <indexterm zone="poppler pdftops">
380 <primary sortas="b-pdftops">pdftops</primary>
381 </indexterm>
382 </listitem>
383 </varlistentry>
384
385 <varlistentry id="pdftotext">
386 <term><command>pdftotext</command></term>
387 <listitem>
388 <para>
389 converts PDF files to plain text.
390 </para>
391 <indexterm zone="poppler pdftotext">
392 <primary sortas="b-pdftotext">pdftotext</primary>
393 </indexterm>
394 </listitem>
395 </varlistentry>
396
397 <varlistentry id="pdfunite">
398 <term><command>pdfunite</command></term>
399 <listitem>
400 <para>
401 merges several PDF files, in the order of their occurrence on the
402 command line, to one PDF output file.
403 </para>
404 <indexterm zone="poppler pdfunite">
405 <primary sortas="b-pdfunite">pdfunite</primary>
406 </indexterm>
407 </listitem>
408 </varlistentry>
409
410 <varlistentry id="poppler-glib-demo">
411 <term><command>poppler-glib-demo</command></term>
412 <listitem>
413 <para>
414 is a tool to demonstrate the API, and for use when debugging and
415 testing <application>Poppler</application>.
416 </para>
417 <indexterm zone="poppler poppler-glib-demo">
418 <primary sortas="b-poppler-glib-demo">poppler-glib-demo</primary>
419 </indexterm>
420 </listitem>
421 </varlistentry>
422
423 <varlistentry id="libpoppler">
424 <term><filename class="libraryfile">libpoppler.so</filename></term>
425 <listitem>
426 <para>
427 contains the API functions to render PDF files.
428 </para>
429 <indexterm zone="poppler libpoppler">
430 <primary sortas="c-libpoppler">libpoppler.so</primary>
431 </indexterm>
432 </listitem>
433 </varlistentry>
434
435 <varlistentry id="libpoppler-cpp">
436 <term><filename class="libraryfile">libpoppler-cpp.so</filename></term>
437 <listitem>
438 <para>
439 is a C++ backend for rendering PDF files.
440 </para>
441 <indexterm zone="poppler libpoppler-cpp">
442 <primary sortas="c-libpoppler-cpp">libpoppler-cpp.so</primary>
443 </indexterm>
444 </listitem>
445 </varlistentry>
446
447 <varlistentry id="libpoppler-glib">
448 <term><filename class="libraryfile">libpoppler-glib.so</filename></term>
449 <listitem>
450 <para>
451 is a wrapper library used to interface the PDF rendering functions
452 with <application>GTK+</application>.
453 </para>
454 <indexterm zone="poppler libpoppler-glib">
455 <primary sortas="c-libpoppler-glib">libpoppler-glib.so</primary>
456 </indexterm>
457 </listitem>
458 </varlistentry>
459
460 <varlistentry id="libpoppler-qt4">
461 <term><filename class="libraryfile">libpoppler-qt4.so</filename></term>
462 <listitem>
463 <para>
464 is a wrapper library used to interface the PDF rendering functions
465 with <application>Qt</application>4.
466 </para>
467 <indexterm zone="poppler libpoppler-qt4">
468 <primary sortas="c-libpoppler-qt4">libpoppler-qt4.so</primary>
469 </indexterm>
470 </listitem>
471 </varlistentry>
472
473 <varlistentry id="libpoppler-qt5">
474 <term><filename class="libraryfile">libpoppler-qt5.so</filename></term>
475 <listitem>
476 <para>
477 is a wrapper library used to interface the PDF rendering functions
478 with <application>Qt</application>5.
479 </para>
480 <indexterm zone="poppler libpoppler-qt5">
481 <primary sortas="c-libpoppler-qt5">libpoppler-qt5.so</primary>
482 </indexterm>
483 </listitem>
484 </varlistentry>
485
486 </variablelist>
487
488 </sect2>
489
490</sect1>
Note: See TracBrowser for help on using the repository browser.