source: general/graphlib/poppler.xml@ 50cbddce

10.0 10.1 11.0 11.1 11.2 lazarus plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since 50cbddce was 50cbddce, checked in by Douglas R. Reno <renodr@…>, 3 years ago

Update to babl-0.1.76
Update to Net::DNS-1.24 (Perl Module)
Update to valgrind-3.16.0
Update to poppler-0.89.0
Update to cryptsetup-2.3.3
Update to cmake-3.17.3

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23211 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 16.0 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY poppler-download-http "https://poppler.freedesktop.org/poppler-&poppler-version;.tar.xz">
8 <!ENTITY poppler-download-ftp " ">
9 <!ENTITY poppler-md5sum "92ac57f60ae8c3a1f8bfe01c9530b7b5">
10 <!ENTITY poppler-size "1.5 MB">
11 <!ENTITY poppler-buildsize "91 MB (with Qt5 library and tests)">
12 <!ENTITY poppler-time "1.2 SBU (with parallelism=4, Qt5 library, and tests)">
13
14 <!ENTITY poppler-data-version "0.4.9">
15
16 <!ENTITY poppler-data-download-http "https://poppler.freedesktop.org/poppler-data-&poppler-data-version;.tar.gz">
17 <!ENTITY poppler-data-md5sum "35cc7beba00aa174631466f06732be40">
18 <!ENTITY poppler-data-size "4.1 MB">
19 <!ENTITY poppler-data-buildsize "13 MB">
20 <!ENTITY poppler-data-time "less than 0.1 SBU">
21]>
22
23<sect1 id="poppler" xreflabel="Poppler-&poppler-version;">
24 <?dbhtml filename="poppler.html"?>
25
26 <sect1info>
27 <othername>$LastChangedBy$</othername>
28 <date>$Date$</date>
29 </sect1info>
30
31 <title>Poppler-&poppler-version;</title>
32
33 <indexterm zone="poppler">
34 <primary sortas="a-Poppler">Poppler</primary>
35 </indexterm>
36
37 <sect2 role="package">
38 <title>Introduction to Poppler</title>
39
40 <para>
41 The <application>Poppler</application> package contains a PDF rendering
42 library and command line tools used to manipulate PDF files. This is
43 useful for providing PDF rendering functionality as a shared library.
44 </para>
45
46 &lfs91_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&poppler-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&poppler-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &poppler-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &poppler-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &poppler-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &poppler-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83
84 <itemizedlist spacing="compact">
85 <title>Poppler Encoding Data</title>
86 <listitem>
87 <para>
88 Download (HTTP): <ulink url="&poppler-data-download-http;"/>
89 </para>
90 </listitem>
91 <listitem>
92 <para>
93 Download MD5 sum: &poppler-data-md5sum;
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download size: &poppler-data-size;
99 </para>
100 </listitem>
101 <listitem>
102 <para>
103 Estimated disk space required: &poppler-data-buildsize;
104 </para>
105 </listitem>
106 <listitem>
107 <para>
108 Estimated build time: &poppler-data-time;
109 </para>
110 </listitem>
111 </itemizedlist>
112
113 <para>
114 The additional package consists of encoding files for use with
115 <application>Poppler</application>. The encoding files are optional and
116 <application>Poppler</application> will automatically read them if they
117 are present. When installed, they enable
118 <application>Poppler</application> to render CJK and Cyrillic properly.
119 </para>
120
121 <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
122
123 <bridgehead renderas="sect4">Required</bridgehead>
124 <para role="required">
125 <xref linkend="cmake"/> and
126 <xref linkend="fontconfig"/>
127 </para>
128
129 <bridgehead renderas="sect4">Recommended</bridgehead>
130 <para role="recommended">
131 <xref linkend="cairo"/>,
132 <xref linkend="lcms2"/>,
133 <xref linkend="libjpeg"/>,
134 <xref linkend="libpng"/>,
135 <xref linkend="nss"/>, and
136 <xref linkend="openjpeg2"/>
137 </para>
138
139 <bridgehead renderas="sect4">Optional</bridgehead>
140 <para role="optional">
141 <xref linkend="boost"/>,
142 <xref linkend="curl"/>,
143 <xref linkend="gdk-pixbuf"/>,
144 <xref linkend="git"/> (for downloading test files),
145 <xref linkend="gobject-introspection"/>,
146 <xref linkend="gtk-doc"/>,
147 <xref linkend="gtk3"/>,
148 <xref linkend="libtiff"/>, and
149 <xref linkend="qt5"/>
150 (required for PDF support in <xref role="nodep" linkend="okular5"/>)
151 </para>
152
153 <para condition="html" role="usernotes">
154 User Notes: <ulink url="&blfs-wiki;/poppler"/>
155 </para>
156 </sect2>
157
158 <sect2 role="installation">
159 <title>Installation of Poppler</title>
160
161 <para>
162 Install <application>Poppler</application> by running the following
163 commands:
164 </para>
165
166<screen><userinput>mkdir build &amp;&amp;
167cd build &amp;&amp;
168
169cmake -DCMAKE_BUILD_TYPE=Release \
170 -DCMAKE_INSTALL_PREFIX=/usr \
171 -DTESTDATADIR=$PWD/testfiles \
172 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
173<!-- -DENABLE_GTK_DOC=ON \
174--> .. &amp;&amp;
175make</userinput></screen>
176
177 <para>
178 In order to run the test suite, some testcases are needed and can
179 be obtained only from a git repository. The command to download
180 them is:
181<command>git clone git://git.freedesktop.org/git/poppler/test testfiles</command>.
182 Then issue: <command>LC_ALL=en_US.UTF-8 make test</command>.
183 </para>
184
185 <para>
186 Now, as the <systemitem class="username">root</systemitem> user:
187 </para>
188
189<screen role="root"><userinput>make install</userinput></screen>
190<!-- Seems makeinstall does the job now:
191 <para>
192 If you have Qt installed, again as the
193 <systemitem class="username">root</systemitem> user:
194 </para>
195
196<screen role="root"><userinput>make -C qt5 install &amp;&amp;
197install -m644 poppler-qt5.pc /usr/lib/pkgconfig</userinput></screen>
198-->
199 <para>
200 To install the documentation, run the following commands as
201 <systemitem class="username">root</systemitem>:
202 </para>
203
204<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/poppler-&poppler-version; &amp;&amp;
205cp -vr ../glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput></screen>
206
207<!-- ==== Poppler Data ====== -->
208 <bridgehead renderas="sect3">Poppler Data</bridgehead>
209
210 <para>
211 If you downloaded the additional encoding data package, install it by
212 issuing the following commands:
213 </para>
214
215<screen><userinput>tar -xf ../../poppler-data-&poppler-data-version;.tar.gz &amp;&amp;
216cd poppler-data-&poppler-data-version;</userinput></screen>
217
218 <para>
219 Now, as the <systemitem class="username">root</systemitem> user:
220 </para>
221
222<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
223
224 </sect2>
225
226 <sect2 role="commands">
227 <title>Command Explanations</title>
228
229 <para>
230 <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
231 to apply a higher level of compiler optimizations.
232 </para>
233
234 <para>
235 <parameter>-DTESTDATADIR=$PWD/testfiles</parameter>: Tell the test
236 programs where the auxiliary files are located.
237 </para>
238
239 <para>
240 <parameter>-DENABLE_UNSTABLE_API_ABI_HEADERS=ON</parameter>: Install some old
241 <application>Xpdf</application> headers required by certain programs (e.g.
242 <application>Inkscape</application>).
243 </para>
244<!-- This was broken for me - Bruce
245 Still broken with 0.69.0 - Doug
246 Seems to work with 0.73.0 - Pierre -->
247 <para>
248 <option>-DENABLE_GTK_DOC=ON</option>: Use this parameter if
249 GTK-Doc is installed and you wish to rebuild and install
250 the API documentation. If Python 2 is not installed, one script
251 needs to be changed: run <command>sed -i '1s/python/&amp;3/'
252 make-glib-api-docs</command> first.
253 </para>
254
255 <para>
256 <command>LC_ALL=en_US.UTF-8 make test</command>: Run the test suite.
257 The environment variable LC_ALL=en_US.UTF-8 is only needed if the
258 default locale does not include UTF-8.
259 </para>
260
261 </sect2>
262
263 <sect2 role="content">
264 <title>Contents</title>
265
266 <segmentedlist>
267 <segtitle>Installed Programs</segtitle>
268 <segtitle>Installed Libraries</segtitle>
269 <segtitle>Installed Directories</segtitle>
270
271 <seglistitem>
272 <seg>
273 pdfattach, pdfdetach, pdffonts, pdfimages, pdfinfo, pdfseparate,
274 pdfsig, pdftocairo, pdftohtml, pdftoppm, pdftops, pdftotext, and
275 pdfunite
276 </seg>
277 <seg>
278 libpoppler.so,
279 libpoppler-cpp.so,
280 libpoppler-glib.so, and
281 libpoppler-qt5.so
282 </seg>
283 <seg>
284 /usr/include/poppler,
285 /usr/share/poppler, and
286 /usr/share/doc/poppler-&poppler-version;
287 </seg>
288 </seglistitem>
289 </segmentedlist>
290
291 <variablelist>
292 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
293 <?dbfo list-presentation="list"?>
294 <?dbhtml list-presentation="table"?>
295
296 <varlistentry id="pdfattach">
297 <term><command>pdfattach</command></term>
298 <listitem>
299 <para>
300 adds a new embedded file to an existing PDF file.
301 </para>
302 <indexterm zone="poppler pdfattach">
303 <primary sortas="b-pdfattach">pdfattach</primary>
304 </indexterm>
305 </listitem>
306 </varlistentry>
307
308 <varlistentry id="pdfdetach">
309 <term><command>pdfdetach</command></term>
310 <listitem>
311 <para>
312 lists or extracts embedded files from PDF files.
313 </para>
314 <indexterm zone="poppler pdfdetach">
315 <primary sortas="b-pdfdetach">pdfdetach</primary>
316 </indexterm>
317 </listitem>
318 </varlistentry>
319
320 <varlistentry id="pdffonts">
321 <term><command>pdffonts</command></term>
322 <listitem>
323 <para>
324 lists the fonts used in a PDF file along with various information
325 for each font.
326 </para>
327 <indexterm zone="poppler pdffonts">
328 <primary sortas="b-pdffonts">pdffonts</primary>
329 </indexterm>
330 </listitem>
331 </varlistentry>
332
333 <varlistentry id="pdfimages">
334 <term><command>pdfimages</command></term>
335 <listitem>
336 <para>
337 saves images from a PDF file as PPM, PBM, or JPEG files.
338 </para>
339 <indexterm zone="poppler pdfimages">
340 <primary sortas="b-pdfimages">pdfimages</primary>
341 </indexterm>
342 </listitem>
343 </varlistentry>
344
345 <varlistentry id="pdfinfo">
346 <term><command>pdfinfo</command></term>
347 <listitem>
348 <para>
349 prints the contents of the 'Info' dictionary (plus some other useful
350 information) from a PDF file.
351 </para>
352 <indexterm zone="poppler pdfinfo">
353 <primary sortas="b-pdfinfo">pdfinfo</primary>
354 </indexterm>
355 </listitem>
356 </varlistentry>
357
358 <varlistentry id="pdfseparate">
359 <term><command>pdfseparate</command></term>
360 <listitem>
361 <para>
362 extracts single pages from a PDF file.
363 </para>
364 <indexterm zone="poppler pdfseparate">
365 <primary sortas="b-pdseparate">pdfseparate</primary>
366 </indexterm>
367 </listitem>
368 </varlistentry>
369
370 <varlistentry id="pdfsig">
371 <term><command>pdfsig</command></term>
372 <listitem>
373 <para>
374 verifies the digital signatures in a PDF document.
375 </para>
376 <indexterm zone="poppler pdfsig">
377 <primary sortas="b-pdseparate">pdfsig</primary>
378 </indexterm>
379 </listitem>
380 </varlistentry>
381
382 <varlistentry id="pdftocairo">
383 <term><command>pdftocairo</command></term>
384 <listitem>
385 <para>
386 converts a PDF file to one of several formats (PNG, JPEG, PDF, PS,
387 EPS, SVG) using the cairo output device of the poppler library.
388 </para>
389 <indexterm zone="poppler pdftocairo">
390 <primary sortas="b-pdftocairo">pdftocairo</primary>
391 </indexterm>
392 </listitem>
393 </varlistentry>
394
395 <varlistentry id="pdftohtml">
396 <term><command>pdftohtml</command></term>
397 <listitem>
398 <para>
399 converts a PDF file to HTML.
400 </para>
401 <indexterm zone="poppler pdftohtml">
402 <primary sortas="b-pdftohtml">pdftohtml</primary>
403 </indexterm>
404 </listitem>
405 </varlistentry>
406
407 <varlistentry id="pdftoppm">
408 <term><command>pdftoppm</command></term>
409 <listitem>
410 <para>
411 converts PDF files to PBM, PGM and PPM formats.
412 </para>
413 <indexterm zone="poppler pdftoppm">
414 <primary sortas="b-pdftoppm">pdftoppm</primary>
415 </indexterm>
416 </listitem>
417 </varlistentry>
418
419 <varlistentry id="pdftops">
420 <term><command>pdftops</command></term>
421 <listitem>
422 <para>
423 converts PDF files to Postscript format.
424 </para>
425 <indexterm zone="poppler pdftops">
426 <primary sortas="b-pdftops">pdftops</primary>
427 </indexterm>
428 </listitem>
429 </varlistentry>
430
431 <varlistentry id="pdftotext">
432 <term><command>pdftotext</command></term>
433 <listitem>
434 <para>
435 converts PDF files to plain text.
436 </para>
437 <indexterm zone="poppler pdftotext">
438 <primary sortas="b-pdftotext">pdftotext</primary>
439 </indexterm>
440 </listitem>
441 </varlistentry>
442
443 <varlistentry id="pdfunite">
444 <term><command>pdfunite</command></term>
445 <listitem>
446 <para>
447 merges several PDF files, in the order of their occurrence on the
448 command line, to one PDF output file.
449 </para>
450 <indexterm zone="poppler pdfunite">
451 <primary sortas="b-pdfunite">pdfunite</primary>
452 </indexterm>
453 </listitem>
454 </varlistentry>
455
456 <varlistentry id="libpoppler">
457 <term><filename class="libraryfile">libpoppler.so</filename></term>
458 <listitem>
459 <para>
460 contains the API functions to render PDF files.
461 </para>
462 <indexterm zone="poppler libpoppler">
463 <primary sortas="c-libpoppler">libpoppler.so</primary>
464 </indexterm>
465 </listitem>
466 </varlistentry>
467
468 <varlistentry id="libpoppler-cpp">
469 <term><filename class="libraryfile">libpoppler-cpp.so</filename></term>
470 <listitem>
471 <para>
472 is a C++ backend for rendering PDF files.
473 </para>
474 <indexterm zone="poppler libpoppler-cpp">
475 <primary sortas="c-libpoppler-cpp">libpoppler-cpp.so</primary>
476 </indexterm>
477 </listitem>
478 </varlistentry>
479
480 <varlistentry id="libpoppler-glib">
481 <term><filename class="libraryfile">libpoppler-glib.so</filename></term>
482 <listitem>
483 <para>
484 is a wrapper library used to interface the PDF rendering functions
485 with <application>GTK+</application>.
486 </para>
487 <indexterm zone="poppler libpoppler-glib">
488 <primary sortas="c-libpoppler-glib">libpoppler-glib.so</primary>
489 </indexterm>
490 </listitem>
491 </varlistentry>
492
493 <varlistentry id="libpoppler-qt5">
494 <term><filename class="libraryfile">libpoppler-qt5.so</filename></term>
495 <listitem>
496 <para>
497 is a wrapper library used to interface the PDF rendering functions
498 with <application>Qt</application>5.
499 </para>
500 <indexterm zone="poppler libpoppler-qt5">
501 <primary sortas="c-libpoppler-qt5">libpoppler-qt5.so</primary>
502 </indexterm>
503 </listitem>
504 </varlistentry>
505
506 </variablelist>
507
508 </sect2>
509
510</sect1>
Note: See TracBrowser for help on using the repository browser.