source: general/graphlib/poppler.xml@ a82b4c61

10.0 10.1 11.0 11.1 11.2 lazarus plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since a82b4c61 was a82b4c61, checked in by Douglas R. Reno <renodr@…>, 2 years ago

Update to epiphany-3.36.3
Update to poppler-0.90.0
Update to nasm-2.15.02
Update to dhcpcd-9.1.3
Update to gnome-control-center-3.36.4
Update to evolution-data-server-3.36.4 (Security Update)
Update to evolution-3.36.4

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23360 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 16.0 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY poppler-download-http "https://poppler.freedesktop.org/poppler-&poppler-version;.tar.xz">
8 <!ENTITY poppler-download-ftp " ">
9 <!ENTITY poppler-md5sum "5af9e25d8d2b9efc0d538ce2213be22e">
10 <!ENTITY poppler-size "1.5 MB">
11 <!ENTITY poppler-buildsize "91 MB (with Qt5 library and tests)">
12 <!ENTITY poppler-time "0.8 SBU (with parallelism=4, Qt5 library, and tests)">
13
14 <!ENTITY poppler-data-version "0.4.9">
15
16 <!ENTITY poppler-data-download-http "https://poppler.freedesktop.org/poppler-data-&poppler-data-version;.tar.gz">
17 <!ENTITY poppler-data-md5sum "35cc7beba00aa174631466f06732be40">
18 <!ENTITY poppler-data-size "4.1 MB">
19 <!ENTITY poppler-data-buildsize "13 MB">
20 <!ENTITY poppler-data-time "less than 0.1 SBU">
21]>
22
23<sect1 id="poppler" xreflabel="Poppler-&poppler-version;">
24 <?dbhtml filename="poppler.html"?>
25
26 <sect1info>
27 <othername>$LastChangedBy$</othername>
28 <date>$Date$</date>
29 </sect1info>
30
31 <title>Poppler-&poppler-version;</title>
32
33 <indexterm zone="poppler">
34 <primary sortas="a-Poppler">Poppler</primary>
35 </indexterm>
36
37 <sect2 role="package">
38 <title>Introduction to Poppler</title>
39
40 <para>
41 The <application>Poppler</application> package contains a PDF rendering
42 library and command line tools used to manipulate PDF files. This is
43 useful for providing PDF rendering functionality as a shared library.
44 </para>
45
46 &lfs91_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&poppler-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&poppler-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &poppler-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &poppler-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &poppler-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &poppler-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83
84 <itemizedlist spacing="compact">
85 <title>Poppler Encoding Data</title>
86 <listitem>
87 <para>
88 Download (HTTP): <ulink url="&poppler-data-download-http;"/>
89 </para>
90 </listitem>
91 <listitem>
92 <para>
93 Download MD5 sum: &poppler-data-md5sum;
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download size: &poppler-data-size;
99 </para>
100 </listitem>
101 <listitem>
102 <para>
103 Estimated disk space required: &poppler-data-buildsize;
104 </para>
105 </listitem>
106 <listitem>
107 <para>
108 Estimated build time: &poppler-data-time;
109 </para>
110 </listitem>
111 </itemizedlist>
112
113 <para>
114 The additional package consists of encoding files for use with
115 <application>Poppler</application>. The encoding files are optional and
116 <application>Poppler</application> will automatically read them if they
117 are present. When installed, they enable
118 <application>Poppler</application> to render CJK and Cyrillic properly.
119 </para>
120
121 <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
122
123 <bridgehead renderas="sect4">Required</bridgehead>
124 <para role="required">
125 <xref linkend="cmake"/> and
126 <xref linkend="fontconfig"/>
127 </para>
128
129 <bridgehead renderas="sect4">Recommended</bridgehead>
130 <para role="recommended">
131 <xref linkend="cairo"/>,
132 <xref linkend="lcms2"/>,
133 <xref linkend="libjpeg"/>,
134 <xref linkend="libpng"/>,
135 <xref linkend="nss"/>, and
136 <xref linkend="openjpeg2"/>
137 </para>
138
139 <bridgehead renderas="sect4">Optional</bridgehead>
140 <para role="optional">
141 <xref linkend="boost"/>,
142 <xref linkend="curl"/>,
143 <xref linkend="gdk-pixbuf"/>,
144 <xref linkend="git"/> (for downloading test files),
145 <xref linkend="gobject-introspection"/>,
146 <xref linkend="gtk-doc"/>,
147 <xref linkend="gtk3"/>,
148 <xref linkend="libtiff"/>, and
149 <xref linkend="qt5"/>
150 (required for PDF support in <xref role="nodep" linkend="okular5"/>)
151 </para>
152
153 <para condition="html" role="usernotes">
154 User Notes: <ulink url="&blfs-wiki;/poppler"/>
155 </para>
156 </sect2>
157
158 <sect2 role="installation">
159 <title>Installation of Poppler</title>
160
161 <para>
162 Install <application>Poppler</application> by running the following
163 commands:
164 </para>
165
166<screen><userinput>mkdir build &amp;&amp;
167cd build &amp;&amp;
168
169cmake -DCMAKE_BUILD_TYPE=Release \
170 -DCMAKE_INSTALL_PREFIX=/usr \
171 -DTESTDATADIR=$PWD/testfiles \
172 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
173<!-- -DENABLE_GTK_DOC=ON \
174--> .. &amp;&amp;
175make</userinput></screen>
176
177 <para>
178 In order to run the test suite, some testcases are needed and can
179 be obtained only from a git repository. The command to download
180 them is:
181<command>git clone git://git.freedesktop.org/git/poppler/test testfiles</command>.
182 Then issue: <command>LC_ALL=en_US.UTF-8 make test</command>.
183 </para>
184
185 <para>
186 Now, as the <systemitem class="username">root</systemitem> user:
187 </para>
188
189<screen role="root"><userinput>make install</userinput></screen>
190<!-- Seems makeinstall does the job now:
191 <para>
192 If you have Qt installed, again as the
193 <systemitem class="username">root</systemitem> user:
194 </para>
195
196<screen role="root"><userinput>make -C qt5 install &amp;&amp;
197install -m644 poppler-qt5.pc /usr/lib/pkgconfig</userinput></screen>
198-->
199 <para>
200 To install the documentation, run the following commands as
201 <systemitem class="username">root</systemitem>:
202 </para>
203
204<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/poppler-&poppler-version; &amp;&amp;
205cp -vr ../glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput></screen>
206
207<!-- ==== Poppler Data ====== -->
208 <bridgehead renderas="sect3">Poppler Data</bridgehead>
209
210 <para>
211 If you downloaded the additional encoding data package, install it by
212 issuing the following commands:
213 </para>
214
215<screen><userinput>tar -xf ../../poppler-data-&poppler-data-version;.tar.gz &amp;&amp;
216cd poppler-data-&poppler-data-version;</userinput></screen>
217
218 <para>
219 Now, as the <systemitem class="username">root</systemitem> user:
220 </para>
221
222<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
223
224 </sect2>
225
226 <sect2 role="commands">
227 <title>Command Explanations</title>
228
229 <para>
230 <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
231 to apply a higher level of compiler optimizations.
232 </para>
233
234 <para>
235 <parameter>-DTESTDATADIR=$PWD/testfiles</parameter>: Tells the test
236 programs where the auxiliary files are located.
237 </para>
238
239 <para>
240 <parameter>-DENABLE_UNSTABLE_API_ABI_HEADERS=ON</parameter>: Installs some old
241 <application>Xpdf</application> headers required by certain programs (e.g.
242 <application>Inkscape</application>).
243 </para>
244
245<!-- This was broken for me - Bruce
246 Still broken with 0.69.0 - Doug
247 Seems to work with 0.73.0 - Pierre -->
248 <para>
249 <option>-DENABLE_GTK_DOC=ON</option>: Use this parameter if
250 GTK-Doc is installed and you wish to rebuild and install
251 the API documentation. If Python 2 is not installed, one script
252 needs to be changed: run <command>sed -i '1s/python/&amp;3/'
253 make-glib-api-docs</command> first.
254 </para>
255
256 <para>
257 <command>LC_ALL=en_US.UTF-8 make test</command>: Runs the test suite.
258 The environment variable LC_ALL=en_US.UTF-8 is only needed if the
259 default locale does not include UTF-8.
260 </para>
261
262 </sect2>
263
264 <sect2 role="content">
265 <title>Contents</title>
266
267 <segmentedlist>
268 <segtitle>Installed Programs</segtitle>
269 <segtitle>Installed Libraries</segtitle>
270 <segtitle>Installed Directories</segtitle>
271
272 <seglistitem>
273 <seg>
274 pdfattach, pdfdetach, pdffonts, pdfimages, pdfinfo, pdfseparate,
275 pdfsig, pdftocairo, pdftohtml, pdftoppm, pdftops, pdftotext, and
276 pdfunite
277 </seg>
278 <seg>
279 libpoppler.so,
280 libpoppler-cpp.so,
281 libpoppler-glib.so, and
282 libpoppler-qt5.so
283 </seg>
284 <seg>
285 /usr/include/poppler,
286 /usr/share/poppler, and
287 /usr/share/doc/poppler-&poppler-version;
288 </seg>
289 </seglistitem>
290 </segmentedlist>
291
292 <variablelist>
293 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
294 <?dbfo list-presentation="list"?>
295 <?dbhtml list-presentation="table"?>
296
297 <varlistentry id="pdfattach">
298 <term><command>pdfattach</command></term>
299 <listitem>
300 <para>
301 adds a new embedded file to an existing PDF file.
302 </para>
303 <indexterm zone="poppler pdfattach">
304 <primary sortas="b-pdfattach">pdfattach</primary>
305 </indexterm>
306 </listitem>
307 </varlistentry>
308
309 <varlistentry id="pdfdetach">
310 <term><command>pdfdetach</command></term>
311 <listitem>
312 <para>
313 lists or extracts embedded files from PDF files.
314 </para>
315 <indexterm zone="poppler pdfdetach">
316 <primary sortas="b-pdfdetach">pdfdetach</primary>
317 </indexterm>
318 </listitem>
319 </varlistentry>
320
321 <varlistentry id="pdffonts">
322 <term><command>pdffonts</command></term>
323 <listitem>
324 <para>
325 lists the fonts used in a PDF file along with various information
326 for each font.
327 </para>
328 <indexterm zone="poppler pdffonts">
329 <primary sortas="b-pdffonts">pdffonts</primary>
330 </indexterm>
331 </listitem>
332 </varlistentry>
333
334 <varlistentry id="pdfimages">
335 <term><command>pdfimages</command></term>
336 <listitem>
337 <para>
338 saves images from a PDF file as PPM, PBM, or JPEG files.
339 </para>
340 <indexterm zone="poppler pdfimages">
341 <primary sortas="b-pdfimages">pdfimages</primary>
342 </indexterm>
343 </listitem>
344 </varlistentry>
345
346 <varlistentry id="pdfinfo">
347 <term><command>pdfinfo</command></term>
348 <listitem>
349 <para>
350 prints the contents of the 'Info' dictionary (plus some other useful
351 information) from a PDF file.
352 </para>
353 <indexterm zone="poppler pdfinfo">
354 <primary sortas="b-pdfinfo">pdfinfo</primary>
355 </indexterm>
356 </listitem>
357 </varlistentry>
358
359 <varlistentry id="pdfseparate">
360 <term><command>pdfseparate</command></term>
361 <listitem>
362 <para>
363 extracts single pages from a PDF file.
364 </para>
365 <indexterm zone="poppler pdfseparate">
366 <primary sortas="b-pdseparate">pdfseparate</primary>
367 </indexterm>
368 </listitem>
369 </varlistentry>
370
371 <varlistentry id="pdfsig">
372 <term><command>pdfsig</command></term>
373 <listitem>
374 <para>
375 verifies the digital signatures in a PDF document.
376 </para>
377 <indexterm zone="poppler pdfsig">
378 <primary sortas="b-pdseparate">pdfsig</primary>
379 </indexterm>
380 </listitem>
381 </varlistentry>
382
383 <varlistentry id="pdftocairo">
384 <term><command>pdftocairo</command></term>
385 <listitem>
386 <para>
387 converts a PDF file to one of several formats (PNG, JPEG, PDF, PS,
388 EPS, SVG) using the cairo output device of the poppler library.
389 </para>
390 <indexterm zone="poppler pdftocairo">
391 <primary sortas="b-pdftocairo">pdftocairo</primary>
392 </indexterm>
393 </listitem>
394 </varlistentry>
395
396 <varlistentry id="pdftohtml">
397 <term><command>pdftohtml</command></term>
398 <listitem>
399 <para>
400 converts a PDF file to HTML.
401 </para>
402 <indexterm zone="poppler pdftohtml">
403 <primary sortas="b-pdftohtml">pdftohtml</primary>
404 </indexterm>
405 </listitem>
406 </varlistentry>
407
408 <varlistentry id="pdftoppm">
409 <term><command>pdftoppm</command></term>
410 <listitem>
411 <para>
412 converts PDF files to PBM, PGM and PPM formats.
413 </para>
414 <indexterm zone="poppler pdftoppm">
415 <primary sortas="b-pdftoppm">pdftoppm</primary>
416 </indexterm>
417 </listitem>
418 </varlistentry>
419
420 <varlistentry id="pdftops">
421 <term><command>pdftops</command></term>
422 <listitem>
423 <para>
424 converts PDF files to Postscript format.
425 </para>
426 <indexterm zone="poppler pdftops">
427 <primary sortas="b-pdftops">pdftops</primary>
428 </indexterm>
429 </listitem>
430 </varlistentry>
431
432 <varlistentry id="pdftotext">
433 <term><command>pdftotext</command></term>
434 <listitem>
435 <para>
436 converts PDF files to plain text.
437 </para>
438 <indexterm zone="poppler pdftotext">
439 <primary sortas="b-pdftotext">pdftotext</primary>
440 </indexterm>
441 </listitem>
442 </varlistentry>
443
444 <varlistentry id="pdfunite">
445 <term><command>pdfunite</command></term>
446 <listitem>
447 <para>
448 merges several PDF files, in the order of their occurrence on the
449 command line, to one PDF output file.
450 </para>
451 <indexterm zone="poppler pdfunite">
452 <primary sortas="b-pdfunite">pdfunite</primary>
453 </indexterm>
454 </listitem>
455 </varlistentry>
456
457 <varlistentry id="libpoppler">
458 <term><filename class="libraryfile">libpoppler.so</filename></term>
459 <listitem>
460 <para>
461 contains the API functions to render PDF files.
462 </para>
463 <indexterm zone="poppler libpoppler">
464 <primary sortas="c-libpoppler">libpoppler.so</primary>
465 </indexterm>
466 </listitem>
467 </varlistentry>
468
469 <varlistentry id="libpoppler-cpp">
470 <term><filename class="libraryfile">libpoppler-cpp.so</filename></term>
471 <listitem>
472 <para>
473 is a C++ backend for rendering PDF files.
474 </para>
475 <indexterm zone="poppler libpoppler-cpp">
476 <primary sortas="c-libpoppler-cpp">libpoppler-cpp.so</primary>
477 </indexterm>
478 </listitem>
479 </varlistentry>
480
481 <varlistentry id="libpoppler-glib">
482 <term><filename class="libraryfile">libpoppler-glib.so</filename></term>
483 <listitem>
484 <para>
485 is a wrapper library used to interface the PDF rendering functions
486 with <application>GTK+</application>.
487 </para>
488 <indexterm zone="poppler libpoppler-glib">
489 <primary sortas="c-libpoppler-glib">libpoppler-glib.so</primary>
490 </indexterm>
491 </listitem>
492 </varlistentry>
493
494 <varlistentry id="libpoppler-qt5">
495 <term><filename class="libraryfile">libpoppler-qt5.so</filename></term>
496 <listitem>
497 <para>
498 is a wrapper library used to interface the PDF rendering functions
499 with <application>Qt</application>5.
500 </para>
501 <indexterm zone="poppler libpoppler-qt5">
502 <primary sortas="c-libpoppler-qt5">libpoppler-qt5.so</primary>
503 </indexterm>
504 </listitem>
505 </varlistentry>
506
507 </variablelist>
508
509 </sect2>
510
511</sect1>
Note: See TracBrowser for help on using the repository browser.