source: general/graphlib/poppler.xml@ afffc809

11.0 ken/refactor-virt lazarus qt5new trunk
Last change on this file since afffc809 was afffc809, checked in by Xi Ruoyao <xry111@…>, 5 months ago

poppler: use --depth 1 in git clone command

We don't care the history of poppler/test, so save some time and band
width.

  • Property mode set to 100644
File size: 16.0 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY poppler-download-http "https://poppler.freedesktop.org/poppler-&poppler-version;.tar.xz">
8 <!ENTITY poppler-download-ftp " ">
9 <!ENTITY poppler-md5sum "c3a76a9ef4625f54718136699c74c9b1">
10 <!ENTITY poppler-size "1.7 MB">
11 <!ENTITY poppler-buildsize "77 MB (with Qt5 library and tests)">
12 <!ENTITY poppler-time "0.8 SBU (with parallelism=4, Qt5 library, and tests)">
13 <!-- Time increase might be due to git.freedesktop.org -->
14
15 <!ENTITY poppler-data-version "0.4.10">
16
17 <!ENTITY poppler-data-download-http "https://poppler.freedesktop.org/poppler-data-&poppler-data-version;.tar.gz">
18 <!ENTITY poppler-data-md5sum "a7f15fb2f26c60a7a92093cfdf2378d5">
19 <!ENTITY poppler-data-size "4.3 MB">
20 <!ENTITY poppler-data-buildsize "25 MB">
21 <!ENTITY poppler-data-time "less than 0.1 SBU">
22]>
23
24<sect1 id="poppler" xreflabel="Poppler-&poppler-version;">
25 <?dbhtml filename="poppler.html"?>
26
27 <sect1info>
28 <date>$Date$</date>
29 </sect1info>
30
31 <title>Poppler-&poppler-version;</title>
32
33 <indexterm zone="poppler">
34 <primary sortas="a-Poppler">Poppler</primary>
35 </indexterm>
36
37 <sect2 role="package">
38 <title>Introduction to Poppler</title>
39
40 <para>
41 The <application>Poppler</application> package contains a PDF rendering
42 library and command line tools used to manipulate PDF files. This is
43 useful for providing PDF rendering functionality as a shared library.
44 </para>
45
46 &lfs101_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&poppler-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&poppler-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &poppler-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &poppler-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &poppler-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &poppler-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83
84 <itemizedlist spacing="compact">
85 <title>Poppler Encoding Data</title>
86 <listitem>
87 <para>
88 Download (HTTP): <ulink url="&poppler-data-download-http;"/>
89 </para>
90 </listitem>
91 <listitem>
92 <para>
93 Download MD5 sum: &poppler-data-md5sum;
94 </para>
95 </listitem>
96 <listitem>
97 <para>
98 Download size: &poppler-data-size;
99 </para>
100 </listitem>
101 <listitem>
102 <para>
103 Estimated disk space required: &poppler-data-buildsize;
104 </para>
105 </listitem>
106 <listitem>
107 <para>
108 Estimated build time: &poppler-data-time;
109 </para>
110 </listitem>
111 </itemizedlist>
112
113 <para>
114 The additional package consists of encoding files for use with
115 <application>Poppler</application>. The encoding files are optional and
116 <application>Poppler</application> will automatically read them if they
117 are present. When installed, they enable
118 <application>Poppler</application> to render CJK and Cyrillic properly.
119 </para>
120
121 <bridgehead renderas="sect3">Poppler Dependencies</bridgehead>
122
123 <bridgehead renderas="sect4">Required</bridgehead>
124 <para role="required">
125 <xref linkend="cmake"/> and
126 <xref linkend="fontconfig"/>
127 </para>
128
129 <bridgehead renderas="sect4">Recommended</bridgehead>
130 <para role="recommended">
131 <xref linkend="cairo"/>,
132 <xref linkend="lcms2"/>,
133 <xref linkend="libjpeg"/>,
134 <xref linkend="libpng"/>,
135 <xref linkend="nss"/>, and
136 <xref linkend="openjpeg2"/>
137 </para>
138
139 <bridgehead renderas="sect4">Optional</bridgehead>
140 <para role="optional">
141 <xref linkend="boost"/>,
142 <xref linkend="curl"/>,
143 <xref linkend="gdk-pixbuf"/>,
144 <xref linkend="git"/> (for downloading test files),
145 <xref linkend="gobject-introspection"/>,
146 <xref linkend="gtk-doc"/>,
147 <xref linkend="pygments"/>,
148 <xref linkend="gtk3"/>,
149 <xref linkend="libtiff"/>, and
150 <xref linkend="qt5"/>
151 (required for PDF support in <xref role="nodep" linkend="okular5"/>)
152 </para>
153
154 <para condition="html" role="usernotes">
155 User Notes: <ulink url="&blfs-wiki;/poppler"/>
156 </para>
157 </sect2>
158
159 <sect2 role="installation">
160 <title>Installation of Poppler</title>
161
162 <para>
163 Install <application>Poppler</application> by running the following
164 commands:
165 </para>
166
167<screen><userinput>mkdir build &amp;&amp;
168cd build &amp;&amp;
169
170cmake -DCMAKE_BUILD_TYPE=Release \
171 -DCMAKE_INSTALL_PREFIX=/usr \
172 -DTESTDATADIR=$PWD/testfiles \
173 -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \
174 .. &amp;&amp;
175make</userinput></screen>
176
177 <para>
178 In order to run the test suite, some testcases are needed and can
179 be obtained only from a git repository. The command to download
180 them is:
181<command>git clone --depth 1 git://git.freedesktop.org/git/poppler/test testfiles</command>.
182 Then issue: <command>LC_ALL=en_US.UTF-8 make test</command>.
183 </para>
184
185 <para>
186 Now, as the <systemitem class="username">root</systemitem> user:
187 </para>
188
189<screen role="root"><userinput>make install</userinput></screen>
190<!-- Seems makeinstall does the job now:
191 <para>
192 If you have Qt installed, again as the
193 <systemitem class="username">root</systemitem> user:
194 </para>
195
196<screen role="root"><userinput>make -C qt5 install &amp;&amp;
197install -m644 poppler-qt5.pc /usr/lib/pkgconfig</userinput></screen>
198-->
199 <para>
200 To install the documentation, run the following commands as
201 <systemitem class="username">root</systemitem>:
202 </para>
203
204<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/poppler-&poppler-version; &amp;&amp;
205cp -vr ../glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput></screen>
206
207<!-- ==== Poppler Data ====== -->
208 <bridgehead renderas="sect3">Poppler Data</bridgehead>
209
210 <para>
211 If you downloaded the additional encoding data package, install it by
212 issuing the following commands:
213 </para>
214
215<screen><userinput>tar -xf ../../poppler-data-&poppler-data-version;.tar.gz &amp;&amp;
216cd poppler-data-&poppler-data-version;</userinput></screen>
217
218 <para>
219 Now, as the <systemitem class="username">root</systemitem> user:
220 </para>
221
222<screen role="root"><userinput>make prefix=/usr install</userinput></screen>
223
224 </sect2>
225
226 <sect2 role="commands">
227 <title>Command Explanations</title>
228
229 <para>
230 <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
231 to apply a higher level of compiler optimizations.
232 </para>
233
234 <para>
235 <parameter>-DTESTDATADIR=$PWD/testfiles</parameter>: Tells the test
236 programs where the auxiliary files are located.
237 </para>
238
239 <para>
240 <parameter>-DENABLE_UNSTABLE_API_ABI_HEADERS=ON</parameter>: Installs some old
241 <application>Xpdf</application> headers required by certain programs.
242 <!--(e.g. <application>Inkscape</application>).-->
243 </para>
244
245<!-- This was broken for me - Bruce
246 Still broken with 0.69.0 - Doug
247 Seems to work with 0.73.0 - Pierre
248 Works with 20.09.0 but without the
249 sed -i '1s/python/&3/' make-glib-api-docs
250 and pygments is required - Thomas
251-->
252 <para>
253 <option>-DENABLE_GTK_DOC=ON</option>: Use this parameter if
254 GTK-Doc and Pygments is installed and you wish to rebuild and install
255 the API documentation.
256 </para>
257
258 <para>
259 <command>LC_ALL=en_US.UTF-8 make test</command>: Runs the test suite.
260 The environment variable LC_ALL=en_US.UTF-8 is only needed if the
261 default locale does not include UTF-8.
262 </para>
263
264 </sect2>
265
266 <sect2 role="content">
267 <title>Contents</title>
268
269 <segmentedlist>
270 <segtitle>Installed Programs</segtitle>
271 <segtitle>Installed Libraries</segtitle>
272 <segtitle>Installed Directories</segtitle>
273
274 <seglistitem>
275 <seg>
276 pdfattach, pdfdetach, pdffonts, pdfimages, pdfinfo, pdfseparate,
277 pdfsig, pdftocairo, pdftohtml, pdftoppm, pdftops, pdftotext, and
278 pdfunite
279 </seg>
280 <seg>
281 libpoppler.so,
282 libpoppler-cpp.so,
283 libpoppler-glib.so, and
284 libpoppler-qt5.so
285 </seg>
286 <seg>
287 /usr/include/poppler,
288 /usr/share/poppler, and
289 /usr/share/doc/poppler-&poppler-version;
290 </seg>
291 </seglistitem>
292 </segmentedlist>
293
294 <variablelist>
295 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
296 <?dbfo list-presentation="list"?>
297 <?dbhtml list-presentation="table"?>
298
299 <varlistentry id="pdfattach">
300 <term><command>pdfattach</command></term>
301 <listitem>
302 <para>
303 adds a new embedded file to an existing PDF file
304 </para>
305 <indexterm zone="poppler pdfattach">
306 <primary sortas="b-pdfattach">pdfattach</primary>
307 </indexterm>
308 </listitem>
309 </varlistentry>
310
311 <varlistentry id="pdfdetach">
312 <term><command>pdfdetach</command></term>
313 <listitem>
314 <para>
315 lists or extracts embedded files from PDF files
316 </para>
317 <indexterm zone="poppler pdfdetach">
318 <primary sortas="b-pdfdetach">pdfdetach</primary>
319 </indexterm>
320 </listitem>
321 </varlistentry>
322
323 <varlistentry id="pdffonts">
324 <term><command>pdffonts</command></term>
325 <listitem>
326 <para>
327 lists the fonts used in a PDF file along with various information
328 for each font
329 </para>
330 <indexterm zone="poppler pdffonts">
331 <primary sortas="b-pdffonts">pdffonts</primary>
332 </indexterm>
333 </listitem>
334 </varlistentry>
335
336 <varlistentry id="pdfimages">
337 <term><command>pdfimages</command></term>
338 <listitem>
339 <para>
340 saves images from a PDF file as PPM, PBM, or JPEG files
341 </para>
342 <indexterm zone="poppler pdfimages">
343 <primary sortas="b-pdfimages">pdfimages</primary>
344 </indexterm>
345 </listitem>
346 </varlistentry>
347
348 <varlistentry id="pdfinfo">
349 <term><command>pdfinfo</command></term>
350 <listitem>
351 <para>
352 prints the contents of the 'Info' dictionary (plus some other useful
353 information) from a PDF file
354 </para>
355 <indexterm zone="poppler pdfinfo">
356 <primary sortas="b-pdfinfo">pdfinfo</primary>
357 </indexterm>
358 </listitem>
359 </varlistentry>
360
361 <varlistentry id="pdfseparate">
362 <term><command>pdfseparate</command></term>
363 <listitem>
364 <para>
365 extracts single pages from a PDF file
366 </para>
367 <indexterm zone="poppler pdfseparate">
368 <primary sortas="b-pdseparate">pdfseparate</primary>
369 </indexterm>
370 </listitem>
371 </varlistentry>
372
373 <varlistentry id="pdfsig">
374 <term><command>pdfsig</command></term>
375 <listitem>
376 <para>
377 verifies the digital signatures in a PDF document
378 </para>
379 <indexterm zone="poppler pdfsig">
380 <primary sortas="b-pdseparate">pdfsig</primary>
381 </indexterm>
382 </listitem>
383 </varlistentry>
384
385 <varlistentry id="pdftocairo">
386 <term><command>pdftocairo</command></term>
387 <listitem>
388 <para>
389 converts a PDF file to one of several formats (PNG, JPEG, PDF, PS,
390 EPS, SVG) using the cairo output device of the poppler library
391 </para>
392 <indexterm zone="poppler pdftocairo">
393 <primary sortas="b-pdftocairo">pdftocairo</primary>
394 </indexterm>
395 </listitem>
396 </varlistentry>
397
398 <varlistentry id="pdftohtml">
399 <term><command>pdftohtml</command></term>
400 <listitem>
401 <para>
402 converts a PDF file to HTML
403 </para>
404 <indexterm zone="poppler pdftohtml">
405 <primary sortas="b-pdftohtml">pdftohtml</primary>
406 </indexterm>
407 </listitem>
408 </varlistentry>
409
410 <varlistentry id="pdftoppm">
411 <term><command>pdftoppm</command></term>
412 <listitem>
413 <para>
414 converts PDF files to PBM, PGM and PPM formats
415 </para>
416 <indexterm zone="poppler pdftoppm">
417 <primary sortas="b-pdftoppm">pdftoppm</primary>
418 </indexterm>
419 </listitem>
420 </varlistentry>
421
422 <varlistentry id="pdftops">
423 <term><command>pdftops</command></term>
424 <listitem>
425 <para>
426 converts PDF files to Postscript format
427 </para>
428 <indexterm zone="poppler pdftops">
429 <primary sortas="b-pdftops">pdftops</primary>
430 </indexterm>
431 </listitem>
432 </varlistentry>
433
434 <varlistentry id="pdftotext">
435 <term><command>pdftotext</command></term>
436 <listitem>
437 <para>
438 converts PDF files to plain text
439 </para>
440 <indexterm zone="poppler pdftotext">
441 <primary sortas="b-pdftotext">pdftotext</primary>
442 </indexterm>
443 </listitem>
444 </varlistentry>
445
446 <varlistentry id="pdfunite">
447 <term><command>pdfunite</command></term>
448 <listitem>
449 <para>
450 merges several PDF files, in the order of their occurrence on the
451 command line, to one PDF output file
452 </para>
453 <indexterm zone="poppler pdfunite">
454 <primary sortas="b-pdfunite">pdfunite</primary>
455 </indexterm>
456 </listitem>
457 </varlistentry>
458
459 <varlistentry id="libpoppler">
460 <term><filename class="libraryfile">libpoppler.so</filename></term>
461 <listitem>
462 <para>
463 contains the API functions to render PDF files
464 </para>
465 <indexterm zone="poppler libpoppler">
466 <primary sortas="c-libpoppler">libpoppler.so</primary>
467 </indexterm>
468 </listitem>
469 </varlistentry>
470
471 <varlistentry id="libpoppler-cpp">
472 <term><filename class="libraryfile">libpoppler-cpp.so</filename></term>
473 <listitem>
474 <para>
475 is a C++ backend for rendering PDF files
476 </para>
477 <indexterm zone="poppler libpoppler-cpp">
478 <primary sortas="c-libpoppler-cpp">libpoppler-cpp.so</primary>
479 </indexterm>
480 </listitem>
481 </varlistentry>
482
483 <varlistentry id="libpoppler-glib">
484 <term><filename class="libraryfile">libpoppler-glib.so</filename></term>
485 <listitem>
486 <para>
487 is a wrapper library used to interface the PDF rendering functions
488 with <application>GTK+</application>
489 </para>
490 <indexterm zone="poppler libpoppler-glib">
491 <primary sortas="c-libpoppler-glib">libpoppler-glib.so</primary>
492 </indexterm>
493 </listitem>
494 </varlistentry>
495
496 <varlistentry id="libpoppler-qt5">
497 <term><filename class="libraryfile">libpoppler-qt5.so</filename></term>
498 <listitem>
499 <para>
500 is a wrapper library used to interface the PDF rendering functions
501 with <application>Qt</application>5
502 </para>
503 <indexterm zone="poppler libpoppler-qt5">
504 <primary sortas="c-libpoppler-qt5">libpoppler-qt5.so</primary>
505 </indexterm>
506 </listitem>
507 </varlistentry>
508
509 </variablelist>
510
511 </sect2>
512
513</sect1>
Note: See TracBrowser for help on using the repository browser.