source: general/prog/python2.xml@ bfbc72a

10.1 11.0 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since bfbc72a was bfbc72a, checked in by Douglas R. Reno <renodr@…>, 7 months ago

Tags
GDB: Mention the TUI test suite failing

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@24240 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 11.4 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY python2-download-http
8 "https://www.python.org/ftp/python/&python2-version;/Python-&python2-version;.tar.xz">
9 <!ENTITY python2-download-ftp " ">
10 <!ENTITY python2-md5sum "fd6cc8ec0a78c44036f825e739f36e5a">
11 <!ENTITY python2-size "12.2 MB">
12 <!ENTITY python2-buildsize "134 MB (add 17 MB for tests)">
13 <!ENTITY python2-time "0.7 SBU (Using parallelism=4; add 7.1 SBU for tests)">
14
15 <!ENTITY python2htmldoc-download-http
16 "https://docs.python.org/ftp/python/doc/&python2-version;/python-&python2-version;-docs-html.tar.bz2">
17]>
18
19<sect1 id="python2" xreflabel="Python-&python2-version;">
20 <?dbhtml filename="python2.html" ?>
21
22 <sect1info>
23 <othername>$LastChangedBy$</othername>
24 <date>$Date$</date>
25 </sect1info>
26
27 <title>Python-&python2-version;</title>
28
29 <indexterm zone="python2">
30 <primary sortas="a-Python2">Python2</primary>
31 </indexterm>
32
33 <sect2 role="package">
34 <title>Introduction to Python 2</title>
35
36 <para>
37 The <application>Python 2</application> package contains the
38 <application>Python</application> development environment. It is useful
39 for object-oriented programming, writing scripts, prototyping large
40 programs or developing entire applications. This version is for backward
41 compatibility with other dependent packages.
42 </para>
43
44 <note>
45 <para>
46 Python2 has been deprecated by the upstream developers.
47 Support for Python2 was discontinued on January 1st, 2020.
48 </para>
49
50 <para>
51 BLFS is attempting to use Python3 as much as possible, but some
52 packages have not been updated to support Python3.
53 </para>
54 </note>
55
56 &lfs101_checked;
57
58 <bridgehead renderas="sect3">Package Information</bridgehead>
59 <itemizedlist spacing="compact">
60 <listitem>
61 <para>
62 Download (HTTP): <ulink url="&python2-download-http;"/>
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download (FTP): <ulink url="&python2-download-ftp;"/>
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Download MD5 sum: &python2-md5sum;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Download size: &python2-size;
78 </para>
79 </listitem>
80 <listitem>
81 <para>
82 Estimated disk space required: &python2-buildsize;
83 </para>
84 </listitem>
85 <listitem>
86 <para>
87 Estimated build time: &python2-time;
88 </para>
89 </listitem>
90 </itemizedlist>
91
92 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
93
94 <itemizedlist spacing="compact">
95 <title>Optional HTML Documentation</title>
96 <listitem>
97 <para>
98 Download (HTTP): <ulink url="&python2htmldoc-download-http;"/>
99 </para>
100 </listitem>
101 </itemizedlist>
102
103 <bridgehead renderas="sect3">Python 2 Dependencies</bridgehead>
104<!--
105 <bridgehead renderas="sect4">Recommended</bridgehead>
106 <para role="recommended">
107 <xref linkend="libffi"/>
108 </para>
109-->
110 <bridgehead renderas="sect4">Optional</bridgehead>
111 <para role="optional">
112 <xref linkend="bluez"/> and
113 <xref linkend="valgrind"/>
114 </para>
115
116 <bridgehead renderas="sect4">Optional (For Additional Modules)</bridgehead>
117 <para role="optional">
118 <xref linkend="sqlite"/> and
119 <xref linkend="tk"/>
120 </para>
121
122 <para condition="html" role="usernotes">
123 User Notes: <ulink url="&blfs-wiki;/Python"/>
124 </para>
125 </sect2>
126
127 <sect2 role="installation">
128 <title>Installation of Python 2</title>
129<!--
130 <caution>
131 <para>
132 After installing this package or
133 updating <application>pip2</application> with the command
134 <command>pip2 install - -upgrade pip</command>, it will remove
135 <application>pip3</application> installed in LFS. To reset
136 <application>pip</application> and <application>pip3</application>,
137 run, as the <systemitem class="username">root</systemitem> user:
138 </para>
139
140<screen role="nodump"><userinput>python3 -m pip install - -force pip</userinput></screen>
141 </caution>
142-->
143 <para>
144 First, disable the installation of a script that overwrites a more
145 recent script:
146 </para>
147
148<screen><userinput>sed -i '/2to3/d' ./setup.py</userinput></screen>
149
150 <para>
151 Install <application>Python 2</application> by running the following
152 commands:
153 </para>
154
155<screen><userinput>./configure --prefix=/usr \
156 --enable-shared \
157 --with-system-expat \
158 --with-system-ffi \
159 --enable-unicode=ucs4 &amp;&amp;
160make</userinput></screen>
161
162 <para>
163 To test the results, issue: <command>make -k test</command>.
164 </para>
165
166 <para>
167 Now, as the <systemitem class="username">root</systemitem> user:
168 </para>
169
170<screen role="root"><userinput>make altinstall &amp;&amp;
171ln -s python2.7 /usr/bin/python2 &amp;&amp;
172ln -s python2.7-config /usr/bin/python2-config &amp;&amp;
173chmod -v 755 /usr/lib/libpython&python2-majorver;.so.1.0</userinput></screen>
174
175 <para>
176 Since <application>Python 2</application> is in maintenance mode, and
177 <application>Python 3</application> is recommended by upstream for
178 development, you probably do not need to install the documentation.
179 However, if you still want to install documentation for both
180 <application>Python</application> versions, be sure to define the
181 <envar>PYTHONDOCS</envar>
182 variable for the version you want to use, each time you need to consult
183 the documentation. If you have downloaded the preformatted documentation
184 from <ulink url="http://docs.python.org/download.html"/>, install it
185 as the <systemitem class="username">root</systemitem> user:
186 </para>
187
188<screen role="root"><userinput>install -v -dm755 /usr/share/doc/python-&python2-version; &amp;&amp;
189
190tar --strip-components=1 \
191 --no-same-owner \
192 --directory /usr/share/doc/python-&python2-version; \
193 -xvf ../python-&python2-version;-docs-html.tar.bz2 &amp;&amp;
194
195find /usr/share/doc/python-&python2-version; -type d -exec chmod 0755 {} \; &amp;&amp;
196find /usr/share/doc/python-&python2-version; -type f -exec chmod 0644 {} \;</userinput></screen>
197 </sect2>
198
199 <sect2 role="commands">
200 <title>Command Explanations</title>
201
202 <para>
203 <parameter>--with-system-expat</parameter>: This switch enables linking
204 against system version of <application>Expat</application>.
205 </para>
206
207 <para>
208 <parameter>--with-system-ffi</parameter>: This switch enables linking
209 against system version of <application>libffi</application>.
210 </para>
211
212 <para>
213 <parameter>--enable-unicode=ucs4</parameter>: This switch enables
214 32bit Unicode support in <application>Python</application>.
215 </para>
216
217 <para>
218 <option>--with-ensurepip=yes</option> : This switch enables building
219 <command>pip</command> and <command>setuptools</command> packaging programs.
220 <command>setuptools</command> is needed for building some Python modules.
221 This switch is not recommended because this version of Python is being phased out.
222 </para>
223
224 <para>
225 <option>--with-dbmliborder=bdb:gdbm:ndbm</option>: Use this switch
226 if you want to build <application>Python</application> DBM Module
227 against <application>Berkeley DB</application> instead of
228 <application>GDBM</application>.
229 </para>
230
231 <para>
232 <command>make altinstall</command>: This make target omits some default
233 symbolic links that may interfere with Python 3.
234 </para>
235
236 <para>
237 <command>chmod ...</command>: Fix permissions for libraries to be
238 consistent with other libraries.
239 </para>
240
241 </sect2>
242
243 <sect2 role="configuration">
244 <title>Configuring Python 2</title>
245
246 <para>
247 In order for <command>python</command> to find the installed
248 documentation, you must add the following environment variable to
249 individual user's or the system's profile:
250 </para>
251
252<screen role="root"><userinput>export PYTHONDOCS=/usr/share/doc/python-&python2-version;</userinput></screen>
253
254 </sect2>
255
256 <sect2 role="content">
257 <title>Contents</title>
258
259 <segmentedlist>
260 <segtitle>Installed Programs</segtitle>
261 <segtitle>Installed Library</segtitle>
262 <segtitle>Installed Directories</segtitle>
263
264 <seglistitem>
265 <seg>
266 pydoc,
267 python2 (symlink),
268 python2-config (symlink),
269 python&python2-majorver;,
270 python&python2-majorver;-config,
271 smtpd.py, and
272 idle
273 </seg>
274 <seg>
275 libpython&python2-majorver;.so
276 </seg>
277 <seg>
278 /usr/{include,lib}/python&python2-majorver; and
279 /usr/share/doc/python-&python2-version;
280 </seg>
281 </seglistitem>
282 </segmentedlist>
283
284 <variablelist>
285 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
286 <?dbfo list-presentation="list"?>
287 <?dbhtml list-presentation="table"?>
288
289 <varlistentry id="idle">
290 <term><command>idle</command></term>
291 <listitem>
292 <para>
293 is a wrapper script that opens a <application>Python</application>
294 aware GUI editor. For this script to run, you must have installed
295 <application>Tk</application> before Python so that the Tkinter
296 Python module is built
297 </para>
298 <indexterm zone="python2 idle">
299 <primary sortas="b-idle">idle</primary>
300 </indexterm>
301 </listitem>
302 </varlistentry>
303
304 <varlistentry id="pydoc2">
305 <term><command>pydoc</command></term>
306 <listitem>
307 <para>
308 is the <application>Python</application> documentation tool
309 </para>
310 <indexterm zone="python2 pydoc2">
311 <primary sortas="b-pydoc2">pydoc</primary>
312 </indexterm>
313 </listitem>
314 </varlistentry>
315
316 <varlistentry id="python">
317 <term><command>python2</command></term>
318 <listitem>
319 <para>
320 is an interpreted, interactive, object-oriented programming
321 language
322 </para>
323 <indexterm zone="python2 python">
324 <primary sortas="b-python2">python</primary>
325 </indexterm>
326 </listitem>
327 </varlistentry>
328
329 <varlistentry id="python2-ver">
330 <term><command>python&python2-majorver;</command></term>
331 <listitem>
332 <para>
333 is a version-specific name for the <command>python</command>
334 program
335 </para>
336 <indexterm zone="python2 python2-ver">
337 <primary sortas="b-python&python2-majorver;">python&python2-majorver;</primary>
338 </indexterm>
339 </listitem>
340 </varlistentry>
341
342 <varlistentry id="smtpd.py">
343 <term><command>smtpd.py</command></term>
344 <listitem>
345 <para>
346 is an SMTP proxy implemented in <application>Python</application>
347 </para>
348 <indexterm zone="python2 smtpd.py">
349 <primary sortas="b-smtpd.py">smtpd.py</primary>
350 </indexterm>
351 </listitem>
352 </varlistentry>
353
354 </variablelist>
355
356 </sect2>
357
358</sect1>
Note: See TracBrowser for help on using the repository browser.