source: gnome/add/evince.xml@ 21f1f1f

10.0 10.1 11.0 6.3 6.3-rc1 6.3-rc2 6.3-rc3 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 21f1f1f was 21f1f1f, checked in by Randy McMurchy <randy@…>, 15 years ago

Added the D-Bus GLib bindings as a required dependency of GNOME VFS and removed it from other packages where it became redundant

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@6988 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 7.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY evince-download-http "&gnome-download-http;/evince/0.8/evince-&evince-version;.tar.bz2">
8 <!ENTITY evince-download-ftp "&gnome-download-ftp;/evince/0.8/evince-&evince-version;.tar.bz2">
9 <!ENTITY evince-md5sum "94be73485eeb8584b4aeaa8ac87699f0">
10 <!ENTITY evince-size "994 KB">
11 <!ENTITY evince-buildsize "35.2 MB">
12 <!ENTITY evince-time "0.7 SBU">
13]>
14
15<sect1 id="evince" xreflabel="Evince-&evince-version;">
16 <?dbhtml filename="evince.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>Evince-&evince-version;</title>
24
25 <indexterm zone="evince">
26 <primary sortas="a-Evince">Evince</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to Evince</title>
31
32 <para>The <application>Evince</application> package contains a document
33 viewer for multiple document formats. It currently supports PDF,
34 Postscript, DjVu, TIFF and DVI. This is useful for viewing documents of
35 various types using one simple application instead of the multiple document
36 viewers that once existed on the GNOME Desktop.</para>
37
38 <bridgehead renderas="sect3">Package Information</bridgehead>
39 <itemizedlist spacing="compact">
40 <listitem>
41 <para>Download (HTTP): <ulink url="&evince-download-http;"/></para>
42 </listitem>
43 <listitem>
44 <para>Download (FTP): <ulink url="&evince-download-ftp;"/></para>
45 </listitem>
46 <listitem>
47 <para>Download MD5 sum: &evince-md5sum;</para>
48 </listitem>
49 <listitem>
50 <para>Download size: &evince-size;</para>
51 </listitem>
52 <listitem>
53 <para>Estimated disk space required: &evince-buildsize;</para>
54 </listitem>
55 <listitem>
56 <para>Estimated build time: &evince-time;</para>
57 </listitem>
58 </itemizedlist>
59
60 <!--
61 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
62 <itemizedlist spacing="compact">
63 <listitem>
64 <para>Required patch: <ulink
65 url="&patch-root;/evince-&evince-version;-t1lib-1.patch"/></para>
66 </listitem>
67 </itemizedlist>
68 -->
69
70 <bridgehead renderas="sect3">Evince Dependencies</bridgehead>
71
72 <bridgehead renderas="sect4">Required</bridgehead>
73 <para role="required"><xref linkend="libgnomeui"/>,
74 <xref linkend="gnome-doc-utils"/>, and
75 <xref linkend="poppler"/>
76 (<emphasis role='strong'>must be a version &gt;= 5.1</emphasis> and built
77 with <application>GTK+</application> support)</para>
78
79 <bridgehead renderas="sect4">Run-Time Requirement</bridgehead>
80 <para><xref linkend="shared-mime-info"/></para>
81
82 <bridgehead renderas="sect4">Optional</bridgehead>
83 <para role="optional"><xref linkend="intltool"/>,
84 <xref linkend="libtiff"/>,
85 <xref linkend="tetex"/> (required to build the DVI viewer),
86 <xref linkend="libgnomeprintui"/>
87 (required to print from <application>Evince</application>),
88 <xref linkend="nautilus"/>
89 (required to build the <application>Nautilus</application> plugin),
90 <xref linkend="espgs"/> or <xref linkend="gs"/>
91 (required for Postscript ability from <application>Evince</application>),
92 <ulink url="http://djvulibre.djvuzone.org/">DjVuLibre</ulink>
93 (required for DjVu graphics from <application>Evince</application>), and
94 <ulink url="ftp://sunsite.unc.edu/pub/Linux/libs/graphics/">t1lib</ulink>
95 (required for Type1 font support in the DVI viewer)</para>
96
97 <para condition="html" role="usernotes">User Notes:
98 <ulink url="&blfs-wiki;/evince"/></para>
99
100 </sect2>
101
102 <sect2 role="installation">
103 <title>Installation of Evince</title>
104
105 <para>Install <application>Evince</application> by running the following
106 commands:</para>
107
108<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
109 --sysconfdir=&gnome-etc-dir; \
110 --localstatedir=/var/lib \
111 --disable-ps \
112 --enable-pixbuf &amp;&amp;
113make</userinput></screen>
114
115 <para>This package does not come with a test suite.</para>
116
117 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
118
119<screen role="root"><userinput>make install</userinput></screen>
120
121 </sect2>
122
123 <sect2 role="commands">
124 <title>Command Explanations</title>
125
126 <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
127 href="../../xincludes/gnome-prefix.xml"/>
128
129 <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
130 href="../../xincludes/gnome-sysconfdir.xml"/>
131
132 <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
133 href="../../xincludes/scrollkeeper-dir.xml"/>
134
135 <para><option>--disable-ps</option>: This parameter is required if you
136 don't have a Ghostscript package installed. Remove the parameter if you
137 do have a Ghostscript package installed and wish to build the DVI
138 viewer.</para>
139
140 <para><option>--enable-djvu</option>: Use this parameter if you have the
141 <application>DjVuLibre</application> package installed and you wish to
142 build support to view DjVu files.</para>
143
144 <para><option>--enable-dvi</option>: Use this parameter if you have the
145 <application>teTeX</application> package installed and you wish to build
146 support to view DVI files.</para>
147
148 <para><option>--enable-t1lib</option>: Use this parameter if you have the
149 <application>t1lib</application> package installed and you wish to build
150 support for Type1 fonts in the DVI viewer.</para>
151
152 </sect2>
153
154 <sect2 role="content">
155 <title>Contents</title>
156
157 <segmentedlist>
158 <segtitle>Installed Programs</segtitle>
159 <segtitle>Installed Library</segtitle>
160 <segtitle>Installed Directories</segtitle>
161
162 <seglistitem>
163 <seg>evince and evince-thumbnailer</seg>
164 <seg>libevince-properties-page.{so,a}
165 <application>Nautilus</application> extension</seg>
166 <seg><envar>$GNOME_PREFIX</envar>/share/{,gnome/help/ ,omf/}evince</seg>
167 </seglistitem>
168 </segmentedlist>
169
170 <variablelist>
171 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
172 <?dbfo list-presentation="list"?>
173 <?dbhtml list-presentation="table"?>
174
175 <varlistentry id="evince-prog">
176 <term><command>evince</command></term>
177 <listitem>
178 <para>is a multiple format document viewer.</para>
179 <indexterm zone="evince evince-prog">
180 <primary sortas="b-evince">evince</primary>
181 </indexterm>
182 </listitem>
183 </varlistentry>
184
185 <varlistentry id="evince-thumbnailer">
186 <term><command>evince-thumbnailer</command></term>
187 <listitem>
188 <para>is a simple program used to create thumbnail images of
189 supported documents.</para>
190 <indexterm zone="evince evince-thumbnailer">
191 <primary sortas="b-evince-thumbnailer">evince-thumbnailer</primary>
192 </indexterm>
193 </listitem>
194 </varlistentry>
195
196 </variablelist>
197
198 </sect2>
199
200</sect1>
Note: See TracBrowser for help on using the repository browser.