source: gnome/core/libgnomeui.xml@ 7cdaed0

10.0 10.1 11.0 6.2 6.2.0 6.2.0-rc1 6.2.0-rc2 6.3 6.3-rc1 6.3-rc2 6.3-rc3 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 7cdaed0 was 7cdaed0, checked in by Randy McMurchy <randy@…>, 15 years ago

Moved the GNOME xinclude files to the global xinclude directory because more than just GNOME packages can use them

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@6214 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.4 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.4//EN"
3 "http://www.oasis-open.org/docbook/xml/4.4/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libgnomeui-download-http "&gnome-download-http;/libgnomeui/&gnome-version;/libgnomeui-&libgnomeui-version;.tar.bz2">
8 <!ENTITY libgnomeui-download-ftp "&gnome-download-ftp;/libgnomeui/&gnome-version;/libgnomeui-&libgnomeui-version;.tar.bz2">
9 <!ENTITY libgnomeui-md5sum "ff6b6c25de0e7e39c79998621cdec048">
10 <!ENTITY libgnomeui-size "1.8 MB">
11 <!ENTITY libgnomeui-buildsize "40.0 MB">
12 <!ENTITY libgnomeui-time "0.7 SBU">
13]>
14
15<sect1 id="libgnomeui" xreflabel="libgnomeui-&libgnomeui-version;">
16 <?dbhtml filename="libgnomeui.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>libgnomeui-&libgnomeui-version;</title>
24
25 <indexterm zone="libgnomeui">
26 <primary sortas="a-Libgnomeui">Libgnomeui</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to libgnomeui</title>
31
32 <para>The <application>libgnomeui</application> package contains
33 <filename class="libraryfile">libgnomeui</filename> libraries.</para>
34
35 <bridgehead renderas="sect3">Package Information</bridgehead>
36 <itemizedlist spacing="compact">
37 <listitem>
38 <para>Download (HTTP): <ulink url="&libgnomeui-download-http;"/></para>
39 </listitem>
40 <listitem>
41 <para>Download (FTP): <ulink url="&libgnomeui-download-ftp;"/></para>
42 </listitem>
43 <listitem>
44 <para>Download MD5 sum: &libgnomeui-md5sum;</para>
45 </listitem>
46 <listitem>
47 <para>Download size: &libgnomeui-size;</para>
48 </listitem>
49 <listitem>
50 <para>Estimated disk space required: &libgnomeui-buildsize;</para>
51 </listitem>
52 <listitem>
53 <para>Estimated build time: &libgnomeui-time;</para>
54 </listitem>
55 </itemizedlist>
56
57 <bridgehead renderas="sect3">libgnomeui Dependencies</bridgehead>
58
59 <bridgehead renderas="sect4">Required</bridgehead>
60 <para role="required"><xref linkend="libbonoboui"/> and
61 <xref linkend="gnome-keyring"/></para>
62
63 <bridgehead renderas="sect4">Optional</bridgehead>
64 <para role="optional"><xref linkend="libjpeg"/>,
65 <xref linkend="esound"/>, and
66 <xref linkend="gtk-doc"/></para>
67
68 <para condition="html" role="usernotes">User Notes:
69 <ulink url="&blfs-wiki;/libgnomeui"/></para>
70
71 </sect2>
72
73 <sect2 role="installation">
74 <title>Installation of libgnomeui</title>
75
76 <para>Install <application>libgnomeui</application> by running the following
77 commands:</para>
78
79<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
80 --libexecdir=$(pkg-config \
81 --variable=prefix ORBit-2.0)/lib/libgnomeui &amp;&amp;
82make</userinput></screen>
83
84 <para>This package does not come with a test suite.</para>
85
86 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
87
88<screen role="root"><userinput>make install</userinput></screen>
89
90 <para>If your <application>GNOME</application> installation prefix is
91 anything other than <filename class='directory'>/usr</filename>, create
92 the following symbolic link as the
93 <systemitem class="username">root</systemitem> user:</para>
94
95<screen role="root"><userinput>ln -v -s $(pkg-config \
96 --variable=prefix ORBit-2.0)/lib/gtk-2.0/2.4.0/filesystems \
97 /usr/lib/gtk-2.0/2.4.0</userinput></screen>
98
99 </sect2>
100
101 <sect2 role="commands">
102 <title>Command Explanations</title>
103
104 <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
105 href="../../xincludes/gnome-prefix.xml"/>
106
107 <para><parameter>--libexecdir=$(pkg-config --variable=prefix
108 ORBit-2.0)/lib/libgnomeui</parameter>: This parameter causes the libexec
109 files to be installed in the preferred location of
110 <filename class="directory">$GNOME_PREFIX/lib/libgnomeui</filename> instead
111 of <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
112
113 <para><option>--with-kde-datadir=$KDE_PREFIX/share</option>: Use this
114 parameter if you have <application>KDE</application> installed in any prefix
115 other than <filename class='directory'>/usr</filename>.</para>
116
117 <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
118 href="../../xincludes/gtk-doc-rebuild.xml"/>
119
120 </sect2>
121
122 <sect2 role="configuration">
123 <title>Configuring libgnomeui</title>
124
125 <sect3>
126 <title>Configuration Information</title>
127
128 <para>Some applications cannot properly discover the
129 <application>libglade</application> interface library installed by
130 <application>libgnomeui</application>. Get around this problem by
131 initializing an environment variable which identifies the location
132 of the library. Add the following line to the system-wide
133 <filename>/etc/profile</filename> file, or to individual user's
134 <filename>~/.profile</filename> or <filename>~/.bashrc</filename>
135 files:</para>
136
137<screen><literal>export LIBGLADE_MODULE_PATH=$GNOME_PREFIX/lib/libglade/2.0</literal></screen>
138
139 </sect3>
140
141 </sect2>
142
143 <sect2 role="content">
144 <title>Contents</title>
145
146 <segmentedlist>
147 <segtitle>Installed Programs</segtitle>
148 <segtitle>Installed Libraries</segtitle>
149 <segtitle>Installed Directories</segtitle>
150
151 <seglistitem>
152 <seg></seg>
153 <seg>libgnomeui-2.{so,a}, the libgnome.{so,a} Glade library, and
154 the libgnome-vfs.{so,a} <application>GTK+</application> library</seg>
155 <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
156 include/libgnomeui-2.0,
157 lib/{gtk-2.0/2.4.0/filesystems, libgnomeui} and
158 share/gtk-doc/html/libgnomeui</seg>
159 </seglistitem>
160 </segmentedlist>
161
162 <variablelist>
163 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
164 <?dbfo list-presentation="list"?>
165 <?dbhtml list-presentation="table"?>
166
167 <varlistentry id="libgnomeui-2">
168 <term><filename class='libraryfile'>libgnomeui-2.{so,a}</filename></term>
169 <listitem>
170 <para>are the GUI portion of the <application>GNOME</application>
171 libraries.</para>
172 <indexterm zone="libgnomeui libgnomeui-2">
173 <primary sortas="c-libgnomeui-2">libgnomeui-2.{so,a}</primary>
174 </indexterm>
175 </listitem>
176 </varlistentry>
177
178 </variablelist>
179
180 </sect2>
181
182</sect1>
Note: See TracBrowser for help on using the repository browser.