source: kde/polkit-qt.xml@ 9e04432

10.0 10.1 11.0 7.10 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt lazarus nosym perl-modules qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 9e04432 was 9e04432, checked in by Bruce Dubbs <bdubbs@…>, 6 years ago

Remove KDE4

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@17157 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.0 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../general.ent">
5 %general-entities;
6
7 <!ENTITY polkit-qt-download-http "&kde-download-http;apps/KDE4.x/admin/polkit-qt-1-&polkit-qt-version;.tar.bz2">
8 <!ENTITY polkit-qt-download-ftp "&kde-download-ftp;apps/KDE4.x/admin/polkit-qt-1-&polkit-qt-version;.tar.bz2">
9 <!ENTITY polkit-qt-md5sum "bee71b71c12797e6fc498540a06c829b">
10 <!ENTITY polkit-qt-size "68 KB">
11 <!ENTITY polkit-qt-buildsize "4.2 MB">
12 <!ENTITY polkit-qt-time "0.1 SBU">
13]>
14
15<sect1 id="polkit-qt" xreflabel="polkit-qt-&polkit-qt-version;">
16 <?dbhtml filename="polkit-qt.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>Polkit-Qt-&polkit-qt-version;</title>
24
25 <indexterm zone="polkit-qt">
26 <primary sortas="a-polkit-qt">polkit-qt</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to Polkit-Qt</title>
31
32 <para><application>Polkit-Qt</application> provides an API to PolicyKit in
33 the Qt environment. <!--Its libraries are used by both KDE4 and KF5, but they
34 must be linked to <xref linkend='qt4'/> and <xref linkend='qt5'/>
35 respectively. The two versions do not conflict with each other.--> </para>
36
37 &lfs79_checked;
38
39 <bridgehead renderas="sect3">Package Information</bridgehead>
40 <itemizedlist spacing="compact">
41 <listitem>
42 <para>Download (HTTP): <ulink url="&polkit-qt-download-http;"/></para>
43 </listitem>
44 <listitem>
45 <para>Download (FTP): <ulink url="&polkit-qt-download-ftp;"/></para>
46 </listitem>
47 <listitem>
48 <para>Download MD5 sum: &polkit-qt-md5sum;</para>
49 </listitem>
50 <listitem>
51 <para>Download size: &polkit-qt-size;</para>
52 </listitem>
53 <listitem>
54 <para>Estimated disk space required: &polkit-qt-buildsize;</para>
55 </listitem>
56 <listitem>
57 <para>Estimated build time: &polkit-qt-time;</para>
58 </listitem>
59 </itemizedlist>
60
61<!--
62 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
63 <itemizedlist spacing='compact'>
64 <listitem>
65 <para>Required patch: <ulink
66 url="&patch-root;/polkit-qt-&polkit-qt-version;-fixes-1.patch"/></para>
67 </listitem>
68 </itemizedlist>
69-->
70 <bridgehead renderas="sect3">Polkit-Qt Dependencies</bridgehead>
71
72 <bridgehead renderas="sect4">Required</bridgehead>
73 <para role="required">
74 <xref linkend="cmake"/>,
75 <xref linkend="polkit"/>, and
76 <!--<xref linkend="qt4"/>--> or <xref linkend="qt5"/>
77 </para>
78
79 <para condition="html" role="usernotes">User Notes:
80 <ulink url="&blfs-wiki;/polkit-qt"/></para>
81
82 </sect2>
83
84 <sect2 role="installation">
85 <title>Installation of Polkit-Qt</title>
86<!--
87 <para>Install the Qt4 based version of <application>Polkit-Qt</application>
88 by running the following commands:</para>
89
90<screen><userinput>source /usr/bin/setqt4 &amp;&amp;
91
92mkdir build &amp;&amp;
93cd build &amp;&amp;
94
95cmake -DCMAKE_INSTALL_PREFIX=/usr \
96 -DCMAKE_BUILD_TYPE=Release \
97 -DCMAKE_INSTALL_LIBDIR=lib \
98 -DUSE_QT4=TRUE \
99 -Wno-dev .. &amp;&amp;
100make</userinput></screen>
101
102 <para>
103 This package does not come with a test suite.
104 </para>
105
106 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
107
108<screen role="root"><userinput>make install</userinput></screen>
109-->
110 <para>Install <!--the Qt5 based version of --><application>Polkit-Qt</application>
111 by running the following commands:</para>
112
113<screen><userinput>source /usr/bin/setqt5 &amp;&amp;
114
115mkdir build &amp;&amp;
116cd build &amp;&amp;
117
118cmake -DCMAKE_INSTALL_PREFIX=/usr \
119 -DCMAKE_BUILD_TYPE=Release \
120 -DCMAKE_INSTALL_LIBDIR=lib \
121 -Wno-dev .. &amp;&amp;
122make</userinput></screen>
123
124 <para>
125 This package does not come with a test suite.
126 </para>
127
128 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
129
130<screen role="root"><userinput>make install</userinput></screen>
131
132 </sect2>
133
134 <sect2 role="commands">
135 <title>Command Explanations</title>
136
137 <para>
138 <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
139 to apply higher level of the compiler optimizations.
140 </para>
141
142 <para>
143 <parameter>-DCMAKE_INSTALL_LIBDIR=lib</parameter>: This switch is
144 used to get libraries to install to <filename
145 class="directory">&kde-dir;/lib</filename> instead of <filename
146 class="directory">&kde-dir;/lib64</filename> on a 64 bit system.
147 </para>
148<!--
149 <para>
150 <parameter>-DUSE_QT4=TRUE</parameter>: This switch is used to ensure
151 that <application>Qt4</application> version of the library is
152 built even if <application>Qt5</application> is present.
153 </para>
154-->
155 </sect2>
156
157 <sect2 role="content">
158 <title>Contents</title>
159
160 <segmentedlist>
161 <segtitle>Installed Programs</segtitle>
162 <segtitle>Installed Libraries</segtitle>
163 <segtitle>Installed Directories</segtitle>
164
165 <seglistitem>
166 <seg>none</seg>
167 <seg>
168 libpolkit-qt5-agent-1.so,
169 libpolkit-qt5-core-1.so, and
170 libpolkit-qt5-gui-1.so</seg>
171 <seg>
172 /usr/include/polkit-qt5-1 and
173 /usr/lib/cmake/PolkitQt5-1
174 </seg>
175 </seglistitem>
176 </segmentedlist>
177<!--
178 <variablelist>
179 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
180 <?dbfo list-presentation="list"?>
181 <?dbhtml list-presentation="table"?>
182
183 <varlistentry id="a-polkit-qt">
184 <term><command>polkit-qt</command></term>
185 <listitem>
186 <para>is a testing utility for polkit-qt-generated build trees.</para>
187 <indexterm zone="a-polkit-qt polkit-qt">
188 <primary sortas="b-polkit-qt">polkit-qt</primary>
189 </indexterm>
190 </listitem>
191 </varlistentry>
192
193 </variablelist>
194-->
195 </sect2>
196
197</sect1>
Note: See TracBrowser for help on using the repository browser.