source: multimedia/libdriv/gst10-plugins-bad.xml@ 53eba27

10.0 10.1 11.0 11.1 11.2 8.4 9.0 9.1 lazarus plabs/python-mods qt5new trunk upgradedb xry111/intltool xry111/soup3 xry111/test-20220226
Last change on this file since 53eba27 was 53eba27, checked in by DJ Lucas <dj@…>, 4 years ago

Add patch for gst-plugins-bad to allow build with fdkaac-2.0.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21126 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 8.6 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY gst10-plugins-bad-download-http
8 "&gstreamer-dl;/gst-plugins-bad/gst-plugins-bad-&gst10-plugins-bad-version;.tar.xz">
9 <!ENTITY gst10-plugins-bad-download-ftp " ">
10 <!ENTITY gst10-plugins-bad-md5sum "5d20a91d027708abcf924f6c1279dd25">
11 <!ENTITY gst10-plugins-bad-size "4.5 MB">
12 <!ENTITY gst10-plugins-bad-buildsize "173 MB (with tests)">
13 <!ENTITY gst10-plugins-bad-time "1.9 SBU (Using parallelism=4; with tests)">
14]>
15
16<sect1 id="gst10-plugins-bad" xreflabel="gst-plugins-bad-&gst10-plugins-bad-version;">
17 <?dbhtml filename="gst10-plugins-bad.html"?>
18
19 <sect1info>
20 <othername>$LastChangedBy$</othername>
21 <date>$Date$</date>
22 </sect1info>
23
24 <title>gst-plugins-bad-&gst10-plugins-bad-version;</title>
25
26 <indexterm zone="gst10-plugins-bad">
27 <primary sortas="a-gst-plugins-bad">gst-plugins-bad</primary>
28 </indexterm>
29
30 <sect2 role="package">
31 <title>Introduction to GStreamer Bad Plug-ins</title>
32
33 <para>
34 The <application>GStreamer Bad Plug-ins</application> package contains a
35 set of plug-ins that aren't up to par compared to the rest. They
36 might be close to being good quality, but they're missing something - be
37 it a good code review, some documentation, a set of tests, a real live
38 maintainer, or some actual wide use.
39 </para>
40
41 &lfs83_checked;
42
43 <bridgehead renderas="sect3">Package Information</bridgehead>
44 <itemizedlist spacing="compact">
45 <listitem>
46 <para>
47 Download (HTTP): <ulink url="&gst10-plugins-bad-download-http;"/>
48 </para>
49 </listitem>
50 <listitem>
51 <para>
52 Download (FTP): <ulink url="&gst10-plugins-bad-download-ftp;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download MD5 sum: &gst10-plugins-bad-md5sum;
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download size: &gst10-plugins-bad-size;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Estimated disk space required: &gst10-plugins-bad-buildsize;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated build time: &gst10-plugins-bad-time;
73 </para>
74 </listitem>
75 </itemizedlist>
76
77
78 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
79 <itemizedlist spacing="compact">
80 <listitem>
81 <para>
82 Required patch:
83 <ulink url="&patch-root;/gst10-plugins-bad-&gst10-plugins-bad-version;-fdkaac_2-1.patch"/>
84 </para>
85 </listitem>
86 </itemizedlist>
87
88 <bridgehead renderas="sect3">GStreamer Bad Plug-ins Dependencies</bridgehead>
89
90 <bridgehead renderas="sect4">Required</bridgehead>
91 <para role="required">
92 <xref linkend="gst10-plugins-base"/>
93 </para>
94
95 <!-- Common formats, output and input codecs and requirements
96 for GNOME apps. What's a multimedia framework useful if it
97 can't be used to play anything (common)? -->
98 <bridgehead renderas="sect4">Recommended</bridgehead>
99 <para role="recommended">
100 <xref linkend="libdvdread"/>,
101 <xref linkend="libdvdnav"/>,
102 <xref linkend="llvm"/>, and
103 <xref linkend="soundtouch"/>
104 </para>
105
106 <bridgehead renderas="sect4">Optional</bridgehead>
107 <para role="optional">
108 <xref linkend="bluez"/>,
109 <xref linkend="clutter"/>,
110 <xref linkend="curl"/>,
111 <xref linkend="faac"/>,
112 <xref linkend="faad2"/>,
113 <xref linkend="gnutls"/>,
114 <xref linkend="gtk-doc"/>,
115 <xref linkend="gtk2"/> or
116 <xref linkend="gtk3"/>,
117 <xref linkend="lcms2"/>,
118 <xref linkend="libass"/>,
119 <xref linkend="libexif"/>,
120 <xref linkend="libgcrypt"/>,
121 <xref linkend="libgudev"/>,
122 <xref linkend="libmpeg2"/>,
123 <xref linkend="libssh2"/>,
124 <xref linkend="libusb"/>,
125 <xref linkend="libvdpau"/>,
126 <xref linkend="libwebp"/>,
127 <xref linkend="neon"/>,
128 <xref linkend="nettle"/>,
129 <xref linkend="opencv"/> (with additional modules),
130 <xref linkend="openjpeg2"/>,
131 <xref linkend="opus"/>,
132 <xref linkend="qt5"/> (for examples),
133 <xref linkend="sdl"/>,
134 <xref linkend="valgrind"/>,
135 <xref linkend="wayland"/> (<xref linkend="gtk3"/> must have been
136 compiled with wayland support),
137 <xref linkend="x265"/>,
138 <xref linkend="xorg7-lib"/>,
139 <ulink url="http://bs2b.sourceforge.net/">bs2b</ulink>,
140 <ulink url="https://acoustid.org/chromaprint">Chromaprint</ulink>,
141 <ulink url="https://www.xiph.org/daala/">daala</ulink>,
142 <ulink url="http://www.speech.cs.cmu.edu/flite/">Flite</ulink>,
143 <ulink url="https://bitbucket.org/mpyne/game-music-emu/">Game Music Emu</ulink>,
144 <ulink url="http://www.quut.com/gsm/">GSM</ulink>,
145 <ulink url="https://www.ladspa.org/">LADSPA</ulink>,
146 <ulink url="http://sourceforge.net/projects/farsight/files/libmimic/">libmimic</ulink>,
147 <ulink url="http://sourceforge.net/projects/libmms/">libmms</ulink>,
148 <ulink url="http://code.google.com/p/musicip-libofa/">libofa</ulink>,
149 <ulink url="http://mjpeg.sourceforge.net/">MJPEG Tools</ulink>,
150 <ulink url="http://kcat.strangesoft.net/openal.html">OpenAL</ulink>,
151 <ulink url="http://gstreamer.freedesktop.org/src/orc/">Orc</ulink>,
152 <ulink url="http://sourceforge.net/projects/opencore-amr/files/vo-aacenc/">VO AAC</ulink>,
153 <ulink url="http://sourceforge.net/projects/opencore-amr/files/vo-amrwbenc/">VO AMRWB</ulink>, and
154 <ulink url="http://zbar.sourceforge.net/">ZBAR</ulink>
155 </para>
156
157 <para condition="html" role="usernotes">
158 User Notes: <ulink url="&blfs-wiki;/gst10-plugins-bad"/>
159 </para>
160 </sect2>
161
162 <sect2 role="installation">
163 <title>Installation of GStreamer Bad Plug-ins</title>
164
165 <note><para>If you need a plugin for a given dependency, that dependency
166 needs to be installed before this application.
167 </para></note>
168
169 <para>
170 Install <application>GStreamer Bad Plug-ins</application> by running the
171 following commands:
172 </para>
173
174<screen><userinput>./configure --prefix=/usr \
175 --disable-wayland \
176 --disable-opencv \
177 --with-package-name="GStreamer Bad Plugins &gst10-plugins-bad-version; BLFS" \
178 --with-package-origin="http://www.linuxfromscratch.org/blfs/view/svn/" &amp;&amp;
179make</userinput></screen>
180
181 <para>
182 To test the results, issue: <command>make check</command>. Several tests
183 need a terminal emulator in a graphical session. One test, dash_mpd,
184 is known to fail.
185 </para>
186
187 <para>
188 Now, as the <systemitem class="username">root</systemitem> user:
189 </para>
190
191<screen role="root"><userinput>make install</userinput></screen>
192 </sect2>
193
194 <sect2 role="commands">
195 <title>Command Explanations</title>
196
197 <para>
198 <parameter>--disable-wayland</parameter>: This switch is required
199 without a full wayland based desktop environment.
200 </para>
201
202 <para>
203 <parameter>--disable-opencv</parameter>: This switch is required
204 if <xref linkend="opencv"/> is installed without additional modules
205 (specifically bgsegm).
206 </para>
207
208 </sect2>
209
210 <sect2 role="content">
211 <title>Contents</title>
212
213 <segmentedlist>
214 <segtitle>Installed Programs</segtitle>
215 <segtitle>Installed Libraries</segtitle>
216 <segtitle>Installed Directories</segtitle>
217
218 <seglistitem>
219 <seg>
220 None
221 </seg>
222 <seg>
223 libgstadaptivedemux-1.0.so,
224 libgstbadaudio-1.0.so,
225 libgstbadvideo-1.0.so,
226 libgstbasecamerabinsrc-1.0.so,
227 libgstcodecparsers-1.0.so,
228 libgstinsertbin-1.0.so,
229 libgstisoff-1.0.so,
230 libgstmpegts-1.0.so,
231 libgstphotography-1.0.so,
232 libgstplayer-1.0.so,
233 libgsturidownloader-1.0.so,
234 libgstwayland-1.0.so,
235 libgstwebrtc-1.0.so, and
236 several plugins under /usr/lib/gstreamer-1.0
237 </seg>
238 <seg>
239 /usr/include/gstreamer-1.0/gst/{audio,basecamerabinsrc,codecparsers},
240 /usr/include/gstreamer-1.0/gst/{insertbin,interfaces,is,mpegts},
241 /usr/include/gstreamer-1.0/gst/{player,uridownloader,video,webrtc},
242 /usr/lib/gstreamer-1.0/include, and
243 /usr/share/gtk-doc/html/gst-plugins-bad-{libs,plugins}-1.0
244 </seg>
245 </seglistitem>
246 </segmentedlist>
247
248 </sect2>
249
250</sect1>
Note: See TracBrowser for help on using the repository browser.