source: multimedia/libdriv/gst10-plugins-good.xml@ 0c61cb89

10.0 10.1 11.0 9.0 9.1 ken/refactor-virt lazarus qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 0c61cb89 was 0c61cb89, checked in by Bruce Dubbs <bdubbs@…>, 3 years ago

Update to gstreamer

gstreamer-vaapi
gst-plugins-{base,good,bad,ugly}
gst-libav 1.16.0.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21512 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY gst10-plugins-good-download-http
8 "&gstreamer-dl;/gst-plugins-good/gst-plugins-good-&gst10-plugins-good-version;.tar.xz">
9 <!ENTITY gst10-plugins-good-download-ftp " ">
10 <!ENTITY gst10-plugins-good-md5sum "d1a7b442994d9522418de4af4330e034">
11 <!ENTITY gst10-plugins-good-size "3.7 MB">
12 <!ENTITY gst10-plugins-good-buildsize "97 MB (with tests)">
13 <!ENTITY gst10-plugins-good-time "0.5 SBU (Using parallelism=4; with tests)">
14]>
15
16<sect1 id="gst10-plugins-good" xreflabel="gst-plugins-good-&gst10-plugins-good-version;">
17 <?dbhtml filename="gst10-plugins-good.html"?>
18
19 <sect1info>
20 <othername>$LastChangedBy$</othername>
21 <date>$Date$</date>
22 </sect1info>
23
24 <title>gst-plugins-good-&gst10-plugins-good-version;</title>
25
26 <indexterm zone="gst10-plugins-good">
27 <primary sortas="a-gst-plugins-good">gst-plugins-good</primary>
28 </indexterm>
29
30 <sect2 role="package">
31 <title>Introduction to GStreamer Good Plug-ins</title>
32
33 <para>
34 The <application>GStreamer Good Plug-ins</application> is a set of plug-ins
35 considered by the <application>GStreamer</application> developers to have
36 good quality code, correct functionality, and the preferred license (LGPL
37 for the plug-in code, LGPL or LGPL-compatible for the supporting library).
38 A wide range of video and audio decoders, encoders, and filters are included.
39 </para>
40
41 &lfs84_checked;
42
43 <bridgehead renderas="sect3">Package Information</bridgehead>
44 <itemizedlist spacing="compact">
45 <listitem>
46 <para>
47 Download (HTTP): <ulink url="&gst10-plugins-good-download-http;"/>
48 </para>
49 </listitem>
50 <listitem>
51 <para>
52 Download (FTP): <ulink url="&gst10-plugins-good-download-ftp;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download MD5 sum: &gst10-plugins-good-md5sum;
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download size: &gst10-plugins-good-size;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Estimated disk space required: &gst10-plugins-good-buildsize;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated build time: &gst10-plugins-good-time;
73 </para>
74 </listitem>
75 </itemizedlist>
76
77 <bridgehead renderas="sect3">GStreamer Good Plug-ins Dependencies</bridgehead>
78
79 <bridgehead renderas="sect4">Required</bridgehead>
80 <para role="required">
81 <xref linkend="gst10-plugins-base"/>
82 </para>
83
84 <!-- Common formats, output and input codecs and requirements
85 for GNOME apps. What's a multimedia framework useful if it
86 can't be used to play anything (common)? -->
87 <bridgehead renderas="sect4">Recommended</bridgehead>
88 <para role="recommended">
89 <xref linkend="cairo"/>,
90 <xref linkend="flac"/>,
91 <xref linkend="lame"/>,
92 <xref linkend="mpg123"/>,
93 <xref linkend="mesa"/>,
94 <xref linkend="gdk-pixbuf"/>,
95 <xref linkend="libgudev"/>,
96 <xref linkend="libjpeg"/>,
97 <xref linkend="libpng"/>,
98 <xref linkend="libsoup"/>,
99 <xref linkend="libvpx"/>, and
100 <xref linkend="xorg7-lib"/> <!-- build time requirements only,
101 you don't need either apps, fonts or xorg server to build this
102 package. You'll need xserver for any X app that wants to play
103 something though, but that should be obvious. -->
104 </para>
105
106 <bridgehead renderas="sect4">Optional</bridgehead>
107 <para role="optional">
108 <xref linkend="aalib"/>,
109 <xref linkend="alsa-oss"/>,
110 <xref linkend="gtk3"/> (for examples),
111 <xref linkend="gtk-doc"/>,
112 <xref linkend="libdv"/>,
113 <xref linkend="pulseaudio"/>,
114 <xref linkend="qt5"/>,
115 <xref linkend="speex"/>,
116 <xref linkend="taglib"/>,
117 <xref linkend="valgrind"/>,
118 <xref linkend='v4l-utils'/>,
119 <xref linkend="wayland"/>,
120 <ulink url="http://jackaudio.org/">JACK</ulink>,
121 <ulink url="http://caca.zoy.org/wiki/libcaca">libcaca</ulink>,
122 <ulink url="http://sourceforge.net/projects/libraw1394/">libiec61883</ulink>,
123 <ulink url="http://sourceforge.net/projects/libraw1394/">libraw1394</ulink>,
124 <ulink url="http://www.icecast.org/download.php">libshout</ulink>,
125 <ulink url="http://gstreamer.freedesktop.org/src/orc/">Orc</ulink>,
126 <ulink url="http://www.twolame.org/">TwoLame</ulink>, and
127 <ulink url="http://wavpack.com/">WavPack</ulink>
128 </para>
129
130 <para condition="html" role="usernotes">
131 User Notes: <ulink url="&blfs-wiki;/gst10-plugins-good"/>
132 </para>
133 </sect2>
134
135 <sect2 role="installation">
136 <title>Installation of GStreamer Good Plug-ins</title>
137
138 <note><para>If you need a plugin for a given dependency, that dependency
139 needs to be installed before this application.
140 </para></note>
141
142 <caution><para>
143 If you have Qt5 installed, the build may fail if you have Wayland support
144 enabled in Qt. To fix this, run the <command>remove-la-files.sh</command>
145 script that is in <xref linkend="la-files"/>.
146 </para></caution>
147
148 <para>
149 Install <application>GStreamer Good Plug-ins</application> by running the
150 following commands:
151 </para>
152
153<screen><userinput>mkdir build &amp;&amp;
154cd build &amp;&amp;
155
156meson --prefix=/usr \
157 -Dbuildtype=release \
158 -Dpackage-origin=http://www.linuxfromscratch.org/blfs/view/svn/ \
159 -Dpackage-name="GStreamer &gst10-plugins-good-version; BLFS" &amp;&amp;
160ninja</userinput></screen>
161
162 <para>
163 To test the results, issue: <command>ninja test</command>. The souphttpsrc
164 test is known to fail.
165 <!-- This is due to API changes in libsoup-2.56+. The async/sync,
166 disconnect, and soup messaging functions were changed, and as a result,
167 the souphttpsrc test fails. -->
168 </para>
169
170 <para>
171 Now, as the <systemitem class="username">root</systemitem> user:
172 </para>
173
174<screen role="root"><userinput>ninja install</userinput></screen>
175 </sect2>
176
177 <sect2 role="content">
178 <title>Contents</title>
179
180 <segmentedlist>
181 <segtitle>Installed Programs</segtitle>
182 <segtitle>Installed Libraries</segtitle>
183 <segtitle>Installed Directories</segtitle>
184
185 <seglistitem>
186 <seg>
187 None
188 </seg>
189 <seg>
190 Several plugins under /usr/lib/gstreamer-1.0
191 </seg>
192 <seg>
193 /usr/share/gstreamer-1.0/presets and
194 /usr/share/gtk-doc/html/gst-plugins-good-plugins-1.0
195 </seg>
196 </seglistitem>
197 </segmentedlist>
198
199 </sect2>
200
201</sect1>
Note: See TracBrowser for help on using the repository browser.