source: networking/netlibs/libpcap.xml@ 6bc3d8c

11.0 lazarus qt5new trunk
Last change on this file since 6bc3d8c was 6bc3d8c, checked in by Bruce Dubbs <bdubbs@…>, 4 months ago

Package updates.
Update to ristretto-0.11.0.
Update to vlc-3.0.15.
Update to gnumeric-1.12.50.
Update to goffice-0.10.50.
Update to libpcap-1.10.1.
Update to libksba-1.6.0.
Update to nss-3.67.

  • Property mode set to 100644
File size: 5.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libpcap-download-http "https://www.tcpdump.org/release/libpcap-&libpcap-version;.tar.gz">
8 <!ENTITY libpcap-download-ftp " ">
9 <!ENTITY libpcap-md5sum "21af603d9a591c7d96a6457021d84e6c">
10 <!ENTITY libpcap-size "844 KB">
11 <!ENTITY libpcap-buildsize "11 MB">
12 <!ENTITY libpcap-time "less than 0.1 SBU">
13]>
14
15<sect1 id="libpcap" xreflabel="libpcap-&libpcap-version;">
16 <?dbhtml filename="libpcap.html"?>
17
18 <sect1info>
19 <date>$Date$</date>
20 </sect1info>
21
22 <title>libpcap-&libpcap-version;</title>
23
24 <indexterm zone="libpcap">
25 <primary sortas="a-libpcap">libpcap</primary>
26 </indexterm>
27
28 <sect2 role="package">
29 <title>Introduction to libpcap</title>
30
31 <para>
32 <application>libpcap</application> provides functions for user-level
33 packet capture, used in low-level network monitoring.
34 </para>
35
36 &lfs101_checked;
37
38 <bridgehead renderas="sect3">Package Information</bridgehead>
39 <itemizedlist spacing="compact">
40 <listitem>
41 <para>
42 Download (HTTP): <ulink url="&libpcap-download-http;"/>
43 </para>
44 </listitem>
45 <listitem>
46 <para>
47 Download (FTP): <ulink url="&libpcap-download-ftp;"/>
48 </para>
49 </listitem>
50 <listitem>
51 <para>
52 Download MD5 sum: &libpcap-md5sum;
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download size: &libpcap-size;
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Estimated disk space required: &libpcap-buildsize;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Estimated build time: &libpcap-time;
68 </para>
69 </listitem>
70 </itemizedlist>
71
72<!-- Not needed with 1.10.0
73 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
74 <itemizedlist spacing="compact">
75 <listitem>
76 <para>
77 Recommended patch:
78 <ulink url="&patch-root;/libpcap-&libpcap-version;-enable_bluetooth-1.patch"/>
79 (Needed for bluez-5.21)
80 </para>
81 </listitem>
82 </itemizedlist>
83-->
84
85 <bridgehead renderas="sect3">libpcap Dependencies</bridgehead>
86
87 <bridgehead renderas="sect4">Optional</bridgehead>
88 <para role="optional">
89 <xref linkend="bluez"/>,
90 <xref linkend="libnl"/>,
91 <xref linkend="libusb"/>,
92 Software distribution for the
93 <ulink url="http://www.endace.com/">DAG</ulink>, and
94 <ulink url="http://www.intel.com/">Septel</ulink> range of passive
95 network monitoring cards.
96 </para>
97
98 <para condition="html" role="usernotes">User Notes:
99 <ulink url="&blfs-wiki;/libpcap"/>
100 </para>
101 </sect2>
102
103 <sect2 role="installation">
104 <title>Installation of libpcap</title>
105
106 <para>
107 Install <application>libpcap</application> by running the
108 following commands:
109 </para>
110
111<screen><userinput>./configure --prefix=/usr &amp;&amp;
112make</userinput></screen>
113
114 <para>
115 This package does not come with a test suite.
116 </para>
117
118 <para>
119 If you want to disable installing the static library, use this sed:
120 </para>
121
122<screen><userinput>sed -i '/INSTALL_DATA.*libpcap.a\|RANLIB.*libpcap.a/ s/^/#/' Makefile</userinput></screen>
123
124 <para>
125 Now, as the <systemitem class="username">root</systemitem> user:
126 </para>
127
128<screen role="root"><userinput>make install</userinput></screen>
129
130 </sect2>
131
132<!--
133 <sect2 role="commands">
134 <title>Command Explanations</title>
135
136 <para>
137 <option>- -enable-bluetooth=no</option>: Necessary, if the recommended
138 patch is not applied, because since 1.6.1 this application needs a fix,
139 in order to build with <application>bluez-5.21</application>.
140 </para>
141
142 </sect2>
143-->
144
145 <sect2 role="content">
146 <title>Contents</title>
147
148 <segmentedlist>
149 <segtitle>Installed Program</segtitle>
150 <segtitle>Installed Libraries</segtitle>
151 <segtitle>Installed Directory</segtitle>
152
153 <seglistitem>
154 <seg>
155 pcap-config
156 </seg>
157 <seg>
158 libpcap.so
159 </seg>
160 <seg>
161 /usr/include/pcap
162 </seg>
163 </seglistitem>
164 </segmentedlist>
165
166 <variablelist>
167 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
168 <?dbfo list-presentation="list"?>
169 <?dbhtml list-presentation="table"?>
170
171 <varlistentry id="pcap-config">
172 <term><command>pcap-config</command></term>
173 <listitem>
174 <para>
175 provides configuration information for
176 <application>libpcap</application>
177 </para>
178 <indexterm zone="libpcap pcap-config">
179 <primary sortas="c-libpcap">pcap-config</primary>
180 </indexterm>
181 </listitem>
182 </varlistentry>
183
184 <varlistentry id="libpcap-lib">
185 <term><filename class="libraryfile">libpcap.{a,so}</filename></term>
186 <listitem>
187 <para>
188 are libraries used for user-level packet capture
189 </para>
190 <indexterm zone="libpcap libpcap-lib">
191 <primary sortas="c-libpcap">libpcap.{a,so}</primary>
192 </indexterm>
193 </listitem>
194 </varlistentry>
195
196 </variablelist>
197
198 </sect2>
199
200</sect1>
Note: See TracBrowser for help on using the repository browser.