source: networking/netlibs/libsoup.xml@ a6852d6

10.0 10.1 11.0 ken/refactor-virt lazarus qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since a6852d6 was a6852d6, checked in by Douglas R. Reno <renodr@…>, 2 years ago

Update to lxsession-0.5.5
Update to totem-pl-parser-3.26.5
Update to enchant-2.2.8
Update to geoclue-2.5.6
Update to libnotify-0.7.9
Update to libsoup-2.68.4
Update to libgusb-0.3.4

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@22778 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 6.4 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libsoup-download-http
8 "&gnome-download-http;/libsoup/2.68/libsoup-&libsoup-version;.tar.xz">
9 <!ENTITY libsoup-download-ftp
10 "&gnome-download-ftp;/libsoup/2.68/libsoup-&libsoup-version;.tar.xz">
11 <!ENTITY libsoup-md5sum "603f3a945cd6ecc1fda644d7853b3b81">
12 <!ENTITY libsoup-size "1.4 MB">
13 <!ENTITY libsoup-buildsize "25 MB (with tests)">
14 <!ENTITY libsoup-time "0.3 SBU (Using parallelism=4; with tests)">
15]>
16
17<sect1 id="libsoup" xreflabel="libsoup-&libsoup-version;">
18 <?dbhtml filename="libsoup.html"?>
19
20 <sect1info>
21 <othername>$LastChangedBy$</othername>
22 <date>$Date$</date>
23 </sect1info>
24
25 <title>libsoup-&libsoup-version;</title>
26
27 <indexterm zone="libsoup">
28 <primary sortas="a-libsoup">libsoup</primary>
29 </indexterm>
30
31 <sect2 role="package">
32 <title>Introduction to libsoup</title>
33
34 <para>
35 The <application>libsoup</application> is a HTTP client/server library for
36 <application>GNOME</application>. It uses GObject and the GLib main loop
37 to integrate with <application>GNOME</application> applications and
38 it also has an asynchronous API for use in threaded applications.
39 </para>
40
41 &lfs91_checked;
42
43 <bridgehead renderas="sect3">Package Information</bridgehead>
44 <itemizedlist spacing="compact">
45 <listitem>
46 <para>
47 Download (HTTP): <ulink url="&libsoup-download-http;"/>
48 </para>
49 </listitem>
50 <listitem>
51 <para>
52 Download (FTP): <ulink url="&libsoup-download-ftp;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download MD5 sum: &libsoup-md5sum;
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download size: &libsoup-size;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Estimated disk space required: &libsoup-buildsize;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated build time: &libsoup-time;
73 </para>
74 </listitem>
75 </itemizedlist>
76
77 <bridgehead renderas="sect3">libsoup Dependencies</bridgehead>
78
79 <bridgehead renderas="sect4">Required</bridgehead>
80 <para role="required">
81 <xref linkend="glib-networking"/>,
82 <xref linkend="libpsl"/>,
83 <xref linkend="libxml2"/> and
84 <xref linkend="sqlite"/>
85 </para>
86
87 <bridgehead renderas="sect4">Recommended</bridgehead>
88 <para role="recommended">
89 <xref linkend="gobject-introspection"/> and
90 <xref linkend="vala"/>
91 </para>
92
93 <bridgehead renderas="sect4">Optional</bridgehead>
94 <para role="optional">
95 <xref linkend="apache"/> (required to run the test suite),
96 <xref linkend="brotli"/>,
97 <xref linkend="curl"/> (required to run the test suite),
98 <xref linkend="mitkrb"/> (required to run the test suite),
99 <xref linkend="gtk-doc"/>,
100 <xref linkend="php"/> compiled with XMLRPC-EPI <!-- It seems that XMLRPC is part of PHP 5.4.10 -->
101 support (only used for the XMLRPC regression tests) and
102 <xref linkend="samba"/> (ntlm_auth is required to run the test suite).
103 </para>
104
105 <para condition="html" role="usernotes">
106 User Notes: <ulink url="&blfs-wiki;/libsoup"/>
107 </para>
108 </sect2>
109
110 <sect2 role="installation">
111 <title>Installation of libsoup</title>
112
113 <para>
114 Install <application>libsoup</application> by running the following
115 commands:
116 </para>
117
118<screen><userinput>mkdir build &amp;&amp;
119cd build &amp;&amp;
120
121meson --prefix=/usr -Dvapi=enabled -Dgssapi=disabled .. &amp;&amp;
122ninja</userinput></screen>
123
124 <para>
125 To test the results, issue: <command>ninja test</command>.
126 Two hsts tests are known to fail.
127 </para>
128
129 <para>
130 Now, as the <systemitem class="username">root</systemitem> user:
131 </para>
132
133<screen role="root"><userinput>ninja install</userinput></screen>
134
135 </sect2>
136
137 <sect2 role="commands">
138 <title>Command Explanations</title>
139
140 <para>
141 <option>-Dvapi=disabled</option>: use this if you have not installed
142 <application>Vala</application>, e.g. because you are not building
143 <application>GNOME</application>.
144 </para>
145
146 <para>
147 <option>-Ddoc=enabled</option>: Use this option if you want to build
148 the documentation. Note that you must have <xref linkend="gtk-doc"/> installed.
149 </para>
150
151 <para>
152 <parameter>-Dgssapi=disabled</parameter>: libsoup defaults to building with GSSAPI support,
153 which requires Kerberos (as does the test suite). If you are building GNOME or
154 have kerberos installed, remove this switch.
155 </para>
156
157 </sect2>
158
159 <sect2 role="content">
160 <title>Contents</title>
161
162 <segmentedlist>
163 <segtitle>Installed Programs</segtitle>
164 <segtitle>Installed Libraries</segtitle>
165 <segtitle>Installed Directories</segtitle>
166
167 <seglistitem>
168 <seg>
169 None
170 </seg>
171 <seg>
172 libsoup-2.4.so and libsoup-gnome-2.4.so
173 </seg>
174 <seg>
175 /usr/include/libsoup-2.4,
176 /usr/include/libsoup-gnome-2.4 and
177 /usr/share/gtk-doc/html/libsoup-2.4 <!-- only installed if -Ddoc=true is
178 passed. -->
179 </seg>
180 </seglistitem>
181 </segmentedlist>
182
183 <variablelist>
184 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
185 <?dbfo list-presentation="list"?>
186 <?dbhtml list-presentation="table"?>
187
188 <varlistentry id="libsoup-2">
189 <term><filename class="libraryfile">libsoup-2.4.so</filename></term>
190 <listitem>
191 <para>
192 provides functions for asynchronous HTTP connections.
193 </para>
194 <indexterm zone="libsoup libsoup-2">
195 <primary sortas="c-libsoup-2">libsoup-2.4.so</primary>
196 </indexterm>
197 </listitem>
198 </varlistentry>
199
200 <varlistentry id="libsoup-gnome-2">
201 <term><filename class="libraryfile">libsoup-gnome-2.4.so</filename></term>
202 <listitem>
203 <para>
204 provides <application>GNOME</application> specific features.
205 </para>
206 <indexterm zone="libsoup libsoup-gnome-2">
207 <primary sortas="c-libsoup-gnome-2">libsoup-gnome-2.4.so</primary>
208 </indexterm>
209 </listitem>
210 </varlistentry>
211
212 </variablelist>
213
214 </sect2>
215
216</sect1>
Note: See TracBrowser for help on using the repository browser.