source: postlfs/security/gpgme.xml@ 22c07de

lazarus qt5new trunk upgradedb
Last change on this file since 22c07de was 22c07de, checked in by Douglas R. Reno <renodr@…>, 3 months ago

Fix building GPGME with Python 3.10 installed

  • Property mode set to 100644
File size: 8.5 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY gpgme-download-http "&gnupg-http;/gpgme/gpgme-&gpgme-version;.tar.bz2">
8 <!ENTITY gpgme-download-ftp "&gnupg-ftp;/gpgme/gpgme-&gpgme-version;.tar.bz2">
9 <!ENTITY gpgme-download-ftp " ">
10 <!ENTITY gpgme-md5sum "e31b9e0efc5a2e1ec1bbed22e7a082a4">
11 <!ENTITY gpgme-size "1.6 MB">
12 <!ENTITY gpgme-buildsize "222 MB">
13 <!ENTITY gpgme-time "0.8 SBU (with parallelism=4; with all bindings, add 0.7 SBU for tests)">
14]>
15
16<sect1 id="gpgme" xreflabel="GPGME-&gpgme-version;">
17 <?dbhtml filename="gpgme.html"?>
18
19 <sect1info>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>GPGME-&gpgme-version;</title>
24
25 <indexterm zone="gpgme">
26 <primary sortas="a-GPGME">GPGME</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to GPGME</title>
31
32 <para>
33 The <application>GPGME</application> package is a C library
34 that allows cryptography support to be added to a
35 program. It is designed to make access to public key crypto
36 engines like <application>GnuPG</application> or GpgSM easier
37 for applications. <application>GPGME</application> provides
38 a high-level crypto API for encryption, decryption, signing,
39 signature verification and key management.
40 </para>
41
42 &lfs110a_checked;
43
44 <bridgehead renderas="sect3">Package Information</bridgehead>
45 <itemizedlist spacing="compact">
46 <listitem>
47 <para>
48 Download (HTTP): <ulink url="&gpgme-download-http;"/>
49 </para>
50 </listitem>
51 <listitem>
52 <para>
53 Download (FTP): <ulink url="&gpgme-download-ftp;"/>
54 </para>
55 </listitem>
56 <listitem>
57 <para>
58 Download MD5 sum: &gpgme-md5sum;
59 </para>
60 </listitem>
61 <listitem>
62 <para>
63 Download size: &gpgme-size;
64 </para>
65 </listitem>
66 <listitem>
67 <para>
68 Estimated disk space required: &gpgme-buildsize;
69 </para>
70 </listitem>
71 <listitem>
72 <para>
73 Estimated build time: &gpgme-time;
74 </para>
75 </listitem>
76 </itemizedlist>
77
78 <bridgehead renderas="sect3">GPGME Dependencies</bridgehead>
79
80 <bridgehead renderas="sect4">Required</bridgehead>
81 <para role="required">
82 <xref linkend="libassuan"/>
83 </para>
84
85 <bridgehead renderas="sect4">Optional</bridgehead>
86 <para role="optional">
87 <xref linkend="doxygen"/> and
88 <xref linkend="graphviz"/> (for API documentation),
89 <xref linkend="gnupg2"/> (required if Qt or SWIG are installed;
90 used during the testsuite),
91 <xref linkend="clisp"/>,<!--
92gpgme can still use python 2.7, but can use python3 as well,
93so do not advertise python2
94 <xref linkend="python2"/>,-->
95 <xref linkend="qt5"/>, and/or
96 <xref linkend="swig"/> (for language bindings)
97 </para>
98
99 <para condition="html" role="usernotes">User Notes:
100 <ulink url="&blfs-wiki;/gpgme"/>
101 </para>
102 </sect2>
103
104 <sect2 role="installation">
105 <title>Installation of GPGME</title>
106
107 <para>
108 First, fix an issue building the package with Glibc-2.34 or later:
109 </para>
110
111<screen><userinput remap="pre">sed 's/defined(__sun.*$/1/' -i src/posix-io.c</userinput></screen>
112
113 <para>
114 Next, fix an issue building with Python 3.10 installed:
115 </para>
116
117<screen><userinput remap="pre">sed -e 's/3\.9/3\.10/' \
118 -e '23664,+3 s/^/#/' \
119 -i configure</userinput></screen>
120
121 <para>
122 Install <application>GPGME</application> by running the following
123 commands:
124 </para>
125
126<screen><userinput>./configure --prefix=/usr --disable-gpg-test &amp;&amp;
127make</userinput></screen>
128
129 <para>
130 To test the results, you should have <xref linkend="gnupg2"/> installed
131 and remove the <command>--disable-gpg-test</command> above. Issue:
132 <command>make -k check</command>.
133 </para>
134
135 <para>
136 Now, as the <systemitem class="username">root</systemitem> user:
137 </para>
138
139<screen role="root"><userinput>make install</userinput></screen>
140
141 </sect2>
142
143 <sect2 role="commands">
144 <title>Command Explanations</title>
145
146 <para>
147 <parameter>--disable-gpg-test</parameter>: if this parameter is not
148 passed to configure, the test programs are built during
149 <command>make</command> stage, which requires <xref linkend="gnupg2"/>.
150 This parameter is not needed if <xref linkend="gnupg2"/> is installed.
151 </para>
152
153 </sect2>
154
155 <sect2 role="content">
156 <title>Contents</title>
157
158 <segmentedlist>
159 <segtitle>Installed Program</segtitle>
160 <segtitle>Installed Libraries</segtitle>
161 <segtitle>Installed Directory</segtitle>
162
163 <seglistitem>
164 <seg>
165 gpgme-config, gpgme-json, and gpgme-tool
166 </seg>
167 <seg>
168 libgpgme, libgpgmepp.so, and libqgpgme.so
169 </seg>
170 <seg>
171 /usr/include/{gpgme++,qgpgme,QGpgME},
172 /usr/lib/cmake/{Gpgmepp,QGpgme}.
173 /usr/lib/python{2.7,3.9}/site-packages/gpg, and
174 /usr/share/common-lisp/source/gpgme
175 </seg>
176 </seglistitem>
177 </segmentedlist>
178
179 <variablelist>
180 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
181 <?dbfo list-presentation="list"?>
182 <?dbhtml list-presentation="table"?>
183
184 <varlistentry id="gpgme-config">
185 <term><command>gpgme-config</command></term>
186 <listitem>
187 <para>
188 is used to obtain <application>GPGME</application> compilation and
189 linking information
190 </para>
191 <indexterm zone="gpgme gpgme-config">
192 <primary sortas="b-gpgme-config">gpgme-config</primary>
193 </indexterm>
194 </listitem>
195 </varlistentry>
196
197 <varlistentry id="gpgme-json">
198 <term><command>gpgme-json</command></term>
199 <listitem>
200 <para>
201 outputs <application>GPGME</application> commands in JSON format
202 </para>
203 <indexterm zone="gpgme gpgme-json">
204 <primary sortas="b-gpgme-json">gpgme-json</primary>
205 </indexterm>
206 </listitem>
207 </varlistentry>
208
209 <varlistentry id="gpgme-tool">
210 <term><command>gpgme-tool</command></term>
211 <listitem>
212 <para>
213 is an assuan server exposing <application>GPGME</application>
214 operations, such as printing fingerprints and keyids with
215 keyservers
216 </para>
217 <indexterm zone="gpgme gpgme-tool">
218 <primary sortas="b-gpgme-tool">gpgme-tool</primary>
219 </indexterm>
220 </listitem>
221 </varlistentry>
222
223 <!-- As of 1.13.1, this library isn't present anymore.
224 <varlistentry id="libgpgme-pthread">
225 <term><filename class="libraryfile">libgpgme-pthread.so</filename></term>
226 <listitem>
227 <para>
228 contains the <application>GPGME</application> API functions for
229 applications using pthread.
230 </para>
231 <indexterm zone="gpgme libgpgme-pthread">
232 <primary sortas="c-libgpgme-pthread">libgpgme-pthread.so</primary>
233 </indexterm>
234 </listitem>
235 </varlistentry>
236 -->
237
238 <varlistentry id="libgpgme">
239 <term><filename class="libraryfile">libgpgme.so</filename></term>
240 <listitem>
241 <para>
242 contains the <application>GPGME</application> API functions
243 </para>
244 <indexterm zone="gpgme libgpgme">
245 <primary sortas="c-libgpgme">libgpgme.so</primary>
246 </indexterm>
247 </listitem>
248 </varlistentry>
249
250 <varlistentry id="libgpgmepp">
251 <term><filename class="libraryfile">libgpgmepp.so</filename></term>
252 <listitem>
253 <para>
254 contains the C++ <application>GPGME</application> API functions
255 </para>
256 <indexterm zone="gpgme libgpgmepp">
257 <primary sortas="c-libgpgmepp">libgpgmepp.so</primary>
258 </indexterm>
259 </listitem>
260 </varlistentry>
261
262 <varlistentry id="libqgpgme">
263 <term><filename class="libraryfile">libqgpgme.so</filename></term>
264 <listitem>
265 <para>
266 contains API functions for handling GPG operations in
267 <application>Qt</application> applications
268 </para>
269 <indexterm zone="gpgme libqgpgme">
270 <primary sortas="c-libqgpgme">libqgpgme.so</primary>
271 </indexterm>
272 </listitem>
273 </varlistentry>
274
275 </variablelist>
276
277 </sect2>
278
279</sect1>
Note: See TracBrowser for help on using the repository browser.