source: pst/typesetting/biber.xml@ 21007b1b

10.0 10.1 11.0 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind ken/refactor-virt lazarus perl-modules qt5new trunk upgradedb xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 21007b1b was 21007b1b, checked in by Ken Moffat <ken@…>, 5 years ago

Biber - use versioned tarball from github, change name to biber from biblatex-biber.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@18262 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 9.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY biber-download-http "https://github.com/plk/biber/archive/v&biber-version;.tar.gz">
8 <!ENTITY biber-download-ftp " ">
9 <!ENTITY biber-md5sum "md5sum 0bb4b95df612b477c5f63250f33355da">
10 <!ENTITY biber-size "1.3 MB">
11 <!-- buildsize includes the installed biblatex -->
12 <!ENTITY biber-buildsize "35 MB">
13 <!ENTITY biber-time "0.3 SBU including tests">
14
15 <!ENTITY biblatex-download-http "http://sourceforge.net/projects/biblatex/files/biblatex-&biblatex-version;/biblatex-&biblatex-version;.tds.tgz">
16 <!ENTITY biblatex-download-ftp "">
17 <!ENTITY biblatex-md5sum "dac897831d75e3f932de7d570a499583">
18 <!ENTITY biblatex-size "19 MB">
19
20]>
21
22<sect1 id="biber" xreflabel="biber-&biber-version;">
23 <?dbhtml filename="biber.html"?>
24
25 <sect1info>
26 <othername>$LastChangedBy$</othername>
27 <date>$Date$</date>
28 </sect1info>
29
30 <title>biber-&biber-version;</title>
31
32 <indexterm zone="biber">
33 <primary sortas="a-biber">Biber</primary>
34 </indexterm>
35
36 <sect2 role="package">
37 <title>Introduction to biber</title>
38
39 <para>Biber is a BibTeX replacement for users of biblatex, written in
40 <application>Perl</application>, with full Unicode support.</para>
41
42 &lfs7a_checked;
43
44 <bridgehead renderas="sect3">Package Information</bridgehead>
45 <itemizedlist spacing="compact">
46 <listitem>
47 <para>Download (HTTP): <ulink url="&biber-download-http;"/></para>
48 </listitem>
49 <listitem>
50 <para>Download (FTP): <ulink url="&biber-download-ftp;"/></para>
51 </listitem>
52 <listitem>
53 <para>Download MD5 sum: &biber-md5sum;</para>
54 </listitem>
55 <listitem>
56 <para>Download size: &biber-size;</para>
57 </listitem>
58 <listitem>
59 <para>Estimated disk space required: &biber-buildsize;</para>
60 </listitem>
61 <listitem>
62 <para>Estimated build time: &biber-time;</para>
63 </listitem>
64 </itemizedlist>
65
66 <bridgehead renderas="sect3">Required Additional Download</bridgehead>
67
68
69 <itemizedlist spacing="compact">
70 <listitem>
71 <para>The corresponding version of <application>biblatex</application> is
72 a separate project - the tds tarball is pre-packaged for untarring into
73 the <filename class="directory">texmf-dist</filename> directory.
74 Download (HTTP): <ulink url="&biblatex-download-http;"/></para>
75 </listitem>
76 <listitem>
77 <para>Download MD5 sum: &biblatex-md5sum;</para>
78 </listitem>
79 <listitem>
80 <para>Download size: &biblatex-size;</para>
81 </listitem>
82 </itemizedlist>
83
84 <bridgehead renderas="sect3">Biber Dependencies</bridgehead>
85
86 <bridgehead renderas="sect4">Required</bridgehead>
87 <para role="required">
88 <!-- KFM: because I always get confused by these deps, I've decided
89 to add some comments.
90 Both Config::AutoConf and ExtUtils::LibBuilder are listed as build
91 requirements in Build.PL, the rest are just requirements, but the
92 difference seems moot. Those two are needed to build Text::BibTeX
93 so not listed separately. -->
94 <xref linkend="perl-autovivification"/>
95 <xref linkend="perl-business-isbn"/>
96 <xref linkend="perl-business-ismn"/>
97 <xref linkend="perl-business-issn"/>
98 <xref linkend="perl-class-accessor"/>
99 <xref linkend="perl-data-compare"/>
100 <xref linkend="perl-data-dump"/>
101 <xref linkend="perl-data-uniqid"/>
102 <xref linkend="perl-datetime-calendar-julian"/>
103 <xref linkend="perl-datetime-format-builder"/>
104 <xref linkend="perl-encode-eucjpascii"/>
105 <xref linkend="perl-encode-hanextra"/>
106 <xref linkend="perl-encode-jis2k"/>
107 <xref linkend="perl-file-slurp"/>
108 <!-- IPC::Cmd is a part of core perl -->
109 <xref linkend="perl-ipc-run3"/>
110 <xref linkend="perl-lingua-translit"/>
111 <xref linkend="perl-list-allutils"/>
112 <!-- List::MoreUtils was pulled in for the testsuite of List::AllUtils,
113 but it needs to be present even if people do not run the tests -->
114 <xref linkend="perl-list-moreutils"/>
115 <!-- List::MoreUtils::XS is listed as a dep, but it is part of
116 List::MoreUtils -->
117 <xref linkend="perl-log-log4perl"/>
118 <!-- I initially misread LWP-Protocol-https as part of libwww-perl
119 when I was preparing this list. In fact, it depends on that -->
120 <xref linkend="perl-lwp-protocol-https"/>
121 <!-- LWP::Simple is part of libwww-perl,
122 that is pulled in by LWP::Protocol::https -->
123 <!-- Module::Build is pulled in by perl-text-bibtex, but mention it explicitly
124 so that the note on automatically installing missing dependencies can be run -->
125 <xref linkend="perl-module-build"/>
126 <!-- Mozilla::CA is a dependency of LWP-Protocol-https -->
127 <xref linkend="perl-regexp-common"/>
128 <xref linkend="perl-sort-key"/>
129 <xref linkend="perl-text-bibtex"/>
130 <xref linkend="perl-text-csv"/>
131 <!-- Text-CSV_XS is a recommended dependency for Text-CSV -->
132 <xref linkend="perl-text-roman"/>
133 <!-- Unicode::GCstring is part of Unicode::LineBreak -->
134 <xref linkend="perl-unicode-linebreak"/>
135 <xref linkend="perl-xml-libxml-simple"/>
136 <xref linkend="perl-xml-libxslt"/>
137 <xref linkend="perl-xml-writer"/> and
138 <!-- untarring biblatex requires that the texmf directories already exist -->
139 <xref linkend="texlive"/>
140 (or <xref linkend="tl-installer"/>)
141 </para>
142
143 <note> <!-- FIXME remove this after our 8.0 release, so that it is noted
144 in at least one release of the book -->
145 <para>This version of <application>biber</application> requires at least
146 <application>perl-5.24.0</application>. If you are using an older version
147 of <command>perl</command> you may prefer to install v2.5 - for that see
148 the BLFS-7.10 book (that source is now in
149 <filename class="directory">files/biblatex-biber/2.5/</filename> instead of
150 <filename class="directory">files/biblatex-biber/current/</filename>).</para>
151 </note>
152
153 <bridgehead renderas="sect4">Optional</bridgehead>
154 <para role="optional">
155 <xref linkend="perl-file-which"/> and
156 <xref linkend="perl-test-differences"/> to run the testsuite
157 </para>
158
159 <note>
160 <para>
161 It is possible to install all missing dependencies automatically.
162 But from <application>perl-5.22.0</application> onwards,
163 <xref linkend="perl-module-build"/> is no longer part of the core perl
164 distribution. And for <xref linkend="perl-data-uniqid"/> we have to
165 patch it to skip over a test which always fails - that failing test may
166 break the automatic install. To automatically install the remaining perl
167 dependencies you can install those two modules first using <xref
168 linkend="perl-auto-install"/>. then run <command>perl ./Build.PL</command>
169 and when it prompts you, become the root user and run
170 <command>./Build installdeps</command>
171 </para>
172 </note>
173
174 <para condition="html" role="usernotes">User Notes:
175 <ulink url='&blfs-wiki;/biber'/></para>
176
177 </sect2>
178
179 <sect2 role="installation">
180 <title>Installation of Biber</title>
181
182 <para>Install <application>Biber</application> by running the following
183 commands:</para>
184
185<screen><userinput>perl ./Build.PL &amp;&amp;
186./Build</userinput></screen>
187
188 <para>To test the results, enter: <command>./Build test</command></para>
189
190 <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
191
192<screen role="root"><userinput>tar -xf ../biblatex-&biblatex-version;.tds.tgz -C /opt/texlive/&texlive-year;/texmf-dist &amp;&amp;
193texhash &amp;&amp;
194./Build install</userinput></screen>
195
196 </sect2>
197
198 <sect2 role="commands">
199 <title>Command Explanations</title>
200
201 <para>
202 <command>tar -xf biblatex-&biblatex-version;.tds.tar.gz -C
203 /opt/texlive/&texlive-year;/texmf-dist</command>:
204 this installs the new <application>biblatex</application> files over those
205 installed by <application>texlive</application>.
206 </para>
207
208 <para>
209 <command>texhash</command> : this updates the file hash tables (otherwise
210 known as the file name database).
211 </para>
212
213 </sect2>
214
215 <sect2 role="content">
216 <title>Contents</title>
217
218 <segmentedlist>
219 <segtitle>Installed Programs</segtitle>
220 <segtitle>Installed Library</segtitle>
221 <segtitle>Installed Directory</segtitle>
222
223 <seglistitem>
224 <seg>biber</seg>
225 <seg>None</seg>
226 <seg>/usr/lib/perl5/site_perl/5.*{,/&lt;arch&gt;-linux/auto}/Biber</seg>
227 </seglistitem>
228 </segmentedlist>
229
230 <variablelist>
231 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
232 <?dbfo list-presentation="list"?>
233 <?dbhtml list-presentation="table"?>
234
235 <varlistentry id="biber-prog">
236 <term><command>biber</command></term>
237 <listitem>
238 <para>is used for producing bibliographies in LaTeX documents.</para>
239 <indexterm zone="biber biber-prog">
240 <primary sortas="b-biber">biber</primary>
241 </indexterm>
242 </listitem>
243 </varlistentry>
244
245 </variablelist>
246
247 </sect2>
248
249</sect1>
Note: See TracBrowser for help on using the repository browser.