source: template/template-perl-module.xml@ 4392a40

10.0 10.1 11.0 8.4 9.0 9.1 bdubbs/svn elogind qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 4392a40 was 4392a40, checked in by Ken Moffat <ken@…>, 3 years ago

Change all new-perl- items to perl- now that the corresponding items in the old perl-modules.xml are no-longer present.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@20713 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 5.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../../general.ent">
5 %general-entities;
6
7 <!-- for modules referenced outside of perl, put them in general/prog/perl-modules/
8 and use a link to &perl_authors;/id/X/XY/XYZZY/Fu-Bar-$Fu-Bar-version; -->
9 <!ENTITY my-download-http "&perl_authors;/id/X/XY/XYZZY/Fu-Bar-&Fu-Bar-version;.tar.gz">
10 <!-- but for modules which are only dependencies of other modules, put them in
11 general/pprog/perl-deps with a link to &metacpan_authors; that includes the /id part -->
12 <!ENTITY my-download-http "&metacpan_authors;/X/XY/XYZZY/Fu-Bar-&Fu-Bar-version;.tar.gz">
13 <!-- only one of the above choices -->
14 <!ENTITY my-md5sum "fix-me-please-editor-0cc7774186c">
15
16]>
17
18 <!-- Begin Fu::Bar -->
19 <sect2 id="perl-fu-bar" xreflabel="Fu-Bar-&Fu-Bar-version;">
20
21 <title>Fu::Bar-&Fu-Bar-version;</title>
22
23 <indexterm zone="perl-fu-bar">
24 <primary sortas="a-Fu-Bar">Fu::Bar</primary>
25 </indexterm>
26
27 <sect3 role="package">
28 <title>Introduction to Fu::Bar</title>
29
30 <para>
31 Fu::Bar does something.
32 </para>
33
34 <bridgehead renderas="sect4">Additional Download</bridgehead>
35 <itemizedlist spacing="compact">
36 <listitem>
37 <para>
38 Required patch:
39 <ulink url="&patch-root;/Fu-Bar-&Fu-Bar-version;-do_something-1.patch"/>
40 </para>
41 </listitem>
42 </itemizedlist>
43
44<!-- &lfs8x_checked; -->
45
46 <bridgehead renderas="sect4">Package Information</bridgehead>
47 <itemizedlist spacing="compact">
48 <listitem>
49 <para>
50 Download (HTTP): <ulink url="&my-download-http;"/>
51 </para>
52 </listitem>
53 <listitem>
54 <para>
55 Download MD5 sum: &my-md5sum;
56 </para>
57 </listitem>
58 </itemizedlist>
59
60 <!-- omit dependencies if not needed.
61 If module A currently brings in the required dep of B, add a comment that
62 B is pulled in by A. This is to keep it maintainable as deps change. -->
63 <bridgehead renderas="sect4">Fu::Bar Dependencies</bridgehead>
64
65 <bridgehead renderas="sect5">Required</bridgehead>
66 <para role="required">
67 <xref linkend="perl-bar-baz"/>,
68 <!-- perl-bar-baz pulls in perl-mojotasticity -->
69 <xref linkend="perl-wibble"/> and
70 <xref linkend="perl-wobble"/>
71
72 <bridgehead renderas="sect5">Recommended (required for the testsuite)</bridgehead>
73 <para role="recommended">
74 <xref linkend="perl-silly"/>,
75 <!-- perl-silly pulls in perl-bar-eejit for its own testsuite -->
76 <xref linkend="perl-teststuff"/>
77
78 </para>
79
80 </sect3>
81
82 <sect3 role="installation">
83 <title>Installation of Fu::Bar</title>
84
85 <para>
86 First, apply a patch to do something ...
87 </para>
88
89<!-- Any specific action for the module (patches, etc) should come first -->
90<screen><userinput>patch -Np1 -i ../Fu-Bar-https-&Fu-Bar-version;-do_something-1.patch</userinput></screen>
91
92<!-- If the module uses standard installation instructions: -->
93 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
94 href="../../../xincludes/perl-standard-install.xml"/>
95
96<!-- If the module uses installation instructions using Build.PL: -->
97 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
98 href="../../../xincludes/perl-build-install.xml"/>
99
100<!-- Exceptionally, if a scripted build requires a value to be passed to 'yes',
101 copy the xinclude inline and add the command explanation -->
102 </sect3>
103
104 <!-- only include a command explanation if yes or similar is needed in
105 scripting -->
106 <sect3 role="commands">
107 <title>Command Explanations</title>
108
109 <para>
110 <command>yes 'n'</command>: Perl will ask if you wish to do ...
111 and will wait for a response. Using 'yes' allows you to script this.
112 </para>
113
114 </sect3>
115
116 <!-- omit content unless prog(s) or lib is installed in /usr -->
117 <sect3 role="content">
118 <title>Contents</title>
119
120 <segmentedlist>
121 <segtitle>Installed Programs</segtitle>
122 <!-- omit libraries entirely unless present in /usr, there are often
123 perl libraries in site-perl so 'none' can be misleading -->
124 <segtitle>Installed Libraries</segtitle>
125
126 <seglistitem>
127 <seg>
128 dibbler
129 </seg>
130 </seglistitem>
131 </segmentedlist>
132
133 <variablelist>
134 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
135 <?dbfo list-presentation="list"?>
136 <?dbhtml list-presentation="table"?>
137
138 <varlistentry id="dibbler-prog">
139 <term><command>dibbler</command></term>
140 <listitem>
141 <para>sells sausage inna bun.</para>
142 <!-- the -prog is for while (old) and new- perl module pages
143 are both in the book, without it the link to the package is
144 correct, but the link to the prog goes to the progs in old
145 perl-modules.xml -->
146 <indexterm zone="perl-fu-bar dibbler-prog">
147 <primary sortas="b-dibbler">dibbler</primary>
148 </indexterm>
149 </listitem>
150 </varlistentry>
151
152 </variablelist>
153
154 </sect3>
155
156 </sect2>
Note: See TracBrowser for help on using the repository browser.