source: x/lib/webkitgtk.xml@ e51a42b6

10.0 10.1 11.0 7.10 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since e51a42b6 was e51a42b6, checked in by Fernando de Oliveira <fernando@…>, 8 years ago

Include some dependencies in CMake-2.8.12.2, WebKitGTK+-1.10.2 and WebKitGTK+-2.2.4.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@12810 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 7.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY webkitgtk-download-http "http://webkitgtk.org/releases/webkitgtk-&webkitgtk-version;.tar.xz">
8 <!ENTITY webkitgtk-download-ftp " ">
9 <!ENTITY webkitgtk-md5sum "7b1a652af1eb11bee5bf7209e9ff67e6">
10 <!ENTITY webkitgtk-size "8.3 MB">
11 <!ENTITY webkitgtk-buildsize "650 MB">
12 <!ENTITY webkitgtk-time "55 SBU">
13]>
14
15<sect1 id="webkitgtk" xreflabel="WebKitGTK+-&webkitgtk-version;">
16 <?dbhtml filename="webkitgtk.html"?>
17
18 <sect1info>
19 <othername>$LastChangedBy$</othername>
20 <date>$Date$</date>
21 </sect1info>
22
23 <title>WebKitGTK+-&webkitgtk-version;</title>
24
25 <indexterm zone="webkitgtk">
26 <primary sortas="a-WebKitGTK+">WebKitGTK+</primary>
27 </indexterm>
28
29 <sect2 role="package">
30 <title>Introduction to WebKitGTK+</title>
31
32 <para>
33 The <application>WebKitGTK+</application> is the port of the portable
34 web rendering engine <application>WebKit</application> to the
35 <application>GTK+ 2</application> platform.
36 </para>
37
38 &lfs75_checked;
39
40 <bridgehead renderas="sect3">Package Information</bridgehead>
41 <itemizedlist spacing="compact">
42 <listitem>
43 <para>
44 Download (HTTP): <ulink url="&webkitgtk-download-http;"/>
45 </para>
46 </listitem>
47 <listitem>
48 <para>
49 Download (FTP): <ulink url="&webkitgtk-download-ftp;"/>
50 </para>
51 </listitem>
52 <listitem>
53 <para>
54 Download MD5 sum: &webkitgtk-md5sum;
55 </para>
56 </listitem>
57 <listitem>
58 <para>
59 Download size: &webkitgtk-size;
60 </para>
61 </listitem>
62 <listitem>
63 <para>
64 Estimated disk space required: &webkitgtk-buildsize;
65 </para>
66 </listitem>
67 <listitem>
68 <para>
69 Estimated build time: &webkitgtk-time;
70 </para>
71 </listitem>
72 </itemizedlist>
73
74 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
75 <itemizedlist spacing="compact">
76 <listitem>
77 <para>
78 Required patch:
79 <ulink url="&patch-root;/webkitgtk-&webkitgtk-version;-fix_librt_linking-1.patch"/>
80 </para>
81 </listitem>
82 </itemizedlist>
83
84 <bridgehead renderas="sect3">WebKitGTK+ Dependencies</bridgehead>
85
86 <bridgehead renderas="sect4">Required</bridgehead>
87 <para role="required">
88 <xref linkend="gperf"/>,
89 <xref linkend="gst-plugins-base"/>,
90 <xref linkend="gtk2"/>,
91 <xref linkend="icu"/>,
92 <xref linkend="libsoup"/>,
93 <xref linkend="mesalib"/>,
94 <xref linkend="ruby"/>,
95 <xref linkend="sqlite"/> and
96 <xref linkend="which"/>
97 </para>
98
99 <bridgehead renderas="sect4">Recommended</bridgehead>
100 <para role="recommended">
101 <xref linkend="enchant"/>,
102 <xref linkend="geoclue"/> and
103 <xref linkend="hicolor-icon-theme"/>
104 </para>
105
106 <bridgehead renderas="sect4">Optional</bridgehead>
107 <para role="optional">
108 <xref linkend="curl"/>,
109 <xref linkend="gobject-introspection"/>,
110 <xref linkend="gtk-doc"/> and
111 <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>
112 </para>
113
114 <para condition="html" role="usernotes">
115 User Notes: <ulink url="&blfs-wiki;/webkitgtk"/>
116 </para>
117 </sect2>
118
119 <sect2 role="installation">
120 <title>Installation of WebKitGTK+</title>
121
122 <para>
123 If you have not installed <xref linkend="gtk-doc"/>, fix a bug that will
124 cause <command>make install</command> to fail:
125 </para>
126
127<screen><userinput>sed -i '/generate-gtkdoc --rebase/s:^:# :' GNUmakefile.in</userinput></screen>
128
129 <para>
130 Install <application>WebKitGTK+</application> by running the
131 following commands:
132 </para>
133
134<screen><userinput>sed -i '/parse-param/ a%lex-param {YYLEX_PARAM}' \
135 Source/ThirdParty/ANGLE/src/compiler/glslang.y</userinput> &amp;&amp;
136<userinput>patch -Np1 -i ../webkitgtk-&webkitgtk-version;-fix_librt_linking-1.patch &amp;&amp;
137./configure --prefix=/usr --with-gtk=2.0 --disable-webkit2 &amp;&amp;
138make</userinput></screen>
139
140 <para>
141 This package does not have a working testsuite. However, there is a
142 useable basic graphical web browser in the source directory,
143 <application>Programs/GtkLauncher</application>. If it fails, there is a
144 problem with the build.
145 </para>
146
147 <para>
148 Now, as the <systemitem class="username">root</systemitem> user:
149 </para>
150
151<screen role="root"><userinput>make install</userinput></screen>
152 </sect2>
153
154 <sect2 role="commands">
155 <title>Command Explanations</title>
156
157 <para>
158 <command>sed ... Source/ThirdParty/ANGLE/src/compiler/glslang.y</command>:
159 This command corrects a problem caused by the most recent version of
160 Bison.
161 </para>
162
163 <para>
164 <parameter>--with-gtk=2.0 --disable-webkit2</parameter>: These parameters
165 force <application>WebKitGTK+</application> to compile against
166 <application>GTK+ 2</application>, even if
167 <application>GTK+ 3</application> is also installed.
168 </para>
169
170 <para>
171 <option>--disable-geolocation</option>: Use this option if you did not
172 install <xref linkend="geoclue"/> or <command>configure</command> will
173 fail.
174 </para>
175
176 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
177 href="../../xincludes/gtk-doc-rebuild.xml"/>
178
179 </sect2>
180
181 <sect2 role="content">
182 <title>Contents</title>
183
184 <segmentedlist>
185 <segtitle>Installed Program</segtitle>
186 <segtitle>Installed Libraries</segtitle>
187 <segtitle>Installed Directories</segtitle>
188
189 <seglistitem>
190 <seg>
191 jsc-1
192 </seg>
193 <seg>
194 libjavascriptcoregtk-1.0.so and libwebkit-1.0.so
195 </seg>
196 <seg>
197 /usr/include/webkit-1.0 and
198 /usr/share/webkit-1.0
199 </seg>
200 </seglistitem>
201 </segmentedlist>
202
203 <variablelist>
204 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
205 <?dbfo list-presentation="list"?>
206 <?dbhtml list-presentation="table"?>
207
208 <varlistentry id="jsc-1">
209 <term><command>jsc-1</command></term>
210 <listitem>
211 <para>
212 is a command-line utility that allows you to run JavaScript programs
213 outside of the context of a web browser.
214 </para>
215 <indexterm zone="webkitgtk jsc-1">
216 <primary sortas="b-jsc-1">jsc-1</primary>
217 </indexterm>
218 </listitem>
219 </varlistentry>
220
221 <varlistentry id="libjavascriptcoregtk-1">
222 <term><filename
223 class="libraryfile">libjavascriptcoregtk-1.0.so</filename></term>
224 <listitem>
225 <para>
226 contains core JavaScript API functions used by <command>jsc-1</command>
227 and <filename class="libraryfile">libwebkitgtk-1.0.so</filename>.
228 </para>
229 <indexterm zone="webkitgtk libjavascriptcoregtk-1">
230 <primary sortas="c-libjavascriptcoregtk-1">libjavascriptcoregtk-1.0.so</primary>
231 </indexterm>
232 </listitem>
233 </varlistentry>
234
235 <varlistentry id="libwebkitgtk-1">
236 <term><filename class="libraryfile">libwebkitgtk-1.0.so</filename></term>
237 <listitem>
238 <para>
239 contains the <application>WebKitGTK+</application> API functions for
240 <application>GTK+ 2</application>.
241 </para>
242 <indexterm zone="webkitgtk libwebkitgtk-1">
243 <primary sortas="c-libwebkitgtk-1">libwebkitgtk-1.0.so</primary>
244 </indexterm>
245 </listitem>
246 </varlistentry>
247
248 </variablelist>
249
250 </sect2>
251
252</sect1>
Note: See TracBrowser for help on using the repository browser.