source: x/wm/xfce/xfce-inst.xml@ 7ce6b7c

10.0 10.1 11.0 11.1 6.0 6.1 6.2 6.2.0 6.2.0-rc1 6.2.0-rc2 6.3 6.3-rc1 6.3-rc2 6.3-rc3 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk upgradedb v5_0 v5_0-pre1 v5_1 v5_1-pre1 xry111/intltool xry111/test-20220226
Last change on this file since 7ce6b7c was 7ce6b7c, checked in by Larry Lawrence <larry@…>, 19 years ago

update to xfce-4.0

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@1226 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 2.2 KB
Line 
1<sect2>
2<title>Installation of <application>XFce</application></title>
3
4<para><application>XFce</application> now distributes as a tarball of
5base packages and module packages. These instructions will only cover
6the bare minimum to run the application. The remaining modules would
7all follow the same pattern which will soon become obvious.</para>
8<para>Install <application>XFce</application> by running the following commands:</para>
9
10<screen><userinput><command>cd src &amp;&amp;
11tar -xzvf libxfce4util-&xfce-version; &amp;&amp;
12cd libxfce4util-&xfce-version; &amp;&amp;
13./configure --prefix=/usr &amp;&amp;
14make &amp;&amp;
15make install &amp;&amp;
16cd .. &amp;&amp;
17tar -xzvf libxfcegui4-&xfce-version; &amp;&amp;
18cd libxfcegui4-&xfce-version; &amp;&amp;
19./configure --prefix=/usr &amp;&amp;
20make &amp;&amp;
21make install &amp;&amp;
22cd .. &amp;&amp;
23tar -xzvf libxfce4mcs-&xfce-version; &amp;&amp;
24cd libxfce4mcs-&xfce-version; &amp;&amp;
25./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
26make &amp;&amp;
27make install &amp;&amp;
28cd .. &amp;&amp;
29tar -xzvf xfce-mcs-manager-&xfce-version; &amp;&amp;
30cd xfce-mcs-manager-&xfce-version; &amp;&amp;
31./configure --prefix=/usr &amp;&amp;
32make &amp;&amp;
33make install &amp;&amp;
34cd .. &amp;&amp;
35tar -xzvf xfwm4-&xfce-version; &amp;&amp;
36cd xfwm4r-&xfce-version; &amp;&amp;
37./configure --prefix=/usr &amp;&amp;
38make &amp;&amp;
39make install &amp;&amp;
40cd .. &amp;&amp;
41tar -xzvf xfdesktop-&xfce-version; &amp;&amp;
42cd xfdesktop-&xfce-version; &amp;&amp;
43./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
44make &amp;&amp;
45make install &amp;&amp;
46cd .. &amp;&amp;
47tar -xzvf xfce4-panel-&xfce-version; &amp;&amp;
48cd xfce4-panel-&xfce-version; &amp;&amp;
49./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
50make &amp;&amp;
51make install &amp;&amp;
52cd .. &amp;&amp;
53tar -xzvf xfce-utils-&xfce-version; &amp;&amp;
54cd xfce-utils-&xfce-version; &amp;&amp;
55./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
56make &amp;&amp;
57make install</command></userinput></screen>
58
59<para>Modules not installed above are: dbh-1.0.15 (required for xffm),
60gtk-xfce-engine-2.1.6, xfce-mcs-plugins, xfce4-iconbox, xfce4-mixer,
61xfce4-systray, sxfce4-themes, xfce4-toys, xfce4-trigger-launcher, xffm,
62xffm-icons, xfprint, and xfwm4-themes.</para>
63
64</sect2>
Note: See TracBrowser for help on using the repository browser.