source: xincludes/perl-unsafe-install.xml@ 45ab6c7

11.0 qt5new trunk
Last change on this file since 45ab6c7 was 45ab6c7, checked in by Xi Ruoyao <xry111@…>, 5 months ago

more SVN prop clean up

Remove "$LastChanged$" everywhere, and also some unused $Date$

  • Property mode set to 100644
File size: 927 bytes
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE para PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" >
4
5
6 <!-- typically, these modules fail to reference inc::Module::Install
7 when perl Makefile.PL is run, AND they are OLD, so any update is
8 likely to change them to using the standard install -->
9 <para>
10 This module uses the 'unsafe' build and installation instructions
11 (In <application>perl-5.26.0</application> the use of the current
12 directory in <literal>@INC</literal> was removed for security
13 reasons and this module has not been updated) :
14
15<screen><userinput>PERL_USE_UNSAFE_INC=1 perl Makefile.PL &amp;&amp;
16make &amp;&amp;
17make test</userinput></screen>
18
19 Now, as the <systemitem class="username">root</systemitem> user:
20
21<screen role="root"><userinput>make install</userinput></screen>
22
23 </para>
Note: See TracBrowser for help on using the repository browser.