source: xsoft/graphweb/mozilla/mozilla-inst.xml@ 583cf2e

10.0 10.1 11.0 6.0 6.1 6.2 6.2.0 6.2.0-rc1 6.2.0-rc2 6.3 6.3-rc1 6.3-rc2 6.3-rc3 7.10 7.4 7.5 7.6 7.6-blfs 7.6-systemd 7.7 7.8 7.9 8.0 8.1 8.2 8.3 8.4 9.0 9.1 basic bdubbs/svn elogind gnome kde5-13430 kde5-14269 kde5-14686 ken/refactor-virt krejzi/svn lazarus nosym perl-modules qt5new systemd-11177 systemd-13485 trunk upgradedb v5_0 v5_1 v5_1-pre1 xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 583cf2e was 583cf2e, checked in by Tushar Teredesai <tushar@…>, 18 years ago

Fixed mozilla

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@1364 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 5.7 KB
Line 
1<sect2>
2<title>Installation of <application>Mozilla</application></title>
3
4<para>Install <application>Mozilla</application> by running the following
5commands:</para>
6
7<screen><userinput><command>export MOZILLA_OFFICIAL="1" &amp;&amp;
8export BUILD_OFFICIAL="1" &amp;&amp;
9<!--
10export MOZ_INTERNAL_LIBART_LGPL="1" &amp;&amp;
11cd extensions &amp;&amp;
12rm -rf spellcheck &amp;&amp;
13tar -xjf ../../mozilla-&mozilla-version;-spellchecker.tar.bz2 &amp;&amp;
14cd .. &amp;&amp;
15-->
16for p in ../mozilla-&mozilla-version;-*.patch
17do patch -Np1 -i $p
18done</command></userinput></screen>
19
20<para>According to the financial institutions, the following hack makes your
21browser insecure. You have been warned. Many sites use an MS-IE specific tag
22(autocomplete=off) to prevent autocomplete from working in some forms. This
23tag is now supported in <application>Mozilla</application> to appease the financial institutions. As per
24the requirements of the financial institutions, they will not even accept a
25solution where this a preference option. However our opinion is that it should
26be in the hands of the user. To enable autocomplete to bypass
27this restriction, we need to make a slight modification in the code.</para>
28
29<para>Open the file <filename>extensions/wallet/src/wallet.cpp</filename> in
30the <application>Mozilla</application> source tree and search for the line:
31<screen>#define WALLET_DONT_CACHE_ALL_PASSWORDS</screen>
32Then delete or comment out the line. Now, if anyone tells you MS-IE is user
33friendly, give them this example!</para>
34
35<screen><userinput><command>./configure --prefix=/usr \
36 --enable-default-mozilla-five-home \
37 --enable-toolkit-gtk2 --enable-default-toolkit=gtk2 \
38 --with-x --with-system-zlib \
39 --with-system-jpeg --with-system-png --with-system-mng \
40 --enable-xft --enable-crypto \
41 --enable-java-supplement \
42 --disable-accessibility \
43 --disable-tests --disable-debug \
44 --disable-logging --enable-reorder \
45 --enable-strip --disable-pedantic \
46 --enable-cpp-rtti --enable-extensions=all &amp;&amp;
47make &amp;&amp;
48make install &amp;&amp;
49install -d /usr/include/mozilla-&mozilla-version;/nss &amp;&amp;
50cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
51 /usr/include/mozilla-&mozilla-version;/nss &amp;&amp;
52<!--
53install -d /usr/lib/mozilla-&mozilla-version;/openoffice &amp;&amp;
54cp -f dist/lib/libembed_base_s.a dist/lib/liblber50.a \
55 dist/lib/libmozreg_s.a /usr/lib/mozilla-&mozilla-version;/openoffice &amp;&amp;
56-->
57ln -nsf mozilla-&mozilla-version; /usr/include/mozilla &amp;&amp;
58ln -nsf mozilla-&mozilla-version; /usr/lib/mozilla &amp;&amp;
59cd /usr/lib/mozilla-&mozilla-version; &amp;&amp;
60export LD_LIBRARY_PATH="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
61export MOZILLA_FIVE_HOME="/usr/lib/mozilla-&mozilla-version;" &amp;&amp;
62./regxpcom &amp;&amp;
63./regchrome &amp;&amp;
64touch `find /usr/lib/mozilla-&mozilla-version; -name *.rdf`</command></userinput></screen>
65
66</sect2>
67
68<sect2>
69<title>Optional Extra Switches</title>
70
71<para>Each of these switches can be added to the configure line in order to
72have the described effect on the <application>Mozilla</application> compile.</para>
73
74<para><option>--enable-elf-dynstr-gc</option>: Removes un-referenced
75strings from <acronym>ELF</acronym> shared objects generated during the build.
76Note that this option breaks build on alpha.</para>
77
78<para><option>--disable-mailnews</option>: Disable the mail and news
79clients.</para>
80
81<para><option>--disable-ldap</option>: Disable <acronym>LDAP</acronym>
82Support, recommended if mail is disabled.</para>
83
84<para><option>--enable-calendar</option>: Build the calendar client.
85You will need to download the calendar source via
86<application><acronym>CVS</acronym></application> since it is not included
87with the release source.
88(Warning, this option is not yet stable).</para>
89
90<para><option>--enable-xterm-updates</option>: This option is
91for enabling the <command>xterm</command> title with the current command when
92compiling.</para>
93
94<para><option>--enable-plaintext-editor-only</option>: Disable support
95for <acronym>HTML</acronym> editing. Do not use this switch if you are building
96the mail-news component.</para>
97
98</sect2>
99
100<sect2>
101<title>Additional build notes for <application>Mozilla Firebird</application> &firebird-version;</title>
102
103<para>Add the following env variable (The variable is named Phoenix since
104that was the original name for the <application>Mozilla
105Firebird</application> project):</para>
106
107<screen><userinput><command>export MOZILLA_PHOENIX="1"</command></userinput></screen>
108
109<para>Make sure that the following switches are passed to
110<command>./configure</command>: <option>--disable-calendar</option> and
111<option>--disable-mailnews</option>.</para>
112
113<para>We recommend installing in a separate prefix
114such as <parameter>--prefix=/opt/firebird-&firebird-version;</parameter>
115to prevent clashes with
116an installed <application>Mozilla</application>.</para>
117
118<para>The <application>Mozilla Firebird</application> executable is
119<command>MozillaFirebird</command>.</para>
120
121</sect2>
122
123<sect2>
124<title>Additional build notes for <application>Mozilla Thunderbird</application> &thunderbird-version;</title>
125
126<para>Add the following env variable:</para>
127
128<screen><userinput><command>export MOZ_THUNDERBIRD="1"</command></userinput></screen>
129
130<para>Make sure that the following switches is passed to
131<command>./configure</command>: <option>--disable-calendar</option>.</para>
132
133<para>We recommend installing in a separate prefix
134such as
135<parameter>--prefix=/opt/thunderbird-&thunderbird-version;</parameter>
136to prevent clashes with
137an installed <application>Mozilla</application>.</para>
138
139<para>The <application>Mozilla Thunderbird</application> executable is
140<command>thunderbird</command>.</para>
141
142</sect2>
Note: See TracBrowser for help on using the repository browser.