source: xsoft/office/abiword.xml@ e713e66c

11.0 ken/refactor-virt lazarus qt5new trunk upgradedb
Last change on this file since e713e66c was e713e66c, checked in by Douglas R. Reno <renodr@…>, 5 months ago

Package updates and some tweaks.

Update to abiword-3.0.5
Make AsciiDoctor internal in Wireshark
Patch polkit-gnome to use the proper icon system again.
Patch cups-pk-helper to work with future versions of CUPS and GLib.

  • Property mode set to 100644
File size: 11.8 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY AbiWord-minor-version "3.0">
8 <!ENTITY AbiWord-docs-version "3.0.2">
9
10 <!ENTITY AbiWord-download-http
11 "https://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-&AbiWord-version;.tar.gz">
12 <!ENTITY AbiWord-download-ftp " ">
13 <!ENTITY AbiWord-md5sum "a8f218b711450e4ccae43a0522e0e806">
14 <!ENTITY AbiWord-size "11 MB">
15
16 <!ENTITY AbiWordDocs-download-http
17 "https://www.abisource.com/downloads/abiword/&AbiWord-docs-version;/source/abiword-docs-&AbiWord-docs-version;.tar.gz">
18 <!ENTITY AbiWordDocs-md5sum "c92c0e1e2081db20757231a53d80c338">
19 <!ENTITY AbiWordDocs-size "1.5 MB">
20
21 <!ENTITY AbiWord-buildsize "690 MB, with docs (76 MB installed)">
22 <!ENTITY AbiWord-time "2.4 SBU (Using parallelism=4, with docs)">
23]>
24
25<sect1 id="abiword" xreflabel="AbiWord-&AbiWord-version;">
26 <?dbhtml filename="AbiWord.html" ?>
27
28 <sect1info>
29 <date>$Date$</date>
30 </sect1info>
31
32 <title>AbiWord-&AbiWord-version;</title>
33
34 <indexterm zone="abiword">
35 <primary sortas="a-AbiWord">AbiWord</primary>
36 </indexterm>
37
38 <sect2 role="package">
39 <title>Introduction to AbiWord</title>
40
41 <para>
42 <application>AbiWord</application> is a word processor which is useful for
43 writing reports, letters and other formatted documents.
44 </para>
45
46 &lfs101_checked;
47
48 <bridgehead renderas="sect3">Package Information</bridgehead>
49 <itemizedlist spacing="compact">
50 <listitem>
51 <para>
52 Download (HTTP): <ulink url="&AbiWord-download-http;"/>
53 </para>
54 </listitem>
55 <listitem>
56 <para>
57 Download (FTP): <ulink url="&AbiWord-download-ftp;"/>
58 </para>
59 </listitem>
60 <listitem>
61 <para>
62 Download MD5 sum: &AbiWord-md5sum;
63 </para>
64 </listitem>
65 <listitem>
66 <para>
67 Download size: &AbiWord-size;
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Estimated disk space required: &AbiWord-buildsize;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Estimated build time: &AbiWord-time;
78 </para>
79 </listitem>
80 </itemizedlist>
81
82 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
83 <itemizedlist spacing="compact">
84 <listitem>
85 <para>
86 AbiWord Docs: <ulink url="&AbiWordDocs-download-http;"/>
87 </para>
88 </listitem>
89 <listitem>
90 <para>
91 AbiWord Docs MD5 sum: &AbiWordDocs-md5sum;
92 </para>
93 </listitem>
94 <listitem>
95 <para>
96 AbiWord Docs size: &AbiWordDocs-size;
97 </para>
98 </listitem>
99<!--
100 <listitem>
101 <para>
102 Required patch:
103 <ulink url="&patch-root;/abiword-&AbiWord-version;-gcc11_fixes-1.patch"/>
104 </para>
105 </listitem>
106-->
107 </itemizedlist>
108
109
110 <bridgehead renderas="sect3">AbiWord Dependencies</bridgehead>
111
112 <bridgehead renderas="sect4">Required</bridgehead>
113 <para role="required">
114 <xref linkend="boost"/>,
115 <xref linkend="curl"/>,
116 <xref linkend="fribidi"/>,
117 <xref linkend="goffice010"/>, and
118 <xref linkend="wv"/>
119 </para>
120
121 <bridgehead renderas="sect4">Recommended</bridgehead>
122 <para role="recommended">
123 <xref linkend="enchant"/>
124 </para>
125
126 <bridgehead renderas="sect4">Optional</bridgehead>
127 <para role="optional">
128 <xref linkend="dbus-glib"/>,
129 <xref linkend="evolution-data-server"/>,
130 <xref linkend="gobject-introspection"/>,
131 <xref linkend="libchamplain"/>,
132 <xref linkend="libgcrypt"/>,
133 <xref linkend="libical"/>,
134 <xref linkend="libsoup"/>,
135 <xref linkend="redland"/>,
136 <xref linkend="telepathy-glib"/>,
137 <xref linkend="valgrind"/>.
138 <ulink url="http://aiksaurus.sourceforge.net/">Aiksaurus</ulink>,
139 <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink>,
140 <ulink url="https://sourceforge.net/projects/wvware">libwmf</ulink>,
141 <ulink url="https://sourceforge.net/projects/libwpd/">libwpd</ulink>,
142 <ulink url="https://sourceforge.net/projects/libwpg/">libwpg</ulink>,
143 <ulink url="https://sourceforge.net/projects/libwps/">libwps</ulink>,
144 <ulink url="http://www.abisource.com/projects/link-grammar/">
145 Link Grammar Parser</ulink>,
146 <ulink url="&gnome-download-http;/loudmouth">Loudmouth</ulink>,
147 <ulink url="https://sourceforge.net/projects/otslibrary/">OTS</ulink>, and
148 <ulink url="http://software.frodo.looijaard.name/psiconv/">Psiconv</ulink>
149 </para>
150
151 <note>
152 <para>
153 To enable many of the optional dependencies, review the information
154 from <command>./configure --help</command> for the necessary switches
155 you must pass to the <command>configure</command> script.
156 </para>
157 </note>
158
159
160 <para condition="html" role="usernotes">
161 User Notes: <ulink url="&blfs-wiki;/abiword"/>
162 </para>
163 </sect2>
164
165 <sect2 role="installation">
166 <title>Installation of AbiWord</title>
167
168<!--
169 <para>
170 First, fix a build failure when using GCC-11:
171 </para>
172
173<screen><userinput remap="pre">patch -Np1 -i ../abiword-&AbiWord-version;-gcc11_fixes-1.patch</userinput></screen>
174-->
175
176 <para>
177 Install <application>AbiWord</application> by running the following
178 commands:
179 </para>
180
181<screen><userinput>sed -e "s/free_suggestions/free_string_list/" \
182 -e "s/_to_personal//" \
183 -e "s/in_session/added/" \
184 -i src/af/xap/xp/enchant_checker.cpp &amp;&amp;
185
186./configure --prefix=/usr &amp;&amp;
187make</userinput></screen>
188
189 <para>
190 This program does not come with a functional test suite.
191 </para>
192
193 <para>
194 Now, as the <systemitem class="username">root</systemitem> user:
195 </para>
196
197<screen role="root"><userinput>make install</userinput></screen>
198
199 <note>
200 <para>
201 In order to install the local help files,
202 a graphics session is recommended.
203 </para>
204 </note>
205
206 <para>
207 If you wish to install the local help files, untar and build them first:
208 </para>
209
210 <note>
211 <para>
212 The current version of the docs expands to abiword-docs-3.0.1
213 and not the expected abiword-docs-3.0.2.
214 </para>
215 </note>
216
217<!-- I had to hardcode the docs version here, as it doesn't decompress to
218 abiword-docs-3.0.2. -->
219<screen><userinput>tar -xf ../abiword-docs-&AbiWord-docs-version;.tar.gz &amp;&amp;
220cd abiword-docs-3.0.1 &amp;&amp;
221./configure --prefix=/usr &amp;&amp;
222make</userinput></screen>
223
224 <para>
225 and then, as the <systemitem class="username">root</systemitem> user:
226 </para>
227
228<screen role="root"><userinput>make install</userinput></screen>
229
230 </sect2>
231
232 <sect2 role="commands">
233 <title>Command Explanations</title>
234
235 <para>
236 <command>sed ...</command>: This command corrects the source for
237 changes in the dependency <xref linkend="enchant"/>.
238 </para>
239<!--
240 <para>
241 <parameter>- -without-evolution-data-server</parameter>: This switch
242 disables <application>AbiWord</application>
243 <application>Evolution Data Server</application> support which is known
244 to fail when using recent versions of
245 <application>Evolution Data Server</application>.
246 </para>
247-->
248 <para>
249 <option>--enable-plugins="collab openxml goffice grammar"</option>: Build
250 some or all plugins. The openxml plugin enables
251 <application>Abiword</application> to open some .docx files.
252 The grammar plugin requires
253 <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar
254 Parser</ulink>
255 </para>
256
257 </sect2>
258
259 <sect2 role="configuration">
260 <title>Configuring AbiWord</title>
261
262 <sect3 id="abiword-config">
263 <title>Config File</title>
264
265 <para>
266 <filename>~/.AbiSuite/templates/normal.awt</filename>
267 </para>
268
269 <indexterm zone="abiword abiword-config">
270 <primary sortas="e-AA.AbiSuite-templates-normal">~/.AbiSuite/templates/normal.awt</primary>
271 </indexterm>
272 </sect3>
273
274 <sect3>
275 <title>Configuration Information</title>
276
277 <para>
278 Choose the right template for your language and locale from the list
279 produced by the following command:
280 </para>
281
282<screen><userinput>ls /usr/share/abiword-&AbiWord-minor-version;/templates</userinput></screen>
283
284 <para>
285 Create the folder
286 <filename class='directory'>~/.AbiSuite/templates</filename> then copy
287 the <filename>normal.awt</filename> you want into it:
288 </para>
289
290<screen><userinput>install -v -m750 -d ~/.AbiSuite/templates &amp;&amp;
291install -v -m640 /usr/share/abiword-&AbiWord-minor-version;/templates/normal.awt-<replaceable>&lt;lang&gt;</replaceable> \
292 ~/.AbiSuite/templates/normal.awt</userinput></screen>
293
294 <para>
295 Change <replaceable>&lt;lang&gt;</replaceable> by the above command to
296 fit the name of the file you want.
297 </para>
298
299 <para>
300 If you are using multiple languages, you may need to edit the template
301 to use a font with greater coverage (e.g. one of the
302 <xref linkend="dejavu-fonts"/>,
303 <!--
304 <ulink url="http://dejavu.sourceforge.net/">DejaVu fonts</ulink>), -->
305 because <application>Abiword</application> does not use
306 <application>fontconfig</application> and can only display glyphs that
307 are provided in the chosen font.
308 </para>
309
310 <para>
311 If you have <xref linkend="desktop-file-utils"/> installed, you should
312 run the <command>update-desktop-database</command> command to update the
313 mimeinfo cache and allow the Help system to work.
314 </para>
315
316 <para>
317 If you have <xref linkend="xdg-utils"/> installed, you should
318 run the <command>xdg-icon-resource forceupdate --theme hicolor</command>
319 command, for the installed icon to be displayed in the menu item.
320 </para>
321
322 </sect3>
323
324 </sect2>
325
326 <sect2 role="content">
327 <title>Contents</title>
328
329 <segmentedlist>
330 <segtitle>Installed Program</segtitle>
331 <segtitle>Installed Library</segtitle>
332 <segtitle>Installed Directories</segtitle>
333
334 <seglistitem>
335 <seg>
336 abiword
337 </seg>
338 <seg>
339 libabiword-&AbiWord-minor-version;.so
340 </seg>
341 <seg>
342 /usr/include/abiword-&AbiWord-minor-version;,
343 /usr/lib/abiword-&AbiWord-minor-version;, and
344 /usr/share/abiword-&AbiWord-minor-version;
345 </seg>
346 </seglistitem>
347 </segmentedlist>
348
349 <variablelist>
350 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
351 <?dbfo list-presentation="list"?>
352 <?dbhtml list-presentation="table"?>
353
354 <varlistentry id="abiword-prog">
355 <term><command>abiword</command></term>
356 <listitem>
357 <para>
358 is the word processor, a wrapper for the functions in
359 libabiword-&AbiWord-minor-version; - it can also be used on the
360 command line, see <command>man 1 abiword</command>
361 </para>
362 <indexterm zone="abiword abiword-prog">
363 <primary sortas="b-abiword">abiword</primary>
364 </indexterm>
365 </listitem>
366 </varlistentry>
367
368 <varlistentry id="libabiword">
369 <term><filename class="libraryfile">libabiword-&AbiWord-minor-version;.so</filename></term>
370 <listitem>
371 <para>
372 provides functions to access MS Word documents
373 </para>
374 <indexterm zone="abiword libabiword">
375 <primary sortas="c-libabiword">libabiword-&AbiWord-minor-version;.so</primary>
376 </indexterm>
377 </listitem>
378 </varlistentry>
379
380 </variablelist>
381
382 </sect2>
383
384</sect1>
Note: See TracBrowser for help on using the repository browser.