source: xsoft/office/libreoffice.xml@ 1d23596

10.0 10.1 11.0 9.0 9.1 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 1d23596 was 1d23596, checked in by Douglas R. Reno <renodr@…>, 2 years ago

Update to Samba-4.10.6
Abiword, Libreoffice, Pidgin - fix optional dependencies now that evolution-data-server, telepathy-glib, zenity, and others are now available to elogind systems
TigerVNC - Remove redundant creation of a desktop file, since the Makefile now installs one

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21886 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 30.9 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libreoffice-dl "http://download.documentfoundation.org/libreoffice/src/&libreoffice-version;">
8
9 <!ENTITY libreoffice-core-download-http "&libreoffice-dl;/libreoffice-&libreoffice-dlversion;.tar.xz">
10 <!ENTITY libreoffice-core-md5sum "8239de1ab99236bd97623f8ceedfe926">
11 <!ENTITY libreoffice-core-size "205 MB">
12
13 <!ENTITY libreoffice-dict-download-http "&libreoffice-dl;/libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz">
14 <!ENTITY libreoffice-dict-md5sum "29b6ed9c014f920f0be311d296e2ac27">
15 <!ENTITY libreoffice-dict-size "43 MB">
16
17 <!ENTITY libreoffice-help-download-http "&libreoffice-dl;/libreoffice-help-&libreoffice-dlversion;.tar.xz">
18 <!ENTITY libreoffice-help-md5sum "2baa1653f425be4d4d7b36541d8e30cd">
19 <!ENTITY libreoffice-help-size "13 MB">
20
21 <!ENTITY libreoffice-translations-download-http "&libreoffice-dl;/libreoffice-translations-&libreoffice-dlversion;.tar.xz">
22 <!ENTITY libreoffice-translations-md5sum "fabd0015403771c06ace8c8ca024b9fd">
23 <!ENTITY libreoffice-translations-size "136 MB">
24
25 <!-- full size still accurate for 6.0.2, reconfiguring and rebuilding
26 the built source after initial DESTDIR install doesn't take a vast time -->
27
28 <!ENTITY libreoffice-buildsize "6.1 GB (749 MB installed). Installing the whole set of languages was previously reported to require up to 26 GB (2.9 GB installed)">
29
30 <!-- for 6.1.2.1 I allowed 2 SBU for downloads, my total was
31 64.76 SBU with fast downloads
32 for 6.1.4.2 I just used the total time - bdubbs
33 -->
34 <!ENTITY libreoffice-time "63 SBU with parallelism=4 including typical download time">
35
36]>
37
38<sect1 id="libreoffice" xreflabel="LibreOffice-&libreoffice-dlversion;">
39 <?dbhtml filename="libreoffice.html"?>
40
41 <sect1info>
42 <othername>$LastChangedBy$</othername>
43 <date>$Date$</date>
44 </sect1info>
45
46 <title>LibreOffice-&libreoffice-version;</title>
47
48 <indexterm zone="libreoffice">
49 <primary sortas="a-LibreOffice">LibreOffice</primary>
50 </indexterm>
51
52 <sect2 role="package">
53 <title>Introduction to LibreOffice</title>
54
55 <para>
56 <application>LibreOffice</application> is a full-featured office suite.
57 It is largely compatible with <application>Microsoft Office</application>
58 and is descended from <application>OpenOffice.org</application>.
59 </para>
60
61 &lfs84_checked;
62
63 <bridgehead renderas="sect3">Package Information</bridgehead>
64 <itemizedlist spacing="compact">
65 <listitem>
66 <para>
67 Core Download: <ulink url="&libreoffice-core-download-http;"/>
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Core Download MD5 sum: &libreoffice-core-md5sum;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Core Download size: &libreoffice-core-size;
78 </para>
79 </listitem>
80 <listitem>
81 <para>
82 Estimated disk space required: &libreoffice-buildsize;
83 </para>
84 </listitem>
85 <listitem>
86 <para>
87 Estimated build time: &libreoffice-time;
88 </para>
89 </listitem>
90 </itemizedlist>
91
92 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
93 <itemizedlist spacing="compact">
94 <listitem>
95 <para>
96 Dictionaries: <ulink url="&libreoffice-dict-download-http;"/>
97 </para>
98 </listitem>
99
100 <listitem>
101 <para>
102 Dictionaries MD5 sum: &libreoffice-dict-md5sum;
103 </para>
104 </listitem>
105
106 <listitem>
107 <para>
108 Dictionaries size: &libreoffice-dict-size;
109 </para>
110 </listitem>
111
112 <listitem>
113 <para>
114 Help Files: <ulink url="&libreoffice-help-download-http;"/>
115 </para>
116 </listitem>
117
118 <listitem>
119 <para>
120 Help Files MD5 sum: &libreoffice-help-md5sum;
121 </para>
122 </listitem>
123
124 <listitem>
125 <para>
126 Help Files size: &libreoffice-help-size;
127 </para>
128 </listitem>
129
130 <listitem>
131 <para>
132 Translations: <ulink url="&libreoffice-translations-download-http;"/>
133 </para>
134 </listitem>
135
136 <listitem>
137 <para>
138 Translations MD5 sum: &libreoffice-translations-md5sum;
139 </para>
140 </listitem>
141
142 <listitem>
143 <para>
144 Translations size: &libreoffice-translations-size;
145 </para>
146 </listitem>
147
148
149<!-- keep one commented patch, it's sure to again need one or more in a few months:
150For libreoffice 6.2.0.4, almost blfs 8.4: no patch needed, only a sed below
151 <listitem>
152 <para>
153 Required patch to fix building with system <xref linkend="poppler"/> (all
154 recent versions) and <xref linkend="boost"/>:
155 <ulink url="&patch-root;/libreoffice-&libreoffice-dlversion;-consolidated_fixes-1.patch"/>
156 </para>
157 </listitem>
158-->
159
160 </itemizedlist>
161 <bridgehead renderas="sect3">LibreOffice Dependencies</bridgehead>
162
163 <bridgehead renderas="sect4">Required</bridgehead>
164 <para role="required">
165 <xref linkend="perl-archive-zip"/>,
166 <xref linkend="unzip"/>,
167 <xref linkend="wget"/>,
168 <xref linkend="which"/>, and
169 <xref linkend="zip"/>
170 </para>
171
172 <bridgehead renderas="sect4">Recommended</bridgehead>
173 <note>
174 <para>
175 Most of these packages are recommended because if they're not installed,
176 the build process will compile and install its own (often older)
177 version, with the side effect of increasing build and installed disk
178 space and build time.
179 </para>
180 </note>
181
182 <para role="recommended">
183 <xref linkend="apache-ant"/>,
184 <xref linkend="apr"/>,
185 <xref linkend="boost"/>,
186 <xref linkend="clucene"/>,
187 <xref linkend="cups"/>,
188 <xref linkend="curl"/>,
189 <xref linkend="dbus-glib"/>,
190 <xref linkend="libjpeg"/>,
191 <xref linkend="glm"/>,
192 <xref linkend="glu"/>,
193 <xref linkend="gpgme"/>,
194 <xref linkend="graphite2"/>,
195 <xref linkend="gst10-plugins-base"/>,
196 <xref linkend="gtk3"/> and
197 <xref linkend="gtk2"/> (see <quote>Command Explanations</quote>),
198 <xref linkend="harfbuzz"/>,
199 <xref linkend="icu"/>,
200 <xref linkend="libatomic_ops"/>,
201 <xref linkend="lcms2"/>,
202 <xref linkend="librsvg"/>,
203 <xref linkend="libxml2"/> and
204 <xref linkend="libxslt"/>,
205 <xref linkend="mesa"/>,
206 <xref linkend="neon"/>,
207 <xref linkend="nss"/>,
208 <xref linkend="openldap"/> (if connecting to an LDAP server),
209 <xref linkend="poppler"/>,
210 <xref linkend="postgresql"/>,
211 <xref linkend="redland"/>,
212 <xref linkend="serf"/>, and
213 <xref linkend="unixodbc"/>
214 </para>
215
216 <bridgehead renderas="sect4">Optional</bridgehead>
217 <para role="optional">
218 <xref linkend="avahi"/>,
219 <xref linkend="bluez"/>,
220 <xref linkend="dconf"/>,
221 <xref linkend="desktop-file-utils"/>,
222 <xref linkend="doxygen"/> (not relevant if using --disable-odk),
223 <xref linkend="evolution-data-server"/>,
224 <xref linkend="gdb"/>,
225 <xref linkend="gnutls"/>,
226<!-- not anymore in the book, but included in apache-ant
227 <xref linkend="junit"/>, -->
228 <xref linkend="kf5-frameworks"/>,
229 <xref linkend="libpaper"/>,
230 <xref linkend="mariadb"/> or <ulink url="http://www.mysql.com/">MySQL</ulink>,
231 <xref linkend="mitkrb"/>,
232 <xref linkend="nasm"/>,
233 <xref linkend="sane"/>,
234 <xref linkend="telepathy-glib"/>,
235 <xref linkend="valgrind"/>,
236 <xref linkend="vlc"/>,
237 <xref linkend="zenity"/>,
238 <ulink url="https://commons.apache.org/proper/commons-codec/">Apache Commons Codec</ulink>,
239 <ulink url="https://hc.apache.org/httpclient-3.x/">Apache Commons HttpClient</ulink>,
240 <ulink url="https://commons.apache.org/proper/commons-lang/">Apache Commons Lang</ulink>,
241 <ulink url="https://commons.apache.org/proper/commons-logging/">Apache Commons Logging</ulink>,
242 <ulink url="http://www.beanshell.org/">BeanShell</ulink>,
243 <ulink url="https://projects.coin-or.org/CoinMP/">CoinMP</ulink>,
244 <ulink url="http://sourceforge.net/projects/cppunit/">Cppunit</ulink>,
245 <ulink url="http://www.firebirdsql.org/">Firebird</ulink>,
246 <ulink url="https://github.com/behdad/glyphy">glyphy</ulink>,
247 <ulink url="http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/">Gnome VFS</ulink>,
248
249 <ulink url="https://github.com/hamcrest/JavaHamcrest/releases">hamcrest</ulink>,
250 <ulink url="https://hunspell.github.io/">Hunspell</ulink>,
251 <ulink url="http://sourceforge.net/projects/hunspell/files/Hyphen/">Hyphen</ulink>,
252 <ulink url="http://include-what-you-use.org/">iwyu</ulink>,
253 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libabw">libabw</ulink>,
254 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr">libcdr</ulink>,
255 <ulink url="http://sourceforge.net/projects/libcmis/">libcmis</ulink>,
256 <ulink url="http://www.sourceforge.net/projects/libebook/">libebook</ulink>,
257 <ulink url="https://wiki.documentfoundation.org/Libexttextcat">libexttextcat</ulink>,
258 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand">libfreehand</ulink>,
259 <ulink url="http://tagoh.bitbucket.org/liblangtag/">liblangtag</ulink>,
260 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub">libmspub</ulink>,
261 <ulink url="http://sourceforge.net/projects/libmwaw/">libmwaw</ulink>,
262 <ulink url="http://sourceforge.net/projects/libwpd/files/libodfgen/">libodfgen</ulink>,
263 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker">libpagemaker</ulink>,
264 <ulink url="http://sourceforge.net/projects/libwpd/files/librevenge/">librevenge (WordPerfect Document importer)</ulink>,
265 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libvisio">libvisio</ulink>,
266 <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
267 <ulink url="http://libwpg.sourceforge.net/">libwpg</ulink>,
268 <ulink url="http://libwps.sourceforge.net/">libwps</ulink>,
269 <ulink url="http://lpsolve.sourceforge.net/">lp_solve</ulink>,
270 <ulink url="https://gitlab.com/mdds/mdds">mdds</ulink>,
271 <ulink url="http://sourceforge.net/projects/hunspell/files/MyThes/">MyThes</ulink>,
272 <ulink url="https://github.com/KhronosGroup/OpenCOLLADA/">OpenCOLLADA</ulink>,
273 <ulink url="https://gitlab.com/orcus/orcus">Orcus</ulink>, and
274 <ulink url="https://ukoethe.github.io/vigra/">VIGRA</ulink>
275 </para>
276
277 <para>There are many optional dependencies not listed here. They can be
278 found in <quote>download.lst</quote> (source directory).
279 </para>
280
281 <para condition="html" role="usernotes">
282 User Notes: <ulink url="&blfs-wiki;/libreoffice"/>
283 </para>
284 </sect2>
285
286 <sect2 role="installation">
287 <title>Installation of LibreOffice</title>
288
289 <important>
290 <para>
291 Unlike the other packages, we assume that you have not yet unpacked the
292 package. This is because the <option>--no-overwrite-dir</option>
293 switch is needed in case you unpack as the <systemitem
294 class="username">root</systemitem> user.
295 </para>
296 </important>
297
298<screen role="nodump"><userinput>tar -xf libreoffice-&libreoffice-dlversion;.tar.xz --no-overwrite-dir &amp;&amp;
299cd libreoffice-&libreoffice-dlversion;</userinput></screen>
300
301<!-- keep a commented instruction if no patches are currently required
302 <para> <!- - for all recent versions - ->
303 Fix build failures introduced by recent versions of <xref linkend="poppler"/>
304 and <xref linkend="boost"/>:
305 </para>
306
307<screen><userinput>patch -Np1 -i ../libreoffice-&libreoffice-dlversion;-consolidated_fixes-1.patch</userinput></screen>
308-->
309
310 <para>
311 Create symlinks to tarballs from the source directory so they won't
312 get downloaded again:
313 </para>
314
315<screen><userinput>install -dm755 external/tarballs &amp;&amp;
316ln -sv ../../../libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz external/tarballs/ &amp;&amp;
317ln -sv ../../../libreoffice-help-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
318
319 <para>
320 If you have downloaded the translations tarball, create a symlink:
321 </para>
322
323<screen><userinput>ln -sv ../../../libreoffice-translations-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
324
325 <note>
326 <para>
327 During the build process, some packages will be downloaded (including
328 the ones listed as recommended and optional dependencies) if they are
329 not present on the system. Because of this, build time may vary from the
330 published time more than usual.
331 </para>
332 </note>
333
334 <para>
335 Due to the large size of the package, you may prefer to install it in
336 <filename class="directory">/opt</filename>, instead of
337 <filename class="directory">/usr</filename>. Depending on your choice,
338 replace <replaceable>&lt;PREFIX&gt;</replaceable> by
339 <filename class="directory">/usr</filename> or by
340 <filename class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>:
341 </para>
342
343<screen><userinput>export LO_PREFIX=<replaceable>&lt;PREFIX&gt;</replaceable></userinput></screen>
344
345 <para>
346 Locales "fr" and "en-GB", you will find below, are just examples; you
347 should change them to suit your needs - you might want to read the
348 "Command Explanations", further below, before proceeding.
349 </para>
350
351 <para>
352 Prepare <application>LibreOffice</application> for compilation by running
353 the following commands:
354 </para>
355
356<screen><userinput>sed -e "/gzip -f/d" \
357 -e "s|.1.gz|.1|g" \
358 -i bin/distro-install-desktop-integration &amp;&amp;
359
360sed -e "/distro-install-file-lists/d" -i Makefile.in &amp;&amp;
361
362<!-- Removed in 6.2 - -with-alloc=system \-->
363./autogen.sh --prefix=$LO_PREFIX \
364 --sysconfdir=/etc \
365 --with-vendor=BLFS \
366 --with-lang='fr en-GB' \
367 --with-help \
368 --with-myspell-dicts \
369 --without-junit \
370 --without-system-dicts \
371 --disable-dconf \
372 --disable-odk \
373 --enable-release-build=yes \
374 --enable-python=system \
375 --with-system-apr \
376 --with-system-boost \
377 --with-system-cairo \
378 --with-system-clucene \
379 --with-system-curl \
380 --with-system-expat \
381 --with-system-glm \
382 --with-system-gpgmepp \
383 --with-system-graphite \
384 --with-system-harfbuzz \
385 --with-system-icu \
386 --with-system-jpeg \
387 --with-system-lcms2 \
388 --with-system-libatomic_ops \
389 --with-system-libpng \
390 --with-system-libxml \
391 --with-system-neon \
392 --with-system-nss \
393 --with-system-odbc \
394 --with-system-openldap \
395 --with-system-openssl \
396 --with-system-poppler \
397 --with-system-postgresql \
398 --with-system-redland \
399 --with-system-serf \
400 --with-system-zlib</userinput></screen>
401
402 <para>
403 The instructions below will only build the package without running
404 any unit tests. If you prefer to run the unit tests, replace
405 <command>make build-nocheck</command> with <command>make build</command>
406 or (as a regular user only) just <command>make</command>, but do not be
407 surprised if a unit test fails right at the end of the build and
408 breaks it.
409 </para>
410
411 <para>
412 Build the package:
413 </para>
414
415<screen><userinput>make build-nocheck</userinput></screen>
416<!--<screen><userinput>CPPFLAGS='-DU_USING_ICU_NAMESPACE=1' make build-nocheck</userinput></screen>-->
417
418 <para>
419 Now, as the <systemitem class="username">root</systemitem> user:
420 </para>
421
422<screen role="root"><userinput>make distro-pack-install</userinput></screen>
423
424 <para>
425 If installed in <filename
426 class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>
427 some additional steps are necessary. Issue the following commands, as
428 <systemitem class="username">root</systemitem> user:
429 </para>
430
431<screen role="root"><userinput>if [ "$LO_PREFIX" != "/usr" ]; then
432
433 # This symlink is necessary for the desktop menu entries
434 ln -svf $LO_PREFIX/lib/libreoffice/program/soffice /usr/bin/libreoffice &amp;&amp;
435
436 # Set up a generic location independent of version number
437 ln -sfv libreoffice-&libreoffice-dlversion; /opt/libreoffice
438
439 # Icons
440 mkdir -vp /usr/share/pixmaps
441 for i in $LO_PREFIX/share/icons/hicolor/32x32/apps/*; do
442 ln -svf $i /usr/share/pixmaps
443 done &amp;&amp;
444
445 # Desktop menu entries
446 for i in $LO_PREFIX/lib/libreoffice/share/xdg/*; do
447 ln -svf $i /usr/share/applications/libreoffice-$(basename $i)
448 done &amp;&amp;
449
450 # Man pages
451 for i in $LO_PREFIX/share/man/man1/*; do
452 ln -svf $i /usr/share/man/man1/
453 done
454
455 unset i
456fi</userinput></screen>
457
458 <para>
459 If you have installed <xref linkend="desktop-file-utils"/>, and you wish
460 to update the MIME database, issue, as the <systemitem class="username">
461 root</systemitem> user:
462 </para>
463
464<screen role="root"><userinput>update-desktop-database</userinput></screen>
465
466 <para>
467 The suite and main modules can be started from the menu. From a terminal,
468 the suite can be started with <command>libreoffice</command> command and
469 the modules with <command>libreoffice
470 --<replaceable>&lt;module&gt;</replaceable></command> command,
471 respectively, where <replaceable>&lt;module&gt;</replaceable> is one of
472 base, calc, draw, impress, math or writer. Modules cannot be started using
473 their shell starting script names (see "Installed Programs", below), if
474 LO_PREFIX is other than <filename class='directory'>/usr</filename>,
475 unless <filename class='directory'>$LO_PREFIX/bin</filename> directory is
476 appended to the PATH.
477 </para>
478
479 </sect2>
480
481 <sect2 role="commands">
482 <title>Command Explanations</title>
483
484 <para>
485 <command>sed -e ...</command>: The first sed prevents compression of the
486 manual pages and the second one prevents the install from failing.
487 </para>
488
489 <para>
490 <parameter>--with-vendor=BLFS</parameter>: This switch sets BLFS as
491 the vendor which is mentioned when you click "About" from the Help menu
492 on the toolbar.
493 </para>
494
495 <para>
496 <parameter>--with-lang='fr en-GB'</parameter>: This switch sets
497 what languages to support. To list several languages, separate them with
498 a space. For all languages, use
499 <parameter>--with-lang=ALL</parameter>.
500 </para>
501
502 <note>
503 <para>
504 For a list of the available languages, look in
505 <filename>solenv/inc/langlist.mk</filename>.
506 </para>
507 </note>
508
509 <para>
510 <parameter>--with-help</parameter>: Without this switch, the help files
511 are not built.
512 </para>
513
514 <para>
515 <parameter>--with-myspell-dicts</parameter>: This switch adds myspell
516 dictionaries to the <application>LibreOffice</application> installation
517 set.
518 </para>
519 <!-- Unrecognized as of 6.2.0.3
520 <para>
521 <parameter>- -with-alloc=system</parameter>: This switch tells
522 <application>LibreOffice</application> to use the system allocator
523 instead of its internal one.
524 </para>
525 -->
526 <para>
527 <parameter>--with-system-boost</parameter>: This switch enables using
528 system boost. From time to time, recent versions of boost break
529 the build of libreoffice. In this case, it is possible to use the
530 bundled copy of boost, by removing this flag.
531 </para>
532
533 <para>
534 <parameter>--disable-dconf</parameter>: This switch disables compiling
535 <application>LibreOffice</application> with the
536 <application>GNOME DConf</application> configuration system support.
537 </para>
538
539 <para>
540 <parameter>--without-junit</parameter>: This switch disables the tests
541 for the deprecated HSQLDB driver which is written in Java. If you wish
542 to build this driver replace this switch with the set of switches
543 described below under '--with-java'.
544 </para>
545
546 <para>
547 <parameter>--without-system-dicts</parameter>: This switch disables use
548 of dictionaries from system paths, so the ones installed by this package
549 are used.
550 </para>
551
552 <para>
553 <parameter>--disable-odk</parameter>: This switch disables installing the
554 office development kit. Remove if you want to develop a
555 <application>LibreOffice</application> based application.
556 </para>
557
558 <para>
559 <parameter>--enable-release-build=yes</parameter>: This switch enables a
560 Release Build. <application>LibreOffice</application> can be built as a
561 Release Build or as a Developer Build, because their default installation
562 paths and user profile paths are different. Developer Build displays the
563 words "Dev" and "Beta" in several places (e.g, menu and splash screen).
564 </para>
565
566 <para>
567 <parameter>--enable-python=system</parameter>: This switch tells
568 <application>LibreOffice</application> to use installed
569 <application>Python 3</application> to build the translations instead of
570 the bundled one.
571 </para>
572
573 <para>
574 <parameter>--with-system-*</parameter>: These switches prevent
575 <application>LibreOffice</application> from trying to compile its own
576 versions of these dependencies. If you've not installed some of the
577 dependencies, remove the corresponding switches.
578 </para>
579
580<!--
581 <para>
582 <command>CPPFLAGS='-DU_USING_ICU_NAMESPACE=1' make ...</command>: <xref
583 linkend="icu"/> has removed an implicit namespace <quote>using</quote>
584 from its headers files. Setting <envar>U_USING_ICU_NAMESPACE</envar> to
585 1 allows to restore the former behavior, which is required for building
586 <application>libreoffice</application>.
587 </para>
588-->
589 <para>
590 <command>make distro-pack-install</command>: this does a normal
591 install, but if you add a DESTDIR environment variable it will also
592 install a lot of (text) gid_Module_* files in the DESTDIR, to help
593 distributions which want to break the package into parts.
594 </para>
595
596 <para>
597 <option>--with-parallelism=&lt;count&gt;</option>: This switch
598 tells <application>LibreOffice</application> to use &lt;count&gt; CPU
599 cores to compile in parallel. (Do not include literal angle brackets.)
600 The default is to use all available cores on the system.
601 </para>
602
603 <para>
604 <option>--disable-cups</option>: Use this switch if you don't need
605 printing support.
606 </para>
607
608 <para>
609 <option>--disable-dbus</option>: Use this switch if you've not installed
610 D-Bus-1.8.0 or later. It also disables Bluetooth support and font install
611 via PackageKit.
612 </para>
613
614 <para>
615 <option>--disable-firebird-sdbc</option>: By default, the ability to
616 connect to a <application>firebird</application> database is enabled.
617 Add this switch if you do not need that feature.
618 </para>
619
620 <para>
621 <option>--disable-gstreamer-1-0</option>: Use this switch if you have not
622 installed <xref linkend="gst10-plugins-base"/>.
623 </para>
624
625 <para>
626 <option>--disable-gtk3</option>: Use this switch if you have not installed
627 <application>GTK+-3</application>, or if you have installed it but wish
628 to use <application>GTK+-2</application> (the menu icons differ).
629 Note that a <application>GTK+-3</application> build still
630 requires <application>GTK+-2</application> to build the gtk-plugin.
631 </para>
632
633 <para>
634 <option>--disable-postgresql-sdbc</option>: This switch disables compiling
635 <application>LibreOffice</application> with the ability to connect to a
636 <application>PostgreSQL</application> database. Use it if you have not
637 installed <application>PostgreSQL</application> and you do not want
638 <application>LibreOffice</application> to compile its bundled copy.
639 </para>
640
641 <para>
642 <option>--enable-lto</option>: This switch will enable Link Time
643 Optimization, which results in slightly smaller libraries (about 40 MB).
644 This is said to make <application>LibreOffice</application> programs
645 load faster (and possibly run faster, e.g. when recalculating a
646 spreadsheet). On an 8-core machine with 16GB of memory, the difference
647 in compile times was minimal, but an extra 2GB was used for the work
648 files. On machines with fewer processors or a lack of memory, the compile
649 might be much slower.
650 </para>
651
652 <para>
653 <option>--without-java</option>: This switch disables
654 <application>Java</application> support in
655 <application>LibreOffice</application>. Java is needed for the
656 deprecated HSQLDB driver, which allows reading databases created by
657 other programs or in earlier versions of libreoffice
658 <application>base</application>.
659 </para>
660
661 <para>
662 <option>--with-junit=/opt/ant/lib/junit-4.12.jar</option> and
663 <option>--with-hamcrest=/opt/ant/lib/hamcrest-core-1.3.jar</option>:
664 Those options are needed if you want to run the tests.
665 </para>
666
667 <para>
668 <option>--without-fonts</option>: <application>LibreOffice</application>
669 includes a number of third-party TrueType fonts. If you have already
670 installed some or all of the same fonts, you may prefer to use the system
671 versions.
672 </para>
673
674 <para>
675 <!-- Brings in - -enable-qt5 as well. -->
676 <option>--enable-kde5</option>: Builds with KDE/Plasma integration. If
677 <xref linkend="qt5"/> and/or <xref linkend="kf5-frameworks"/> are not
678 installed in <filename class="directory">/usr</filename>, the include
679 and library directories must be specified in <envar>QT5INC</envar>,
680 <envar>QT5LIB</envar>, <envar>KF5INC</envar>, and <envar>KF5LIB</envar>,
681 respectively.
682 </para>
683
684 <para revision="systemd">
685 <option>--enable-evolution2</option>: Enables support for Evolution
686 address books through Evolution Data Server. Note that Evolution Data
687 Server must be installed for this feature to function.
688 </para>
689
690 </sect2>
691
692 <sect2 role="content">
693 <title>Contents</title>
694
695 <segmentedlist>
696 <segtitle>Installed Programs</segtitle>
697 <segtitle>Installed Libraries</segtitle>
698 <segtitle>Installed Directory</segtitle>
699
700 <seglistitem>
701 <seg>
702 libreoffice, lobase, localc, lodraw, loffice, lofromtemplate,
703 loimpress, lomath, loweb, lowriter, soffice and unopkg;
704 several programs under
705 $LO_PREFIX/lib/libreoffice/program
706 </seg>
707 <seg>
708 several libraries under
709 $LO_PREFIX/lib/libreoffice/program
710 </seg>
711 <seg>
712 $LO_PREFIX/lib/libreoffice
713 </seg>
714 </seglistitem>
715 </segmentedlist>
716
717 <variablelist>
718 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
719 <?dbfo list-presentation="list"?>
720 <?dbhtml list-presentation="table"?>
721
722 <varlistentry id="libreoffice-suite">
723 <term><command>libreoffice (or soffice)</command></term>
724 <listitem>
725 <para>
726 is the main libreofice suite (symlink to
727 $LO_PREFIX/lib/libreoffice/program/soffice).
728 </para>
729 <indexterm zone="libreoffice libreoffice-suite">
730 <primary sortas="b-libreoffice-suite">libreoffice-suite</primary>
731 </indexterm>
732 </listitem>
733 </varlistentry>
734
735 <varlistentry id="lobase">
736 <term><command>lobase</command></term>
737 <listitem>
738 <para>
739 is the database manager module shell starting script.
740 </para>
741 <indexterm zone="libreoffice lobase">
742 <primary sortas="b-lobase">lobase</primary>
743 </indexterm>
744 </listitem>
745 </varlistentry>
746
747 <varlistentry id="localc">
748 <term><command>localc</command></term>
749 <listitem>
750 <para>
751 is the spreadsheet module shell starting script.
752 </para>
753 <indexterm zone="libreoffice localc">
754 <primary sortas="b-localc">localc</primary>
755 </indexterm>
756 </listitem>
757 </varlistentry>
758
759 <varlistentry id="lodraw">
760 <term><command>lodraw</command></term>
761 <listitem>
762 <para>
763 is the vector graphics editor and diagramming tool module shell
764 starting script.
765 </para>
766 <indexterm zone="libreoffice lodraw">
767 <primary sortas="b-lodraw">lodraw</primary>
768 </indexterm>
769 </listitem>
770 </varlistentry>
771
772 <varlistentry id="loimpress">
773 <term><command>loimpress</command></term>
774 <listitem>
775 <para>
776 is the (PowerPoint) presentations editor and displayer
777 module shell starting script.
778 </para>
779 <indexterm zone="libreoffice loimpress">
780 <primary sortas="b-loimpress">loimpress</primary>
781 </indexterm>
782 </listitem>
783 </varlistentry>
784
785 <varlistentry id="lomath">
786 <term><command>lomath</command></term>
787 <listitem>
788 <para>
789 is the mathematical formula editor module shell starting script.
790 </para>
791 <indexterm zone="libreoffice lomath">
792 <primary sortas="b-lomath">lomath</primary>
793 </indexterm>
794 </listitem>
795 </varlistentry>
796
797 <varlistentry id="loweb">
798 <term><command>loweb</command></term>
799 <listitem>
800 <para>
801 is the HTML editor module shell starting script.
802 </para>
803 <indexterm zone="libreoffice loweb">
804 <primary sortas="b-loweb">loweb</primary>
805 </indexterm>
806 </listitem>
807 </varlistentry>
808
809 <varlistentry id="lowriter">
810 <term><command>lowriter</command></term>
811 <listitem>
812 <para>
813 is the word processor module shell starting script.
814 </para>
815 <indexterm zone="libreoffice lowriter">
816 <primary sortas="b-lowriter">lowriter</primary>
817 </indexterm>
818 </listitem>
819 </varlistentry>
820
821 <varlistentry id="unopkg">
822 <term><command>unopkg</command></term>
823 <listitem>
824 <para>
825 is a tool to manage <application>LibreOffice</application>
826 extensions from the command line.
827 </para>
828 <indexterm zone="libreoffice unopkg">
829 <primary sortas="b-unopkg">unopkg</primary>
830 </indexterm>
831 </listitem>
832 </varlistentry>
833
834 </variablelist>
835
836 </sect2>
837
838</sect1>
Note: See TracBrowser for help on using the repository browser.