source: xsoft/office/libreoffice.xml@ 2e18e741

10.1 11.0 ken/refactor-virt lazarus qt5new trunk xry111/git-date xry111/git-date-for-trunk xry111/git-date-test
Last change on this file since 2e18e741 was 2e18e741, checked in by Bruce Dubbs <bdubbs@…>, 13 months ago

Update to libreoffice-7.0.1.2.
Update to cryptsetup-2.3.4.
Update to postfix-3.5.7.
Update to brotli-1.0.9.
Fix scour URL.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23689 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 33.6 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libreoffice-dl "http://download.documentfoundation.org/libreoffice/src/&libreoffice-version;">
8
9 <!ENTITY libreoffice-core-download-http "&libreoffice-dl;/libreoffice-&libreoffice-dlversion;.tar.xz">
10 <!ENTITY libreoffice-core-md5sum "c44ed1c4be60fc5455256e29503a78e6">
11 <!ENTITY libreoffice-core-size "225 MB">
12
13 <!ENTITY libreoffice-dict-download-http "&libreoffice-dl;/libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz">
14 <!ENTITY libreoffice-dict-md5sum "eb7b5275818d7399c74b5c80af04d315">
15 <!ENTITY libreoffice-dict-size "44 MB">
16
17 <!ENTITY libreoffice-help-download-http "&libreoffice-dl;/libreoffice-help-&libreoffice-dlversion;.tar.xz">
18 <!ENTITY libreoffice-help-md5sum "608916aad698ade4cd884e3288af1544">
19 <!ENTITY libreoffice-help-size "106 MB">
20
21 <!ENTITY libreoffice-translations-download-http "&libreoffice-dl;/libreoffice-translations-&libreoffice-dlversion;.tar.xz">
22 <!ENTITY libreoffice-translations-md5sum "fd1d69b26c568e55d54979a548608902">
23 <!ENTITY libreoffice-translations-size "167 MB">
24
25 <!-- full size remeasured for 7.0.0.3 -->
26
27 <!ENTITY libreoffice-buildsize "6.5 GB including the additional files if downloaded during the build (775 MB installed). Installing the whole set of languages requires more than 25 GB (around 3 GB installed)">
28
29 <!-- Editors: many updates to poppler will break LO using system poppler until
30 somebody is able to provide a patch or sed. In these cases, please mark
31 the dependency as currently broken and move the \-\-with-system-poppler
32 line to a comment. Also please switch poppler between recommended and
33 optional according to whether or not we use the system version. The
34 installed size will be increased by 2 MB if using the shipped poppler, but
35 the variation in build times will be lost in the noise. - ken -->
36
37 <!-- for 6.1.2.1 I allowed 2 SBU for downloads, my total was
38 64.76 SBU with fast downloads
39 for 6.1.4.2 I and 7.0.0.3 just used the total time - bdubbs
40
41 For 6.4.0.3 downloading everything including dictionaries,
42 help, translations took less than 2 minutes (1.1 SBU) with
43 a good domestic internet connection. Total time was 60 SBU - ken
44
45 60 SBU not including download of translations, help and dictionary
46 for 6.4.6.2 - pierre
47 -->
48 <!ENTITY libreoffice-time "45 SBU with parallelism=4 including typical download time">
49
50]>
51
52<sect1 id="libreoffice" xreflabel="LibreOffice-&libreoffice-dlversion;">
53 <?dbhtml filename="libreoffice.html"?>
54
55 <sect1info>
56 <othername>$LastChangedBy$</othername>
57 <date>$Date$</date>
58 </sect1info>
59
60 <title>LibreOffice-&libreoffice-version;</title>
61
62 <indexterm zone="libreoffice">
63 <primary sortas="a-LibreOffice">LibreOffice</primary>
64 </indexterm>
65
66 <sect2 role="package">
67 <title>Introduction to LibreOffice</title>
68
69 <para>
70 <application>LibreOffice</application> is a full-featured office suite.
71 It is largely compatible with <application>Microsoft Office</application>
72 and is descended from <application>OpenOffice.org</application>.
73 </para>
74
75 &lfs10_checked;
76
77 <bridgehead renderas="sect3">Package Information</bridgehead>
78 <itemizedlist spacing="compact">
79 <listitem>
80 <para>
81 Core Download: <ulink url="&libreoffice-core-download-http;"/>
82 </para>
83 </listitem>
84 <listitem>
85 <para>
86 Core Download MD5 sum: &libreoffice-core-md5sum;
87 </para>
88 </listitem>
89 <listitem>
90 <para>
91 Core Download size: &libreoffice-core-size;
92 </para>
93 </listitem>
94 <listitem>
95 <para>
96 Estimated disk space required: &libreoffice-buildsize;
97 </para>
98 </listitem>
99 <listitem>
100 <para>
101 Estimated build time: &libreoffice-time;
102 </para>
103 </listitem>
104 </itemizedlist>
105
106 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
107
108 <note>
109 <para>
110 Around 80 smallish tarballs and zip files will be downloaded during the
111 build. If you have not downloaded one or more of the following, they too
112 will also be downloaded during the build.
113 </para>
114 </note>
115
116 <itemizedlist spacing="compact">
117 <listitem>
118 <para>
119 Dictionaries: <ulink url="&libreoffice-dict-download-http;"/>
120 </para>
121 </listitem>
122
123 <listitem>
124 <para>
125 Dictionaries MD5 sum: &libreoffice-dict-md5sum;
126 </para>
127 </listitem>
128
129 <listitem>
130 <para>
131 Dictionaries size: &libreoffice-dict-size;
132 </para>
133 </listitem>
134
135 <listitem>
136 <para>
137 Help Files: <ulink url="&libreoffice-help-download-http;"/>
138 </para>
139 </listitem>
140
141 <listitem>
142 <para>
143 Help Files MD5 sum: &libreoffice-help-md5sum;
144 </para>
145 </listitem>
146
147 <listitem>
148 <para>
149 Help Files size: &libreoffice-help-size;
150 </para>
151 </listitem>
152
153 <listitem>
154 <para>
155 Translations: <ulink url="&libreoffice-translations-download-http;"/>
156 </para>
157 </listitem>
158
159 <listitem>
160 <para>
161 Translations MD5 sum: &libreoffice-translations-md5sum;
162 </para>
163 </listitem>
164
165 <listitem>
166 <para>
167 Translations size: &libreoffice-translations-size;
168 </para>
169 </listitem>
170
171
172<!-- keep one commented patch, it's sure to again need one or more in a few months:
173-->
174<!--
175 <listitem>
176 <para>
177 Required patch to fix building with GCC 10 and later:
178 <ulink url="&patch-root;/libreoffice-&libreoffice-dlversion;-format_overflow-1.patch"/>
179 </para>
180 </listitem>
181-->
182 </itemizedlist>
183 <bridgehead renderas="sect3">LibreOffice Dependencies</bridgehead>
184
185 <bridgehead renderas="sect4">Required</bridgehead>
186 <para role="required">
187 <xref linkend="perl-archive-zip"/>,
188 <xref linkend="unzip"/>,
189 <xref linkend="wget"/>,
190 <xref linkend="which"/>, and
191 <xref linkend="zip"/>
192 </para>
193
194 <bridgehead renderas="sect4">Recommended</bridgehead>
195 <note>
196 <para>
197 Most of these packages are recommended because if they're not installed,
198 the build process will compile and install its own (often older)
199 version, with the side effect of increasing build and installed disk
200 space and build time.
201 </para>
202 </note>
203
204 <para role="recommended">
205 <xref linkend="apache-ant"/>,
206 <xref linkend="apr"/>,
207 <xref linkend="boost"/>,
208 <xref linkend="clucene"/>,
209 <xref linkend="cups"/>,
210 <xref linkend="curl"/>,
211 <xref linkend="dbus-glib"/>,
212 <xref linkend="libepoxy"/>,
213 <xref linkend="libjpeg"/>,
214 clang from <xref linkend="llvm"/> (preferred for rendering with skia),
215 <xref linkend="glm"/>,
216 <xref linkend="glu"/>,
217 <xref linkend="gpgme"/>,
218 <xref linkend="graphite2"/>,
219 <xref linkend="gst10-plugins-base"/>,
220 <xref linkend="gtk3"/>,
221 <!-- <xref linkend="gtk2"/> -->
222 <xref linkend="harfbuzz"/>,
223 <xref linkend="icu"/>,
224 <xref linkend="libatomic_ops"/>,
225 <xref linkend="lcms2"/>,
226 <xref linkend="librsvg"/>,
227 <xref linkend="libxml2"/> and
228 <xref linkend="libxslt"/>,
229 <xref linkend="lxml"/>,
230 <xref linkend="mesa"/>,
231 <xref linkend="neon"/>,
232 <xref linkend="nss"/>,
233 <xref linkend="openldap"/> (if connecting to an LDAP server),
234 <xref linkend="poppler"/>,
235 <xref linkend="postgresql"/>,
236 <xref linkend="redland"/>,
237 <xref linkend="serf"/>, and
238 <xref linkend="unixodbc"/>
239 </para>
240
241
242 <bridgehead renderas="sect4">Optional</bridgehead>
243 <para role="optional">
244 <xref linkend="avahi"/>,
245 <xref linkend="bluez"/>,
246 <xref linkend="dconf"/>,
247 <xref linkend="desktop-file-utils"/>,
248 <xref linkend="doxygen"/> (not relevant if using --disable-odk),
249 <xref linkend="evolution-data-server"/>,
250 <xref linkend="gdb"/>,
251 <xref linkend="gnutls"/>,
252<!-- not anymore in the book, but included in apache-ant
253 <xref linkend="junit"/>, -->
254 <xref linkend="kf5-frameworks"/>,
255 <xref linkend="libpaper"/>,
256 <xref linkend="mariadb"/> or <ulink url="http://www.mysql.com/">MySQL</ulink>,
257 <xref linkend="mitkrb"/>,
258 <xref linkend="nasm"/>,
259 <xref linkend="sane"/>,
260 <xref linkend="telepathy-glib"/>,
261 <xref linkend="valgrind"/>,
262 <xref linkend="vlc"/>,
263 <xref linkend="zenity"/>,
264 <ulink url="https://commons.apache.org/proper/commons-codec/">Apache Commons Codec</ulink>,
265 <ulink url="https://hc.apache.org/httpcomponents-client-ga/index.html">Apache Commons HttpClient</ulink>,
266 <ulink url="https://commons.apache.org/proper/commons-lang/">Apache Commons Lang</ulink>,
267 <ulink url="https://commons.apache.org/proper/commons-logging/">Apache Commons Logging</ulink>,
268 <ulink url="http://www.beanshell.org/">BeanShell</ulink>,
269 <ulink url="https://projects.coin-or.org/CoinMP/">CoinMP</ulink>,
270 <ulink url="http://sourceforge.net/projects/cppunit/">Cppunit</ulink>,
271 <ulink url="http://www.firebirdsql.org/">Firebird</ulink>,
272 <ulink url="https://github.com/behdad/glyphy">glyphy</ulink>,
273 <ulink url="http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/">Gnome VFS</ulink>,
274
275 <ulink url="https://github.com/hamcrest/JavaHamcrest/releases">hamcrest</ulink>,
276 <ulink url="https://hunspell.github.io/">Hunspell</ulink>,
277 <ulink url="http://sourceforge.net/projects/hunspell/files/Hyphen/">Hyphen</ulink>,
278 <ulink url="http://include-what-you-use.org/">iwyu</ulink>,
279 <ulink url="https://github.com/junit-team/junit4/releases">junit4</ulink>,
280 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libabw">libabw</ulink>,
281 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr">libcdr</ulink>,
282 <ulink url="http://sourceforge.net/projects/libcmis/">libcmis</ulink>,
283 <ulink url="http://www.sourceforge.net/projects/libebook/">libebook</ulink>,
284 <ulink url="https://wiki.documentfoundation.org/Libexttextcat">libexttextcat</ulink>,
285 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand">libfreehand</ulink>,
286 <ulink url="http://tagoh.github.io/liblangtag/">liblangtag</ulink>,
287 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub">libmspub</ulink>,
288 <ulink url="http://sourceforge.net/projects/libmwaw/">libmwaw</ulink>,
289 <ulink url="http://sourceforge.net/projects/libwpd/files/libodfgen/">libodfgen</ulink>,
290 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker">libpagemaker</ulink>,
291 <ulink url="http://sourceforge.net/projects/libwpd/files/librevenge/">librevenge (WordPerfect Document importer)</ulink>,
292 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libvisio">libvisio</ulink>,
293 <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
294 <ulink url="http://libwpg.sourceforge.net/">libwpg</ulink>,
295 <ulink url="http://libwps.sourceforge.net/">libwps</ulink>,
296 <ulink url="http://lpsolve.sourceforge.net/">lp_solve</ulink>,
297 <ulink url="https://gitlab.com/mdds/mdds">mdds</ulink>,
298 <ulink url="http://sourceforge.net/projects/hunspell/files/MyThes/">MyThes</ulink>,
299 <ulink url="https://github.com/KhronosGroup/OpenCOLLADA/">OpenCOLLADA</ulink>,
300 <ulink url="https://gitlab.com/orcus/orcus">Orcus</ulink>,
301 <ulink url="https://sourceware.org/systemtap/">SystemTap</ulink>, and
302 <ulink url="https://ukoethe.github.io/vigra/">VIGRA</ulink>
303 </para>
304
305 <para>
306 There are many optional dependencies not listed here. They can be
307 found in <quote>download.lst</quote> (source directory).
308 </para>
309
310 <para condition="html" role="usernotes">
311 User Notes: <ulink url="&blfs-wiki;/libreoffice"/>
312 </para>
313 </sect2>
314
315 <sect2 role="installation">
316 <title>Installation of LibreOffice</title>
317
318 <important>
319 <para>
320 Unlike the other packages, we assume that you have not yet unpacked the
321 package. This is because the <option>--no-overwrite-dir</option>
322 switch is needed in case you unpack as the <systemitem
323 class="username">root</systemitem> user.
324 </para>
325 </important>
326
327<screen role="nodump"><userinput>tar -xf libreoffice-&libreoffice-dlversion;.tar.xz --no-overwrite-dir &amp;&amp;
328cd libreoffice-&libreoffice-dlversion;</userinput></screen>
329
330<!-- keep a commented instruction if no patches are currently required -->
331<!--
332 <para>
333 Fix build failures introduced by GCC 10 and later:
334 </para>
335
336<screen><userinput>patch -Np1 -i ../libreoffice-&libreoffice-dlversion;-format_overflow-1.patch</userinput></screen>
337-->
338 <para>
339 If you have downloaded the dictionaries, help and translations tarballs,
340 create symlinks to them from the source directory so they won't get
341 downloaded again:
342 </para>
343
344<screen><userinput>install -dm755 external/tarballs &amp;&amp;
345ln -sv ../../../libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz external/tarballs/ &amp;&amp;
346ln -sv ../../../libreoffice-help-&libreoffice-dlversion;.tar.xz external/tarballs/ &amp;&amp;
347ln -sv ../../../libreoffice-translations-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
348
349 <note>
350 <para>
351 During the build process, some packages will be downloaded (including
352 the ones listed as recommended and optional dependencies) if they are
353 not present on the system. Because of this, build time may vary from the
354 published time more than usual.
355 </para>
356 </note>
357
358 <para>
359 Due to the large size of the package, you may prefer to install it in
360 <filename class="directory">/opt</filename>, instead of
361 <filename class="directory">/usr</filename>. Depending on your choice,
362 replace <replaceable>&lt;PREFIX&gt;</replaceable> by
363 <filename class="directory">/usr</filename> or by
364 <filename class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>:
365 </para>
366
367<screen><userinput>export LO_PREFIX=<replaceable>&lt;PREFIX&gt;</replaceable></userinput></screen>
368
369 <para>
370 Locales "fr" and "en-GB", you will find below, are just examples; you
371 should change them to suit your needs - you might want to read the
372 "Command Explanations", further below, before proceeding.
373 </para>
374
375 <para>
376 Prepare <application>LibreOffice</application> for compilation by running
377 the following commands:
378 </para>
379
380<screen><userinput>sed -e "/gzip -f/d" \
381 -e "s|.1.gz|.1|g" \
382 -i bin/distro-install-desktop-integration &amp;&amp;
383
384sed -e "/distro-install-file-lists/d" -i Makefile.in &amp;&amp;
385
386sed -e 's@getURI()->c_str()@getURI().c_str()@' \
387 -i sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx &amp;&amp;
388
389./autogen.sh --prefix=$LO_PREFIX \
390 --sysconfdir=/etc \
391 --with-vendor=BLFS \
392 --with-lang='fr en-GB' \
393 --with-help \
394 --with-myspell-dicts \
395 --without-junit \
396 --without-system-dicts \
397 --disable-dconf \
398 --disable-odk \
399 --enable-release-build=yes \
400 --enable-python=system \
401 --with-jdk-home=/opt/jdk \
402 --with-system-apr \
403 --with-system-boost \
404 --with-system-clucene \
405 --with-system-curl \
406 --with-system-epoxy \
407 --with-system-expat \
408 --with-system-glm \
409 --with-system-gpgmepp \
410 --with-system-graphite \
411 --with-system-harfbuzz \
412 --with-system-icu \
413 --with-system-jpeg \
414 --with-system-lcms2 \
415 --with-system-libatomic_ops \
416 --with-system-libpng \
417 --with-system-libxml \
418 --with-system-neon \
419 --with-system-nss \
420 --with-system-odbc \
421 --with-system-openldap \
422 --with-system-openssl \
423 --with-system-poppler \
424 --with-system-postgresql \
425 --with-system-redland \
426 --with-system-serf \
427 --with-system-zlib</userinput></screen>
428
429 <para>
430 The instructions below will only build the package without running
431 any unit tests. If you prefer to run the unit tests, replace
432 <command>make build-nocheck</command> with <command>make build</command>
433 or (as a regular user only) just <command>make</command>, but do not be
434 surprised if a unit test fails right at the end of the build and
435 breaks it.
436 </para>
437
438 <para>
439 Build the package:
440 </para>
441
442<screen><userinput>make build-nocheck</userinput></screen>
443
444 <para>
445 Now, as the <systemitem class="username">root</systemitem> user:
446 </para>
447
448<screen role="root"><userinput>make distro-pack-install</userinput></screen>
449
450 <para>
451 If installed in <filename
452 class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>
453 some additional steps are necessary. Issue the following commands, as
454 <systemitem class="username">root</systemitem> user:
455 </para>
456
457<screen role="root"><userinput>if [ "$LO_PREFIX" != "/usr" ]; then
458
459 # This symlink is necessary for the desktop menu entries
460 ln -svf $LO_PREFIX/lib/libreoffice/program/soffice /usr/bin/libreoffice &amp;&amp;
461
462 # Set up a generic location independent of version number
463 ln -sfv libreoffice-&libreoffice-dlversion; /opt/libreoffice
464
465 # Icons
466 mkdir -vp /usr/share/pixmaps
467 for i in $LO_PREFIX/share/icons/hicolor/32x32/apps/*; do
468 ln -svf $i /usr/share/pixmaps
469 done &amp;&amp;
470
471 # Desktop menu entries
472 for i in $LO_PREFIX/lib/libreoffice/share/xdg/*; do
473 ln -svf $i /usr/share/applications/libreoffice-$(basename $i)
474 done &amp;&amp;
475
476 # Man pages
477 for i in $LO_PREFIX/share/man/man1/*; do
478 ln -svf $i /usr/share/man/man1/
479 done
480
481 unset i
482fi</userinput></screen>
483
484 <para>
485 If you have installed <xref linkend="desktop-file-utils"/>, and you wish
486 to update the MIME database, issue, as the <systemitem class="username">
487 root</systemitem> user:
488 </para>
489
490<screen role="root"><userinput>update-desktop-database</userinput></screen>
491
492 <para>
493 The suite and main modules can be started from the menu. From a terminal,
494 the suite can be started with <command>libreoffice</command> command and
495 the modules with <command>libreoffice
496 --<replaceable>&lt;module&gt;</replaceable></command> command,
497 respectively, where <replaceable>&lt;module&gt;</replaceable> is one of
498 base, calc, draw, impress, math, web, or writer. Modules cannot be started
499 using their shell starting script names (see "Installed Programs", below),
500 if LO_PREFIX is other than <filename class='directory'>/usr</filename>,
501 unless <filename class='directory'>$LO_PREFIX/bin</filename> directory is
502 appended to the PATH.
503 </para>
504
505 </sect2>
506
507 <sect2 role="commands">
508 <title>Command Explanations</title>
509
510 <para>
511 <command>sed -e ...</command>: The first sed prevents compression of the
512 manual pages, the second one prevents the install from failing, and the
513 third one allows the build to use poppler-0.86.1 and later.
514 <!-- FIXME update hardcoded poppler version in text when necessary -->
515 </para>
516
517 <para>
518 <parameter>--with-vendor=BLFS</parameter>: This switch sets BLFS as
519 the vendor which is mentioned when you click "About" from the Help menu
520 on the toolbar.
521 </para>
522
523 <para>
524 <parameter>--with-lang='fr en-GB'</parameter>: This switch sets
525 what languages to support. To list several languages, separate them with
526 a space. For all languages, use
527 <parameter>--with-lang=ALL</parameter>. Note that the translations file
528 is not needed and won't be downloaded if using only en_US as a language.
529 </para>
530
531 <note>
532 <para>
533 For a list of the available languages, look in
534 <filename>solenv/inc/langlist.mk</filename>.
535 </para>
536 </note>
537
538 <para>
539 <parameter>--with-help</parameter>: Without this switch, the help files
540 are not built.
541 </para>
542
543 <para>
544 <parameter>--with-jdk-home=/opt/jdk</parameter>: This parameter will silence
545 a warning that the configure script attempted to find JAVA_HOME
546 automatically (even though that is passed in the environment). Omit this if
547 you disabled java.
548 </para>
549
550 <para>
551 <parameter>--with-myspell-dicts</parameter>: This switch adds myspell
552 dictionaries to the <application>LibreOffice</application> installation
553 set.
554 </para>
555 <!-- Unrecognized as of 6.2.0.3
556 <para>
557 <parameter>- -with-alloc=system</parameter>: This switch tells
558 <application>LibreOffice</application> to use the system allocator
559 instead of its internal one.
560 </para>
561 -->
562 <para>
563 <parameter>--with-system-boost</parameter>: This switch enables using
564 system boost. From time to time, recent versions of boost break
565 the build of libreoffice. In this case, it is possible to use the
566 bundled copy of boost, by removing this flag.
567 </para>
568
569 <para>
570 <parameter>--disable-dconf</parameter>: This switch disables compiling
571 <application>LibreOffice</application> with the
572 <application>GNOME DConf</application> configuration system support.
573 </para>
574
575 <para>
576 <parameter>--without-junit</parameter>: This switch disables the tests
577 for the deprecated HSQLDB driver which is written in Java.
578 <!-- If you wish
579 to build this driver replace this switch with the set of switches
580 described below after '- -without-java'.-->
581 </para>
582
583 <para>
584 <parameter>--without-system-dicts</parameter>: This switch disables use
585 of dictionaries from system paths, so the ones installed by this package
586 are used.
587 </para>
588
589 <para>
590 <parameter>--disable-odk</parameter>: This switch disables installing the
591 office development kit. Remove if you want to develop a
592 <application>LibreOffice</application> based application.
593 </para>
594
595 <para>
596 <parameter>--enable-release-build=yes</parameter>: This switch enables a
597 Release Build. <application>LibreOffice</application> can be built as a
598 Release Build or as a Developer Build, because their default installation
599 paths and user profile paths are different. Developer Build displays the
600 words "Dev" and "Beta" in several places (e.g, menu and splash screen).
601 </para>
602
603 <para>
604 <parameter>--enable-python=system</parameter>: This switch tells
605 <application>LibreOffice</application> to use the system installed
606 <application>Python 3</application> instead of
607 the bundled one.
608 </para>
609
610 <para>
611 <parameter>--with-system-*</parameter>: These switches prevent
612 <application>LibreOffice</application> from trying to compile its own
613 versions of these dependencies. If you've not installed some of the
614 dependencies, remove the corresponding switches.
615 </para>
616
617<!--
618 <para>
619 <command>CPPFLAGS='-DU_USING_ICU_NAMESPACE=1' make ...</command>: <xref
620 linkend="icu"/> has removed an implicit namespace <quote>using</quote>
621 from its headers files. Setting <envar>U_USING_ICU_NAMESPACE</envar> to
622 1 allows to restore the former behavior, which is required for building
623 <application>libreoffice</application>.
624 </para>
625-->
626 <para>
627 <command>make distro-pack-install</command>: this does a normal
628 install, but if you add a DESTDIR environment variable it will also
629 install a lot of (text) gid_Module_* files in the DESTDIR, to help
630 distributions which want to break the package into parts.
631 </para>
632
633 <para>
634 <option>--with-parallelism=&lt;count&gt;</option>: This switch
635 tells <application>LibreOffice</application> to use &lt;count&gt; CPU
636 cores to compile in parallel. (Do not include literal angle brackets.)
637 The default is to use all available cores on the system.
638 </para>
639
640 <para>
641 <option>--disable-cups</option>: Use this switch if you don't need
642 printing support.
643 </para>
644
645 <para>
646 <option>--disable-dbus</option>: Use this switch if you've not installed
647 D-Bus-1.8.0 or later. It also disables Bluetooth support and font install
648 via PackageKit.
649 </para>
650
651 <para>
652 <option>--disable-firebird-sdbc</option>: By default, the ability to
653 connect to a <application>firebird</application> database is enabled.
654 Add this switch if you do not need that feature.
655 </para>
656
657 <para>
658 <option>--disable-gstreamer-1-0</option>: Use this switch if you have not
659 installed <xref linkend="gst10-plugins-base"/>.
660 </para>
661
662<!-- only gtk3 is referenced in the configure script for 6.4.0.3
663 <para>
664 <option>\-\-disable-gtk3</option>: Use this switch if you have not installed
665 <application>GTK+-3</application>, or if you have installed it but wish
666 to use <application>GTK+-2</application> (the menu icons differ).
667 <!\-\- Note that a <application>GTK+-3</application> build still
668 requires <application>GTK+-2</application> to build the gtk-plugin.\-\->
669 </para>-->
670
671 <para>
672 <option>--disable-postgresql-sdbc</option>: This switch disables compiling
673 <application>LibreOffice</application> with the ability to connect to a
674 <application>PostgreSQL</application> database. Use it if you have not
675 installed <application>PostgreSQL</application> and you do not want
676 <application>LibreOffice</application> to compile its bundled copy.
677 </para>
678
679 <para>
680 <option>--disable-skia</option>: Use <xref linkend="cairo"/> for rendering
681 instead of skia.
682 </para>
683
684 <para>
685 <option>--enable-gtk3-kde5</option>: This switch allows the Visual Class
686 Library, which is responsible for widgets, to be built with KF5 file
687 dialogs if GTK+-3, Qt5 and Plasma are all available.
688 </para>
689
690 <para>
691 <option>--enable-lto</option>: This switch will enable Link Time
692 Optimization, which results in slightly smaller libraries (about 40 MB).
693 This is said to make <application>LibreOffice</application> programs
694 load faster (and possibly run faster, e.g. when recalculating a
695 spreadsheet). On an 8-core machine with 16GB of memory, the difference
696 in compile times was minimal, but an extra 2GB was used for the work
697 files. On machines with fewer processors or a lack of memory, the compile
698 might be much slower.
699 </para>
700
701 <para>
702 <option>--without-java</option>: This switch disables
703 <application>Java</application> support in
704 <application>LibreOffice</application>. Java is needed for the
705 deprecated HSQLDB driver, which allows reading databases created by
706 other programs or in earlier versions of libreoffice
707 <application>base</application>.
708 </para>
709 <!-- junit is not included anymore in ant, and neither hamcrest. Since
710 the hsqldb backend is deprecated anyway, forget this:
711 <para>
712 <option>- -with-junit=/opt/ant/lib/junit-4.12.jar</option> and
713 <option>- -with-hamcrest=/opt/ant/lib/hamcrest-core-1.3.jar</option>:
714 Those options are needed if you want to run the tests.
715 </para>
716 -->
717 <para>
718 <option>--without-fonts</option>: <application>LibreOffice</application>
719 includes a number of third-party TrueType fonts. If you have already
720 installed some or all of the same fonts, you may prefer to use the system
721 versions.
722 </para>
723
724 <para>
725 <!-- Brings in - -enable-qt5 as well. -->
726 <option>--enable-kf5</option>: Builds with KDE/Plasma integration. If
727 <xref linkend="qt5"/> and/or <xref linkend="kf5-frameworks"/> are not
728 installed in <filename class="directory">/usr</filename>, the include
729 and library directories must be specified in <envar>QT5INC</envar>,
730 <envar>QT5LIB</envar>, <envar>KF5INC</envar>, and <envar>KF5LIB</envar>,
731 respectively.
732 </para>
733
734 <para>
735 <option>--enable-evolution2</option>: Enables support for Evolution
736 address books through Evolution Data Server. Note that Evolution Data
737 Server must be installed for this feature to function.
738 </para>
739
740 <!--
741 <para>
742 <option>- -with-system-icu</option>: This command would use the system
743 version of <xref linkend="icu"/> which is normally considered to be a good
744 thing to do. However, one of the very minor packages pulled in by
745 <application>LibreOffice</application>, libfreehand-0.1.2, does not compile
746 with ICU-65.1 because of a missing semi-colon at the end of one line in one
747 of its files. Do not use this option unless you have separately installed a
748 patched or newer version of
749 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand">libfreehand</ulink>.
750 </para>
751 -->
752
753 </sect2>
754
755 <sect2 role="content">
756 <title>Contents</title>
757
758 <segmentedlist>
759 <segtitle>Installed Programs</segtitle>
760 <segtitle>Installed Libraries</segtitle>
761 <segtitle>Installed Directory</segtitle>
762
763 <seglistitem>
764 <seg>
765 libreoffice, lobase, localc, lodraw, loffice, lofromtemplate,
766 loimpress, lomath, loweb, lowriter, soffice and unopkg;
767 several programs under
768 $LO_PREFIX/lib/libreoffice/program
769 </seg>
770 <seg>
771 several libraries under
772 $LO_PREFIX/lib/libreoffice/program
773 </seg>
774 <seg>
775 $LO_PREFIX/lib/libreoffice
776 </seg>
777 </seglistitem>
778 </segmentedlist>
779
780 <variablelist>
781 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
782 <?dbfo list-presentation="list"?>
783 <?dbhtml list-presentation="table"?>
784
785 <varlistentry id="libreoffice-suite">
786 <term><command>libreoffice (or soffice)</command></term>
787 <listitem>
788 <para>
789 is the main libreofice suite (symlink to
790 $LO_PREFIX/lib/libreoffice/program/soffice).
791 </para>
792 <indexterm zone="libreoffice libreoffice-suite">
793 <primary sortas="b-libreoffice-suite">libreoffice-suite</primary>
794 </indexterm>
795 </listitem>
796 </varlistentry>
797
798 <varlistentry id="lobase">
799 <term><command>lobase</command></term>
800 <listitem>
801 <para>
802 is the database manager module shell starting script.
803 </para>
804 <indexterm zone="libreoffice lobase">
805 <primary sortas="b-lobase">lobase</primary>
806 </indexterm>
807 </listitem>
808 </varlistentry>
809
810 <varlistentry id="localc">
811 <term><command>localc</command></term>
812 <listitem>
813 <para>
814 is the spreadsheet module shell starting script.
815 </para>
816 <indexterm zone="libreoffice localc">
817 <primary sortas="b-localc">localc</primary>
818 </indexterm>
819 </listitem>
820 </varlistentry>
821
822 <varlistentry id="lodraw">
823 <term><command>lodraw</command></term>
824 <listitem>
825 <para>
826 is the vector graphics editor and diagramming tool module shell
827 starting script.
828 </para>
829 <indexterm zone="libreoffice lodraw">
830 <primary sortas="b-lodraw">lodraw</primary>
831 </indexterm>
832 </listitem>
833 </varlistentry>
834
835 <varlistentry id="loimpress">
836 <term><command>loimpress</command></term>
837 <listitem>
838 <para>
839 is the (PowerPoint) presentations editor and displayer
840 module shell starting script.
841 </para>
842 <indexterm zone="libreoffice loimpress">
843 <primary sortas="b-loimpress">loimpress</primary>
844 </indexterm>
845 </listitem>
846 </varlistentry>
847
848 <varlistentry id="lomath">
849 <term><command>lomath</command></term>
850 <listitem>
851 <para>
852 is the mathematical formula editor module shell starting script.
853 </para>
854 <indexterm zone="libreoffice lomath">
855 <primary sortas="b-lomath">lomath</primary>
856 </indexterm>
857 </listitem>
858 </varlistentry>
859
860 <varlistentry id="loweb">
861 <term><command>loweb</command></term>
862 <listitem>
863 <para>
864 is the HTML editor module shell starting script.
865 </para>
866 <indexterm zone="libreoffice loweb">
867 <primary sortas="b-loweb">loweb</primary>
868 </indexterm>
869 </listitem>
870 </varlistentry>
871
872 <varlistentry id="lowriter">
873 <term><command>lowriter</command></term>
874 <listitem>
875 <para>
876 is the word processor module shell starting script.
877 </para>
878 <indexterm zone="libreoffice lowriter">
879 <primary sortas="b-lowriter">lowriter</primary>
880 </indexterm>
881 </listitem>
882 </varlistentry>
883
884 <varlistentry id="unopkg">
885 <term><command>unopkg</command></term>
886 <listitem>
887 <para>
888 is a tool to manage <application>LibreOffice</application>
889 extensions from the command line.
890 </para>
891 <indexterm zone="libreoffice unopkg">
892 <primary sortas="b-unopkg">unopkg</primary>
893 </indexterm>
894 </listitem>
895 </varlistentry>
896
897 </variablelist>
898
899 </sect2>
900
901</sect1>
Note: See TracBrowser for help on using the repository browser.