source: xsoft/office/libreoffice.xml@ a90582a1

10.0 10.1 11.0 11.1 9.0 9.1 lazarus qt5new trunk upgradedb xry111/intltool xry111/test-20220226
Last change on this file since a90582a1 was a90582a1, checked in by Ken Moffat <ken@…>, 3 years ago

Recommend lxml for libreoffice.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21971 af4574ff-66df-0310-9fd7-8a98e5e911e0

  • Property mode set to 100644
File size: 31.7 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY libreoffice-dl "http://download.documentfoundation.org/libreoffice/src/&libreoffice-version;">
8
9 <!ENTITY libreoffice-core-download-http "&libreoffice-dl;/libreoffice-&libreoffice-dlversion;.tar.xz">
10 <!ENTITY libreoffice-core-md5sum "d24bd7e5116743196c67e7df4b18458f">
11 <!ENTITY libreoffice-core-size "215 MB">
12
13 <!ENTITY libreoffice-dict-download-http "&libreoffice-dl;/libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz">
14 <!ENTITY libreoffice-dict-md5sum "81df66dd522a2c56a4f11b24247fb114">
15 <!ENTITY libreoffice-dict-size "44 MB">
16
17 <!ENTITY libreoffice-help-download-http "&libreoffice-dl;/libreoffice-help-&libreoffice-dlversion;.tar.xz">
18 <!ENTITY libreoffice-help-md5sum "483f654eaa94f17c462494029d42334a">
19 <!ENTITY libreoffice-help-size "13 MB">
20
21 <!ENTITY libreoffice-translations-download-http "&libreoffice-dl;/libreoffice-translations-&libreoffice-dlversion;.tar.xz">
22 <!ENTITY libreoffice-translations-md5sum "21459291d488ecd7e4e8fb0fdcc55aca">
23 <!ENTITY libreoffice-translations-size "140 MB">
24
25 <!-- full size still accurate for 6.0.2, reconfiguring and rebuilding
26 the built source after initial DESTDIR install doesn't take a vast time -->
27
28 <!ENTITY libreoffice-buildsize "8.7 GB (821 MB installed). Installing the whole set of languages was previously reported to require up to 26 GB (2.9 GB installed)">
29
30 <!-- for 6.1.2.1 I allowed 2 SBU for downloads, my total was
31 64.76 SBU with fast downloads
32 for 6.1.4.2 I just used the total time - bdubbs
33 -->
34 <!ENTITY libreoffice-time "60 SBU with parallelism=4 including typical download time">
35
36]>
37
38<sect1 id="libreoffice" xreflabel="LibreOffice-&libreoffice-dlversion;">
39 <?dbhtml filename="libreoffice.html"?>
40
41 <sect1info>
42 <othername>$LastChangedBy$</othername>
43 <date>$Date$</date>
44 </sect1info>
45
46 <title>LibreOffice-&libreoffice-version;</title>
47
48 <indexterm zone="libreoffice">
49 <primary sortas="a-LibreOffice">LibreOffice</primary>
50 </indexterm>
51
52 <sect2 role="package">
53 <title>Introduction to LibreOffice</title>
54
55 <para>
56 <application>LibreOffice</application> is a full-featured office suite.
57 It is largely compatible with <application>Microsoft Office</application>
58 and is descended from <application>OpenOffice.org</application>.
59 </para>
60
61 &lfs84_checked;
62
63 <bridgehead renderas="sect3">Package Information</bridgehead>
64 <itemizedlist spacing="compact">
65 <listitem>
66 <para>
67 Core Download: <ulink url="&libreoffice-core-download-http;"/>
68 </para>
69 </listitem>
70 <listitem>
71 <para>
72 Core Download MD5 sum: &libreoffice-core-md5sum;
73 </para>
74 </listitem>
75 <listitem>
76 <para>
77 Core Download size: &libreoffice-core-size;
78 </para>
79 </listitem>
80 <listitem>
81 <para>
82 Estimated disk space required: &libreoffice-buildsize;
83 </para>
84 </listitem>
85 <listitem>
86 <para>
87 Estimated build time: &libreoffice-time;
88 </para>
89 </listitem>
90 </itemizedlist>
91
92 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
93 <itemizedlist spacing="compact">
94 <listitem>
95 <para>
96 Dictionaries: <ulink url="&libreoffice-dict-download-http;"/>
97 </para>
98 </listitem>
99
100 <listitem>
101 <para>
102 Dictionaries MD5 sum: &libreoffice-dict-md5sum;
103 </para>
104 </listitem>
105
106 <listitem>
107 <para>
108 Dictionaries size: &libreoffice-dict-size;
109 </para>
110 </listitem>
111
112 <listitem>
113 <para>
114 Help Files: <ulink url="&libreoffice-help-download-http;"/>
115 </para>
116 </listitem>
117
118 <listitem>
119 <para>
120 Help Files MD5 sum: &libreoffice-help-md5sum;
121 </para>
122 </listitem>
123
124 <listitem>
125 <para>
126 Help Files size: &libreoffice-help-size;
127 </para>
128 </listitem>
129
130 <listitem>
131 <para>
132 Translations: <ulink url="&libreoffice-translations-download-http;"/>
133 </para>
134 </listitem>
135
136 <listitem>
137 <para>
138 Translations MD5 sum: &libreoffice-translations-md5sum;
139 </para>
140 </listitem>
141
142 <listitem>
143 <para>
144 Translations size: &libreoffice-translations-size;
145 </para>
146 </listitem>
147
148
149<!-- keep one commented patch, it's sure to again need one or more in a few months:
150For libreoffice 6.2.0.4, almost blfs 8.4: no patch needed, only a sed below
151 <listitem>
152 <para>
153 Required patch to fix building with system <xref linkend="poppler"/> (all
154 recent versions) and <xref linkend="boost"/>:
155 <ulink url="&patch-root;/libreoffice-&libreoffice-dlversion;-consolidated_fixes-1.patch"/>
156 </para>
157 </listitem>
158-->
159
160 </itemizedlist>
161 <bridgehead renderas="sect3">LibreOffice Dependencies</bridgehead>
162
163 <bridgehead renderas="sect4">Required</bridgehead>
164 <para role="required">
165 <xref linkend="perl-archive-zip"/>,
166 <xref linkend="unzip"/>,
167 <xref linkend="wget"/>,
168 <xref linkend="which"/>, and
169 <xref linkend="zip"/>
170 </para>
171
172 <bridgehead renderas="sect4">Recommended</bridgehead>
173 <note>
174 <para>
175 Most of these packages are recommended because if they're not installed,
176 the build process will compile and install its own (often older)
177 version, with the side effect of increasing build and installed disk
178 space and build time.
179 </para>
180 </note>
181
182 <para role="recommended">
183 <xref linkend="apache-ant"/>,
184 <xref linkend="apr"/>,
185 <xref linkend="boost"/>,
186 <xref linkend="clucene"/>,
187 <xref linkend="cups"/>,
188 <xref linkend="curl"/>,
189 <xref linkend="dbus-glib"/>,
190 <xref linkend="libjpeg"/>,
191 <xref linkend="glm"/>,
192 <xref linkend="glu"/>,
193 <xref linkend="gpgme"/>,
194 <xref linkend="graphite2"/>,
195 <xref linkend="gst10-plugins-base"/>,
196 <xref linkend="gtk3"/> and
197 <xref linkend="gtk2"/> (see <quote>Command Explanations</quote>),
198 <xref linkend="harfbuzz"/>,
199 <xref linkend="icu"/>,
200 <xref linkend="libatomic_ops"/>,
201 <xref linkend="lcms2"/>,
202 <xref linkend="librsvg"/>,
203 <xref linkend="libxml2"/> and
204 <xref linkend="libxslt"/>,
205 <xref linkend="lxml"/>,
206 <xref linkend="mesa"/>,
207 <xref linkend="neon"/>,
208 <xref linkend="nss"/>,
209 <xref linkend="openldap"/> (if connecting to an LDAP server),
210 <xref linkend="poppler"/>,
211 <xref linkend="postgresql"/>,
212 <xref linkend="redland"/>,
213 <xref linkend="serf"/>, and
214 <xref linkend="unixodbc"/>
215 </para>
216
217 <bridgehead renderas="sect4">Optional</bridgehead>
218 <para role="optional">
219 <xref linkend="avahi"/>,
220 <xref linkend="bluez"/>,
221 <xref linkend="dconf"/>,
222 <xref linkend="desktop-file-utils"/>,
223 <xref linkend="doxygen"/> (not relevant if using --disable-odk),
224 <xref linkend="evolution-data-server"/>,
225 <xref linkend="gdb"/>,
226 <xref linkend="gnutls"/>,
227<!-- not anymore in the book, but included in apache-ant
228 <xref linkend="junit"/>, -->
229 <xref linkend="kf5-frameworks"/>,
230 <xref linkend="libpaper"/>,
231 <xref linkend="mariadb"/> or <ulink url="http://www.mysql.com/">MySQL</ulink>,
232 <xref linkend="mitkrb"/>,
233 <xref linkend="nasm"/>,
234 <xref linkend="sane"/>,
235 <xref linkend="telepathy-glib"/>,
236 <xref linkend="valgrind"/>,
237 <xref linkend="vlc"/>,
238 <xref linkend="zenity"/>,
239 <ulink url="https://commons.apache.org/proper/commons-codec/">Apache Commons Codec</ulink>,
240 <ulink url="https://hc.apache.org/httpclient-3.x/">Apache Commons HttpClient</ulink>,
241 <ulink url="https://commons.apache.org/proper/commons-lang/">Apache Commons Lang</ulink>,
242 <ulink url="https://commons.apache.org/proper/commons-logging/">Apache Commons Logging</ulink>,
243 <ulink url="http://www.beanshell.org/">BeanShell</ulink>,
244 <ulink url="https://projects.coin-or.org/CoinMP/">CoinMP</ulink>,
245 <ulink url="http://sourceforge.net/projects/cppunit/">Cppunit</ulink>,
246 <ulink url="http://www.firebirdsql.org/">Firebird</ulink>,
247 <ulink url="https://github.com/behdad/glyphy">glyphy</ulink>,
248 <ulink url="http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/">Gnome VFS</ulink>,
249
250 <ulink url="https://github.com/hamcrest/JavaHamcrest/releases">hamcrest</ulink>,
251 <ulink url="https://hunspell.github.io/">Hunspell</ulink>,
252 <ulink url="http://sourceforge.net/projects/hunspell/files/Hyphen/">Hyphen</ulink>,
253 <ulink url="http://include-what-you-use.org/">iwyu</ulink>,
254 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libabw">libabw</ulink>,
255 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr">libcdr</ulink>,
256 <ulink url="http://sourceforge.net/projects/libcmis/">libcmis</ulink>,
257 <ulink url="http://www.sourceforge.net/projects/libebook/">libebook</ulink>,
258 <ulink url="https://wiki.documentfoundation.org/Libexttextcat">libexttextcat</ulink>,
259 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand">libfreehand</ulink>,
260 <ulink url="http://tagoh.bitbucket.org/liblangtag/">liblangtag</ulink>,
261 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub">libmspub</ulink>,
262 <ulink url="http://sourceforge.net/projects/libmwaw/">libmwaw</ulink>,
263 <ulink url="http://sourceforge.net/projects/libwpd/files/libodfgen/">libodfgen</ulink>,
264 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker">libpagemaker</ulink>,
265 <ulink url="http://sourceforge.net/projects/libwpd/files/librevenge/">librevenge (WordPerfect Document importer)</ulink>,
266 <ulink url="https://wiki.documentfoundation.org/DLP/Libraries/libvisio">libvisio</ulink>,
267 <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
268 <ulink url="http://libwpg.sourceforge.net/">libwpg</ulink>,
269 <ulink url="http://libwps.sourceforge.net/">libwps</ulink>,
270 <ulink url="http://lpsolve.sourceforge.net/">lp_solve</ulink>,
271 <ulink url="https://gitlab.com/mdds/mdds">mdds</ulink>,
272 <ulink url="http://sourceforge.net/projects/hunspell/files/MyThes/">MyThes</ulink>,
273 <ulink url="https://github.com/KhronosGroup/OpenCOLLADA/">OpenCOLLADA</ulink>,
274 <ulink url="https://gitlab.com/orcus/orcus">Orcus</ulink>, and
275 <ulink url="https://ukoethe.github.io/vigra/">VIGRA</ulink>
276 </para>
277
278 <para>There are many optional dependencies not listed here. They can be
279 found in <quote>download.lst</quote> (source directory).
280 </para>
281
282 <para condition="html" role="usernotes">
283 User Notes: <ulink url="&blfs-wiki;/libreoffice"/>
284 </para>
285 </sect2>
286
287 <sect2 role="installation">
288 <title>Installation of LibreOffice</title>
289
290 <important>
291 <para>
292 Unlike the other packages, we assume that you have not yet unpacked the
293 package. This is because the <option>--no-overwrite-dir</option>
294 switch is needed in case you unpack as the <systemitem
295 class="username">root</systemitem> user.
296 </para>
297 </important>
298
299<screen role="nodump"><userinput>tar -xf libreoffice-&libreoffice-dlversion;.tar.xz --no-overwrite-dir &amp;&amp;
300cd libreoffice-&libreoffice-dlversion;</userinput></screen>
301
302<!-- keep a commented instruction if no patches are currently required
303 <para> <!- - for all recent versions - ->
304 Fix build failures introduced by recent versions of <xref linkend="poppler"/>
305 and <xref linkend="boost"/>:
306 </para>
307
308<screen><userinput>patch -Np1 -i ../libreoffice-&libreoffice-dlversion;-consolidated_fixes-1.patch</userinput></screen>
309-->
310
311 <para>
312 Create symlinks to tarballs from the source directory so they won't
313 get downloaded again:
314 </para>
315
316<screen><userinput>install -dm755 external/tarballs &amp;&amp;
317ln -sv ../../../libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz external/tarballs/ &amp;&amp;
318ln -sv ../../../libreoffice-help-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
319
320 <para>
321 If you have downloaded the translations tarball, create a symlink:
322 </para>
323
324<screen><userinput>ln -sv ../../../libreoffice-translations-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
325
326 <note>
327 <para>
328 During the build process, some packages will be downloaded (including
329 the ones listed as recommended and optional dependencies) if they are
330 not present on the system. Because of this, build time may vary from the
331 published time more than usual.
332 </para>
333 </note>
334
335 <para>
336 Due to the large size of the package, you may prefer to install it in
337 <filename class="directory">/opt</filename>, instead of
338 <filename class="directory">/usr</filename>. Depending on your choice,
339 replace <replaceable>&lt;PREFIX&gt;</replaceable> by
340 <filename class="directory">/usr</filename> or by
341 <filename class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>:
342 </para>
343
344<screen><userinput>export LO_PREFIX=<replaceable>&lt;PREFIX&gt;</replaceable></userinput></screen>
345
346 <para>
347 Locales "fr" and "en-GB", you will find below, are just examples; you
348 should change them to suit your needs - you might want to read the
349 "Command Explanations", further below, before proceeding.
350 </para>
351
352 <para>
353 Prepare <application>LibreOffice</application> for compilation by running
354 the following commands:
355 </para>
356
357<screen><userinput>sed -e "/gzip -f/d" \
358 -e "s|.1.gz|.1|g" \
359 -i bin/distro-install-desktop-integration &amp;&amp;
360
361sed -e "/distro-install-file-lists/d" -i Makefile.in &amp;&amp;
362
363<!-- Removed in 6.2 - -with-alloc=system \-->
364<!-- In 6.3 -disable-gtk -enable-gtk3 added (sic, I accidentally built like
365 that) which allows removal of - -with-system-cairo but did NOT cause
366 system epoxy to be automatically used, as configure claimed -->
367./autogen.sh --prefix=$LO_PREFIX \
368 --sysconfdir=/etc \
369 --with-vendor=BLFS \
370 --with-lang='fr en-GB' \
371 --with-help \
372 --with-myspell-dicts \
373 --without-junit \
374 --without-system-dicts \
375 --disable-dconf \
376 -disable-gtk -enable-gtk3 \
377 --disable-odk \
378 --enable-release-build=yes \
379 --enable-python=system \
380 --with-jdk-home=/opt/jdk \
381 --with-system-apr \
382 --with-system-boost \
383 --with-system-clucene \
384 --with-system-curl \
385 --with-system-epoxy \
386 --with-system-expat \
387 --with-system-glm \
388 --with-system-gpgmepp \
389 --with-system-graphite \
390 --with-system-harfbuzz \
391 --with-system-icu \
392 --with-system-jpeg \
393 --with-system-lcms2 \
394 --with-system-libatomic_ops \
395 --with-system-libpng \
396 --with-system-libxml \
397 --with-system-neon \
398 --with-system-nss \
399 --with-system-odbc \
400 --with-system-openldap \
401 --with-system-openssl \
402 --with-system-poppler \
403 --with-system-postgresql \
404 --with-system-redland \
405 --with-system-serf \
406 --with-system-zlib</userinput></screen>
407
408 <para>
409 The instructions below will only build the package without running
410 any unit tests. If you prefer to run the unit tests, replace
411 <command>make build-nocheck</command> with <command>make build</command>
412 or (as a regular user only) just <command>make</command>, but do not be
413 surprised if a unit test fails right at the end of the build and
414 breaks it.
415 </para>
416
417 <para>
418 Build the package:
419 </para>
420
421<screen><userinput>make build-nocheck</userinput></screen>
422<!--<screen><userinput>CPPFLAGS='-DU_USING_ICU_NAMESPACE=1' make build-nocheck</userinput></screen>-->
423
424 <para>
425 Now, as the <systemitem class="username">root</systemitem> user:
426 </para>
427
428<screen role="root"><userinput>make distro-pack-install</userinput></screen>
429
430 <para>
431 If installed in <filename
432 class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>
433 some additional steps are necessary. Issue the following commands, as
434 <systemitem class="username">root</systemitem> user:
435 </para>
436
437<screen role="root"><userinput>if [ "$LO_PREFIX" != "/usr" ]; then
438
439 # This symlink is necessary for the desktop menu entries
440 ln -svf $LO_PREFIX/lib/libreoffice/program/soffice /usr/bin/libreoffice &amp;&amp;
441
442 # Set up a generic location independent of version number
443 ln -sfv libreoffice-&libreoffice-dlversion; /opt/libreoffice
444
445 # Icons
446 mkdir -vp /usr/share/pixmaps
447 for i in $LO_PREFIX/share/icons/hicolor/32x32/apps/*; do
448 ln -svf $i /usr/share/pixmaps
449 done &amp;&amp;
450
451 # Desktop menu entries
452 for i in $LO_PREFIX/lib/libreoffice/share/xdg/*; do
453 ln -svf $i /usr/share/applications/libreoffice-$(basename $i)
454 done &amp;&amp;
455
456 # Man pages
457 for i in $LO_PREFIX/share/man/man1/*; do
458 ln -svf $i /usr/share/man/man1/
459 done
460
461 unset i
462fi</userinput></screen>
463
464 <para>
465 If you have installed <xref linkend="desktop-file-utils"/>, and you wish
466 to update the MIME database, issue, as the <systemitem class="username">
467 root</systemitem> user:
468 </para>
469
470<screen role="root"><userinput>update-desktop-database</userinput></screen>
471
472 <para>
473 The suite and main modules can be started from the menu. From a terminal,
474 the suite can be started with <command>libreoffice</command> command and
475 the modules with <command>libreoffice
476 --<replaceable>&lt;module&gt;</replaceable></command> command,
477 respectively, where <replaceable>&lt;module&gt;</replaceable> is one of
478 base, calc, draw, impress, math or writer. Modules cannot be started using
479 their shell starting script names (see "Installed Programs", below), if
480 LO_PREFIX is other than <filename class='directory'>/usr</filename>,
481 unless <filename class='directory'>$LO_PREFIX/bin</filename> directory is
482 appended to the PATH.
483 </para>
484
485 </sect2>
486
487 <sect2 role="commands">
488 <title>Command Explanations</title>
489
490 <para>
491 <command>sed -e ...</command>: The first sed prevents compression of the
492 manual pages and the second one prevents the install from failing.
493 </para>
494
495 <para>
496 <parameter>--with-vendor=BLFS</parameter>: This switch sets BLFS as
497 the vendor which is mentioned when you click "About" from the Help menu
498 on the toolbar.
499 </para>
500
501 <para>
502 <parameter>--with-lang='fr en-GB'</parameter>: This switch sets
503 what languages to support. To list several languages, separate them with
504 a space. For all languages, use
505 <parameter>--with-lang=ALL</parameter>.
506 </para>
507
508 <note>
509 <para>
510 For a list of the available languages, look in
511 <filename>solenv/inc/langlist.mk</filename>.
512 </para>
513 </note>
514
515 <para>
516 <parameter>--with-help</parameter>: Without this switch, the help files
517 are not built.
518 </para>
519
520 <para>
521 <parameter>--with-jdk-home=/opt/jdk</parameter>: This parameter will silence
522 a warning that the configure script attempted to find JAVA_HOME
523 automatically (even though that is passed in the environment). Omit this if
524 you disabled java.
525 </para>
526
527 <para>
528 <parameter>--with-myspell-dicts</parameter>: This switch adds myspell
529 dictionaries to the <application>LibreOffice</application> installation
530 set.
531 </para>
532 <!-- Unrecognized as of 6.2.0.3
533 <para>
534 <parameter>- -with-alloc=system</parameter>: This switch tells
535 <application>LibreOffice</application> to use the system allocator
536 instead of its internal one.
537 </para>
538 -->
539 <para>
540 <parameter>--with-system-boost</parameter>: This switch enables using
541 system boost. From time to time, recent versions of boost break
542 the build of libreoffice. In this case, it is possible to use the
543 bundled copy of boost, by removing this flag.
544 </para>
545
546 <para>
547 <parameter>--disable-dconf</parameter>: This switch disables compiling
548 <application>LibreOffice</application> with the
549 <application>GNOME DConf</application> configuration system support.
550 </para>
551
552 <para>
553 <parameter>-disable-gtk -enable-gtk3</parameter>: This pair of switches
554 tell the configure script to use <application>GTK+-3</application> instead
555 of <application>GTK+-2</application>.
556 </para>
557
558 <para>
559 <parameter>--without-junit</parameter>: This switch disables the tests
560 for the deprecated HSQLDB driver which is written in Java. If you wish
561 to build this driver replace this switch with the set of switches
562 described below after '--without-java'.
563 </para>
564
565 <para>
566 <parameter>--without-system-dicts</parameter>: This switch disables use
567 of dictionaries from system paths, so the ones installed by this package
568 are used.
569 </para>
570
571 <para>
572 <parameter>--disable-odk</parameter>: This switch disables installing the
573 office development kit. Remove if you want to develop a
574 <application>LibreOffice</application> based application.
575 </para>
576
577 <para>
578 <parameter>--enable-release-build=yes</parameter>: This switch enables a
579 Release Build. <application>LibreOffice</application> can be built as a
580 Release Build or as a Developer Build, because their default installation
581 paths and user profile paths are different. Developer Build displays the
582 words "Dev" and "Beta" in several places (e.g, menu and splash screen).
583 </para>
584
585 <para>
586 <parameter>--enable-python=system</parameter>: This switch tells
587 <application>LibreOffice</application> to use installed
588 <application>Python 3</application> to build the translations instead of
589 the bundled one.
590 </para>
591
592 <para>
593 <parameter>--with-system-*</parameter>: These switches prevent
594 <application>LibreOffice</application> from trying to compile its own
595 versions of these dependencies. If you've not installed some of the
596 dependencies, remove the corresponding switches.
597 </para>
598
599<!--
600 <para>
601 <command>CPPFLAGS='-DU_USING_ICU_NAMESPACE=1' make ...</command>: <xref
602 linkend="icu"/> has removed an implicit namespace <quote>using</quote>
603 from its headers files. Setting <envar>U_USING_ICU_NAMESPACE</envar> to
604 1 allows to restore the former behavior, which is required for building
605 <application>libreoffice</application>.
606 </para>
607-->
608 <para>
609 <command>make distro-pack-install</command>: this does a normal
610 install, but if you add a DESTDIR environment variable it will also
611 install a lot of (text) gid_Module_* files in the DESTDIR, to help
612 distributions which want to break the package into parts.
613 </para>
614
615 <para>
616 <option>--with-parallelism=&lt;count&gt;</option>: This switch
617 tells <application>LibreOffice</application> to use &lt;count&gt; CPU
618 cores to compile in parallel. (Do not include literal angle brackets.)
619 The default is to use all available cores on the system.
620 </para>
621
622 <para>
623 <option>--disable-cups</option>: Use this switch if you don't need
624 printing support.
625 </para>
626
627 <para>
628 <option>--disable-dbus</option>: Use this switch if you've not installed
629 D-Bus-1.8.0 or later. It also disables Bluetooth support and font install
630 via PackageKit.
631 </para>
632
633 <para>
634 <option>--disable-firebird-sdbc</option>: By default, the ability to
635 connect to a <application>firebird</application> database is enabled.
636 Add this switch if you do not need that feature.
637 </para>
638
639 <para>
640 <option>--disable-gstreamer-1-0</option>: Use this switch if you have not
641 installed <xref linkend="gst10-plugins-base"/>.
642 </para>
643
644 <para>
645 <option>--disable-gtk3</option>: Use this switch if you have not installed
646 <application>GTK+-3</application>, or if you have installed it but wish
647 to use <application>GTK+-2</application> (the menu icons differ).
648 <!-- Note that a <application>GTK+-3</application> build still
649 requires <application>GTK+-2</application> to build the gtk-plugin.-->
650 </para>
651
652 <para>
653 <option>--disable-postgresql-sdbc</option>: This switch disables compiling
654 <application>LibreOffice</application> with the ability to connect to a
655 <application>PostgreSQL</application> database. Use it if you have not
656 installed <application>PostgreSQL</application> and you do not want
657 <application>LibreOffice</application> to compile its bundled copy.
658 </para>
659
660 <para>
661 <option>--enable-lto</option>: This switch will enable Link Time
662 Optimization, which results in slightly smaller libraries (about 40 MB).
663 This is said to make <application>LibreOffice</application> programs
664 load faster (and possibly run faster, e.g. when recalculating a
665 spreadsheet). On an 8-core machine with 16GB of memory, the difference
666 in compile times was minimal, but an extra 2GB was used for the work
667 files. On machines with fewer processors or a lack of memory, the compile
668 might be much slower.
669 </para>
670
671 <para>
672 <option>--without-java</option>: This switch disables
673 <application>Java</application> support in
674 <application>LibreOffice</application>. Java is needed for the
675 deprecated HSQLDB driver, which allows reading databases created by
676 other programs or in earlier versions of libreoffice
677 <application>base</application>.
678 </para>
679
680 <para>
681 <option>--with-junit=/opt/ant/lib/junit-4.12.jar</option> and
682 <option>--with-hamcrest=/opt/ant/lib/hamcrest-core-1.3.jar</option>:
683 Those options are needed if you want to run the tests.
684 </para>
685
686 <para>
687 <option>--without-fonts</option>: <application>LibreOffice</application>
688 includes a number of third-party TrueType fonts. If you have already
689 installed some or all of the same fonts, you may prefer to use the system
690 versions.
691 </para>
692
693 <para>
694 <!-- Brings in - -enable-qt5 as well. -->
695 <option>--enable-kde5</option>: Builds with KDE/Plasma integration. If
696 <xref linkend="qt5"/> and/or <xref linkend="kf5-frameworks"/> are not
697 installed in <filename class="directory">/usr</filename>, the include
698 and library directories must be specified in <envar>QT5INC</envar>,
699 <envar>QT5LIB</envar>, <envar>KF5INC</envar>, and <envar>KF5LIB</envar>,
700 respectively.
701 </para>
702
703 <para revision="systemd">
704 <option>--enable-evolution2</option>: Enables support for Evolution
705 address books through Evolution Data Server. Note that Evolution Data
706 Server must be installed for this feature to function.
707 </para>
708
709 </sect2>
710
711 <sect2 role="content">
712 <title>Contents</title>
713
714 <segmentedlist>
715 <segtitle>Installed Programs</segtitle>
716 <segtitle>Installed Libraries</segtitle>
717 <segtitle>Installed Directory</segtitle>
718
719 <seglistitem>
720 <seg>
721 libreoffice, lobase, localc, lodraw, loffice, lofromtemplate,
722 loimpress, lomath, loweb, lowriter, soffice and unopkg;
723 several programs under
724 $LO_PREFIX/lib/libreoffice/program
725 </seg>
726 <seg>
727 several libraries under
728 $LO_PREFIX/lib/libreoffice/program
729 </seg>
730 <seg>
731 $LO_PREFIX/lib/libreoffice
732 </seg>
733 </seglistitem>
734 </segmentedlist>
735
736 <variablelist>
737 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
738 <?dbfo list-presentation="list"?>
739 <?dbhtml list-presentation="table"?>
740
741 <varlistentry id="libreoffice-suite">
742 <term><command>libreoffice (or soffice)</command></term>
743 <listitem>
744 <para>
745 is the main libreofice suite (symlink to
746 $LO_PREFIX/lib/libreoffice/program/soffice).
747 </para>
748 <indexterm zone="libreoffice libreoffice-suite">
749 <primary sortas="b-libreoffice-suite">libreoffice-suite</primary>
750 </indexterm>
751 </listitem>
752 </varlistentry>
753
754 <varlistentry id="lobase">
755 <term><command>lobase</command></term>
756 <listitem>
757 <para>
758 is the database manager module shell starting script.
759 </para>
760 <indexterm zone="libreoffice lobase">
761 <primary sortas="b-lobase">lobase</primary>
762 </indexterm>
763 </listitem>
764 </varlistentry>
765
766 <varlistentry id="localc">
767 <term><command>localc</command></term>
768 <listitem>
769 <para>
770 is the spreadsheet module shell starting script.
771 </para>
772 <indexterm zone="libreoffice localc">
773 <primary sortas="b-localc">localc</primary>
774 </indexterm>
775 </listitem>
776 </varlistentry>
777
778 <varlistentry id="lodraw">
779 <term><command>lodraw</command></term>
780 <listitem>
781 <para>
782 is the vector graphics editor and diagramming tool module shell
783 starting script.
784 </para>
785 <indexterm zone="libreoffice lodraw">
786 <primary sortas="b-lodraw">lodraw</primary>
787 </indexterm>
788 </listitem>
789 </varlistentry>
790
791 <varlistentry id="loimpress">
792 <term><command>loimpress</command></term>
793 <listitem>
794 <para>
795 is the (PowerPoint) presentations editor and displayer
796 module shell starting script.
797 </para>
798 <indexterm zone="libreoffice loimpress">
799 <primary sortas="b-loimpress">loimpress</primary>
800 </indexterm>
801 </listitem>
802 </varlistentry>
803
804 <varlistentry id="lomath">
805 <term><command>lomath</command></term>
806 <listitem>
807 <para>
808 is the mathematical formula editor module shell starting script.
809 </para>
810 <indexterm zone="libreoffice lomath">
811 <primary sortas="b-lomath">lomath</primary>
812 </indexterm>
813 </listitem>
814 </varlistentry>
815
816 <varlistentry id="loweb">
817 <term><command>loweb</command></term>
818 <listitem>
819 <para>
820 is the HTML editor module shell starting script.
821 </para>
822 <indexterm zone="libreoffice loweb">
823 <primary sortas="b-loweb">loweb</primary>
824 </indexterm>
825 </listitem>
826 </varlistentry>
827
828 <varlistentry id="lowriter">
829 <term><command>lowriter</command></term>
830 <listitem>
831 <para>
832 is the word processor module shell starting script.
833 </para>
834 <indexterm zone="libreoffice lowriter">
835 <primary sortas="b-lowriter">lowriter</primary>
836 </indexterm>
837 </listitem>
838 </varlistentry>
839
840 <varlistentry id="unopkg">
841 <term><command>unopkg</command></term>
842 <listitem>
843 <para>
844 is a tool to manage <application>LibreOffice</application>
845 extensions from the command line.
846 </para>
847 <indexterm zone="libreoffice unopkg">
848 <primary sortas="b-unopkg">unopkg</primary>
849 </indexterm>
850 </listitem>
851 </varlistentry>
852
853 </variablelist>
854
855 </sect2>
856
857</sect1>
Note: See TracBrowser for help on using the repository browser.