Changeset 00a3154


Ignore:
Timestamp:
04/24/2021 01:38:42 AM (3 months ago)
Author:
Ken Moffat <ken@…>
Branches:
trunk
Children:
1715682
Parents:
356e8b5f
Message:

Update to texlive-2021.

Files:
6 edited

Legend:

Unmodified
Added
Removed
  • introduction/welcome/changelog.xml

    r356e8b5f r00a3154  
    4141    </listitem>
    4242    -->
     43
     44   <listitem>
     45      <para>April 23rd, 2021</para>
     46      <itemizedlist>
     47         <listitem>
     48            <para>[ken] - Update to texlive-2021. Fixes
     49            <ulink url="&blfs-ticket-root;14846">#14846</ulink>.</para>
     50         </listitem>
     51      </itemizedlist>
     52   </listitem>
    4353
    4454   <listitem>
  • packages.ent

    r356e8b5f r00a3154  
    10911091
    10921092<!-- Chapter 51 -->
    1093 <!ENTITY texlive-version              "20200406">
    1094 <!ENTITY texmf-version                "20200406">
    1095 <!ENTITY tex-tlpdb-version            "20200406">
     1093<!ENTITY texlive-version              "20210325">
     1094<!ENTITY texmf-version                "20210325">
     1095<!ENTITY tex-tlpdb-version            "20210325">
    10961096<!-- the year is used when setting up PATHs in the tl-installer
    10971097 page, as well as to reference the directory in texlive, also
    10981098 in asymptote, biber and xindy -->
    1099 <!ENTITY texlive-year                 "2020">
     1099<!ENTITY texlive-year                 "2021">
    11001100<!ENTITY asymptote-version            "2.70">
    11011101<!ENTITY biber-version                "2.16">
  • pst/typesetting/texlive.xml

    r356e8b5f r00a3154  
    66  <!ENTITY texlive-download-http " ">
    77  <!ENTITY texlive-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texlive-version;-source.tar.xz">
    8   <!ENTITY texlive-md5sum        "a5d992e3cb8554ce92c55adde03958ba">
     8  <!ENTITY texlive-md5sum        "19da95538956e26570ef7fb202af258f">
    99  <!ENTITY texlive-size          "53 MB">
    1010
    11   <!ENTITY texlive-buildsize      "8.5 GB including the additional download and the tests, 6.4 GB installed">
    12   <!ENTITY texlive-time           "5.8 SBU including the additional download and the tests, building with parallelism=4">
     11  <!ENTITY texlive-buildsize      "8.1 GB including the additional download and the tests, 7.0 GB installed">
     12  <!ENTITY texlive-time           "4.2 SBU including the additional download and the tests, building with parallelism=4">
    1313
    1414  <!ENTITY texlive-texmf-download-http " ">
    1515  <!ENTITY texlive-texmf-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texmf-version;-texmf.tar.xz">
    16   <!ENTITY texlive-texmf-md5sum        "bca40df2ff11269fbcb2d1b4ff0278b1">
    17   <!ENTITY texlive-texmf-size          "3.0 GB">
     16  <!ENTITY texlive-texmf-md5sum        "2426a62e43f8b07397ef2dd8367e0465">
     17  <!ENTITY texlive-texmf-size          "3.3 GB">
    1818
    1919  <!ENTITY texlive-tlpdb-download-http " ">
    2020  <!ENTITY texlive-tlpdb-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&tex-tlpdb-version;-tlpdb-full.tar.gz">
    21   <!ENTITY texlive-tlpdb-md5sum        "d8cd997c1bba422b30c9bc225e508794">
    22   <!ENTITY texlive-tlpdb-size          "2.9 MB">
     21  <!ENTITY texlive-tlpdb-md5sum        "af0240961ecd28be5fd30d0e99b341d5">
     22  <!ENTITY texlive-tlpdb-size          "3.0 MB">
    2323
    2424]>
     
    169169      </listitem>
    170170
    171 <!--  <listitem>
     171      <listitem>
    172172        <para>
    173173          Required patch: <ulink url=
    174           "&patch-root;/texlive-&texlive-version;-source-upstream_fixes-1.patch"/>
    175         </para>
    176       </listitem>-->
     174          "&patch-root;/texlive-&texlive-version;-upstream_fixes-1.patch"/>
     175        </para>
     176      </listitem>
    177177    </itemizedlist>
    178178
     
    223223    <caution>
    224224      <para>
    225         The instructions here for dealing with <application>poppler</application>
    226         will only work with versions of poppler used in BLFS-9.1 and later, i.e.
    227         poppler &gt;= 0.83.0. If you wish to upgrade an older system, there
    228         are versions of <filename>pdftoepdf{,-poppler*}.cc</filename> and
    229         <filename>pdftosrc{,-newpoppler,-poppler*}.cc</filename> in <filename
    230         class="directory">texk/web2c/pdftexdir</filename>. You should establish
    231         which version of <application>poppler</application> is installed and use
    232         the appropriate versions of these files.
    233       </para>
    234 
    235       <para>
    236         Similarly, if you wish to upgrade to current <application>texlive</application>
     225        If you wish to upgrade to current <application>texlive</application>
    237226        on an older system where extra packages (<application>asymptote</application>.
    238227        <application>biber</application>, <application>dvisvgm</application> or
     
    257246EOF</userinput></screen>
    258247
    259     <para>
    260       <application>TexLive</application> ships with a very old version of
    261       <application>poppler</application>, and some updated files for newer versions.
    262       To use the system version, first identify it and then copy the correct
    263       versions of the updated files (please read the Caution above):
    264     </para>
    265 
    266 <!-- on a release, drop this back to current version but update the
    267  Caution above and ideally keep this commented, every other (expletive
    268  deleted) poppler update tends to break this.  Fortunately, upstream
    269  has deleted the poppler directory from their source in
    270  https://tug.org/svn/texlive?view=revision&revision=55138
    271  so from TL2021 this aggravation should be gone. -->
    272 <screen><userinput>SYSPOP= &amp;&amp;
    273 MYPOPPLER_MAJOR=$(pkg-config --modversion poppler | cut -d '.' -f1)
    274 if [ "$MYPOPPLER_MAJOR" = "0" ]; then
    275     # if major was >=20, minor could start with 0 and not fit in octal
    276     # causing error from 'let' in bash.
    277     let MYPOPPLER_MINOR=$(pkg-config --modversion poppler | cut -d '.' -f2)
    278 else
    279     # force a value > 85
    280     let MYPOPPLER_MINOR=99
    281 fi
    282 if [ "$MYPOPPLER_MINOR" -lt 85 ]; then
    283     # BLFS-9.1 uses 0.85.0, ignore earlier versions in this script.
    284     # If updating texlive on an older system, review the available
    285     # variants for pdftoepdf and pdftosrc to use system poppler.
    286     SYSPOP=
    287 else
    288     SYSPOP="--with-system-poppler --with-system-xpdf"
    289     if [ "$MYPOPPLER_MINOR" -lt 86 ]; then
    290         mv -v texk/web2c/pdftexdir/pdftoepdf{-poppler0.83.0,}.cc
    291     else # 0.86.0 or later, including 20.08.0.
    292         mv -v texk/web2c/pdftexdir/pdftoepdf{-poppler0.86.0,}.cc
    293     fi
    294     # For pdftosrc BLFS-9.1 uses 0.83.0 and that is the latest variant.
    295     mv -v texk/web2c/pdftexdir/pdftosrc{-poppler0.83.0,}.cc
    296 fi &amp;&amp;
    297 export SYSPOP &amp;&amp;
    298 unset MYPOPPLER_{MAJOR,MINOR}</userinput></screen>
    299 
    300248    <note>
    301249      <para>
     
    309257      Now, as a normal user:
    310258    </para>
    311 <!-- after the export!
    312 patch -Np1 -i ../texlive-&texlive-version;-source-upstream_fixes-1.patch &amp;&amp;-->
    313 <screen><userinput>export TEXARCH=$(uname -m | sed -e 's/i.86/i386/' -e 's/$/-linux/') &amp;&amp;
     259
     260<screen><userinput>export TEXARCH=$(uname -m |
     261 sed -e 's/i.86/i386/' -e 's/$/-linux/')                 &amp;&amp;
     262patch -Np1 -i ../texlive-&texlive-version;-upstream_fixes-1.patch &amp;&amp;
    314263
    315264mkdir texlive-build &amp;&amp;
    316265cd texlive-build    &amp;&amp;
    317266
    318 ../configure                                                    \
    319     --prefix=/opt/texlive/&texlive-year;                                  \
    320     --bindir=/opt/texlive/&texlive-year;/bin/$TEXARCH                     \
    321     --datarootdir=/opt/texlive/&texlive-year;                             \
    322     --includedir=/opt/texlive/&texlive-year;/include                      \
    323     --infodir=/opt/texlive/&texlive-year;/texmf-dist/doc/info             \
    324     --libdir=/opt/texlive/&texlive-year;/lib                              \
    325     --mandir=/opt/texlive/&texlive-year;/texmf-dist/doc/man               \
    326     --disable-native-texlive-build                              \
    327     --disable-static --enable-shared                            \
    328     --disable-dvisvgm                                           \
    329     --with-system-cairo                                         \
    330     --with-system-fontconfig                                    \
    331     --with-system-freetype2                                     \
    332     --with-system-gmp                                           \
    333     --with-system-graphite2                                     \
    334     --with-system-harfbuzz                                      \
    335     --with-system-icu                                           \
    336     --with-system-libgs                                         \
    337     --with-system-libpaper                                      \
    338     --with-system-libpng                                        \
    339     --with-system-mpfr                                          \
    340     --with-system-pixman                                        \
    341     ${SYSPOP}                                                   \
    342     --with-system-zlib                                          \
     267../configure                                        \
     268    --prefix=/opt/texlive/&texlive-year;                      \
     269    --bindir=/opt/texlive/&texlive-year;/bin/$TEXARCH         \
     270    --datarootdir=/opt/texlive/&texlive-year;                 \
     271    --includedir=/opt/texlive/&texlive-year;/include          \
     272    --infodir=/opt/texlive/&texlive-year;/texmf-dist/doc/info \
     273    --libdir=/opt/texlive/&texlive-year;/lib                  \
     274    --mandir=/opt/texlive/&texlive-year;/texmf-dist/doc/man   \
     275    --disable-native-texlive-build                  \
     276    --disable-static --enable-shared                \
     277    --disable-dvisvgm                               \
     278    --with-system-cairo                             \
     279    --with-system-fontconfig                        \
     280    --with-system-freetype2                         \
     281    --with-system-gmp                               \
     282    --with-system-graphite2                         \
     283    --with-system-harfbuzz                          \
     284    --with-system-icu                               \
     285    --with-system-libgs                             \
     286    --with-system-libpaper                          \
     287    --with-system-libpng                            \
     288    --with-system-mpfr                              \
     289    --with-system-pixman                            \
     290    --with-system-zlib                              \
    343291    --with-banner-add=" - BLFS" &amp;&amp;
    344292
    345 make &amp;&amp;
    346 unset SYSPOP</userinput></screen>
    347 
    348     <para>
    349       To test the results, issue: <command>make -k check</command>.
    350       One of the Kpathsea tests will fail because BLFS uses system
    351       libraries.
    352    <!--  https://tug.org/pipermail/tex-k/2019-August/003036.html -->
     293make</userinput></screen>
     294
     295    <para>
     296      To test the results, issue: <command>make check</command>.
    353297    </para>
    354298
     
    384328
    385329    <para>
     330      It has been established by debian that the <command>python</command>
     331      scripts in <filename class="directory">latex-make</filename> will work
     332      with <command>python3</command>, so update them to invoke that by running
     333      the following command as the <systemitem class="username">root</systemitem>
     334      user:
     335    </para>
     336
     337<screen role="root"><userinput>for F in /opt/texlive/&texlive-year;/texmf-dist/scripts/latex-make/*.py ; do
     338  sed -i 's%/usr/bin/env python%/usr/bin/python3%' $F
     339done
     340</userinput></screen>
     341
     342    <para>
    386343      Still as the <systemitem class="username">root</systemitem> user,
    387344      initialise the new system (the commands <command>fmtutil-sys
     
    409366    <title>Command Explanations</title>
    410367
    411 <!--<para>
     368    <para>
     369      <!-- https://tug.org/pipermail/tlbuild/2021q2/004885.html -->
    412370      <command>patch -Np1 -i ../texlive-&texlive-version;-source-upstream_fixes-1.patch</command>:
    413       various problems have come to light since the shipped source was frozen to
    414       be committed to DVDs.
    415     </para>-->
     371      A small update to mpost and LuaTeX caused the binaries to be rebuilt.
     372      This ptch applies the same fixes.
     373    </para>
    416374
    417375    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
  • pst/typesetting/tl-installer.xml

    r356e8b5f r00a3154  
    88
    99  <!ENTITY tl-installer-download-ftp    " ">
    10   <!ENTITY tl-installer-md5sum          "769eb3849f931ca3efcbeeca093b95c0">
    11   <!ENTITY tl-installer-date             "20200406"> <!-- in the directory name -->
    12   <!ENTITY tl-installer-size            "3.8 MB">
    13 
    14   <!ENTITY tl-installer-buildsize        "6.6 GB if everything is included">
     10  <!ENTITY tl-installer-md5sum          "868c661c8f3c6c1fd7665a3a609390df">
     11  <!ENTITY tl-installer-date             "20210413"> <!-- in the directory name -->
     12  <!ENTITY tl-installer-size            "6.0 MB">
     13
     14  <!ENTITY tl-installer-buildsize        "7.1 GB if everything is included">
    1515  <!ENTITY tl-installer-time            "varies, depending on network speed and traffic">
    1616]>
     
    125125       <xref role="nodep" linkend="epdfview"/>).
    126126    </para>
     127<!-- seems to not be needed in 2021
    127128    <para role="recommended">
    128129      the optional non-wide-character ncurses library (for "some binary-only
     
    130131      page in LFS is needed
    131132      for xindy.run which is used by <application>xindy</application>
    132     </para>
     133    </para> -->
    133134    <para role="recommended">
    134135      The binary version of <application>asy</application> needs
     
    206207    </para>
    207208
     209    <para>
     210      It has been established by debian that the <command>python</command>
     211      scripts in <filename class="directory">latex-make</filename> will work
     212      with <command>python3</command>, so update them to invoke that by running
     213      the following command as the <systemitem class="username">root</systemitem>
     214      user:
     215    </para>
     216
     217<screen role="root"><userinput>for F in /opt/texlive/&texlive-year;/texmf-dist/scripts/latex-make/*.py ; do
     218  test -f $F &amp;&amp; sed -i 's%/usr/bin/env python%/usr/bin/python3%' $F || true
     219done
     220</userinput></screen>
     221
    208222  </sect2>
    209223
    210224  <sect2 role="commands">
    211225    <title>Command Explanations</title>
     226
     227    <para>
     228      <command>test -f $F &amp;&amp; sed ...</command>: in a small install these
     229      files might not be present, so test if they exist and if not return 'true'
     230      to avoid any error if this command has been copied into one of your own install scripts.
     231    </para>
    212232
    213233    <para>
  • xincludes/texrecommendlibs.xml

    r356e8b5f r00a3154  
    1616  <xref linkend="icu"/>,
    1717  <xref linkend="libpaper"/> (used by at least context and xelatex),
    18    and <xref linkend="libpng"/>, also
    19   <xref linkend="poppler"/> (only used if suitable file versions
    20   are available in <filename class="directory">texk/web2c/pdftexdir</filename>)
     18   and <xref linkend="libpng"/>
    2119</para>
  • xincludes/texruntime.xml

    r356e8b5f r00a3154  
    55
    66<para role="recommended">
    7   <xref role="runtime" linkend="python2"/> is used by many scripts.
     7  <xref role="runtime" linkend="python2"/> is used by many scripts - most are
     8  unmaintained. Many invoke <filename>/usr/bin/env python</filename>, a couple
     9  invoke <filename>/usr/bin/python</filename>. It is not generally known if
     10  these will work with a symlink to <command>python3</command> (as used in some
     11  distros) and two from pythontex invoke <command>python2</command>.
    812  <xref role="runtime" linkend="ruby"/> is used by some scripts, mostly within
    913  mtx_context which is part of <application>conTeXt</application>, but also
Note: See TracChangeset for help on using the changeset viewer.