Changeset 14f0ab29


Ignore:
Timestamp:
02/19/2018 02:03:44 PM (4 years ago)
Author:
Pierre Labastie <pieere@…>
Branches:
10.0, 10.1, 11.0, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, ken/refactor-virt, lazarus, perl-modules, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
50cb265e
Parents:
ce8983d8
Message:

Fix gpgme build if gnupg is not installed+tag

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@19805 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • postlfs/security/gpgme.xml

    rce8983d8 r14f0ab29  
    4242    </para>
    4343
    44     &lfs81_checked;
     44    &lfs82_checked;
    4545
    4646    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    108108    </para>
    109109
    110 <screen><userinput>./configure --prefix=/usr &amp;&amp;
     110<screen><userinput>./configure --prefix=/usr --disable-gpg-test &amp;&amp;
    111111make</userinput></screen>
    112112
    113113    <para>
    114       To test the results, issue: <command>make check</command>.
     114      To test the results, you should have <xref linkend="gnupg2"/> installed
     115      and remove the <command>--disable-gpg-test</command> above. Issue:
     116      <command>make check</command>.
    115117    </para>
    116118
     
    120122
    121123<screen role="root"><userinput>make install</userinput></screen>
     124
     125  </sect2>
     126
     127  <sect2 role="commands">
     128    <title>Command Explanations</title>
     129
     130    <para>
     131      <parameter>--disable-gpg-test</parameter>: if this parameter is not
     132      passed to configure, the test programs are built during
     133      <command>make</command> stage, which requires <xref linkend="gnupg2"/>.
     134      This parameter is not needed if <xref linkend="gnupg2"/> is installed.
     135    </para>
    122136
    123137  </sect2>
Note: See TracChangeset for help on using the changeset viewer.