Changeset 191f166


Ignore:
Timestamp:
05/20/2019 04:28:20 AM (2 years ago)
Author:
Douglas R. Reno <renodr@…>
Branches:
10.0, 10.1, 11.0, 9.0, 9.1, ken/refactor-virt, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
bc625a7d
Parents:
b18436b4
Message:

Archive xf86-input-vmmouse. With kernel version 5.1 or later, having the VMMouse driver installed on a VMWare or Qemu system will result in crashes because the work was completed to make this obsolete input driver useless. VMWare ported the VMMouse protocol to use the standard PS/2 subsystem in EVDEV and/or Libinput, so it will work with any VM with either xf86-input-evdev or xf86-input-libinput.

This package has been obsolete for a while, but now causes problems, so let's remove it.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21610 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
2 edited
1 moved

Legend:

Unmodified
Added
Removed
  • archive/x7driver-vmmouse.xml

    rb18436b4 r191f166  
    5353      &lfs84_checked;
    5454      <!-- I used this with both VMWare and QEMU. -->
     55      <!-- with Kernel 5.1, this package is now obsolete and will cause X to crash.-->
    5556
    5657      <bridgehead renderas="sect4">Package Information</bridgehead>
  • introduction/welcome/changelog.xml

    rb18436b4 r191f166  
    4545      <para>May 19th, 2019</para>
    4646      <itemizedlist>
     47        <listitem>
     48          <para>[renodr] - Archive xf86-input-vmmouse. With kernel 5.1 and
     49          later, VMWare made this driver obsolete by mapping VMMouse's
     50          events into the evdev subsystem. Therefore,
     51          xf86-input-evdev now works with it and this package can be archived.
     52          Installing it on a VMWare or Qemu system with 5.1+ will cause
     53          instability and other problems.</para>
     54        </listitem>
    4755        <listitem>
    4856          <para>[ken] - Update details of Intel microcode. Fixes
  • x/installing/x7driver.xml

    rb18436b4 r191f166  
    9393          </para>
    9494        </listitem>
     95        <!-- With Kernel 5.1, VMMouse is now entirely unusable/obsolete.
     96        VMWare has a replacement in the kernel that works for both Qemu and
     97        VMWare, that allows the VMMouse instruction set to run through
     98        EVDEV events.
     99        I archived it on 2019-05-19 as a result. - renodr
    95100        <listitem>
    96101          <para>
     
    98103          </para>
    99104        </listitem>
     105        -->
    100106        <listitem>
    101107          <para>
     
    185191    href="x7driver-synaptics.xml"/>
    186192
    187   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
    188     href="x7driver-vmmouse.xml"/>
     193 <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     194    href="x7driver-vmmouse.xml"/> -->
    189195
    190196  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
Note: See TracChangeset for help on using the changeset viewer.