Changeset 26e8824


Ignore:
Timestamp:
04/12/2020 10:14:10 PM (18 months ago)
Author:
Ken Moffat <ken@…>
Branches:
10.0, 10.1, 11.0, ken/refactor-virt, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
2c7493c7
Parents:
476eb4bd
Message:

texlive-2020

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@22992 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
7 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    r476eb4bd r26e8824  
    11<!-- $LastChangedBy$ $Date$ -->
    22
    3 <!ENTITY day          "11">                   <!-- Always 2 digits -->
     3<!ENTITY day          "12">                   <!-- Always 2 digits -->
    44<!ENTITY month        "04">                   <!-- Always 2 digits -->
    55<!ENTITY year         "2020">
     
    77<!ENTITY copyholder   "The BLFS Development Team">
    88<!ENTITY version      "&year;-&month;-&day;">
    9 <!ENTITY releasedate  "April 11th, &year;">
     9<!ENTITY releasedate  "April 12th, &year;">
    1010<!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
    1111<!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
  • introduction/welcome/changelog.xml

    r476eb4bd r26e8824  
    4343    -->
    4444    <listitem>
     45      <para>April 12th, 2020</para>
     46      <itemizedlist>
     47        <listitem>
     48          <para>[ken] - Update to texlive-20200406. Fixes
     49          <ulink url="&blfs-ticket-root;13394">#13394</ulink>.</para>
     50        </listitem>
     51      </itemizedlist>
     52    </listitem>
     53
     54    <listitem>
    4555      <para>April 11th, 2020</para>
    4656      <itemizedlist>
  • packages.ent

    r476eb4bd r26e8824  
    10651065
    10661066<!-- Chapter 51 -->
    1067 <!ENTITY texlive-version              "20190410">
    1068 <!ENTITY texmf-version                "20190410">
     1067<!ENTITY texlive-version              "20200406">
     1068<!ENTITY texmf-version                "20200406">
    10691069<!-- the year is used when setting up PATHs in the tl-installer
    10701070 page, as well as to reference the directory in texlive, also
    10711071 in asymptote, biber and xindy -->
    1072 <!ENTITY texlive-year                 "2019">
     1072<!ENTITY texlive-year                 "2020">
    10731073<!ENTITY asymptote-version            "2.65">
    10741074<!ENTITY biber-version                "2.14">
  • pst/typesetting/tex-path.xml

    r476eb4bd r26e8824  
    2525    always i386-linux. For x86_64 and i?86 we can generate this as $TEXARCH:
    2626  </para>
     27
     28  <note>
     29    <para>
     30      If upgrading from a previous year's version, you should manually
     31      edit <filename>extrapaths.sh</filename> to ensure that the version for
     32      the year you wish to use is the only TeX present (some people need to
     33      keep multiple years available to ensure there are no regressions in
     34      their documents).
     35    </para>
     36  </note>
    2737
    2838<!-- EOF should NOT be in double quotes, we want it to evaluate $TEXARCH -->
  • pst/typesetting/texlive.xml

    r476eb4bd r26e8824  
    1 <?xml version="1.0" encoding="ISO-8859-1"?>
    21<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    32   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
     
    76  <!ENTITY texlive-download-http " ">
    87  <!ENTITY texlive-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texlive-version;-source.tar.xz">
    9   <!ENTITY texlive-md5sum        "be4b20aa60861bc510bcbc5b228bcb51">
    10   <!ENTITY texlive-size          "52 MB">
    11 
    12   <!ENTITY texlive-buildsize      "7.2 GB including the additional download and the tests, 6.0 GB installed">
    13   <!ENTITY texlive-time           "5.6 SBU including the additional download and the tests, building with parallelism=4">
     8  <!ENTITY texlive-md5sum        "a5d992e3cb8554ce92c55adde03958ba">
     9  <!ENTITY texlive-size          "53 MB">
     10
     11  <!ENTITY texlive-buildsize      "8.5 GB including the additional download and the tests, 6.4 GB installed">
     12  <!ENTITY texlive-time           "5.8 SBU including the additional download and the tests, building with parallelism=4">
    1413
    1514  <!ENTITY texlive-texmf-download-http " ">
    1615  <!ENTITY texlive-texmf-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texmf-version;-texmf.tar.xz">
    17   <!ENTITY texlive-texmf-md5sum        "586bb6cb6c30ce7efba256b956df6bc2">
    18   <!ENTITY texlive-texmf-size          "2.5 GB">
     16  <!ENTITY texlive-texmf-md5sum        "bca40df2ff11269fbcb2d1b4ff0278b1">
     17  <!ENTITY texlive-texmf-size          "3.0 GB">
    1918
    2019]>
     
    4645      if TeX has not already been installed. Additionally,
    4746      <application>biber</application> is not provided within the
    48       <application>texlive</application> source.
    49     </para>
    50 
     47      <application>texlive</application> source and the version of
     48      <application>dvisvgm</application> in the
     49      <application>texlive</application> tree cannot be built
     50      if shared system libraries are used.
     51    </para>
     52
     53      <para>
     54      </para>
    5155    <para>
    5256      All of those packages are dealt with on their own pages and can be
     
    130134        </para>
    131135      </listitem>
    132       <listitem>
     136<!--  <listitem>
    133137        <para>
    134138          Required patch: <ulink url=
    135139          "&patch-root;/texlive-&texlive-version;-source-upstream_fixes-1.patch"/>
    136140        </para>
    137       </listitem>
     141      </listitem>-->
    138142    </itemizedlist>
    139143
     
    182186    </para>
    183187
     188    <caution>
     189      <para>
     190        The instructions here for dealing with <application>poppler</application>
     191        will only work with versions of poppler used in BLFS-9.1 and later, i.e.
     192        poppler &gt;= 0.83.0. If you wish to upgrade an older system, there
     193        are versions of <filename>pdftoepdf{,-poppler*}.cc</filename> and
     194        <filename>pdftosrc{,-newpoppler,-poppler*}.cc</filename> in <filename
     195        class="directory">texk/web2c/pdftexdir</filename>. You should establish
     196        which version of <application>poppler</application> is installed and use
     197        the appropriate versions of these files.
     198      </para>
     199
     200      <para>
     201        Similarly, if you wish to upgrade to current <application>texlive</application>
     202        on an older system where extra packages (<application>asymptote</application>.
     203        <application>biber</application>, <application>dvisvgm</application> or
     204        <application>xindy</application>) have been installed, you will need to
     205        reinstall those as well as fixing up your <literal>PATH</literal> for
     206        <literal>/opt/texlive/&texlive-year;</literal>.
     207      </para>
     208    </caution>
     209
    184210    <para>
    185211      The shared libraries will be installed into a texlive directory.
     
    196222EOF</userinput></screen>
    197223
     224    <para>
     225      <application>TexLive</application> ships with a very old version of
     226      <application>poppler</application>, and some updated files for newer versions.
     227      To use the system version, first identify it and then copy the correct
     228      versions of the updated files (please read the Caution above):
     229    </para>
     230
     231<!-- on a release, drop this back to current version but update the
     232 Caution above and ideally keep this commented, every other (expletive
     233 deleted) poppler update tends to break this. -->
     234<screen><userinput>SYSPOP= &amp;&amp;
     235let MYPOPPLER=$(pkg-config --modversion poppler | cut -d '.' -f2)
     236if [ "$MYPOPPLER" -lt 85 ]; then
     237    # BLFS-9.1 uses 0.85.0, ignore earlier versions in this script.
     238    SYSPOP=
     239else
     240    SYSPOP="--with-system-poppler --with-system-xpdf --with-system-potrace"
     241    if [ $MYPOPPLER -lt 86 ]; then
     242        mv -v texk/web2c/pdftexdir/pdftoepdf{-poppler0.83.0,}.cc
     243    else # 0.86.0 or later.
     244        mv -v texk/web2c/pdftexdir/pdftoepdf{-poppler0.86.0,}.cc
     245    fi
     246    # For pdftosrc BLFS-9.1 uses 0.83.0 and that is the latest variant.
     247    mv -v texk/web2c/pdftexdir/pdftosrc{-poppler0.83.0,}.cc
     248fi &amp;&amp;
     249export SYSPOP &amp;&amp;
     250unset MYPOPPLER</userinput></screen>
     251
    198252    <note>
    199253      <para>
    200         From 2015 onwards, a successful install requires some texlive
     254        A successful install requires some texlive
    201255        commands to be run as the root user, so we will export the TEXARCH
    202256        variable to let <systemitem class="username">root</systemitem> use it.
    203257      </para>
    204 
    205       <para>
    206         In the 2019 release, <application>dvisvgm</application> cannot be built
    207         if shared system libraries are used. This means that
    208         <xref linkend="asymptote"/> will not be able to create svg files.
    209       </para>
    210258    </note>
    211259
     
    213261      Now, as a normal user:
    214262    </para>
     263<!-- after the export!
     264patch -Np1 -i ../texlive-&texlive-version;-source-upstream_fixes-1.patch &amp;&amp;-->
    215265<screen><userinput>export TEXARCH=$(uname -m | sed -e 's/i.86/i386/' -e 's/$/-linux/') &amp;&amp;
    216 
    217 patch -Np1 -i ../texlive-&texlive-version;-source-upstream_fixes-1.patch &amp;&amp;
    218266
    219267mkdir texlive-build &amp;&amp;
    220268cd texlive-build    &amp;&amp;
    221 <!--
    222     \-\-with-system-poppler                                       \
    223     \-\-with-system-xpdf                                          \
    224     potrace was only used by dvisvgm
    225     \-\-with-system-potrace                                       \
    226  -->
     269
    227270../configure                                                    \
    228271    --prefix=/opt/texlive/&texlive-year;                                  \
     
    248291    --with-system-mpfr                                          \
    249292    --with-system-pixman                                        \
     293    ${SYSPOP}                                                   \
    250294    --with-system-zlib                                          \
    251295    --with-banner-add=" - BLFS" &amp;&amp;
    252296
    253 make</userinput></screen>
    254 
    255     <para>
    256       To test the results, issue: <command>make check</command>
    257       A few tests may SKIP because kpathsea
    258       has not yet been installed.
     297make &amp;&amp;
     298unset SYSPOP</userinput></screen>
     299
     300    <para>
     301      To test the results, issue: <command>make -k check</command>.
     302      One of the Kpathsea tests will fail because BLFS uses system
     303      libraries.
     304   <!--  https://tug.org/pipermail/tex-k/2019-August/003036.html -->
    259305    </para>
    260306
     
    305351    <para>
    306352      You can now proceed to <xref linkend="asymptote"/>,
    307       <xref linkend="biber"/> and / or <xref linkend="xindy"/> if you
    308       wish to install them.
     353      <xref linkend="biber"/>, <xref linkend="dvisvgm"/> and / or <xref
     354      linkend="xindy"/> if you wish to install them.
    309355    </para>
    310356
     
    314360    <title>Command Explanations</title>
    315361
    316     <para>
     362<!--<para>
    317363      <command>patch -Np1 -i ../texlive-&texlive-version;-source-upstream_fixes-1.patch</command>:
    318364      various problems have come to light since the shipped source was frozen to
    319365      be committed to DVDs.
    320     </para>
    321 
    322 <!--
    323     <para>
    324       <command>let MYPOPPLER=...</command>: Because the vulnerability fix applies to
    325       many past years of <application>texlive</application>, the tests aim to allow
    326       updating using system versions of poppler since 0.62.0. The amended files for
    327       newer versions of poppler need to be copied over the original versions,
    328       depending on which version is being used.
    329366    </para>-->
    330367
  • pst/typesetting/tl-installer.xml

    r476eb4bd r26e8824  
    88
    99  <!ENTITY tl-installer-download-ftp    " ">
    10   <!ENTITY tl-installer-md5sum          "e80f92667fb65f38dae88d1c5b22dba3">
    11   <!ENTITY tl-installer-date             "20190529"> <!-- in the directory name -->
     10  <!ENTITY tl-installer-md5sum          "769eb3849f931ca3efcbeeca093b95c0">
     11  <!ENTITY tl-installer-date             "20200406"> <!-- in the directory name -->
    1212  <!ENTITY tl-installer-size            "3.8 MB">
    1313
    14   <!ENTITY tl-installer-buildsize        "6.7 GB if everything is included">
     14  <!ENTITY tl-installer-buildsize        "6.6 GB if everything is included">
    1515  <!ENTITY tl-installer-time            "varies, depending on network speed and traffic">
    1616]>
  • xincludes/texrecommendlibs.xml

    r476eb4bd r26e8824  
    1818  <xref linkend="icu"/>,
    1919  <xref linkend="libpaper"/> (used by at least context and xelatex),
    20    and <xref linkend="libpng"/>
    21   <!--<xref linkend="poppler"/>,-->
    22   <!-- and <xref linkend="potrace"/>-->
     20   and <xref linkend="libpng"/>, also
     21  <xref linkend="poppler"/> and
     22  <xref linkend="potrace"/> (both only used if suitable file versions
     23  are available in <filename class="directory">texk/web2c/pdftexdir</filename>)
    2324</para>
Note: See TracChangeset for help on using the changeset viewer.