Changeset 2d1da1f


Ignore:
Timestamp:
08/05/2021 01:43:13 PM (14 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
11.0, 11.1, 11.2, lazarus, qt5new, trunk, upgradedb, xry111/intltool, xry111/soup3, xry111/test-20220226
Children:
77a8b67
Parents:
c6ff8c2
Message:

ibus: add gtk+3 and gtk4 as optional dependencies

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/genutils/ibus.xml

    rc6ff8c2 r2d1da1f  
    103103    <bridgehead renderas="sect4">Optional</bridgehead>
    104104    <para role="optional">
     105      <xref linkend="gtk3"/> (to build IM module for it),
     106      <xref linkend="gtk4"/> (to build IM module for it),
    105107      <xref linkend="dbus-python"/> and
    106108      <xref linkend="pygobject3"/> (both to build the Python support library),
    107109      <xref linkend="gtk-doc"/>,
    108       <xref linkend="pyxdg"/> (for the <command>ibus-setup</command>), and
     110      <xref linkend="pyxdg" role="runtime"/>
     111      (runtime, for the <command>ibus-setup</command>), and
    109112      <xref linkend="libxkbcommon"/>,
    110113      <xref linkend="wayland"/> (both to build the Wayland support programs), and
     
    193196      the <application>GTK+ 2</application> immodule. Use it if
    194197      you have not installed <application>GTK+ 2</application>.
     198    </para>
     199
     200    <para>
     201      <option>--enable-gtk4</option>: This switch enables building
     202      the <application>GTK 4</application> immodule. Use it if
     203      you have installed <application>GTK 4</application>.
    195204    </para>
    196205
Note: See TracChangeset for help on using the changeset viewer.