Changeset 4a95892


Ignore:
Timestamp:
10/11/2018 03:32:00 AM (3 years ago)
Author:
Ken Moffat <ken@…>
Branches:
perl-modules
Children:
09fa46e4
Parents:
20c1f43
Message:

perl modules branch: note that Module::Runtime does not require Module::Build, even though it still lists it as a prerequisite.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/branches/perl-modules@20614 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
3 edited

Legend:

Unmodified
Added
Removed
  • general/prog/perl-deps.xml

    r20c1f43 r4a95892  
    8888      <listitem>
    8989        <para>
     90          <xref linkend="new-perl-cpan-meta-check"/>
     91        </para>
     92      </listitem>
     93      <listitem>
     94        <para>
    9095          <xref linkend="perl-exporter-tiny"/>
    9196        </para>
     
    189194        <para>
    190195          <xref linkend="perl-super"/>
     196        </para>
     197      </listitem>
     198      <listitem>
     199        <para>
     200          <xref linkend="new-perl-test-deep"/>
    191201        </para>
    192202      </listitem>
     
    292302
    293303  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     304    href="perl-deps/perl-cpan-meta-check.xml"/>
     305
     306  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
    294307    href="perl-deps/perl-exporter-tiny.xml"/>
    295308
     
    355368
    356369  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     370    href="perl-deps/perl-test-deep.xml"/>
     371
     372  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
    357373    href="perl-deps/perl-test-exception.xml"/>
    358374
  • general/prog/perl-deps/perl-module-runtime.xml

    r20c1f43 r4a95892  
    4343      </itemizedlist>
    4444
    45       <bridgehead renderas="sect4">Module::Runtime Dependencies</bridgehead>
    46 
    47       <bridgehead renderas="sect5">Required</bridgehead>
    48       <para role="required">
    49         <xref linkend="new-perl-module-build"/>
    50       </para>
    51 
    5245    </sect3>
    5346
     
    5548      <title>Installation of Module::Runtime</title>
    5649
     50      <para>
     51        Although Module::Build is still listed as a prerequisite, it is
     52        no-longer necessary on systems with a working <command>make</command>.
     53      </para>
     54
    5755      <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
    58                   href="../../../xincludes/perl-build-install.xml"/>
     56                  href="../../../xincludes/perl-standard-install.xml"/>
    5957
    6058    </sect3>
  • packages.ent

    r20c1f43 r4a95892  
    416416<!ENTITY Capture-Tiny-version         "0.48">
    417417<!ENTITY Config-AutoConf-version      "0.317">
     418<!ENTITY CPAN-Meta-Check-version      "0.014"> <!-- FIXME might not be needed -->
    418419<!ENTITY Exporter-Tiny-version        "1.002001">
    419420<!ENTITY ExtUtils-LibBuilder-version  "0.06">
     
    437438<!ENTITY Sub-Uplevel-version          "0.2800">
    438439<!ENTITY SUPER-version                "1.20141117">
     440<!ENTITY Test-Deep-version            "1.128"> <!-- FIXME might not be needed -->
    439441<!ENTITY Test-Exception-version       "0.43">
    440442<!ENTITY Test-Fatal-version           "0.014">
Note: See TracChangeset for help on using the changeset viewer.