Changeset 4af651f7


Ignore:
Timestamp:
02/23/2021 03:45:03 PM (7 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
10.1, 11.0, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
b9af11b
Parents:
33f44cf
Message:

js78: add workaround for reinstallation

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@24275 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/genlib/js78.xml

    r33f44cf r4af651f7  
    106106  <sect2 role="installation">
    107107    <title>Installation of JS</title>
    108 
    109     <caution>
    110       <para>
    111         If you are upgrading JS78 from a previously installed old version,
    112         save all work and exit your GNOME Session if you have one running.
    113         Replacing the JS78 binary will cause the GNOME Shell to crash and
    114         return you to your display manager or TTY. After installing the new
    115         version, if GNOME Shell still doesn't work, reinstall
    116         <xref linkend="gjs"/>.
    117       </para>
    118     </caution>
    119108
    120109    <note>
     
    204193
    205194    <para>
     195      An issue in the installation process causes any running program which
     196      links to JS78 shared library (for example, GNOME Shell) to crash, if
     197      JS78 is upgraded or reinstalled.  To workaround this issue, remove
     198      the old version of JS78 shared library before installation:
     199    </para>
     200
     201<screen role="root"><userinput>rm -fv /usr/lib/libmozjs-78.so</userinput></screen>
     202
     203    <para>
    206204      Now, as the <systemitem class="username">root</systemitem> user:
    207205    </para>
Note: See TracChangeset for help on using the changeset viewer.