Changeset 52c9514


Ignore:
Timestamp:
07/25/2019 04:21:35 PM (2 years ago)
Author:
Douglas R. Reno <renodr@…>
Branches:
10.0, 10.1, 11.0, 9.0, 9.1, ken/refactor-virt, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
2420eeb
Parents:
9d10790
Message:

Update to NetworkManager-1.18.2. This also fixes minor breakage in the Wireshark plugin for NetworkManager caused by kernel 5.2

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21866 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
4 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    r9d10790 r52c9514  
    11<!-- $LastChangedBy$ $Date$ -->
    22
    3 <!ENTITY day          "24">                   <!-- Always 2 digits -->
     3<!ENTITY day          "25">                   <!-- Always 2 digits -->
    44<!ENTITY month        "07">                   <!-- Always 2 digits -->
    55<!ENTITY year         "2019">
     
    77<!ENTITY copyholder   "The BLFS Development Team">
    88<!ENTITY version      "&year;-&month;-&day;">
    9 <!ENTITY releasedate  "July 24th, &year;">
     9<!ENTITY releasedate  "July 25th, &year;">
    1010<!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
    1111<!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
  • introduction/welcome/changelog.xml

    r9d10790 r52c9514  
    4242    </listitem>
    4343       -->
     44    <listitem>
     45      <para>July 25th, 2019</para>
     46      <itemizedlist>
     47        <listitem>
     48          <para>[renodr] - Update to NetworkManager-1.18.2. This also fixes
     49          issues with the Wireshark module for NetworkManager and kernel 5.2+.
     50          Fixes <ulink url="&blfs-ticket-root;12316">#12316</ulink>.</para>
     51        </listitem>
     52      </itemizedlist>
     53    </listitem>
    4454
    4555    <listitem>
  • networking/netutils/networkmanager.xml

    r9d10790 r52c9514  
    99  <!ENTITY NetworkManager-download-ftp
    1010           "&gnome-download-ftp;/NetworkManager/1.18/NetworkManager-&NetworkManager-version;.tar.xz">
    11   <!ENTITY NetworkManager-md5sum        "5d4dd0d5ac86f0b616880e44420b8eb5">
     11  <!ENTITY NetworkManager-md5sum        "ca1e6175c6ba97ca1adf65a67861ccd9">
    1212  <!ENTITY NetworkManager-size          "4.6 MB">
    13   <!ENTITY NetworkManager-buildsize     "777 MB (with tests)">
    14   <!ENTITY NetworkManager-time          "0.9 SBU (with tests)">
     13  <!ENTITY NetworkManager-buildsize     "872 MB (with tests)">
     14  <!ENTITY NetworkManager-time          "1.8 SBU (with tests)">
    1515]>
    1616
     
    255255      respective libraries. Remove if you have the needed libraries installed.
    256256    </para>
    257 
     257   
     258<!--
    258259    <para>
    259260      <parameter>-Dlibpsl=false</parameter>: This switch is required if
     
    261262      you have built <application>libpsl</application>.
    262263    </para>
     264-->
    263265
    264266    <para>
     
    468470        </seg>
    469471        <seg>
    470           libnm.so and several modules under /usr/lib/NetworkManager
     472          libnm.so, libnm-glib.so, libnm-glib-vpn.so, libnm-util.so,
     473          and several modules under /usr/lib/NetworkManager
    471474        </seg>
    472475        <seg>
    473476          /etc/NetworkManager,
    474           /usr/include/libnm,
     477              /usr/include/{libnm,libnm-glib,NetworkManager},
    475478          /usr/lib/NetworkManager,
    476479          /usr/share/doc/NetworkManager-&NetworkManager-version;,
     
    480483          /var/lib/NetworkManager
    481484        </seg>
    482         <!-- A lot of libraries were removed here. We should verify compatibilty. -->
     485        <!-- A lot of libraries were removed here. We should verify compatibilty.
     486        RESTORED AT 1.18.2 -renodr -->
    483487      </seglistitem>
    484488    </segmentedlist>
     
    589593      </varlistentry>
    590594
     595      <varlistentry id="libnm-glib">
     596        <term><filename class="libraryfile">libnm-glib.so</filename></term>
     597        <listitem>
     598          <para>
     599            contains the GLib bindings to
     600            <application>NetworkManager</application>
     601          </para>
     602          <indexterm zone="NetworkManager libnm-glib">
     603            <primary sortas="c-libnm-glib">libnm-glib.so</primary>
     604          </indexterm>
     605        </listitem>
     606      </varlistentry>
     607
     608      <varlistentry id="libnm-glib-vpn">
     609        <term><filename class="libraryfile">libnm-glib-vpn.so</filename></term>
     610        <listitem>
     611          <para>
     612            contains the VPN portion of the GLib bindings to
     613            <application>NetworkManager</application>
     614          </para>
     615          <indexterm zone="NetworkManager libnm-glib-vpn">
     616            <primary sortas="c-libnm-glib-vpn">libnm-glib-vpn.so</primary>
     617          </indexterm>
     618        </listitem>
     619      </varlistentry>   
     620
     621      <varlistentry id="libnm-util">
     622        <term><filename class="libraryfile">libnm-util.so</filename></term>
     623        <listitem>
     624          <para>
     625            contains various functions for utilities that use
     626            <application>NetworkManager</application>
     627          </para>
     628          <indexterm zone="NetworkManager libnm-util">
     629            <primary sortas="c-libnm-util">libnm-util.so</primary>
     630          </indexterm>
     631        </listitem>
     632      </varlistentry>     
    591633    </variablelist>
    592634
  • packages.ent

    r9d10790 r52c9514  
    564564<!ENTITY bind-version                 "&bind-minor-version;.4">
    565565<!ENTITY mod_dnssd-version            "0.6">
    566 <!ENTITY NetworkManager-version       "1.18.1">
     566<!ENTITY NetworkManager-version       "1.18.2">
    567567<!ENTITY nmap-version                 "7.70">
    568568<!ENTITY traceroute-version           "2.1.0">
Note: See TracChangeset for help on using the changeset viewer.