Changeset 5a464e4


Ignore:
Timestamp:
01/25/2013 12:48:47 AM (9 years ago)
Author:
Randy McMurchy <randy@…>
Branches:
10.0, 10.1, 11.0, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, krejzi/svn, lazarus, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
8f1699f2
Parents:
cd34755
Message:

Minor changes to various packages

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@10973 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
12 edited

Legend:

Unmodified
Added
Removed
  • general/genlib/libatasmart.xml

    rcd34755 r5a464e4  
    9595    </para>
    9696
    97 <screen role="root"><userinput>make install</userinput></screen>
     97<screen role="root"><userinput>make docdir=/usr/share/doc/libatasmart-&libatasmart-version; install</userinput></screen>
    9898
    9999  </sect2>
     
    137137        <listitem>
    138138          <para>
    139             is an utility that reports on the status of the disk.
     139            is a utility that reports on the status of the disk.
    140140          </para>
    141141          <indexterm zone="libatasmart skdump">
     
    149149        <listitem>
    150150          <para>
    151             is an utility to issue disks tests.
     151            is a utility to issue disks tests.
    152152          </para>
    153153          <indexterm zone="libatasmart sktest">
  • general/genlib/libical.xml

    rcd34755 r5a464e4  
    5757    </itemizedlist>
    5858
     59    <!-- There is no support for the current version of BLFS BDB
    5960    <bridgehead renderas="sect3">libical Dependencies</bridgehead>
    6061
    6162    <bridgehead renderas="sect4">Optional</bridgehead>
    62     <para role="optional"><xref linkend="db"/></para>
     63    <para role="optional"><xref linkend="db"/></para> -->
    6364
    6465    <para condition="html" role="usernotes">User Notes:
     
    8485  </sect2>
    8586
     87  <!--  There is no support for the current version of BLFS BDB
    8688  <sect2 role="commands">
    8789    <title>Command Explanations</title>
    8890
    89     <para><option>--with-bdb4</option>: This option adds support for
     91    <para><option>-with-bdb4</option>: This option adds support for
    9092    <application>Berkeley DB 4.0</application>.</para>
    9193
    9294  </sect2>
     95  -->
    9396
    9497  <sect2 role="content">
  • general/prog/php.xml

    rcd34755 r5a464e4  
    205205
    206206install -v -m755 -d /usr/share/doc/php-&php-version; &amp;&amp;
    207 install -v -m644 CODING_STANDARDS EXTENSIONS INSTALL NEWS \
    208                  README* UPGRADING* php.gif \
    209     /usr/share/doc/php-&php-version; &amp;&amp;
    210 ln -v -sfn /usr/lib/php/doc/Archive_Tar/docs/Archive_Tar.txt \
    211          /usr/share/doc/php-&php-version; &amp;&amp;
    212 ln -v -sfn /usr/lib/php/doc/Structures_Graph/docs \
    213          /usr/share/doc/php-&php-version;</userinput></screen>
     207install -v -m644    CODING_STANDARDS EXTENSIONS INSTALL NEWS \
     208                    README* UPGRADING* php.gif \
     209                    /usr/share/doc/php-&php-version; &amp;&amp;
     210ln -v -sfn          /usr/lib/php/doc/Archive_Tar/docs/Archive_Tar.txt \
     211                    /usr/share/doc/php-&php-version; &amp;&amp;
     212ln -v -sfn          /usr/lib/php/doc/Structures_Graph/docs \
     213                    /usr/share/doc/php-&php-version;</userinput></screen>
    214214
    215215    <para>The pre-built HTML documentation is packaged in two forms: a tarball
     
    273273      enables command line <application>Readline</application> support.</para>
    274274
    275       <para><parameter>--disable-libxml</parameter>: This parameter
     275      <para><option>--disable-libxml</option>: This option
    276276      allows building PHP without <application>libxml2</application>
    277277      installed.</para>
  • general/prog/tcl.xml

    rcd34755 r5a464e4  
    162162
    163163    <para>
    164       <option>$([ $(uname -m) = x86_64 ] &amp;&amp; echo
    165       --enable-64bit)</option>: This switch is used to enable 64 bit
     164      <parameter>$([ $(uname -m) = x86_64 ] &amp;&amp; echo
     165      --enable-64bit)</parameter>: This switch is used to enable 64 bit
    166166      support in <application>Tcl</application> on 64 bit operating
    167167      systems.
  • general/prog/tk.xml

    rcd34755 r5a464e4  
    128128
    129129    <para>
    130       <option>$([ $(uname -m) = x86_64 ] &amp;&amp; echo
    131       --enable-64bit)</option>: This switch is used to enable 64 bit
     130      <parameter>$([ $(uname -m) = x86_64 ] &amp;&amp; echo
     131      --enable-64bit)</parameter>: This switch is used to enable 64 bit
    132132      support in <application>Tk</application> on 64 bit operating
    133133      systems.
  • general/sysutils/bluez.xml

    rcd34755 r5a464e4  
    8383      <xref linkend="alsa-lib"/>,
    8484      <xref linkend="check"/>,
    85       <xref linkend="cups"/>,
     85      <!-- <xref linkend="cups"/>, -->
    8686      <xref linkend="gst-plugins-base"/>,
    8787      <xref linkend="libsndfile"/> and
     
    164164<screen role="root"><userinput>for CONFFILE in audio input network serial ; do
    165165    install -v -m644 ${CONFFILE}/${CONFFILE}.conf /etc/bluetooth/${CONFFILE}.conf
    166 done</userinput></screen>
     166done
     167unset CONFFILE</userinput></screen>
    167168
    168169    <para>
     
    180181
    181182    <para>
    182       <option>--enable-bccmd</option>: This switch enables building of the BCCMD
     183      <parameter>--enable-bccmd</parameter>: This switch enables building of the BCCMD
    183184      interface utility.
    184185    </para>
    185186
    186187    <para>
    187       <option>--enable-dfutool</option>: This switch enables building of the DFU
     188      <parameter>--enable-dfutool</parameter>: This switch enables building of the DFU
    188189      firmware upgrade utility.
    189190    </para>
    190191
    191192    <para>
    192       <option>--enable-dund</option>: This switch enables building of the DUN daemon.
    193     </para>
    194 
    195     <para>
    196       <option>--enable-hid2hci</option>: This switch enables building of the HID
     193      <parameter>--enable-dund</parameter>: This switch enables building of the DUN daemon.
     194    </para>
     195
     196    <para>
     197      <parameter>--enable-hid2hci</parameter>: This switch enables building of the HID
    197198      mode switching utility.
    198199    </para>
    199200
    200201    <para>
    201       <option>--enable-hidd</option>: This switch enables building of the HID daemon.
    202     </para>
    203 
    204     <para>
    205       <option>--enable-pand</option>: This switch enables building of the PAN daemon.
    206     </para>
    207 
    208     <para>
    209       <option>--enable-tools</option>: This switch enables building of the Bluetooth
     202      <parameter>--enable-hidd</parameter>: This switch enables building of the HID daemon.
     203    </para>
     204
     205    <para>
     206      <parameter>--enable-pand</parameter>: This switch enables building of the PAN daemon.
     207    </para>
     208
     209    <para>
     210      <parameter>--enable-tools</parameter>: This switch enables building of the Bluetooth
    210211      utilities.
    211212    </para>
    212213
    213214    <para>
    214       <option>--enable-wiimote</option>: This switch enables building of the Wii
     215      <parameter>--enable-wiimote</parameter>: This switch enables building of the Wii
    215216      Remote plugin.
    216217    </para>
    217218
    218219    <para>
    219       <option>--disable-test</option>: This switch disables installation of the
     220      <parameter>--disable-test</parameter>: This switch disables installation of the
    220221      test programs.
    221222    </para>
    222223
    223224    <para>
    224       <option>--without-systemdunitdir</option>: This switch disables installation
     225      <parameter>--without-systemdunitdir</parameter>: This switch disables installation
    225226      of the systemd units.
    226227    </para>
    227228
    228229    <para>
    229       <option>--enable-alsa</option>: This switch enables ALSA support. Use if you
     230      <option>--enable-cups</option>: This switch enables CUPS backend support. Note
     231      that CUPS does not need to be installed for this support.
     232    </para>
     233
     234    <!-- These options are automatically found and used if the packages are
     235         available. There is no need to use these switches.
     236    <para>
     237      <option>-enable-alsa</option>: This switch enables ALSA support. Use if you
    230238      have <xref linkend="alsa-lib"/> installed.
    231239    </para>
    232240
    233241    <para>
    234       <option>--enable-cups</option>: This switch enables CUPS backend support. Use
    235       if you have <xref linkend="cups"/> installed.
    236     </para>
    237 
    238     <para>
    239       <option>--enable-gstreamer</option>: This switch enables GStreamer support. Use
     242      <option>-enable-gstreamer</option>: This switch enables GStreamer support. Use
    240243      if you have <xref linkend="gst-plugins-base"/> installed.
    241244    </para>
    242245
    243246    <para>
    244       <option>--enable-usb</option>: This switch enables USB support. Use if you have
     247      <option>-enable-usb</option>: This switch enables USB support. Use if you have
    245248      <xref linkend="libusb-compat"/> installed.
    246     </para>
     249    </para> -->
    247250
    248251  </sect2>
  • gnome/core/libsecret.xml

    rcd34755 r5a464e4  
    9292    <bridgehead renderas="sect4">Optional (Required for the testsuite)</bridgehead>
    9393    <para role="optional">
    94       <xref linkend="gjs"/> and
     94      <xref linkend="gjs"/>,
     95      <xref linkend="dbus-python"/> and
    9596      <xref linkend="pygobject3"/>
    9697    </para>
     
    113114
    114115    <para>
    115       To test the results, issue: <command>make check</command>.
     116      To test the results, issue: <command>make -k check</command>. The
     117      JavaScript tests fail for unknown reasons.
    116118    </para>
    117119
  • multimedia/libdriv/gst-plugins-bad.xml

    rcd34755 r5a464e4  
    182182    <para>
    183183      <parameter>--with-gtk=3.0</parameter>: Build against <application>GTK+ 3</application>
    184       instead of the default <application>GTK+ 2</application>: recommended for a
     184      instead of the default <application>GTK+ 2</application>; recommended for a
    185185      <application>GNOME</application> Desktop.
    186186    </para>
    187187
    188188    <para>
    189       <option>--disable-examples</option>: if the dependencies for the camera
     189      <parameter>--disable-examples</parameter>: If the dependencies for the camera
    190190      driver have been satisfied, the associated example code fails to build.
    191191    </para>
  • multimedia/videoutils/mplayer.xml

    rcd34755 r5a464e4  
    191191      <ulink url="http://www.ladspa.org/">LADSPA</ulink>,
    192192      <ulink url="http://sourceforge.net/projects/bs2b/">libbs2b</ulink>,
    193       <ulink url="http://www.lirc.org/">LIRC</ulink> and
    194       <ulink url="http://www.dolda2000.com/~fredrik/lirccd/">LIRC Client Daemon</ulink>,
     193      <ulink url="http://www.lirc.org/">LIRC</ulink> (and
     194      <ulink url="http://www.dolda2000.com/~fredrik/lirccd/">LIRC Client Daemon</ulink>),
    195195      <xref linkend="unrar"/>, and
    196196      <xref linkend="libxslt"/>,
     
    312312      source and without this option it will statically compile the included
    313313      version of FFmpeg into itself. Dynamically linking to a system installed
    314       FFmpeg makes MPlayer and Mencoder about 9MB smaller. If MPlayer is crashy
    315       or unstable linked to a system installed FFmpeg, try recompiling MPlayer
     314      FFmpeg makes MPlayer and Mencoder about 9MB smaller. If MPlayer exhibits
     315      unstable behavior linked to a system installed FFmpeg, try recompiling MPlayer
    316316      without this option (it is always more thoroughly tested with the included
    317317      FFmpeg).
  • networking/netlibs/geoclue.xml

    rcd34755 r5a464e4  
    162162
    163163    <para>
    164       <option>--libexecdir=/usr/lib/geoclue</option>: This option installs
     164      <parameter>--libexecdir=/usr/lib/geoclue</parameter>: This option installs
    165165      <application>GeoClue's</application> private executables into
    166166      <filename class="libraryfile">/usr/lib/geoclue</filename>.
  • postlfs/filesystems/fuse.xml

    rcd34755 r5a464e4  
    9898    <title>Installation of Fuse</title>
    9999
     100    <note>
     101      <para>
     102        After the <command>configure</command> script has finished you will
     103        see a warning shown below. You can safely disregard this warning.
     104      </para>
     105
     106<screen><computeroutput>configure: WARNING:
     107******************************************************************
     108* Please install util-linux version 2.18 or later which supports *
     109* --fake and --no-canonicalize options in mount and umount       *
     110******************************************************************</computeroutput></screen>
     111    </note>
     112
    100113    <para>
    101114      Install <application>Fuse</application> by running the following
     
    107120
    108121    <para>
     122      If you have <xref linkend="doxygen"/> installed and wish to build the API
     123      documentation, issue <command>doxygen doc/Doxyfile</command>.
     124    </para>
     125
     126    <para>
    109127      This package does not come with a test suite.
    110128    </para>
     
    115133
    116134<screen role="root"><userinput>make install &amp;&amp;
    117 mv -v /usr/lib/libfuse.so.* /lib &amp;&amp;
     135
     136mv -v   /usr/lib/libfuse.so.* /lib &amp;&amp;
    118137ln -sfv ../../lib/libfuse.so.&fuse-version; /usr/lib/libfuse.so &amp;&amp;
    119 rm -rf /tmp/init.d</userinput></screen>
     138rm -rf  /tmp/init.d &amp;&amp;
     139
     140install -v -m755 -d /usr/share/doc/fuse-&fuse-version; &amp;&amp;
     141install -v -m644    doc/{how-fuse-works,kernel.txt} \
     142                    /usr/share/doc/fuse-&fuse-version;</userinput></screen>
     143
     144    <para>
     145      If you built the API documentation, install it as the
     146      <systemitem class="username">root</systemitem> user by issuing the
     147      following commands:
     148    </para>
     149
     150<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/fuse-&fuse-version;/api &amp;&amp;
     151install -v -m644    doc/html/* \
     152                    /usr/share/doc/fuse-&fuse-version;/api</userinput></screen>
    120153  </sect2>
    121154
     
    127160
    128161    <para>
    129       <parameter>INIT_D_PATH=/tmp/init.d</parameter>: This parameter makes it
    130       install its bootscript into <filename>/tmp/init.d</filename>.
    131     </para>
    132 
    133     <para>
    134       <command>mv -v /usr/lib/libfuse.so.* /lib</command>: This moves
    135       <application>FUSE</application> library to root filesystem
    136       so that it is available at early boot in case
    137       <filename class="directory">/usr</filename> is on seperate
    138       partition and <xref linkend="ntfs-3g"/> is built with system
    139       <application>FUSE</application>.
     162      <parameter>INIT_D_PATH=/tmp/init.d</parameter>: This parameter installs
     163      the bootscript into <filename class="directory">/tmp/init.d</filename> as
     164      a bootscript is not required.
     165    </para>
     166
     167    <para>
     168      <command>mv -v /usr/lib/libfuse.so.* /lib</command>: This moves the
     169      <application>FUSE</application> library to the root filesystem
     170      so that it is available early in the boot process in case
     171      <filename class="directory">/usr</filename> is mounted on a separate
     172      partition and <xref linkend="ntfs-3g"/> is built with a system-installed
     173      version of <application>FUSE</application>.
    140174    </para>
    141175
  • xincludes/static-libraries.xml

    rcd34755 r5a464e4  
    77
    88    <para>
    9       <option>--disable-static</option>: This switch prevents
     9      <parameter>--disable-static</parameter>: This switch prevents
    1010      installation of static versions of the libraries.
    1111    </para>
Note: See TracChangeset for help on using the changeset viewer.