Changeset 632bfad for kde


Ignore:
Timestamp:
06/26/2015 07:39:08 PM (6 years ago)
Author:
Bruce Dubbs <bdubbs@…>
Branches:
10.0, 10.1, 11.0, 7.10, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, ken/refactor-virt, lazarus, nosym, perl-modules, qt5new, trunk, upgradedb, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
ecb22c1
Parents:
338015f
Message:

Reorganize KDE to support KDE Frameworks 5.
Move several packages to the introduction that are common to KDE4 and FK5.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@16173 af4574ff-66df-0310-9fd7-8a98e5e911e0

Location:
kde
Files:
1 added
4 edited
7 moved

Legend:

Unmodified
Added
Removed
  • kde/add/add-pkgs.xml

    r338015f r632bfad  
    66]>
    77
    8 <sect1 id="kde-add-pkgs" xreflabel="Further KDE packages">
     8<sect1 id="kde-add-pkgs" xreflabel="Further KDE4 packages">
    99  <?dbhtml filename="add-pkgs.html"?>
    1010
     
    1414  </sect1info>
    1515
    16   <title>Further KDE packages</title>
     16  <title>Further KDE4 packages</title>
    1717
    1818  <para>This section did not provide instructions for all of the available
    19   packages in the KDE Software Compilation. The included packages were selected
     19  packages in the KDE4 Software Compilation. The included packages were selected
    2020  based on what most people would want to use on a standard desktop computer.</para>
    2121
    22   <para>For a full list of available packages, have a look on the KDE servers at
     22  <para>For a full list of available packages, have a look on the KDE4 servers at
    2323  <ulink url="&kde-download-http;&kde-version;/src/">
    2424              &kde-download-http;&kde-version;/src/</ulink>
     
    6565      </itemizedlist>
    6666
    67       <para>Most of these packages can be built with the standard KDE instructions:</para>
     67      <para>Most of these packages can be built with the standard KDE4 instructions:</para>
    6868<screen><userinput>mkdir build &amp;&amp;
    6969cd    build &amp;&amp;
  • kde/core/core.xml

    r338015f r632bfad  
    1818  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="pre-install-config.xml"/>
    1919  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="automoc4.xml"/>
     20  <!--
    2021  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
    2122  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>
    2223  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-vlc.xml"/>
     24  -->
    2325  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="akonadi.xml"/>
    2426  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="attica.xml"/>
    2527  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="qimageblitz.xml"/>
     28  <!--
    2629  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="polkit-qt.xml"/>
     30  -->
    2731  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="oxygen-icons.xml"/>
    2832  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kdelibs.xml"/>
  • kde/extra-cmake-modules.xml

    r338015f r632bfad  
    22<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4   <!ENTITY % general-entities SYSTEM "../../general.ent">
     4  <!ENTITY % general-entities SYSTEM "../general.ent">
    55  %general-entities;
    66
    7    <!ENTITY extra-cmake-modules-version       "1.7.0">
    8    <!ENTITY extra-cmake-modules-download-http "&kf5-download-http;/extra-cmake-modules-&extra-cmake-modules-version;.tar.xz">
    9    <!ENTITY extra-cmake-modules-download-ftp  "&kf5-download-ftp;/extra-cmake-modules-&extra-cmake-modules-version;.tar.xz">
    10    <!ENTITY extra-cmake-modules-md5sum        "45fd1e6f38b23b00983e5eab9ba61d15">
    11    <!ENTITY extra-cmake-modules-size          "128 KB">
    12    <!ENTITY extra-cmake-modules-buildsize     "5.8 MB">
     7   <!ENTITY extra-cmake-modules-download-http "&kf5-download-http;/extra-cmake-modules-&kf5-version;.tar.xz">
     8   <!ENTITY extra-cmake-modules-download-ftp  "&kf5-download-ftp;/extra-cmake-modules-&kf5-version;.tar.xz">
     9   <!ENTITY extra-cmake-modules-md5sum        "0e1298c6fce735f06c789a173c0093ff">
     10   <!ENTITY extra-cmake-modules-size          "132 KB">
     11   <!ENTITY extra-cmake-modules-buildsize     "3.3 MB">
    1312   <!ENTITY extra-cmake-modules-time          "less than 0.1 SBU">
    1413]>
    1514
    16 <sect1 id="extra-cmake-modules" xreflabel="extra-cmake-modules-&extra-cmake-modules-version;">
     15<sect1 id="extra-cmake-modules" xreflabel="extra-cmake-modules-&kf5-version;">
    1716  <?dbhtml filename="extra-cmake-modules.html"?>
    1817
     
    2221  </sect1info>
    2322
    24   <title>extra-cmake-modules-&extra-cmake-modules-version;</title>
     23  <title>extra-cmake-modules-&kf5-version;</title>
    2524
    2625  <indexterm zone="extra-cmake-modules">
     
    3736    </para>
    3837
    39     &lfs77_checked;
     38    &lfs77_checked; &gcc5_checked;
    4039   
    4140    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    8281    <bridgehead renderas="sect4">Optional</bridgehead>
    8382    <para role="optional">
    84       <ulink url="https://pypi.python.org/pypi/Sphinx">Sphinx (for building documentation)</ulink>
     83      <ulink url="https://pypi.python.org/pypi/Sphinx">Sphinx</ulink> (for building documentation)
    8584    </para>
    8685
     
    107106      This package does not come with a test suite.
    108107    </para>
     108
     109    <note><para>
     110      Unlike other KF5 packages, this modle is installed in /usr because
     111      it can be used by some non-KF5 packages.
     112    </para></note>
    109113
    110114    <para>
  • kde/introduction.xml

    r338015f r632bfad  
    22<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33  "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4  <!ENTITY % general-entities SYSTEM "../../general.ent">
     4 <!ENTITY % general-entities SYSTEM "../general.ent">
    55 %general-entities;
    66]>
     
    1717
    1818  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kde-intro.xml"/>
    19   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="extra-cmake-modules.xml"/>
    2019  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
    2120  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>
    2221  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-vlc.xml"/>
    2322  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="polkit-qt.xml"/>
     23  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="extra-cmake-modules.xml"/>
    2424
    2525</chapter>
  • kde/kde-intro.xml

    r338015f r632bfad  
    22<!DOCTYPE partintro PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4   <!ENTITY % general-entities SYSTEM "../../general.ent">
     4  <!ENTITY % general-entities SYSTEM "../general.ent">
    55  %general-entities;
    66]>
  • kde/kde.xml

    r338015f r632bfad  
    3131  <ulink url="http://www.kde.org/"/>.</para>
    3232</partintro>
    33 <!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="intro/introduction.xml"/>-->
     33  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="introduction.xml"/>
    3434  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="core/core.xml"/>
    3535  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="add/add.xml"/>
  • kde/kf5/kf5.xml

    r338015f r632bfad  
    1414  <?dbhtml filename="kf5.html"?>
    1515
    16   <title>KDE Frameworks 5</title>
     16  <title>KDE Frameworks 5 (KF5)</title>
    1717 
    1818  <para>Placeholder</para>
    1919
    20   <!--<xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="automoc4.xml"/>-->
    2120
    2221</chapter>
     22
  • kde/kf5/phonon5.xml

    r338015f r632bfad  
    1313]>
    1414
    15 <sect1 id="phonon" xreflabel="phonon-&phonon-version;">
    16   <?dbhtml filename="phonon.html"?>
     15<sect1 id="phonon5" xreflabel="phonon-&phonon-version; (Qt5)">
     16  <?dbhtml filename="phonon5.html"?>
    1717
    1818  <sect1info>
     
    2121  </sect1info>
    2222
    23   <title>Phonon-&phonon-version;</title>
     23  <title>Phonon-&phonon-version; (Qt5)</title>
    2424
    25   <indexterm zone="phonon">
    26     <primary sortas="a-phonon">phonon</primary>
     25  <indexterm zone="phonon5">
     26    <primary sortas="a-phonon5">phonon</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Phonon</title>
     30    <title>Introduction to Phonon (Qt5)</title>
    3131
    32     <para><application>Phonon</application> is the multimedia API for KDE4.
    33     It replaces the old <application>aRts</application> package.
     32    <para><application>Phonon</application> is the multimedia API for KDE5.
     33    This is the same version of Phonon used in KDE4, but must be linked
     34    usign Qt5 libraries.
    3435    Phonon needs either the GStreamer or VLC backend.</para>
    3536
     
    6465      <xref linkend="cmake"/>,
    6566      <xref linkend="glib2"/>, and
    66       <xref linkend="qt4"/>
     67      <xref linkend="qt5"/>
    6768    </para>
    6869
    6970    <bridgehead renderas="sect4">Optional</bridgehead>
    7071    <para role="optional">
    71       <xref linkend="pulseaudio"/> and
    72       <ulink url="http://projects.kde.org/projects/kdesupport/libqzeitgeist/">QZeitgeist</ulink>
     72      <xref linkend="pulseaudio"/>
    7373    </para>
    7474
  • kde/phonon-backend-gstreamer.xml

    r338015f r632bfad  
    22<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4   <!ENTITY % general-entities SYSTEM "../../general.ent">
     4  <!ENTITY % general-entities SYSTEM "../general.ent">
    55  %general-entities;
    66
     
    3030    <title>Introduction to the Phonon-backend-gstreamer</title>
    3131
    32     <para>This package provides a <application>Phonon</application> backend which
    33     utilizes the <application>GStreamer</application> media framework.</para>
     32    <para>This package provides a <application>Phonon</application> backend
     33    which utilizes the <application>GStreamer</application> media framework.
     34    Its library is used by both KDE4 and KF5, but they must be linked to <xref
     35    linkend="qt4"/> and  <xref linkend="qt5"/> respectively. The two versions
     36    do not conflict with each other. </para>
    3437
    3538    &lfs77_checked; &gcc5_checked;
     
    8285    <title>Installation of Phonon-backend-gstreamer</title>
    8386
    84     <para>Install <application>Phonon-backend-gstreamer</application> by
    85     running the following commands:</para>
     87    <para>Install the qt4 based version of
     88    <application>Phonon-backend-gstreamer</application> by running the
     89    following commands:</para>
    8690
    87     <note>
    88       <para>
    89         If you have both Qt4 and Qt5 installed, be sure to run
    90         <userinput>source setqt4</userinput> before installing this package.
    91       </para>
    92     </note>
     91<screen><userinput>source /usr/bin/setqt4 &amp;&amp;
    9392
    94 <screen><userinput>mkdir build &amp;&amp;
     93mkdir build &amp;&amp;
    9594cd    build &amp;&amp;
    9695
    97 cmake -DCMAKE_INSTALL_PREFIX=&kde-dir; \
    98       -DCMAKE_INSTALL_LIBDIR=lib         \
    99       -DCMAKE_BUILD_TYPE=Release         \
     96cmake -DCMAKE_INSTALL_PREFIX=/usr \
     97      -DCMAKE_INSTALL_LIBDIR=lib  \
     98      -DCMAKE_BUILD_TYPE=Release  \
     99      -Wno-dev .. &amp;&amp;
     100make</userinput></screen>
     101
     102    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
     103
     104<screen role="root"><userinput>make install</userinput></screen>
     105
     106    <para>Install the qt5 based version of
     107    <application>Phonon-backend-gstreamer</application> by running the
     108    following commands:</para>
     109
     110<screen><userinput>source /usr/bin/setqt5 &amp;&amp;
     111
     112mkdir build &amp;&amp;
     113cd    build &amp;&amp;
     114
     115cmake -DCMAKE_INSTALL_PREFIX=/usr    \
     116      -DCMAKE_INSTALL_LIBDIR=lib     \
     117      -DCMAKE_BUILD_TYPE=Release     \
     118      -DPHONON_BUILD_PHONON4QT5=ON   \
     119      -D__KDE_HAVE_GCC_VISIBILITY=NO \
    100120      -Wno-dev .. &amp;&amp;
    101121make</userinput></screen>
     
    113133    apply higher level of compiler optimizations.</para>
    114134
     135    <para><option>-DCMAKE_INSTALL_LIBDIR=lib</option>: This switch is used to
     136     get libraries to install to /usr/lib instead of /usr/lib64 on a 64 bit
     137     system.</para>
     138
     139    <para><option>-DPHONON_BUILD_PHONON4QT5=ON</option>: This switch is used to
     140    ensure that Qt5 version of the backend is built even if Qt4 is present.</para>
     141
     142    <para><option>-D__KDE_HAVE_GCC_VISIBILITY=NO</option>: This switch is used to
     143    disable a check that would cause cmake to fail when using Qt-5.4.2 or later.</para>
     144
    115145  </sect2>
    116146 
     
    125155      <seglistitem>
    126156        <seg>none</seg>
    127         <seg>phonon_gstreamer.so</seg>
    128         <seg>/usr/lib/kde4/plugins/phonon_backend and
     157        <seg>phonon_gstreamer.so (two versions in different directories)</seg>
     158        <seg>/usr/lib/kde4/plugins/phonon_backend,
     159             /usr/lib/qt5/plugins/phonon4qt5_backend, and
    129160             /usr/share/kde4/services/phononbackends</seg>
    130161      </seglistitem>
  • kde/phonon-backend-vlc.xml

    r338015f r632bfad  
    22<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4   <!ENTITY % general-entities SYSTEM "../../general.ent">
     4  <!ENTITY % general-entities SYSTEM "../general.ent">
    55  %general-entities;
    66
     
    3030    <title>Introduction to the Phonon-backend-vlc</title>
    3131
    32     <para>This package provides a <application>Phonon</application> backend which
    33     utilizes the <application>VLC</application> media framework.</para>
     32    <para>This package provides a <application>Phonon</application> backend
     33    which utilizes the <application>VLC</application> media framework. Its
     34    library is used by both KDE4 and KF5, but they must be linked to <xref
     35    linkend='qt4'/> and <xref linkend='qt5'/> respectively. The two versions do
     36    not conflict with each other.</para>
    3437
    3538    &lfs77_checked; &gcc5_checked;
     
    7376    <title>Installation of Phonon-backend-vlc</title>
    7477
    75     <para>Install <application>Phonon-backend-vlc</application> by running the following
     78    <para>Install the qt4 based version of
     79    <application>Phonon-backend-vlc</application> by running the following
    7680    commands:</para>
    7781
    78 <screen><userinput>mkdir build &amp;&amp;
     82<screen><userinput>source /usr/bin/setqt4 &amp;&amp;
     83
     84mkdir build &amp;&amp;
    7985cd    build &amp;&amp;
    8086
    81 cmake -DCMAKE_INSTALL_PREFIX=&kde-dir; \
    82       -DCMAKE_INSTALL_LIBDIR=lib         \
    83       -DCMAKE_BUILD_TYPE=Release         \
     87cmake -DCMAKE_INSTALL_PREFIX=/usr \
     88      -DCMAKE_INSTALL_LIBDIR=lib  \
     89      -DCMAKE_BUILD_TYPE=Release  \
     90      -Wno-dev .. &amp;&amp;
     91make</userinput></screen>
     92
     93    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
     94
     95<screen role="root"><userinput>make install</userinput></screen>
     96
     97    <para>Install the qt5 based version of
     98    <application>Phonon-backend-vlc</application> by running the following
     99    commands:</para>
     100
     101<screen><userinput>source /usr/bin/setqt5 &amp;&amp;
     102
     103mkdir build &amp;&amp;
     104cd    build &amp;&amp;
     105
     106cmake -DCMAKE_INSTALL_PREFIX=/usr    \
     107      -DCMAKE_INSTALL_LIBDIR=lib     \
     108      -DCMAKE_BUILD_TYPE=Release     \
     109      -DPHONON_BUILD_PHONON4QT5=ON   \
     110      -D__KDE_HAVE_GCC_VISIBILITY=NO \
    84111      -Wno-dev .. &amp;&amp;
    85112make</userinput></screen>
     
    97124    higher level of compiler optimizations.</para>
    98125
     126    <para><option>-DCMAKE_INSTALL_LIBDIR=lib</option>: This switch is used to
     127     get libraries to install to /usr/lib instead of /usr/lib64 on a 64 bit
     128     system.</para>
     129
     130    <para><option>-DPHONON_BUILD_PHONON4QT5=ON</option>: This switch is used to
     131    ensure that Qt5 version of the backend is built even if Qt4 is present.</para>
     132
     133    <para><option>-D__KDE_HAVE_GCC_VISIBILITY=NO</option>: This switch is used to
     134    disable a check that would cause cmake to fail when using Qt-5.4.2 or later.</para>
     135
    99136  </sect2>
    100137
     
    110147        <seg>none</seg>
    111148        <seg>phonon_vlc.so</seg>
    112         <seg>&kde-dir;/lib/kde4/plugins/phonon_backend and
    113         &kde-dir;/share/kde4/services/phononbackends</seg>
     149        <seg>/usr/lib/kde4/plugins/phonon_backend,
     150             /usr/lib/qt5/plugins/phonon4qt5_backend, and
     151             /usr/share/kde4/services/phononbackends</seg>
    114152      </seglistitem>
    115153    </segmentedlist>
  • kde/polkit-qt.xml

    r338015f r632bfad  
    22<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
    33   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
    4   <!ENTITY % general-entities SYSTEM "../../general.ent">
     4  <!ENTITY % general-entities SYSTEM "../general.ent">
    55  %general-entities;
    66
     
    3030    <title>Introduction to Polkit-Qt</title>
    3131
    32     <para><application>Polkit-Qt</application> provides an API to
    33     <application>polkit</application> in the Qt environment.</para>
     32    <para><application>Polkit-Qt</application> provides an API to PolicyKit in
     33    the Qt environment. Its libraries are used by both KDE4 and KF5, but they
     34    must be linked to <xref linkend='qt4'/> and <xref linkend='qt5'/>
     35    respectively. The two versions to not conflict with each other. </para>
    3436
    3537    &lfs77_checked; &gcc5_checked;
     
    8385    <title>Installation of Polkit-Qt</title>
    8486
    85     <para>Install <application>Polkit-Qt</application> by running the following
    86     commands:</para>
    87 
    88 <screen><userinput>mkdir build &amp;&amp;
     87    <para>Install the qt4 based version of <application>Polkit-Qt</application>
     88    by running the following commands:</para>
     89
     90<screen><userinput>source /usr/bin/setqt4 &amp;&amp;
     91
     92mkdir build &amp;&amp;
    8993cd    build &amp;&amp;
    9094
    91 cmake -DCMAKE_INSTALL_PREFIX=&kde-dir; \
    92       -DCMAKE_BUILD_TYPE=Release         \
    93       -DCMAKE_INSTALL_LIBDIR=lib         \
    94       -DUSE_QT4=TRUE                     \
     95cmake -DCMAKE_INSTALL_PREFIX=/etc \
     96      -DCMAKE_BUILD_TYPE=Release  \
     97      -DCMAKE_INSTALL_LIBDIR=lib  \
     98      -DUSE_QT4=TRUE              \
     99      -Wno-dev .. &amp;&amp;
     100make</userinput></screen>
     101
     102    <para>
     103      This package does not come with a test suite.
     104    </para>
     105
     106    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
     107
     108<screen role="root"><userinput>make install</userinput></screen>
     109
     110    <para>Install the qt4 based version of <application>Polkit-Qt</application>
     111    by running the following commands:</para>
     112
     113<screen><userinput>source /usr/bin/setqt5 &amp;&amp;
     114
     115mkdir build &amp;&amp;
     116cd    build &amp;&amp;
     117
     118cmake -DCMAKE_INSTALL_PREFIX=/etc \
     119      -DCMAKE_BUILD_TYPE=Release  \
     120      -DCMAKE_INSTALL_LIBDIR=lib  \
    95121      -Wno-dev .. &amp;&amp;
    96122make</userinput></screen>
     
    139165      <seglistitem>
    140166        <seg>none</seg>
    141         <seg>libpolkit-qt-agent-1.so, libpolkit-qt-core-1.so and libpolkit-qt-gui-1.so</seg>
    142         <seg>&kde-dir;/include/polkit-qt-1</seg>
     167        <seg>libpolkit-qt-agent-1.so,
     168             libpolkit-qt5-agent-1.so,
     169             libpolkit-qt-core-1.so,
     170             libpolkit-qt5-core-1.so, 
     171             libpolkit-qt-gui-1.so, and
     172             libpolkit-qt5-gui-1.so</seg>
     173        <seg>/usr/include/polkit-qt-1,
     174             /usr/include/polkit-qt5-1,
     175             /usr/lib/cmake/PolkitQt-1, and
     176             /usr/lib/cmake/PolkitQt5-1
     177             </seg>
    143178      </seglistitem>
    144179    </segmentedlist>
Note: See TracChangeset for help on using the changeset viewer.