Changeset 6686ce7


Ignore:
Timestamp:
08/12/2022 02:22:04 AM (4 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
11.2, plabs/python-mods, trunk, xry111/soup3
Children:
6d237be
Parents:
5f729f8
Message:

gnome-shell: drop asciidoc dependency and related option

The release tarball contains generated man pages since gnome-shell-40 so
asciidoc is not a dependency unless you'll build gnome-shell from git
snapshot. And, the option has been renamed to "extensions_tool" and we
don't have any strong reason to use it now.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • gnome/platform/gnome-shell.xml

    r5f729f8 r6686ce7  
    114114    <bridgehead renderas="sect4">Recommended</bridgehead>
    115115    <para role="recommended">
    116       <xref linkend="asciidoc"/>,
    117116      <xref linkend="desktop-file-utils"/>,
    118117      <xref linkend="gnome-bluetooth"/>,
     
    214213      to build the tests. But then <command>meson</command> will fail if
    215214      <xref linkend="mutter"/> tests are not installed.
    216     </para>
    217 
    218     <para>
    219       <option>-Dextensions=false</option>: This option disables building the
    220       <command>gnome-extensions</command> CLI tool. Using this option removes
    221       the need for <xref linkend="asciidoc"/>.
    222215    </para>
    223216
Note: See TracChangeset for help on using the changeset viewer.