Changeset 75f50a9


Ignore:
Timestamp:
01/16/2012 12:06:06 AM (10 years ago)
Author:
Andrew Benton <andy@…>
Branches:
10.0, 10.1, 11.0, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, ken/refactor-virt, krejzi/svn, lazarus, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
a0ace670
Parents:
e052635
Message:

libunique fixes
I'll update it to 1.1.6 tomorrow

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@9181 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/genlib/libunique.xml

    re052635 r75f50a9  
    8080    commands:</para>
    8181
    82 <screen><userinput>./configure --prefix=/usr &amp;&amp;
     82<screen><userinput>sed -i '/DG_DISABLE_DEPRECATED/d' unique/Makefile.in &amp;&amp;
     83./configure --prefix=/usr --disable-static &amp;&amp;
     84sed -i 's#  -Werror ##' unique/dbus/Makefile &amp;&amp;
    8385make</userinput></screen>
    8486
     
    9395  <sect2 role="commands">
    9496    <title>Command Explanations</title>
     97
     98    <para><command>sed -i '/DG_DISABLE_DEPRECATED/d' ...</command>:
     99    <application>Libunique</application> uses functions that are deprecated in
     100    the current version of <application>Glib</application>. This sed allows it
     101    to compile using those deprecated functions.</para>
     102
     103    <para><command>sed -i 's#  -Werror ##' ...</command>: This sed disables
     104    treating warnings as errors in the Makefile that deals with dbus.</para>
    95105
    96106    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
Note: See TracChangeset for help on using the changeset viewer.